mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 13:15:20 +02:00
add axtls embedded ssl/tls library.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3795 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
59e10adc2d
commit
63ef5186e1
@ -210,6 +210,7 @@ source "package/radvd/Config.in"
|
||||
endmenu
|
||||
|
||||
menu "Libraries"
|
||||
source "package/axtls/Config.in"
|
||||
source "package/cgilib/Config.in"
|
||||
source "package/glib/Config.in"
|
||||
source "package/id3lib/Config.in"
|
||||
|
@ -13,6 +13,7 @@ package-$(BR2_PACKAGE_ASTERISK) += asterisk
|
||||
package-$(BR2_COMPILE_ATFTP) += atftp
|
||||
package-$(BR2_PACKAGE_AUTOSSH) += autossh
|
||||
package-$(BR2_COMPILE_AVAHI) += avahi
|
||||
package-$(BR2_COMPILE_AXTLS) += axtls
|
||||
package-$(BR2_COMPILE_BC) += bc
|
||||
package-$(BR2_COMPILE_BIND) += bind
|
||||
package-$(BR2_PACKAGE_BITCHX) += bitchx
|
||||
|
29
openwrt/package/axtls/Config.in
Normal file
29
openwrt/package/axtls/Config.in
Normal file
@ -0,0 +1,29 @@
|
||||
menu "axtls............................. Embedded client/server TLSv1 SSL library"
|
||||
|
||||
config BR2_COMPILE_AXTLS
|
||||
tristate
|
||||
default n
|
||||
depends BR2_PACKAGE_LIBAXTLS
|
||||
|
||||
config BR2_PACKAGE_LIBAXTLS
|
||||
prompt "libaxtls.......................... Embedded client/server TLSv1 SSL library"
|
||||
tristate
|
||||
default m if CONFIG_DEVEL
|
||||
select BR2_COMPILE_AXTLS
|
||||
help
|
||||
Embedded client/server TLSv1 SSL library
|
||||
|
||||
http://www.axtls.co.nr/
|
||||
|
||||
config BR2_PACKAGE_AWHTTPD
|
||||
prompt "awhttpd......................... Anti-Web webserver"
|
||||
tristate
|
||||
default m if CONFIG_DEVEL
|
||||
depends BR2_PACKAGE_LIBAXTLS
|
||||
help
|
||||
Anti-Web is a light-weight, single-process, non-threaded webserver
|
||||
that emphasizes simplicity, efficiency, and security.
|
||||
|
||||
http://www.axtls.co.nr/
|
||||
|
||||
endmenu
|
42
openwrt/package/axtls/Makefile
Normal file
42
openwrt/package/axtls/Makefile
Normal file
@ -0,0 +1,42 @@
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=axtls
|
||||
PKG_VERSION:=0.95
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=cd887f379f303dd3ef691d8641307f0e
|
||||
|
||||
PKG_SOURCE:=axTLS-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.leroc.com.au/axTLS/
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/axTLS
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,LIBAXTLS,libaxtls,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
$(eval $(call PKG_template,AWHTTPD,awhttpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured:
|
||||
$(CP) ./files/config $(PKG_BUILD_DIR)/config/.config
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) oldconfig
|
||||
touch $@
|
||||
|
||||
$(PKG_BUILD_DIR)/.built:
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CC=$(TARGET_CC) \
|
||||
OPT_CFLAGS="$(TARGET_CFLAGS)" OPT_LDFLAGS=""
|
||||
touch $@
|
||||
|
||||
$(IPKG_LIBAXTLS):
|
||||
install -d -m0755 $(IDIR_LIBAXTLS)/usr/lib
|
||||
install -m0755 $(PKG_BUILD_DIR)/libaxtls.so $(IDIR_LIBAXTLS)/usr/lib/
|
||||
$(RSTRIP) $(IDIR_LIBAXTLS)
|
||||
$(IPKG_BUILD) $(IDIR_LIBAXTLS) $(PACKAGE_DIR)
|
||||
|
||||
$(IPKG_AWHTTPD):
|
||||
install -d -m0755 $(IDIR_AWHTTPD)/usr/sbin
|
||||
install -m0755 $(PKG_BUILD_DIR)/awhttpd $(IDIR_AWHTTPD)/usr/sbin/
|
||||
$(RSTRIP) $(IDIR_AWHTTPD)
|
||||
$(IPKG_BUILD) $(IDIR_AWHTTPD) $(PACKAGE_DIR)
|
98
openwrt/package/axtls/files/config
Normal file
98
openwrt/package/axtls/files/config
Normal file
@ -0,0 +1,98 @@
|
||||
#
|
||||
# Automatically generated make config: don't edit
|
||||
#
|
||||
HAVE_DOT_CONFIG=y
|
||||
CONFIG_PLATFORM_LINUX=y
|
||||
# CONFIG_PLATFORM_CYGWIN is not set
|
||||
# CONFIG_PLATFORM_SOLARIS is not set
|
||||
# CONFIG_PLATFORM_WIN32 is not set
|
||||
|
||||
#
|
||||
# General Configuration
|
||||
#
|
||||
# CONFIG_DEBUG is not set
|
||||
# CONFIG_VISUAL_STUDIO_DOT_NET is not set
|
||||
CONFIG_VISUAL_STUDIO_DOT_NET_BASE=""
|
||||
# CONFIG_VISUAL_STUDIO_6_0 is not set
|
||||
CONFIG_VISUAL_STUDIO_6_0_BASE=""
|
||||
CONFIG_EXTRA_CFLAGS_OPTIONS=""
|
||||
CONFIG_EXTRA_LDFLAGS_OPTIONS=""
|
||||
|
||||
#
|
||||
# SSL Library
|
||||
#
|
||||
# CONFIG_SSL_SERVER_ONLY is not set
|
||||
# CONFIG_SSL_CERT_VERIFICATION is not set
|
||||
# CONFIG_SSL_ENABLE_CLIENT is not set
|
||||
CONFIG_SSL_FULL_MODE=y
|
||||
# CONFIG_SSL_PROT_LOW is not set
|
||||
CONFIG_SSL_PROT_MEDIUM=y
|
||||
# CONFIG_SSL_PROT_HIGH is not set
|
||||
CONFIG_SSL_USE_DEFAULT_KEY=y
|
||||
CONFIG_SSL_HAS_PEM=y
|
||||
CONFIG_SSL_USE_PKCS12=y
|
||||
CONFIG_SSL_EXPIRY_TIME=24
|
||||
CONFIG_X509_MAX_CA_CERTS=4
|
||||
CONFIG_SSL_MAX_CERTS=2
|
||||
# CONFIG_WIN32_USE_CRYPTO_LIB is not set
|
||||
# CONFIG_PERFORMANCE_TESTING is not set
|
||||
# CONFIG_SSL_TEST is not set
|
||||
CONFIG_AWHTTPD=y
|
||||
|
||||
#
|
||||
# Awhttpd Configuration
|
||||
#
|
||||
# CONFIG_HTTP_STATIC_BUILD is not set
|
||||
CONFIG_HTTP_HAS_SSL=y
|
||||
CONFIG_HTTP_HTTPS_PORT=443
|
||||
CONFIG_STANDARD_AWHTTPD=y
|
||||
CONFIG_HTTP_WEBROOT=""
|
||||
CONFIG_HTTP_PORT=0
|
||||
# CONFIG_HTTP_USE_TIMEOUT is not set
|
||||
CONFIG_HTTP_TIMEOUT=0
|
||||
CONFIG_HTTP_INITIAL_SLOTS=0
|
||||
CONFIG_HTTP_MAX_USERS=0
|
||||
# CONFIG_HTTP_HAS_CGI is not set
|
||||
CONFIG_HTTP_CGI_EXTENSION=""
|
||||
# CONFIG_HTTP_DIRECTORIES is not set
|
||||
# CONFIG_HTTP_PERM_CHECK is not set
|
||||
# CONFIG_HTTP_HAS_IPV6 is not set
|
||||
# CONFIG_HTTP_VERBOSE is not set
|
||||
# CONFIG_HTTP_IS_DAEMON is not set
|
||||
|
||||
#
|
||||
# Language Bindings
|
||||
#
|
||||
# CONFIG_BINDINGS is not set
|
||||
# CONFIG_CSHARP_BINDINGS is not set
|
||||
# CONFIG_VBNET_BINDINGS is not set
|
||||
CONFIG_DOT_NET_FRAMEWORK_BASE=""
|
||||
# CONFIG_JAVA_BINDINGS is not set
|
||||
CONFIG_JAVA_HOME=""
|
||||
# CONFIG_PERL_BINDINGS is not set
|
||||
CONFIG_PERL_CORE=""
|
||||
CONFIG_PERL_LIB=""
|
||||
|
||||
#
|
||||
# Samples
|
||||
#
|
||||
# CONFIG_SAMPLES is not set
|
||||
# CONFIG_C_SAMPLES is not set
|
||||
# CONFIG_CSHARP_SAMPLES is not set
|
||||
# CONFIG_VBNET_SAMPLES is not set
|
||||
# CONFIG_JAVA_SAMPLES is not set
|
||||
# CONFIG_PERL_SAMPLES is not set
|
||||
|
||||
#
|
||||
# BigInt Options
|
||||
#
|
||||
# CONFIG_BIGINT_CLASSICAL is not set
|
||||
# CONFIG_BIGINT_MONTGOMERY is not set
|
||||
CONFIG_BIGINT_BARRETT=y
|
||||
CONFIG_BIGINT_CRT=y
|
||||
# CONFIG_BIGINT_KARATSUBA is not set
|
||||
MUL_KARATSUBA_THRESH=0
|
||||
SQU_KARATSUBA_THRESH=0
|
||||
CONFIG_BIGINT_SLIDING_WINDOW=y
|
||||
CONFIG_BIGINT_SQUARE=y
|
||||
# CONFIG_BIGINT_CHECK_ON is not set
|
5
openwrt/package/axtls/ipkg/awhttpd.control
Normal file
5
openwrt/package/axtls/ipkg/awhttpd.control
Normal file
@ -0,0 +1,5 @@
|
||||
Package: awhttpd
|
||||
Priority: optional
|
||||
Section: net
|
||||
Description: Anti-Web webserver
|
||||
Depends: libaxtls
|
5
openwrt/package/axtls/ipkg/libaxtls.control
Normal file
5
openwrt/package/axtls/ipkg/libaxtls.control
Normal file
@ -0,0 +1,5 @@
|
||||
Package: libaxtls
|
||||
Priority: optional
|
||||
Section: libs
|
||||
Description: an embedded client/server TLSv1 SSL implementation
|
||||
Depends:
|
33
openwrt/package/axtls/patches/001-opt_flags.patch
Normal file
33
openwrt/package/axtls/patches/001-opt_flags.patch
Normal file
@ -0,0 +1,33 @@
|
||||
diff -ruN axTLS-0.95-old/config/makefile.conf axTLS-0.95-new/config/makefile.conf
|
||||
--- axTLS-0.95-old/config/makefile.conf 2006-02-28 02:50:28.000000000 +0100
|
||||
+++ axTLS-0.95-new/config/makefile.conf 2006-05-18 22:24:02.000000000 +0200
|
||||
@@ -87,20 +87,23 @@
|
||||
endif
|
||||
|
||||
ifdef CONFIG_DEBUG
|
||||
-CFLAGS += -g
|
||||
+OPT_CFLAGS = -g
|
||||
else
|
||||
-LDFLAGS += -s
|
||||
+OPT_LDFLAGS = -s
|
||||
ifdef CONFIG_PLATFORM_SOLARIS
|
||||
-CFLAGS += -O
|
||||
+OPT_CFLAGS = -O
|
||||
else
|
||||
-CFLAGS += -O3
|
||||
+OPT_CFLAGS = -O3
|
||||
endif
|
||||
|
||||
endif # CONFIG_DEBUG
|
||||
endif # WIN32
|
||||
|
||||
-CFLAGS+=$(subst ",, $(strip $(CONFIG_EXTRA_CFLAGS_OPTIONS)))
|
||||
-LDFLAGS+=$(subst ",, $(strip $(CONFIG_EXTRA_LDFLAGS_OPTIONS)))
|
||||
+EXTRA_CFLAGS=$(subst ",, $(strip $(CONFIG_EXTRA_CFLAGS_OPTIONS)))
|
||||
+EXTRA_LDFLAGS=$(subst ",, $(strip $(CONFIG_EXTRA_LDFLAGS_OPTIONS)))
|
||||
+
|
||||
+CFLAGS += $(OPT_CFLAGS) $(EXTRA_CFLAGS)
|
||||
+LDFLAGS += $(OPT_LDFLAGS) $(EXTRA_LDFLAGS)
|
||||
|
||||
endif # not 'clean'
|
||||
|
Loading…
Reference in New Issue
Block a user