1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-06-30 23:41:59 +03:00

[kernel] update to 2.6.26.3 and 2.6.25.16

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12371 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2008-08-22 15:37:19 +00:00
parent ac9bdf20c8
commit 6795275961
38 changed files with 68 additions and 74 deletions

View File

@ -25,11 +25,11 @@ endif
ifeq ($(LINUX_VERSION),2.6.24.7)
LINUX_KERNEL_MD5SUM:=40a73780d51525d28d36dec852c680c4
endif
ifeq ($(LINUX_VERSION),2.6.25.15)
LINUX_KERNEL_MD5SUM:=13ed94f02fc2a11615e3332e1cdf50e7
ifeq ($(LINUX_VERSION),2.6.25.16)
LINUX_KERNEL_MD5SUM:=fdb0e08f0e5a2b4fe6dc711ca35f430e
endif
ifeq ($(LINUX_VERSION),2.6.26.2)
LINUX_KERNEL_MD5SUM:=82472622bd26bed0054790ec3e60ee00
ifeq ($(LINUX_VERSION),2.6.26.3)
LINUX_KERNEL_MD5SUM:=90fe36b18dbac6e2f79374e2df60ac67
endif
# disable the md5sum check for unknown kernel versions

View File

@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
BOARD:=adm5120
BOARDNAME:=Infineon/ADMtek ADM5120
#LINUX_VERSION:=2.6.25.15
LINUX_VERSION:=2.6.26.2
#LINUX_VERSION:=2.6.25.16
LINUX_VERSION:=2.6.26.3
SUBTARGETS:=router_le router_be
INITRAMFS_EXTRA_FILES:=

View File

@ -39,7 +39,7 @@
/* Enable 1k I/O space granularity on the Intel P64H2 */
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
{
@@ -1929,3 +1932,4 @@
@@ -1934,3 +1937,4 @@
quirk_msi_intx_disable_bug);
#endif /* CONFIG_PCI_MSI */

View File

@ -11,7 +11,7 @@ BOARD:=ar7
BOARDNAME:=TI AR7
FEATURES:=squashfs jffs2 atm
LINUX_VERSION:=2.6.25.15
LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk

View File

@ -11,7 +11,7 @@ BOARD:=ar71xx
BOARDNAME:=Atheros AR71xx
FEATURES:=squashfs tgz broken
LINUX_VERSION:=2.6.26.2
LINUX_VERSION:=2.6.26.3
include $(INCLUDE_DIR)/target.mk

View File

@ -1,6 +1,6 @@
--- a/drivers/mtd/redboot.c
+++ b/drivers/mtd/redboot.c
@@ -59,31 +59,32 @@
@@ -62,31 +62,32 @@
static char nullstring[] = "unallocated";
#endif
@ -40,7 +40,7 @@
printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
master->name, offset);
@@ -155,6 +156,11 @@
@@ -158,6 +159,11 @@
}
if (i == numslots) {
/* Didn't find it */

View File

@ -11,7 +11,7 @@ BOARD:=at91
BOARDNAME:=Atmel AT91
FEATURES:=squashfs usb
LINUX_VERSION:=2.6.25.15
LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk

View File

@ -1,6 +1,6 @@
--- a/drivers/usb/serial/usb-serial.c
+++ b/drivers/usb/serial/usb-serial.c
@@ -905,7 +905,7 @@
@@ -904,7 +904,7 @@
dev_err(&interface->dev, "No free urbs available\n");
goto probe_error;
}

View File

@ -11,7 +11,7 @@ BOARD:=atheros
BOARDNAME:=Atheros 231x/5312
FEATURES:=squashfs jffs2
LINUX_VERSION:=2.6.26.2
LINUX_VERSION:=2.6.26.3
include $(INCLUDE_DIR)/target.mk

View File

@ -1,7 +1,5 @@
Index: linux-2.6.26.2/drivers/watchdog/Kconfig
===================================================================
--- linux-2.6.26.2.orig/drivers/watchdog/Kconfig 2008-08-14 16:54:30.000000000 +0200
+++ linux-2.6.26.2/drivers/watchdog/Kconfig 2008-08-14 16:55:40.000000000 +0200
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
@@ -683,6 +683,12 @@
help
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
@ -15,10 +13,8 @@ Index: linux-2.6.26.2/drivers/watchdog/Kconfig
# PARISC Architecture
# POWERPC Architecture
Index: linux-2.6.26.2/drivers/watchdog/Makefile
===================================================================
--- linux-2.6.26.2.orig/drivers/watchdog/Makefile 2008-08-14 16:55:44.000000000 +0200
+++ linux-2.6.26.2/drivers/watchdog/Makefile 2008-08-14 16:58:16.000000000 +0200
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
@@ -97,6 +97,7 @@
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o

View File

@ -1,5 +1,5 @@
--- a/drivers/net/ar2313/ar2313.c (revisione 11911)
+++ a/drivers/net/ar2313/ar2313.c (copia locale)
--- a/drivers/net/ar2313/ar2313.c
+++ b/drivers/net/ar2313/ar2313.c
@@ -291,7 +291,7 @@
sp->mii_bus.write = mdiobus_write;
sp->mii_bus.reset = mdiobus_reset;

View File

@ -1,6 +1,6 @@
--- a/drivers/mtd/redboot.c
+++ b/drivers/mtd/redboot.c
@@ -59,31 +59,32 @@
@@ -62,31 +62,32 @@
static char nullstring[] = "unallocated";
#endif
@ -40,7 +40,7 @@
printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
master->name, offset);
@@ -155,6 +156,11 @@
@@ -158,6 +159,11 @@
}
if (i == numslots) {
/* Didn't find it */

View File

@ -11,7 +11,7 @@ BOARD:=au1000
BOARDNAME:=RMI/AMD AU1x00
FEATURES:=jffs2 usb pci
LINUX_VERSION:=2.6.25.15
LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += yamonenv

View File

@ -10,7 +10,7 @@ ARCH:=avr32
BOARD:=avr32
BOARDNAME:=Atmel AVR32
FEATURES:=squashfs
LINUX_VERSION:=2.6.25.15
LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk

View File

@ -11,7 +11,7 @@ BOARD:=brcm47xx
BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb
LINUX_VERSION:=2.6.25.15
LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-switch kmod-diag

View File

@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM963xx
FEATURES:=squashfs jffs2 broken usb atm
LINUX_VERSION:=2.6.25.15
LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk

View File

@ -10,7 +10,7 @@ ARCH:=cris
BOARD:=etrax
BOARDNAME:=Foxboard (ETRAX 100LX)
FEATURES:=squashfs jffs2 broken
LINUX_VERSION:=2.6.25.15
LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk

View File

@ -428,6 +428,7 @@ CONFIG_HZ_100=y
# CONFIG_HZ_256 is not set
# CONFIG_HZ_300 is not set
# CONFIG_HZ_48 is not set
# CONFIG_I2C_ALGOBIT is not set
# CONFIG_I2C_ALGOPCA is not set
# CONFIG_I2C_ALGOPCF is not set
# CONFIG_I2C_ALI1535 is not set
@ -442,6 +443,7 @@ CONFIG_HZ_100=y
# CONFIG_I2C_DEBUG_CORE is not set
# CONFIG_I2C_ELEKTOR is not set
# CONFIG_I2C_GPIO is not set
# CONFIG_I2C_HELPER_AUTO is not set
# CONFIG_I2C_I801 is not set
# CONFIG_I2C_I810 is not set
# CONFIG_I2C_IBM_IIC is not set

View File

@ -1,6 +1,6 @@
--- a/drivers/net/r8169.c
+++ b/drivers/net/r8169.c
@@ -1537,7 +1537,7 @@
@@ -1539,7 +1539,7 @@
.hw_start = rtl_hw_start_8169,
.region = 1,
.align = 0,
@ -9,7 +9,7 @@
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.msi = 0
@@ -1546,7 +1546,7 @@
@@ -1548,7 +1548,7 @@
.hw_start = rtl_hw_start_8168,
.region = 2,
.align = 8,
@ -18,7 +18,7 @@
TxErr | TxOK | RxOK | RxErr,
.napi_event = TxErr | TxOK | RxOK | RxOverflow,
.msi = RTL_FEATURE_MSI
@@ -1555,7 +1555,7 @@
@@ -1557,7 +1557,7 @@
.hw_start = rtl_hw_start_8101,
.region = 2,
.align = 8,
@ -27,7 +27,7 @@
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.msi = RTL_FEATURE_MSI
@@ -2903,10 +2903,12 @@
@@ -2905,10 +2905,12 @@
break;
}

View File

@ -8,7 +8,7 @@
static int debug;
static struct usb_serial *serial_table[SERIAL_TTY_MINORS]; /* initially all NULL */
static DEFINE_MUTEX(table_lock);
@@ -904,7 +905,7 @@
@@ -903,7 +904,7 @@
dev_err(&interface->dev, "No free urbs available\n");
goto probe_error;
}
@ -17,7 +17,7 @@
port->bulk_in_size = buffer_size;
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
port->bulk_in_buffer = kmalloc (buffer_size, GFP_KERNEL);
@@ -1316,3 +1317,5 @@
@@ -1315,3 +1316,5 @@
module_param(debug, bool, S_IRUGO | S_IWUSR);
MODULE_PARM_DESC(debug, "Debug enabled or not");

View File

@ -1,7 +1,5 @@
Index: linux-2.6.26.2/drivers/mtd/redboot.c
===================================================================
--- linux-2.6.26.2.orig/drivers/mtd/redboot.c 2008-08-19 19:32:17.000000000 +0200
+++ linux-2.6.26.2/drivers/mtd/redboot.c 2008-08-19 19:47:34.000000000 +0200
--- a/drivers/mtd/redboot.c
+++ b/drivers/mtd/redboot.c
@@ -13,6 +13,8 @@
#include <linux/mtd/mtd.h>
#include <linux/mtd/partitions.h>
@ -19,7 +17,7 @@ Index: linux-2.6.26.2/drivers/mtd/redboot.c
int nrparts = 0;
struct fis_image_desc *buf;
struct mtd_partition *parts;
@@ -217,14 +220,14 @@
@@ -211,14 +214,14 @@
}
}
#endif
@ -36,7 +34,7 @@ Index: linux-2.6.26.2/drivers/mtd/redboot.c
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
if (nulllen > 0) {
strcpy(nullname, nullstring);
@@ -243,6 +246,8 @@
@@ -237,6 +240,8 @@
}
#endif
for ( ; i<nrparts; i++) {
@ -45,7 +43,7 @@ Index: linux-2.6.26.2/drivers/mtd/redboot.c
parts[i].size = fl->img->size;
parts[i].offset = fl->img->flash_base;
parts[i].name = names;
@@ -276,6 +281,14 @@
@@ -270,6 +275,14 @@
fl = fl->next;
kfree(tmp_fl);
}

View File

@ -1,6 +1,6 @@
--- a/drivers/net/r8169.c
+++ b/drivers/net/r8169.c
@@ -1537,7 +1537,7 @@
@@ -1539,7 +1539,7 @@
.hw_start = rtl_hw_start_8169,
.region = 1,
.align = 0,
@ -9,7 +9,7 @@
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.msi = 0
@@ -1546,7 +1546,7 @@
@@ -1548,7 +1548,7 @@
.hw_start = rtl_hw_start_8168,
.region = 2,
.align = 8,
@ -18,7 +18,7 @@
TxErr | TxOK | RxOK | RxErr,
.napi_event = TxErr | TxOK | RxOK | RxOverflow,
.msi = RTL_FEATURE_MSI
@@ -1555,7 +1555,7 @@
@@ -1557,7 +1557,7 @@
.hw_start = rtl_hw_start_8101,
.region = 2,
.align = 8,
@ -27,7 +27,7 @@
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.msi = RTL_FEATURE_MSI
@@ -2903,10 +2903,12 @@
@@ -2905,10 +2905,12 @@
break;
}

View File

@ -8,7 +8,7 @@
static int debug;
static struct usb_serial *serial_table[SERIAL_TTY_MINORS]; /* initially all NULL */
static DEFINE_MUTEX(table_lock);
@@ -815,7 +816,7 @@
@@ -814,7 +815,7 @@
dev_err(&interface->dev, "No free urbs available\n");
goto probe_error;
}
@ -17,7 +17,7 @@
port->bulk_in_size = buffer_size;
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
port->bulk_in_buffer = kmalloc (buffer_size, GFP_KERNEL);
@@ -1229,3 +1230,5 @@
@@ -1228,3 +1229,5 @@
module_param(debug, bool, S_IRUGO | S_IWUSR);
MODULE_PARM_DESC(debug, "Debug enabled or not");

View File

@ -6510,7 +6510,7 @@
+
--- a/drivers/crypto/padlock-aes.c
+++ b/drivers/crypto/padlock-aes.c
@@ -385,12 +385,12 @@
@@ -411,12 +411,12 @@
int ret;
if (!cpu_has_xcrypt) {
@ -6527,7 +6527,7 @@
--- a/drivers/crypto/padlock-sha.c
+++ b/drivers/crypto/padlock-sha.c
@@ -254,12 +254,12 @@
@@ -263,12 +263,12 @@
int rc = -ENODEV;
if (!cpu_has_phe) {

View File

@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=ifxmips
BOARDNAME:=Infineon Mips
FEATURES:=squashfs jffs2
LINUX_VERSION:=2.6.25.15
LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES:=uboot-ifxmips

View File

@ -11,7 +11,7 @@ BOARD:=iop32x
BOARDNAME:=Intel IOP32x
FEATURES:=squashfs jffs2
LINUX_VERSION:=2.6.26.2
LINUX_VERSION:=2.6.26.3
include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
FEATURES:=squashfs
SUBTARGETS=generic harddisk
LINUX_VERSION:=2.6.26.2
LINUX_VERSION:=2.6.26.3
include $(INCLUDE_DIR)/target.mk

View File

@ -1,15 +1,15 @@
--- a/drivers/mtd/redboot.c
+++ b/drivers/mtd/redboot.c
@@ -13,6 +13,8 @@
#include <linux/mtd/mtd.h>
#include <linux/mtd/partitions.h>
@@ -15,6 +15,8 @@
#define BOARD_CONFIG_PART "boardconfig"
+#include <asm/mach-types.h>
+
struct fis_image_desc {
unsigned char name[16]; // Null terminated name
uint32_t flash_base; // Address within FLASH of image
@@ -30,7 +32,8 @@
@@ -32,7 +34,8 @@
struct fis_list *next;
};
@ -19,7 +19,7 @@
module_param(directory, int, 0);
static inline int redboot_checksum(struct fis_image_desc *img)
@@ -58,6 +61,8 @@
@@ -61,6 +64,8 @@
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
static char nullstring[] = "unallocated";
#endif

View File

@ -1,6 +1,6 @@
--- a/arch/arm/mach-ixp4xx/wg302v1-setup.c
+++ b/arch/arm/mach-ixp4xx/wg302v1-setup.c
@@ -99,6 +99,36 @@
@@ -115,6 +115,36 @@
&wg302v1_eth[0],
};
@ -37,7 +37,7 @@
static void __init wg302v1_init(void)
{
ixp4xx_sys_init();
@@ -117,6 +147,7 @@
@@ -133,6 +163,7 @@
/* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
.phys_io = IXP4XX_PERIPHERAL_BASE_PHYS,
.io_pg_offst = ((IXP4XX_PERIPHERAL_BASE_VIRT) >> 18) & 0xfffc,

View File

@ -44,4 +44,4 @@
+ platform_device_register(&cambria_gpio);
platform_device_register(&cambria_optional_uart);
cambria_npec_data.phy = 2;
platform_device_register(&cambria_npec_device);

View File

@ -11,7 +11,7 @@ BOARD:=magicbox
BOARDNAME:=Magicbox
FEATURES:=squashfs pci
LINUX_VERSION:=2.6.26.2
LINUX_VERSION:=2.6.26.3
LINUX_KARCH:=ppc
include $(INCLUDE_DIR)/target.mk

View File

@ -11,7 +11,7 @@ BOARD:=orion
BOARDNAME:=Marvell Orion
FEATURES:=squashfs
LINUX_VERSION:=2.6.26.2
LINUX_VERSION:=2.6.26.3
include $(INCLUDE_DIR)/target.mk

View File

@ -11,7 +11,7 @@ BOARD:=ppc40x
BOARDNAME:=AMCC/IBM PPC40x
FEATURES:=squashfs
LINUX_VERSION:=2.6.26.2
LINUX_VERSION:=2.6.26.3
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk

View File

@ -11,7 +11,7 @@ BOARD:=ppc44x
BOARDNAME:=AMCC/IBM PPC44x
FEATURES:=squashfs
LINUX_VERSION:=2.6.26.2
LINUX_VERSION:=2.6.26.3
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk

View File

@ -10,7 +10,7 @@ ARCH:=powerpc
BOARD:=ps3
BOARDNAME:=Sony PS3 Game Console
LINUX_VERSION:=2.6.25.15
LINUX_VERSION:=2.6.25.16
KERNEL_CC:=

View File

@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
FEATURES:=ext2
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
LINUX_VERSION:=2.6.26.2
LINUX_VERSION:=2.6.26.3
include $(INCLUDE_DIR)/target.mk

View File

@ -1,7 +1,5 @@
Index: linux-2.6.26/arch/um/Makefile-i386
===================================================================
--- linux-2.6.26.orig/arch/um/Makefile-i386 2008-07-28 13:43:40.412036547 +0200
+++ linux-2.6.26/arch/um/Makefile-i386 2008-07-28 13:44:00.234033125 +0200
--- a/arch/um/Makefile-i386
+++ b/arch/um/Makefile-i386
@@ -35,7 +35,7 @@
# Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
# a lot more stack due to the lack of sharing of stacklots. Also, gcc

View File

@ -12,7 +12,7 @@ BOARDNAME:=x86
FEATURES:=squashfs jffs2 ext2 vdi
SUBTARGETS=generic
LINUX_VERSION:=2.6.25.15
LINUX_VERSION:=2.6.25.16
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci