1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-05 01:08:54 +03:00

[package] prevent busybox's ping6 from crashing (#4604)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18528 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-11-24 22:13:19 +00:00
parent 9351b5dfae
commit 6b398193ef
2 changed files with 13 additions and 1 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.14.4
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.busybox.net/downloads \

View File

@ -0,0 +1,12 @@
Index: busybox-1.15.2/networking/ping.c
===================================================================
--- busybox-1.15.2.orig/networking/ping.c 2009-11-24 22:57:29.000000000 +0100
+++ busybox-1.15.2/networking/ping.c 2009-11-24 22:58:58.000000000 +0100
@@ -769,6 +769,7 @@
int ping6_main(int argc, char **argv) MAIN_EXTERNALLY_VISIBLE;
int ping6_main(int argc UNUSED_PARAM, char **argv)
{
+ argv[-1] = argv[0];
argv[0] = (char*)"-6";
return ping_main(0 /* argc+1 - but it's unused anyway */,
argv - 1);