mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 23:16:16 +02:00
kernel: update linux 3.0 to 3.0.17
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29725 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
f49dda30e2
commit
6b4b162100
@ -29,8 +29,8 @@ endif
|
|||||||
ifeq ($(LINUX_VERSION),2.6.39.4)
|
ifeq ($(LINUX_VERSION),2.6.39.4)
|
||||||
LINUX_KERNEL_MD5SUM:=a17c748c2070168f1e784e9605ca043d
|
LINUX_KERNEL_MD5SUM:=a17c748c2070168f1e784e9605ca043d
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),3.0.12)
|
ifeq ($(LINUX_VERSION),3.0.17)
|
||||||
LINUX_KERNEL_MD5SUM:=aa5d56ddc2ef01a61759ceeb0f6b8308
|
LINUX_KERNEL_MD5SUM:=fcdd6a945445336e4cd28b2d195f1fea
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),3.1.4)
|
ifeq ($(LINUX_VERSION),3.1.4)
|
||||||
LINUX_KERNEL_MD5SUM:=52643e5a013d450ad69627c3cac490cb
|
LINUX_KERNEL_MD5SUM:=52643e5a013d450ad69627c3cac490cb
|
||||||
|
@ -11,7 +11,7 @@ BOARD:=brcm47xx
|
|||||||
BOARDNAME:=Broadcom BCM947xx/953xx
|
BOARDNAME:=Broadcom BCM947xx/953xx
|
||||||
FEATURES:=squashfs usb pcmcia
|
FEATURES:=squashfs usb pcmcia
|
||||||
|
|
||||||
LINUX_VERSION:=3.0.12
|
LINUX_VERSION:=3.0.17
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
|
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
|
||||||
|
@ -37,7 +37,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
|||||||
depends on USB_OHCI_HCD
|
depends on USB_OHCI_HCD
|
||||||
--- a/drivers/usb/host/ohci-hcd.c
|
--- a/drivers/usb/host/ohci-hcd.c
|
||||||
+++ b/drivers/usb/host/ohci-hcd.c
|
+++ b/drivers/usb/host/ohci-hcd.c
|
||||||
@@ -1114,6 +1114,11 @@ MODULE_LICENSE ("GPL");
|
@@ -1111,6 +1111,11 @@ MODULE_LICENSE ("GPL");
|
||||||
#define PLATFORM_DRIVER ohci_hcd_ath79_driver
|
#define PLATFORM_DRIVER ohci_hcd_ath79_driver
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -49,7 +49,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
|||||||
#if !defined(PCI_DRIVER) && \
|
#if !defined(PCI_DRIVER) && \
|
||||||
!defined(PLATFORM_DRIVER) && \
|
!defined(PLATFORM_DRIVER) && \
|
||||||
!defined(OMAP1_PLATFORM_DRIVER) && \
|
!defined(OMAP1_PLATFORM_DRIVER) && \
|
||||||
@@ -1123,7 +1128,8 @@ MODULE_LICENSE ("GPL");
|
@@ -1120,7 +1125,8 @@ MODULE_LICENSE ("GPL");
|
||||||
!defined(PS3_SYSTEM_BUS_DRIVER) && \
|
!defined(PS3_SYSTEM_BUS_DRIVER) && \
|
||||||
!defined(SM501_OHCI_DRIVER) && \
|
!defined(SM501_OHCI_DRIVER) && \
|
||||||
!defined(TMIO_OHCI_DRIVER) && \
|
!defined(TMIO_OHCI_DRIVER) && \
|
||||||
@ -59,7 +59,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
|||||||
#error "missing bus glue for ohci-hcd"
|
#error "missing bus glue for ohci-hcd"
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@@ -1207,9 +1213,19 @@ static int __init ohci_hcd_mod_init(void
|
@@ -1204,9 +1210,19 @@ static int __init ohci_hcd_mod_init(void
|
||||||
goto error_tmio;
|
goto error_tmio;
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -79,7 +79,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
|||||||
#ifdef TMIO_OHCI_DRIVER
|
#ifdef TMIO_OHCI_DRIVER
|
||||||
platform_driver_unregister(&TMIO_OHCI_DRIVER);
|
platform_driver_unregister(&TMIO_OHCI_DRIVER);
|
||||||
error_tmio:
|
error_tmio:
|
||||||
@@ -1263,6 +1279,9 @@ module_init(ohci_hcd_mod_init);
|
@@ -1260,6 +1276,9 @@ module_init(ohci_hcd_mod_init);
|
||||||
|
|
||||||
static void __exit ohci_hcd_mod_exit(void)
|
static void __exit ohci_hcd_mod_exit(void)
|
||||||
{
|
{
|
||||||
|
@ -38,7 +38,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
|||||||
depends on USB_OHCI_HCD && SUPERH
|
depends on USB_OHCI_HCD && SUPERH
|
||||||
--- a/drivers/usb/host/ohci-hcd.c
|
--- a/drivers/usb/host/ohci-hcd.c
|
||||||
+++ b/drivers/usb/host/ohci-hcd.c
|
+++ b/drivers/usb/host/ohci-hcd.c
|
||||||
@@ -1079,11 +1079,6 @@ MODULE_LICENSE ("GPL");
|
@@ -1076,11 +1076,6 @@ MODULE_LICENSE ("GPL");
|
||||||
#define PS3_SYSTEM_BUS_DRIVER ps3_ohci_driver
|
#define PS3_SYSTEM_BUS_DRIVER ps3_ohci_driver
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -50,7 +50,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
|||||||
#ifdef CONFIG_MFD_SM501
|
#ifdef CONFIG_MFD_SM501
|
||||||
#include "ohci-sm501.c"
|
#include "ohci-sm501.c"
|
||||||
#define SM501_OHCI_DRIVER ohci_hcd_sm501_driver
|
#define SM501_OHCI_DRIVER ohci_hcd_sm501_driver
|
||||||
@@ -1128,7 +1123,6 @@ MODULE_LICENSE ("GPL");
|
@@ -1125,7 +1120,6 @@ MODULE_LICENSE ("GPL");
|
||||||
!defined(PS3_SYSTEM_BUS_DRIVER) && \
|
!defined(PS3_SYSTEM_BUS_DRIVER) && \
|
||||||
!defined(SM501_OHCI_DRIVER) && \
|
!defined(SM501_OHCI_DRIVER) && \
|
||||||
!defined(TMIO_OHCI_DRIVER) && \
|
!defined(TMIO_OHCI_DRIVER) && \
|
||||||
@ -58,7 +58,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
|||||||
!defined(PLATFORM_OHCI_DRIVER)
|
!defined(PLATFORM_OHCI_DRIVER)
|
||||||
#error "missing bus glue for ohci-hcd"
|
#error "missing bus glue for ohci-hcd"
|
||||||
#endif
|
#endif
|
||||||
@@ -1195,12 +1189,6 @@ static int __init ohci_hcd_mod_init(void
|
@@ -1192,12 +1186,6 @@ static int __init ohci_hcd_mod_init(void
|
||||||
goto error_pci;
|
goto error_pci;
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -71,7 +71,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
|||||||
#ifdef SM501_OHCI_DRIVER
|
#ifdef SM501_OHCI_DRIVER
|
||||||
retval = platform_driver_register(&SM501_OHCI_DRIVER);
|
retval = platform_driver_register(&SM501_OHCI_DRIVER);
|
||||||
if (retval < 0)
|
if (retval < 0)
|
||||||
@@ -1234,10 +1222,6 @@ static int __init ohci_hcd_mod_init(void
|
@@ -1231,10 +1219,6 @@ static int __init ohci_hcd_mod_init(void
|
||||||
platform_driver_unregister(&SM501_OHCI_DRIVER);
|
platform_driver_unregister(&SM501_OHCI_DRIVER);
|
||||||
error_sm501:
|
error_sm501:
|
||||||
#endif
|
#endif
|
||||||
@ -82,7 +82,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
|||||||
#ifdef PCI_DRIVER
|
#ifdef PCI_DRIVER
|
||||||
pci_unregister_driver(&PCI_DRIVER);
|
pci_unregister_driver(&PCI_DRIVER);
|
||||||
error_pci:
|
error_pci:
|
||||||
@@ -1288,9 +1272,6 @@ static void __exit ohci_hcd_mod_exit(voi
|
@@ -1285,9 +1269,6 @@ static void __exit ohci_hcd_mod_exit(voi
|
||||||
#ifdef SM501_OHCI_DRIVER
|
#ifdef SM501_OHCI_DRIVER
|
||||||
platform_driver_unregister(&SM501_OHCI_DRIVER);
|
platform_driver_unregister(&SM501_OHCI_DRIVER);
|
||||||
#endif
|
#endif
|
||||||
|
@ -177,7 +177,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
|
|||||||
+MODULE_ALIAS("platform:bcm63xx_ohci");
|
+MODULE_ALIAS("platform:bcm63xx_ohci");
|
||||||
--- a/drivers/usb/host/ohci-hcd.c
|
--- a/drivers/usb/host/ohci-hcd.c
|
||||||
+++ b/drivers/usb/host/ohci-hcd.c
|
+++ b/drivers/usb/host/ohci-hcd.c
|
||||||
@@ -1058,6 +1058,11 @@ MODULE_LICENSE ("GPL");
|
@@ -1055,6 +1055,11 @@ MODULE_LICENSE ("GPL");
|
||||||
#define PLATFORM_DRIVER ohci_hcd_da8xx_driver
|
#define PLATFORM_DRIVER ohci_hcd_da8xx_driver
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -191,7 +191,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
|
|||||||
#define PLATFORM_DRIVER ohci_hcd_sh_driver
|
#define PLATFORM_DRIVER ohci_hcd_sh_driver
|
||||||
--- a/drivers/usb/host/ohci.h
|
--- a/drivers/usb/host/ohci.h
|
||||||
+++ b/drivers/usb/host/ohci.h
|
+++ b/drivers/usb/host/ohci.h
|
||||||
@@ -646,7 +646,7 @@ static inline u32 hc32_to_cpup (const st
|
@@ -645,7 +645,7 @@ static inline u32 hc32_to_cpup (const st
|
||||||
* some big-endian SOC implementations. Same thing happens with PSW access.
|
* some big-endian SOC implementations. Same thing happens with PSW access.
|
||||||
*/
|
*/
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
@@ -751,6 +751,76 @@ static struct board_info __initdata boar
|
@@ -746,6 +746,76 @@ static struct board_info __initdata boar
|
||||||
},
|
},
|
||||||
};
|
};
|
||||||
|
|
||||||
@ -77,7 +77,7 @@
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
/*
|
/*
|
||||||
@@ -1661,6 +1731,7 @@ static const struct board_info __initdat
|
@@ -1656,6 +1726,7 @@ static const struct board_info __initdat
|
||||||
&board_rta1025w_16,
|
&board_rta1025w_16,
|
||||||
&board_96348_D4PW,
|
&board_96348_D4PW,
|
||||||
&board_spw500v,
|
&board_spw500v,
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
@@ -1704,6 +1704,81 @@ static struct board_info __initdata boar
|
@@ -1699,6 +1699,81 @@ static struct board_info __initdata boar
|
||||||
.spis = nb4_spi_devices,
|
.spis = nb4_spi_devices,
|
||||||
.num_spis = ARRAY_SIZE(nb4_spi_devices),
|
.num_spis = ARRAY_SIZE(nb4_spi_devices),
|
||||||
};
|
};
|
||||||
@ -82,7 +82,7 @@
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
/*
|
/*
|
||||||
@@ -1746,6 +1821,7 @@ static const struct board_info __initdat
|
@@ -1741,6 +1816,7 @@ static const struct board_info __initdat
|
||||||
&board_nb4_ser_r2,
|
&board_nb4_ser_r2,
|
||||||
&board_nb4_fxc_r1,
|
&board_nb4_fxc_r1,
|
||||||
&board_nb4_fxc_r2,
|
&board_nb4_fxc_r2,
|
||||||
|
@ -44,7 +44,7 @@
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
/*
|
/*
|
||||||
@@ -1789,6 +1826,7 @@ static const struct board_info __initdat
|
@@ -1784,6 +1821,7 @@ static const struct board_info __initdat
|
||||||
&board_96338gw,
|
&board_96338gw,
|
||||||
&board_96338w,
|
&board_96338w,
|
||||||
&board_96338w2_e7t,
|
&board_96338w2_e7t,
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
@@ -1816,6 +1816,72 @@ static struct board_info __initdata boar
|
@@ -1811,6 +1811,72 @@ static struct board_info __initdata boar
|
||||||
},
|
},
|
||||||
},
|
},
|
||||||
};
|
};
|
||||||
@ -73,7 +73,7 @@
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
/*
|
/*
|
||||||
@@ -1860,6 +1926,7 @@ static const struct board_info __initdat
|
@@ -1855,6 +1921,7 @@ static const struct board_info __initdat
|
||||||
&board_nb4_fxc_r1,
|
&board_nb4_fxc_r1,
|
||||||
&board_nb4_fxc_r2,
|
&board_nb4_fxc_r2,
|
||||||
&board_HW553,
|
&board_HW553,
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
@@ -858,6 +858,63 @@ static struct board_info __initdata boar
|
@@ -853,6 +853,63 @@ static struct board_info __initdata boar
|
||||||
},
|
},
|
||||||
};
|
};
|
||||||
|
|
||||||
@ -64,7 +64,7 @@
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
/*
|
/*
|
||||||
@@ -1911,6 +1968,7 @@ static const struct board_info __initdat
|
@@ -1906,6 +1963,7 @@ static const struct board_info __initdat
|
||||||
&board_96348_D4PW,
|
&board_96348_D4PW,
|
||||||
&board_spw500v,
|
&board_spw500v,
|
||||||
&board_96348sv,
|
&board_96348sv,
|
||||||
@ -72,7 +72,7 @@
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
#ifdef CONFIG_BCM63XX_CPU_6358
|
#ifdef CONFIG_BCM63XX_CPU_6358
|
||||||
@@ -2064,6 +2122,22 @@ void __init board_prom_init(void)
|
@@ -2059,6 +2117,22 @@ void __init board_prom_init(void)
|
||||||
val = bcm_mpi_readl(MPI_CSBASE_REG(0));
|
val = bcm_mpi_readl(MPI_CSBASE_REG(0));
|
||||||
val &= MPI_CSBASE_BASE_MASK;
|
val &= MPI_CSBASE_BASE_MASK;
|
||||||
boot_addr = (u8 *)KSEG1ADDR(val);
|
boot_addr = (u8 *)KSEG1ADDR(val);
|
||||||
@ -95,7 +95,7 @@
|
|||||||
|
|
||||||
/* dump cfe version */
|
/* dump cfe version */
|
||||||
cfe = boot_addr + BCM963XX_CFE_VERSION_OFFSET;
|
cfe = boot_addr + BCM963XX_CFE_VERSION_OFFSET;
|
||||||
@@ -2265,6 +2339,13 @@ int __init board_register_devices(void)
|
@@ -2260,6 +2334,13 @@ int __init board_register_devices(void)
|
||||||
val = bcm_mpi_readl(MPI_CSBASE_REG(0));
|
val = bcm_mpi_readl(MPI_CSBASE_REG(0));
|
||||||
val &= MPI_CSBASE_BASE_MASK;
|
val &= MPI_CSBASE_BASE_MASK;
|
||||||
|
|
||||||
|
@ -63,7 +63,7 @@
|
|||||||
static struct board_info __initdata board_96348gw = {
|
static struct board_info __initdata board_96348gw = {
|
||||||
.name = "96348GW",
|
.name = "96348GW",
|
||||||
.expected_cpu_id = 0x6348,
|
.expected_cpu_id = 0x6348,
|
||||||
@@ -1969,6 +2025,7 @@ static const struct board_info __initdat
|
@@ -1964,6 +2020,7 @@ static const struct board_info __initdat
|
||||||
&board_spw500v,
|
&board_spw500v,
|
||||||
&board_96348sv,
|
&board_96348sv,
|
||||||
&board_V2500V_BB,
|
&board_V2500V_BB,
|
||||||
|
@ -50,7 +50,7 @@
|
|||||||
static struct board_info __initdata board_96348gw = {
|
static struct board_info __initdata board_96348gw = {
|
||||||
.name = "96348GW",
|
.name = "96348GW",
|
||||||
.expected_cpu_id = 0x6348,
|
.expected_cpu_id = 0x6348,
|
||||||
@@ -2026,6 +2069,7 @@ static const struct board_info __initdat
|
@@ -2021,6 +2064,7 @@ static const struct board_info __initdat
|
||||||
&board_96348sv,
|
&board_96348sv,
|
||||||
&board_V2500V_BB,
|
&board_V2500V_BB,
|
||||||
&board_V2110,
|
&board_V2110,
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
@@ -1332,6 +1332,8 @@ static struct board_info __initdata boar
|
@@ -1327,6 +1327,8 @@ static struct board_info __initdata boar
|
||||||
.name = "DWV-S0",
|
.name = "DWV-S0",
|
||||||
.expected_cpu_id = 0x6358,
|
.expected_cpu_id = 0x6358,
|
||||||
|
|
||||||
@ -9,7 +9,7 @@
|
|||||||
.has_enet0 = 1,
|
.has_enet0 = 1,
|
||||||
.has_enet1 = 1,
|
.has_enet1 = 1,
|
||||||
.has_pci = 1,
|
.has_pci = 1,
|
||||||
@@ -1347,6 +1349,7 @@ static struct board_info __initdata boar
|
@@ -1342,6 +1344,7 @@ static struct board_info __initdata boar
|
||||||
},
|
},
|
||||||
|
|
||||||
.has_ohci0 = 1,
|
.has_ohci0 = 1,
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
@@ -2113,7 +2113,7 @@ static void __init nb4_nvram_fixup(void)
|
@@ -2108,7 +2108,7 @@ static void __init nb4_nvram_fixup(void)
|
||||||
* bcm4318 WLAN work
|
* bcm4318 WLAN work
|
||||||
*/
|
*/
|
||||||
#ifdef CONFIG_SSB_PCIHOST
|
#ifdef CONFIG_SSB_PCIHOST
|
||||||
@ -9,7 +9,7 @@
|
|||||||
.revision = 0x02,
|
.revision = 0x02,
|
||||||
.board_rev = 0x17,
|
.board_rev = 0x17,
|
||||||
.country_code = 0x0,
|
.country_code = 0x0,
|
||||||
@@ -2133,6 +2133,7 @@ static struct ssb_sprom bcm63xx_sprom =
|
@@ -2128,6 +2128,7 @@ static struct ssb_sprom bcm63xx_sprom =
|
||||||
.boardflags_lo = 0x2848,
|
.boardflags_lo = 0x2848,
|
||||||
.boardflags_hi = 0x0000,
|
.boardflags_hi = 0x0000,
|
||||||
};
|
};
|
||||||
|
@ -154,35 +154,15 @@
|
|||||||
{
|
{
|
||||||
u16 tmp = pcicore_read16(pc, SSB_PCICORE_SPROM(0));
|
u16 tmp = pcicore_read16(pc, SSB_PCICORE_SPROM(0));
|
||||||
if (((tmp & 0xF000) >> 12) != pc->dev->core_index) {
|
if (((tmp & 0xF000) >> 12) != pc->dev->core_index) {
|
||||||
@@ -514,12 +514,16 @@ static void ssb_pcicore_pcie_setup_worka
|
@@ -514,7 +514,7 @@ static void ssb_pcicore_pcie_setup_worka
|
||||||
* Generic and Clientmode operation code.
|
* Generic and Clientmode operation code.
|
||||||
**************************************************/
|
**************************************************/
|
||||||
|
|
||||||
-static void ssb_pcicore_init_clientmode(struct ssb_pcicore *pc)
|
-static void ssb_pcicore_init_clientmode(struct ssb_pcicore *pc)
|
||||||
+static void __devinit ssb_pcicore_init_clientmode(struct ssb_pcicore *pc)
|
+static void __devinit ssb_pcicore_init_clientmode(struct ssb_pcicore *pc)
|
||||||
{
|
{
|
||||||
- ssb_pcicore_fix_sprom_core_index(pc);
|
struct ssb_device *pdev = pc->dev;
|
||||||
+ struct ssb_device *pdev = pc->dev;
|
struct ssb_bus *bus = pdev->bus;
|
||||||
+ struct ssb_bus *bus = pdev->bus;
|
|
||||||
+
|
|
||||||
+ if (bus->bustype == SSB_BUSTYPE_PCI)
|
|
||||||
+ ssb_pcicore_fix_sprom_core_index(pc);
|
|
||||||
|
|
||||||
/* Disable PCI interrupts. */
|
|
||||||
- ssb_write32(pc->dev, SSB_INTVEC, 0);
|
|
||||||
+ ssb_write32(pdev, SSB_INTVEC, 0);
|
|
||||||
|
|
||||||
/* Additional PCIe always once-executed workarounds */
|
|
||||||
if (pc->dev->id.coreid == SSB_DEV_PCIE) {
|
|
||||||
@@ -529,7 +533,7 @@ static void ssb_pcicore_init_clientmode(
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
-void ssb_pcicore_init(struct ssb_pcicore *pc)
|
|
||||||
+void __devinit ssb_pcicore_init(struct ssb_pcicore *pc)
|
|
||||||
{
|
|
||||||
struct ssb_device *dev = pc->dev;
|
|
||||||
|
|
||||||
--- a/drivers/ssb/embedded.c
|
--- a/drivers/ssb/embedded.c
|
||||||
+++ b/drivers/ssb/embedded.c
|
+++ b/drivers/ssb/embedded.c
|
||||||
@@ -3,7 +3,7 @@
|
@@ -3,7 +3,7 @@
|
||||||
|
@ -164,7 +164,7 @@
|
|||||||
} ____cacheline_aligned;
|
} ____cacheline_aligned;
|
||||||
|
|
||||||
struct seq_file;
|
struct seq_file;
|
||||||
@@ -1997,6 +1998,7 @@ extern long do_sys_open(int dfd, const c
|
@@ -1998,6 +1999,7 @@ extern long do_sys_open(int dfd, const c
|
||||||
extern struct file *filp_open(const char *, int, int);
|
extern struct file *filp_open(const char *, int, int);
|
||||||
extern struct file *file_open_root(struct dentry *, struct vfsmount *,
|
extern struct file *file_open_root(struct dentry *, struct vfsmount *,
|
||||||
const char *, int);
|
const char *, int);
|
||||||
@ -184,7 +184,7 @@
|
|||||||
struct pipe_inode_info *opipe,
|
struct pipe_inode_info *opipe,
|
||||||
--- a/fs/namespace.c
|
--- a/fs/namespace.c
|
||||||
+++ b/fs/namespace.c
|
+++ b/fs/namespace.c
|
||||||
@@ -1495,6 +1495,23 @@ void drop_collected_mounts(struct vfsmou
|
@@ -1492,6 +1492,23 @@ void drop_collected_mounts(struct vfsmou
|
||||||
release_mounts(&umount_list);
|
release_mounts(&umount_list);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -98,6 +98,13 @@ config MICREL_PHY
|
@@ -102,6 +102,13 @@ config MICREL_PHY
|
||||||
---help---
|
---help---
|
||||||
Supports the KSZ9021, VSC8201, KS8001 PHYs.
|
Supports the KSZ9021, VSC8201, KS8001 PHYs.
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -105,6 +105,9 @@ config ADM6996_PHY
|
@@ -109,6 +109,9 @@ config ADM6996_PHY
|
||||||
Currently supports the ADM6996FC and ADM6996M switches.
|
Currently supports the ADM6996FC and ADM6996M switches.
|
||||||
Support for FC is very limited.
|
Support for FC is very limited.
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -108,6 +108,10 @@ config ADM6996_PHY
|
@@ -112,6 +112,10 @@ config ADM6996_PHY
|
||||||
config MVSWITCH_PHY
|
config MVSWITCH_PHY
|
||||||
tristate "Driver for Marvell 88E6060 switches"
|
tristate "Driver for Marvell 88E6060 switches"
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -112,6 +112,10 @@ config IP17XX_PHY
|
@@ -116,6 +116,10 @@ config IP17XX_PHY
|
||||||
tristate "Driver for IC+ IP17xx switches"
|
tristate "Driver for IC+ IP17xx switches"
|
||||||
select SWCONFIG
|
select SWCONFIG
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -116,6 +116,10 @@ config AR8216_PHY
|
@@ -120,6 +120,10 @@ config AR8216_PHY
|
||||||
tristate "Driver for Atheros AR8216 switches"
|
tristate "Driver for Atheros AR8216 switches"
|
||||||
select SWCONFIG
|
select SWCONFIG
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -158,4 +158,29 @@ config MDIO_OCTEON
|
@@ -162,4 +162,29 @@ config MDIO_OCTEON
|
||||||
|
|
||||||
If in doubt, say Y.
|
If in doubt, say Y.
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
|
|
||||||
--- a/drivers/usb/host/pci-quirks.c
|
--- a/drivers/usb/host/pci-quirks.c
|
||||||
+++ b/drivers/usb/host/pci-quirks.c
|
+++ b/drivers/usb/host/pci-quirks.c
|
||||||
@@ -429,6 +429,8 @@ reset_needed:
|
@@ -430,6 +430,8 @@ reset_needed:
|
||||||
}
|
}
|
||||||
EXPORT_SYMBOL_GPL(uhci_check_and_reset_hc);
|
EXPORT_SYMBOL_GPL(uhci_check_and_reset_hc);
|
||||||
|
|
||||||
@ -10,7 +10,7 @@
|
|||||||
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
|
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
|
||||||
{
|
{
|
||||||
u16 cmd;
|
u16 cmd;
|
||||||
@@ -882,3 +884,5 @@ static void __devinit quirk_usb_early_ha
|
@@ -876,3 +878,5 @@ static void __devinit quirk_usb_early_ha
|
||||||
quirk_usb_handoff_xhci(pdev);
|
quirk_usb_handoff_xhci(pdev);
|
||||||
}
|
}
|
||||||
DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
|
DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
|
||||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=le be
|
|||||||
INITRAMFS_EXTRA_FILES:=
|
INITRAMFS_EXTRA_FILES:=
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.0.12
|
LINUX_VERSION:=3.0.17
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
|
|||||||
CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
|
CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.0.12
|
LINUX_VERSION:=3.0.17
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||||||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
|
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.0.12
|
LINUX_VERSION:=3.0.17
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||||||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
|
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.0.9
|
LINUX_VERSION:=3.0.17
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
|
|||||||
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.0.12
|
LINUX_VERSION:=3.0.17
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
|||||||
FEATURES:=ext4 audio
|
FEATURES:=ext4 audio
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.0.12
|
LINUX_VERSION:=3.0.17
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user