mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 01:27:30 +02:00
tools: add b43-tools
Move the b43-tools build from the mac80211 Makefile into an own package in tools and use the newest version of b43-tools. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33668 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
996cb4d751
commit
6c0ffe4c6e
@ -824,35 +824,6 @@ PKG_B43_FWV3_SOURCE:=$(PKG_B43_FWV3_NAME)-$(PKG_B43_FWV3_VERSION).o
|
|||||||
PKG_B43_FWV3_SOURCE_URL:=http://downloads.openwrt.org/sources/
|
PKG_B43_FWV3_SOURCE_URL:=http://downloads.openwrt.org/sources/
|
||||||
PKG_B43_FWV3_MD5SUM:=e08665c5c5b66beb9c3b2dd54aa80cb3
|
PKG_B43_FWV3_MD5SUM:=e08665c5c5b66beb9c3b2dd54aa80cb3
|
||||||
|
|
||||||
ifeq ($(CONFIG_B43_OPENFIRMWARE),y)
|
|
||||||
PKG_B43_FWCUTTER_NAME:=b43-fwcutter
|
|
||||||
PKG_B43_FWCUTTER_VERSION:=3e69531aa65b8f664a0ab00dfc3e2eefeb0cb417
|
|
||||||
PKG_B43_FWCUTTER_SOURCE:=$(PKG_B43_FWCUTTER_NAME)-$(PKG_B43_FWCUTTER_VERSION).tar.bz2
|
|
||||||
PKG_B43_FWCUTTER_PROTO:=git
|
|
||||||
PKG_B43_FWCUTTER_SOURCE_URL:=http://git.bu3sch.de/git/b43-tools.git
|
|
||||||
PKG_B43_FWCUTTER_SUBDIR:=$(PKG_B43_FWCUTTER_NAME)-$(PKG_B43_FWCUTTER_VERSION)
|
|
||||||
PKG_B43_FWCUTTER_OBJECT:=$(PKG_B43_FWCUTTER_NAME)-$(PKG_B43_FWCUTTER_VERSION)/fwcutter/
|
|
||||||
else
|
|
||||||
PKG_B43_FWCUTTER_NAME:=b43-fwcutter
|
|
||||||
PKG_B43_FWCUTTER_VERSION:=015
|
|
||||||
PKG_B43_FWCUTTER_SOURCE:=$(PKG_B43_FWCUTTER_NAME)-$(PKG_B43_FWCUTTER_VERSION).tar.bz2
|
|
||||||
PKG_B43_FWCUTTER_PROTO:=default
|
|
||||||
PKG_B43_FWCUTTER_SOURCE_URL:=http://bu3sch.de/b43/fwcutter/
|
|
||||||
PKG_B43_FWCUTTER_MD5SUM:=628e030565222a107bc40300313cbe76
|
|
||||||
PKG_B43_FWCUTTER_SUBDIR:=b43-fwcutter-$(PKG_B43_FWCUTTER_VERSION)
|
|
||||||
PKG_B43_FWCUTTER_OBJECT:=$(PKG_B43_FWCUTTER_NAME)-$(PKG_B43_FWCUTTER_VERSION)/
|
|
||||||
endif
|
|
||||||
|
|
||||||
define Download/b43-common
|
|
||||||
FILE:=$(PKG_B43_FWCUTTER_SOURCE)
|
|
||||||
URL:=$(PKG_B43_FWCUTTER_SOURCE_URL)
|
|
||||||
MD5SUM:=$(PKG_B43_FWCUTTER_MD5SUM)
|
|
||||||
PROTO:=$(PKG_B43_FWCUTTER_PROTO)
|
|
||||||
VERSION:=$(PKG_B43_FWCUTTER_VERSION)
|
|
||||||
SUBDIR:=$(PKG_B43_FWCUTTER_SUBDIR)
|
|
||||||
endef
|
|
||||||
$(eval $(call Download,b43-common))
|
|
||||||
|
|
||||||
define Download/b43
|
define Download/b43
|
||||||
FILE:=$(PKG_B43_FWV4_SOURCE)
|
FILE:=$(PKG_B43_FWV4_SOURCE)
|
||||||
URL:=$(PKG_B43_FWV4_SOURCE_URL)
|
URL:=$(PKG_B43_FWV4_SOURCE_URL)
|
||||||
@ -867,19 +838,14 @@ define Download/b43legacy
|
|||||||
endef
|
endef
|
||||||
$(eval $(call Download,b43legacy))
|
$(eval $(call Download,b43legacy))
|
||||||
|
|
||||||
define KernelPackage/b43-common
|
|
||||||
|
define KernelPackage/b43
|
||||||
$(call KernelPackage/mac80211/Default)
|
$(call KernelPackage/mac80211/Default)
|
||||||
TITLE:=Generic stuff for Broadcom wireless devices
|
TITLE:=Broadcom 43xx wireless support
|
||||||
URL:=http://linuxwireless.org/en/users/Drivers/b43
|
URL:=http://linuxwireless.org/en/users/Drivers/b43
|
||||||
KCONFIG:= \
|
KCONFIG:= \
|
||||||
CONFIG_HW_RANDOM=y
|
CONFIG_HW_RANDOM=y
|
||||||
DEPENDS+= +kmod-mac80211 +!(TARGET_brcm47xx||TARGET_brcm63xx):kmod-ssb
|
DEPENDS+= +kmod-mac80211 +!TARGET_brcm47xx:kmod-bcma +!(TARGET_brcm47xx||TARGET_brcm63xx):kmod-ssb
|
||||||
endef
|
|
||||||
|
|
||||||
define KernelPackage/b43
|
|
||||||
$(call KernelPackage/b43-common)
|
|
||||||
DEPENDS+= +@DRIVER_11N_SUPPORT +!TARGET_brcm47xx:kmod-bcma
|
|
||||||
TITLE:=Broadcom 43xx wireless support
|
|
||||||
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/b43/b43.ko
|
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/b43/b43.ko
|
||||||
AUTOLOAD:=$(call AutoLoad,30,b43)
|
AUTOLOAD:=$(call AutoLoad,30,b43)
|
||||||
MENU:=1
|
MENU:=1
|
||||||
@ -1041,8 +1007,12 @@ Kernel module for Broadcom 43xx wireless support (mac80211 stack) new
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
define KernelPackage/b43legacy
|
define KernelPackage/b43legacy
|
||||||
$(call KernelPackage/b43-common)
|
$(call KernelPackage/mac80211/Default)
|
||||||
TITLE:=Broadcom 43xx-legacy wireless support
|
TITLE:=Broadcom 43xx-legacy wireless support
|
||||||
|
URL:=http://linuxwireless.org/en/users/Drivers/b43
|
||||||
|
KCONFIG:= \
|
||||||
|
CONFIG_HW_RANDOM=y
|
||||||
|
DEPENDS+= +kmod-mac80211 +!(TARGET_brcm47xx||TARGET_brcm63xx):kmod-ssb
|
||||||
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/b43legacy/b43legacy.ko
|
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/b43legacy/b43legacy.ko
|
||||||
AUTOLOAD:=$(call AutoLoad,30,b43legacy)
|
AUTOLOAD:=$(call AutoLoad,30,b43legacy)
|
||||||
MENU:=1
|
MENU:=1
|
||||||
@ -1519,25 +1489,8 @@ define KernelPackage/iwl4965/install
|
|||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/iwlwifi-4965-2.ucode $(1)/lib/firmware
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/iwlwifi-4965-2.ucode $(1)/lib/firmware
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/b43-common
|
|
||||||
tar xjf "$(DL_DIR)/$(PKG_B43_FWCUTTER_SOURCE)" -C "$(PKG_BUILD_DIR)"
|
|
||||||
patch -p1 -d "$(PKG_BUILD_DIR)/$(PKG_B43_FWCUTTER_OBJECT)" < ./files/b43-fwcutter-fw-dirname.patch
|
|
||||||
$(MAKE) -C "$(PKG_BUILD_DIR)/$(PKG_B43_FWCUTTER_OBJECT)" \
|
|
||||||
CFLAGS="-I$(STAGING_DIR_HOST)/include -include endian.h" \
|
|
||||||
QUIET_SPARSE=:
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_B43_FWCUTTER_OBJECT)/b43-fwcutter $(STAGING_DIR_HOST)/bin/
|
|
||||||
ifeq ($(CONFIG_B43_OPENFIRMWARE),y)
|
|
||||||
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
|
|
||||||
$(MAKE) -C "$(PKG_BUILD_DIR)/$(PKG_B43_FWCUTTER_SUBDIR)/assembler/"
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_B43_FWCUTTER_SUBDIR)/assembler/b43-asm $(STAGING_DIR_HOST)/bin/
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_B43_FWCUTTER_SUBDIR)/assembler/b43-asm.bin $(STAGING_DIR_HOST)/bin/
|
|
||||||
endif
|
|
||||||
$(INSTALL_BIN) ./files/host_bin/b43-fwsquash.py $(STAGING_DIR_HOST)/bin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define KernelPackage/b43/install
|
define KernelPackage/b43/install
|
||||||
rm -rf $(1)/lib/firmware/
|
rm -rf $(1)/lib/firmware/
|
||||||
$(call Build/b43-common)
|
|
||||||
ifeq ($(CONFIG_B43_OPENFIRMWARE),y)
|
ifeq ($(CONFIG_B43_OPENFIRMWARE),y)
|
||||||
tar xzf "$(DL_DIR)/$(PKG_B43_FWV4_SOURCE)" -C "$(PKG_BUILD_DIR)"
|
tar xzf "$(DL_DIR)/$(PKG_B43_FWV4_SOURCE)" -C "$(PKG_BUILD_DIR)"
|
||||||
else
|
else
|
||||||
@ -1559,9 +1512,7 @@ endif
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
define KernelPackage/b43legacy/install
|
define KernelPackage/b43legacy/install
|
||||||
$(call Build/b43-common)
|
|
||||||
$(INSTALL_DIR) $(1)/lib/firmware/
|
$(INSTALL_DIR) $(1)/lib/firmware/
|
||||||
|
|
||||||
b43-fwcutter --unsupported -w $(1)/lib/firmware/ $(DL_DIR)/$(PKG_B43_FWV3_SOURCE)
|
b43-fwcutter --unsupported -w $(1)/lib/firmware/ $(DL_DIR)/$(PKG_B43_FWV3_SOURCE)
|
||||||
ifneq ($(CONFIG_B43LEGACY_FW_SQUASH),)
|
ifneq ($(CONFIG_B43LEGACY_FW_SQUASH),)
|
||||||
b43-fwsquash.py "G" "$(CONFIG_B43LEGACY_FW_SQUASH_COREREVS)" "$(1)/lib/firmware/b43legacy"
|
b43-fwsquash.py "G" "$(CONFIG_B43LEGACY_FW_SQUASH_COREREVS)" "$(1)/lib/firmware/b43legacy"
|
||||||
|
@ -25,6 +25,9 @@ ifneq ($(CONFIG_TARGET_ar71xx),)
|
|||||||
tools-y += lzma-old squashfs
|
tools-y += lzma-old squashfs
|
||||||
endif
|
endif
|
||||||
tools-y += lzma squashfs4
|
tools-y += lzma squashfs4
|
||||||
|
ifneq ($(CONFIG_PACKAGE_kmod-b43)$(CONFIG_PACKAGE_kmod-b43legacy),)
|
||||||
|
tools-y += b43-tools
|
||||||
|
endif
|
||||||
|
|
||||||
ifneq ($(CONFIG_PACKAGE_firmwarehotplug),)
|
ifneq ($(CONFIG_PACKAGE_firmwarehotplug),)
|
||||||
tools-y += sdcc
|
tools-y += sdcc
|
||||||
@ -64,6 +67,7 @@ $(curdir)/missing-macros/compile := $(curdir)/automake/install
|
|||||||
$(curdir)/e2fsprogs/compile := $(curdir)/automake/install
|
$(curdir)/e2fsprogs/compile := $(curdir)/automake/install
|
||||||
$(curdir)/libelf/compile := $(curdir)/automake/install
|
$(curdir)/libelf/compile := $(curdir)/automake/install
|
||||||
$(curdir)/sdcc/compile := $(curdir)/bison/install
|
$(curdir)/sdcc/compile := $(curdir)/bison/install
|
||||||
|
$(curdir)/b43-tools/compile := $(curdir)/bison/install
|
||||||
|
|
||||||
ifneq ($(CONFIG_CCACHE),)
|
ifneq ($(CONFIG_CCACHE),)
|
||||||
$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
|
$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
|
||||||
|
50
tools/b43-tools/Makefile
Normal file
50
tools/b43-tools/Makefile
Normal file
@ -0,0 +1,50 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2012 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=b43-tools
|
||||||
|
PKG_VERSION:=016
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
PKG_SOURCE_URL:=git://git.bues.ch/b43-tools.git
|
||||||
|
PKG_SOURCE_PROTO:=git
|
||||||
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)
|
||||||
|
PKG_SOURCE_VERSION:=38267954aae73659de271c67e6892c744b47f3d8
|
||||||
|
PKG_MIRROR_MD5SUM:=7826262ac6870ac27c22a1b6974f8952
|
||||||
|
HOST_BUILD_DIR=$(BUILD_DIR_HOST)/$(PKG_NAME)
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
|
||||||
|
|
||||||
|
define Host/Compile
|
||||||
|
+$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/fwcutter \
|
||||||
|
CFLAGS="$(HOST_CFLAGS) -include endian.h" \
|
||||||
|
$(HOST_MAKE_FLAGS) \
|
||||||
|
$(1) QUIET_SPARSE=:
|
||||||
|
+$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/assembler \
|
||||||
|
CFLAGS="$(HOST_CFLAGS) -include endian.h" \
|
||||||
|
$(HOST_MAKE_FLAGS) \
|
||||||
|
$(1) QUIET_SPARSE=:
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Host/Install
|
||||||
|
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
|
||||||
|
$(INSTALL_BIN) $(HOST_BUILD_DIR)/fwcutter/b43-fwcutter $(STAGING_DIR_HOST)/bin/
|
||||||
|
$(INSTALL_BIN) $(HOST_BUILD_DIR)/assembler/b43-asm $(STAGING_DIR_HOST)/bin/
|
||||||
|
$(INSTALL_BIN) $(HOST_BUILD_DIR)/assembler/b43-asm.bin $(STAGING_DIR_HOST)/bin/
|
||||||
|
$(INSTALL_BIN) ./files/b43-fwsquash.py $(STAGING_DIR_HOST)/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Host/Clean
|
||||||
|
rm -f $(STAGING_DIR_HOST)/bin/b43-fwcutter
|
||||||
|
rm -f $(STAGING_DIR_HOST)/bin/b43-asm
|
||||||
|
rm -f $(STAGING_DIR_HOST)/bin/b43-asm.bin
|
||||||
|
rm -f $(STAGING_DIR_HOST)/bin/b43-fwsquash.py
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call HostBuild))
|
@ -1,5 +1,5 @@
|
|||||||
--- a/fwcutter.c
|
--- a/fwcutter/fwcutter.c
|
||||||
+++ b/fwcutter.c
|
+++ b/fwcutter/fwcutter.c
|
||||||
@@ -48,13 +48,8 @@
|
@@ -48,13 +48,8 @@
|
||||||
#include "fwcutter.h"
|
#include "fwcutter.h"
|
||||||
#include "fwcutter_list.h"
|
#include "fwcutter_list.h"
|
Loading…
Reference in New Issue
Block a user