1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-05 03:41:06 +03:00

update wpa_supplicant to new upstream stable release (v0.4.7)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2544 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2005-11-22 03:13:26 +00:00
parent 71f9fcb56a
commit 6ca00b6412
2 changed files with 2 additions and 52 deletions

View File

@ -3,9 +3,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=wpa_supplicant
PKG_VERSION:=0.4.5
PKG_VERSION:=0.4.7
PKG_RELEASE:=1
PKG_MD5SUM:=28347563119f09fc963bcdf9d16265a3
PKG_MD5SUM:=1345730f15d5f93f2f083096ddc903eb
PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz

View File

@ -1,50 +0,0 @@
diff -ruN wpa_supplicant-0.4.5-old/driver_madwifi.c wpa_supplicant-0.4.5-new/driver_madwifi.c
--- wpa_supplicant-0.4.5-old/driver_madwifi.c 2005-09-17 07:36:33.000000000 +0200
+++ wpa_supplicant-0.4.5-new/driver_madwifi.c 2005-10-23 14:08:45.000000000 +0200
@@ -27,11 +27,19 @@
#include "wpa_supplicant.h"
#include "wpa.h"
+#include <sys/types.h>
+#include <sys/socket.h>
+#include <linux/types.h>
+#include <linux/socket.h>
+#include <linux/if.h>
+#include <stdint.h>
+#include <linux/if_packet.h>
+#include <linux/netlink.h>
+#include <linux/rtnetlink.h>
+
#include <include/compat.h>
#include <net80211/ieee80211.h>
#ifdef WME_NUM_AC
-/* Assume this is built against BSD branch of madwifi driver. */
-#define MADWIFI_BSD
#include <net80211/_ieee80211.h>
#endif /* WME_NUM_AC */
#include <net80211/ieee80211_crypto.h>
@@ -78,19 +86,19 @@
"ioctl[IEEE80211_IOCTL_SETKEY]",
"ioctl[IEEE80211_IOCTL_GETKEY]",
"ioctl[IEEE80211_IOCTL_DELKEY]",
- NULL,
+ "ioctl[IEEE80211_IOCTL_SETWMMPARAMS]",
"ioctl[IEEE80211_IOCTL_SETMLME]",
- NULL,
+ "ioctl[IEEE80211_IOCTL_GETCHANINFO]",
"ioctl[IEEE80211_IOCTL_SETOPTIE]",
"ioctl[IEEE80211_IOCTL_GETOPTIE]",
"ioctl[IEEE80211_IOCTL_ADDMAC]",
NULL,
"ioctl[IEEE80211_IOCTL_DELMAC]",
- NULL,
- "ioctl[IEEE80211_IOCTL_CHANLIST]",
+ "ioctl[IEEE80211_IOCTL_GETCHANLIST]",
+ "ioctl[IEEE80211_IOCTL_SETCHANLIST]",
};
if (IEEE80211_IOCTL_SETPARAM <= op &&
- op <= IEEE80211_IOCTL_CHANLIST)
+ op <= IEEE80211_IOCTL_SETCHANLIST)
perror(opnames[op - SIOCIWFIRSTPRIV]);
else
perror("ioctl[unknown???]");