mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 15:43:07 +02:00
add a load of fixes from whiterussian to head
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1410 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
21061434be
commit
6ca2a42ec5
@ -4,4 +4,4 @@ Section: apps
|
||||
Maintainer: Waldemar Brodkorb <wbx@dass-it.de>
|
||||
Source: buildroot internal
|
||||
Description: lcd software
|
||||
Depends: ncurses
|
||||
Depends: libncurses
|
||||
|
@ -50,7 +50,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
|
||||
--disable-java \
|
||||
--enable-cxx \
|
||||
--disable-posixmutexes \
|
||||
--enable-uimutexes \
|
||||
--disable-uimutexes \
|
||||
--disable-tcl \
|
||||
--disable-rpc \
|
||||
--enable-compat185 \
|
||||
|
@ -25,7 +25,48 @@ include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,LIBNCURSES,libncurses,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
|
||||
$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.prepared
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
|
||||
./configure \
|
||||
--target=$(GNU_HOST_NAME) \
|
||||
--host=$(GNU_HOST_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_NLS) \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
--enable-echo \
|
||||
--enable-const \
|
||||
--enable-overwrite \
|
||||
--disable-rpath \
|
||||
--without-ada \
|
||||
--without-cxx \
|
||||
--without-cxx-binding \
|
||||
--without-debug \
|
||||
--without-profile \
|
||||
--with-progs \
|
||||
--with-normal \
|
||||
--without-shared \
|
||||
--with-terminfo-dirs=/usr/share/terminfo \
|
||||
--with-default-terminfo-dir=/usr/share/terminfo \
|
||||
);
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
libs install.progs
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
@ -52,33 +93,28 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_NLS) \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
--with-terminfo-dirs=/usr/share/terminfo \
|
||||
--with-default-terminfo-dir=/usr/share/terminfo \
|
||||
--without-ada \
|
||||
--without-cxx \
|
||||
--without-cxx-binding \
|
||||
--without-progs \
|
||||
--without-profile \
|
||||
--without-debug \
|
||||
--disable-rpath \
|
||||
--enable-echo \
|
||||
--enable-const \
|
||||
--enable-overwrite \
|
||||
--with-shared \
|
||||
--disable-rpath \
|
||||
--without-ada \
|
||||
--without-cxx \
|
||||
--without-cxx-binding \
|
||||
--without-debug \
|
||||
--without-profile \
|
||||
--without-progs \
|
||||
--with-normal \
|
||||
--with-shared \
|
||||
--with-terminfo-dirs=/usr/share/terminfo \
|
||||
--with-default-terminfo-dir=/usr/share/terminfo \
|
||||
);
|
||||
touch $@
|
||||
|
||||
$(PKG_BUILD_DIR)/.built:
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
BUILD_CC="$(TARGET_CC)" \
|
||||
HOSTCC="$(HOSTCC)" \
|
||||
HOSTCCFLAGS="\$$(CPPFLAGS)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
libs install.libs install.data
|
||||
touch $@
|
||||
|
||||
$(IPKG_LIBNCURSES):
|
||||
|
@ -1,6 +1,12 @@
|
||||
config BR_PACKAGE_OSIRIS
|
||||
bool
|
||||
default n
|
||||
depends BR2_PACKAGE_OSIRISD
|
||||
|
||||
config BR2_PACKAGE_OSIRISD
|
||||
tristate "osirisd - Host integrity monitoring system (scanning agent)"
|
||||
default m if CONFIG_DEVEL
|
||||
select BR2_PACKAGE_OSIRIS
|
||||
select BR2_PACKAGE_LIBOPENSSL
|
||||
help
|
||||
An host integrity monitoring system (scanning agent)
|
||||
@ -10,6 +16,3 @@ config BR2_PACKAGE_OSIRISD
|
||||
Depends: openssl
|
||||
|
||||
|
||||
config BR_PACKAGE_OSIRIS
|
||||
tristate
|
||||
default BR2_PACKAGE_OSIRISD
|
||||
|
@ -6,3 +6,4 @@ Architecture: [TBDL]
|
||||
Maintainer: Nico <nthill@free.fr>
|
||||
Source: http://nthill.free.fr/openwrt/sources/postgresql/
|
||||
Description: Command Line Interface (CLI) to PostgreSQL databases
|
||||
Depends: libpq
|
||||
|
@ -2,60 +2,62 @@
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME := vtun
|
||||
PKG_VERSION := 2.6
|
||||
PKG_RELEASE := 1
|
||||
PKG_MD5SUM := 309534fd03c5d13a19c43916f61f4bbf
|
||||
PKG_NAME:=vtun
|
||||
PKG_VERSION:=2.6
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=309534fd03c5d13a19c43916f61f4bbf
|
||||
|
||||
PKG_SOURCE_URL := @SF/vtun
|
||||
PKG_SOURCE := $(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
|
||||
PKG_CAT := zcat
|
||||
PKG_SOURCE_URL:=@SF/vtun
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,VTUN,vtun,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured:
|
||||
(cd $(PKG_BUILD_DIR) ; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS) \
|
||||
-I$(STAGING_DIR)/usr/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--sbindir=/usr/sbin \
|
||||
--libexecdir=/usr/lib \
|
||||
--datadir=/usr/share \
|
||||
--infodir=/usr/share/info \
|
||||
--mandir=/usr/share/man \
|
||||
--localstatedir=/var \
|
||||
--sysconfdir=/etc \
|
||||
--with-kernel=$(LINUX_DIR) \
|
||||
--with-zlib=$(STAGING_DIR)/usr/ \
|
||||
--with-lzo-headers=$(STAGING_DIR)/usr/include \
|
||||
--with-lzo-libs=$(STAGING_DIR)/usr/lib \
|
||||
$(DISABLE_NLS) )
|
||||
touch $(PKG_BUILD_DIR)/.configured
|
||||
(cd $(PKG_BUILD_DIR) ; rm -rf config.{cache,status} ; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
|
||||
LIBS="-L$(STAGING_DIR)/usr/lib" \
|
||||
BLOWFISH_HDR_DIR="$(STAGING_DIR)/usr/include/openssl" \
|
||||
LZO_HDR_DIR="$(STAGING_DIR)/usr/include" \
|
||||
SSL_HDR_DIR="$(STAGING_DIR)/usr/include/openssl" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
)
|
||||
touch $@
|
||||
|
||||
$(PKG_BUILD_DIR)/.built:
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CC=$(TARGET_CC) \
|
||||
CFLAGS="$(TARGET_CFLAGS) \
|
||||
-I$(STAGING_DIR)/usr/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -lssl -lz -llzo -lcrypto" \
|
||||
vtund
|
||||
vtund
|
||||
touch $@
|
||||
|
||||
$(IPKG_VTUN):
|
||||
mkdir -p $(IDIR_VTUN)/usr/sbin
|
||||
cp $(PKG_BUILD_DIR)/vtund $(IDIR_VTUN)/usr/sbin/
|
||||
$(STRIP) $(IDIR_VTUN)/usr/sbin/*
|
||||
mkdir -p $(IDIR_VTUN)/etc
|
||||
cp $(PKG_BUILD_DIR)/vtund.conf $(IDIR_VTUN)/etc
|
||||
install -m0755 -d $(IDIR_VTUN)/etc
|
||||
install -m0600 $(PKG_BUILD_DIR)/vtund.conf $(IDIR_VTUN)/etc/
|
||||
install -m0755 -d $(IDIR_VTUN)/usr/sbin
|
||||
install -m0755 $(PKG_BUILD_DIR)/vtund $(IDIR_VTUN)/usr/sbin/
|
||||
$(RSTRIP) $(IDIR_VTUN)
|
||||
$(IPKG_BUILD) $(IDIR_VTUN) $(PACKAGE_DIR)
|
||||
|
@ -5,4 +5,4 @@ Architecture: mipsel
|
||||
Maintainer: marcel@slowthinkers.net
|
||||
Source: buildroot internal
|
||||
Description: A VPN tunnel daemon
|
||||
Depends: openssl, liblzo, zlib, kmod-tun
|
||||
Depends: libopenssl, liblzo, zlib, kmod-tun
|
||||
|
@ -4,3 +4,4 @@ Section: net
|
||||
Maintainer: Nico <nthill@free.fr>
|
||||
Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/wpa_supplicant
|
||||
Description: WPA Supplicant with support for WPA and WPA2
|
||||
Depends: libopenssl
|
||||
|
26
openwrt/package/zlib/patches/zlib-1.2.2-CAN-2005-2096.patch
Normal file
26
openwrt/package/zlib/patches/zlib-1.2.2-CAN-2005-2096.patch
Normal file
@ -0,0 +1,26 @@
|
||||
Name: CAN-2005-2096 (under review)
|
||||
Description:
|
||||
Buffer overflow in zlib 1.2 and later versions allows remote attackers
|
||||
to cause a denial of service (crash) via a crafted compressed stream, as
|
||||
demonstrated using a crafted PNG file.
|
||||
|
||||
References:
|
||||
* DEBIAN:DSA-740
|
||||
http://www.debian.org/security/2005/dsa-740
|
||||
* REDHAT:RHSA-2005:569
|
||||
http://www.redhat.com/support/errata/RHSA-2005-569.html
|
||||
|
||||
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2096
|
||||
|
||||
diff -ruN zlib-1.2.2-old/inftrees.c zlib-1.2.2-new/inftrees.c
|
||||
--- zlib-1.2.2-old/inftrees.c 2004-09-15 16:30:06.000000000 +0200
|
||||
+++ zlib-1.2.2-new/inftrees.c 2005-07-08 21:18:58.000000000 +0200
|
||||
@@ -134,7 +134,7 @@
|
||||
left -= count[len];
|
||||
if (left < 0) return -1; /* over-subscribed */
|
||||
}
|
||||
- if (left > 0 && (type == CODES || (codes - count[0] != 1)))
|
||||
+ if (left > 0 && (type == CODES || max != 1))
|
||||
return -1; /* incomplete set */
|
||||
|
||||
/* generate offsets into symbol table for each length for sorting */
|
@ -115,6 +115,9 @@ $(eval $(call KMOD_template,IDE,ide,\
|
||||
$(MODULES_DIR)/kernel/drivers/ide/*.o \
|
||||
$(MODULES_DIR)/kernel/drivers/ide/*/*.o \
|
||||
,CONFIG_IDE))
|
||||
$(eval $(call KMOD_template,LOOP,loop,\
|
||||
$(MODULES_DIR)/kernel/drivers/block/loop.o \
|
||||
,CONFIG_BLK_DEV_LOOP))
|
||||
$(eval $(call KMOD_template,EXT2,ext2,\
|
||||
$(MODULES_DIR)/kernel/fs/ext2/*.o \
|
||||
,CONFIG_EXT2_FS))
|
||||
|
Loading…
Reference in New Issue
Block a user