mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-12-18 05:57:30 +02:00
fix ppp compile on osx
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4869 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a6cb7e0b3c
commit
6e30a22b87
@ -23,6 +23,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
|||||||
PKG_BUILDDEP:=libpcap linux-atm
|
PKG_BUILDDEP:=libpcap linux-atm
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
define Package/ppp/Default
|
define Package/ppp/Default
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
@ -91,6 +92,14 @@ define Package/pppstats
|
|||||||
This package contains an utility to report PPP statistics.
|
This package contains an utility to report PPP statistics.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
$(call Build/Configure/Default,, \
|
||||||
|
UNAME_S="Linux" \
|
||||||
|
UNAME_R="$(LINUX_VERSION)" \
|
||||||
|
UNAME_M="$(ARCH)" \
|
||||||
|
)
|
||||||
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
rm -rf $(PKG_INSTALL_DIR)
|
rm -rf $(PKG_INSTALL_DIR)
|
||||||
mkdir -p $(PKG_INSTALL_DIR)/usr
|
mkdir -p $(PKG_INSTALL_DIR)/usr
|
||||||
|
20
package/ppp/patches/010-use_target_for_configure.patch
Normal file
20
package/ppp/patches/010-use_target_for_configure.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
|
||||||
|
Use values exported from $(TOPDIR)/rules.mk for determining
|
||||||
|
the target system instead of the host configuration
|
||||||
|
|
||||||
|
--- ppp-2.4.3/configure.orig Sat Nov 6 11:36:32 2004
|
||||||
|
+++ ppp-2.4.3/configure Sun Jun 18 23:40:46 2006
|
||||||
|
@@ -8,9 +8,9 @@ SYSCONF=/etc
|
||||||
|
# if [ -d /NextApps ]; then
|
||||||
|
# system="NeXTStep"
|
||||||
|
# else
|
||||||
|
- system=`uname -s`
|
||||||
|
- release=`uname -r`
|
||||||
|
- arch=`uname -m`
|
||||||
|
+ system=${UNAME_S:-`uname -s`}
|
||||||
|
+ release=${UNAME_R:-`uname -r`}
|
||||||
|
+ arch=${UNAME_M:-`uname -m`}
|
||||||
|
# fi
|
||||||
|
state="unknown"
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user