1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-11-24 08:28:26 +02:00

ar71xx: refresh kernel patches

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33334 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2012-09-08 13:39:04 +00:00
parent c0c235b52c
commit 6f0a45267a
6 changed files with 11 additions and 17 deletions

View File

@ -87,7 +87,7 @@
mutex_unlock(&flash->lock); mutex_unlock(&flash->lock);
@@ -924,6 +950,12 @@ static int __devinit m25p_probe(struct s @@ -925,6 +951,12 @@ static int __devinit m25p_probe(struct s
flash->mtd.erase = m25p80_erase; flash->mtd.erase = m25p80_erase;
flash->mtd.read = m25p80_read; flash->mtd.read = m25p80_read;

View File

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c --- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c +++ b/drivers/mtd/devices/m25p80.c
@@ -1017,7 +1017,9 @@ static int __devinit m25p_probe(struct s @@ -1018,7 +1018,9 @@ static int __devinit m25p_probe(struct s
/* partitions should match sector boundaries; and it may be good to /* partitions should match sector boundaries; and it may be good to
* use readonly partitions for writeprotected sectors (BP2..BP0). * use readonly partitions for writeprotected sectors (BP2..BP0).
*/ */

View File

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c --- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c +++ b/drivers/mtd/devices/m25p80.c
@@ -977,6 +977,7 @@ static int __devinit m25p_probe(struct s @@ -978,6 +978,7 @@ static int __devinit m25p_probe(struct s
if (info->flags & M25P_NO_ERASE) if (info->flags & M25P_NO_ERASE)
flash->mtd.flags |= MTD_NO_ERASE; flash->mtd.flags |= MTD_NO_ERASE;

View File

@ -1,6 +1,6 @@
--- a/drivers/Makefile --- a/drivers/Makefile
+++ b/drivers/Makefile +++ b/drivers/Makefile
@@ -51,8 +51,8 @@ obj-$(CONFIG_IDE) += ide/ @@ -52,8 +52,8 @@ obj-$(CONFIG_IDE) += ide/
obj-$(CONFIG_SCSI) += scsi/ obj-$(CONFIG_SCSI) += scsi/
obj-$(CONFIG_ATA) += ata/ obj-$(CONFIG_ATA) += ata/
obj-$(CONFIG_TARGET_CORE) += target/ obj-$(CONFIG_TARGET_CORE) += target/

View File

@ -679,7 +679,7 @@
endif endif
--- a/arch/mips/ath79/Makefile --- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile +++ b/arch/mips/ath79/Makefile
@@ -36,9 +36,62 @@ obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP) += pci-ath9k-fixup.o @@ -36,9 +36,62 @@ obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP) += p
# #
# Machines # Machines
# #

View File

@ -1,7 +1,5 @@
Index: linux-3.3.8/arch/mips/ath79/Kconfig --- a/arch/mips/ath79/Kconfig
=================================================================== +++ b/arch/mips/ath79/Kconfig
--- linux-3.3.8.orig/arch/mips/ath79/Kconfig
+++ linux-3.3.8/arch/mips/ath79/Kconfig
@@ -38,6 +38,15 @@ config ATH79_MACH_ALL0258N @@ -38,6 +38,15 @@ config ATH79_MACH_ALL0258N
select ATH79_DEV_LEDS_GPIO select ATH79_DEV_LEDS_GPIO
select ATH79_DEV_M25P80 select ATH79_DEV_M25P80
@ -18,10 +16,8 @@ Index: linux-3.3.8/arch/mips/ath79/Kconfig
config ATH79_MACH_AP113 config ATH79_MACH_AP113
bool "Atheros AP113 board support" bool "Atheros AP113 board support"
select SOC_AR724X select SOC_AR724X
Index: linux-3.3.8/arch/mips/ath79/Makefile --- a/arch/mips/ath79/Makefile
=================================================================== +++ b/arch/mips/ath79/Makefile
--- linux-3.3.8.orig/arch/mips/ath79/Makefile
+++ linux-3.3.8/arch/mips/ath79/Makefile
@@ -39,6 +39,7 @@ obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP) += p @@ -39,6 +39,7 @@ obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP) += p
obj-$(CONFIG_ATH79_MACH_ALFA_AP96) += mach-alfa-ap96.o obj-$(CONFIG_ATH79_MACH_ALFA_AP96) += mach-alfa-ap96.o
obj-$(CONFIG_ATH79_MACH_ALFA_NX) += mach-alfa-nx.o obj-$(CONFIG_ATH79_MACH_ALFA_NX) += mach-alfa-nx.o
@ -30,10 +26,8 @@ Index: linux-3.3.8/arch/mips/ath79/Makefile
obj-$(CONFIG_ATH79_MACH_AP113) += mach-ap113.o obj-$(CONFIG_ATH79_MACH_AP113) += mach-ap113.o
obj-$(CONFIG_ATH79_MACH_AP121) += mach-ap121.o obj-$(CONFIG_ATH79_MACH_AP121) += mach-ap121.o
obj-$(CONFIG_ATH79_MACH_AP136) += mach-ap136.o obj-$(CONFIG_ATH79_MACH_AP136) += mach-ap136.o
Index: linux-3.3.8/arch/mips/ath79/machtypes.h --- a/arch/mips/ath79/machtypes.h
=================================================================== +++ b/arch/mips/ath79/machtypes.h
--- linux-3.3.8.orig/arch/mips/ath79/machtypes.h
+++ linux-3.3.8/arch/mips/ath79/machtypes.h
@@ -20,6 +20,7 @@ enum ath79_mach_type { @@ -20,6 +20,7 @@ enum ath79_mach_type {
ATH79_MACH_ALFA_NX, /* ALFA Network N2/N5 board */ ATH79_MACH_ALFA_NX, /* ALFA Network N2/N5 board */
ATH79_MACH_ALL0258N, /* Allnet ALL0258N */ ATH79_MACH_ALL0258N, /* Allnet ALL0258N */