1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-11-18 00:33:10 +02:00

busybox 1.19.4 update patch

This patch updates busybox to 1.19.4 and refreshes all patches.

Signed-off-by: Peter Wagner <tripolar@gmx.at>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30985 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2012-03-18 19:46:52 +00:00
parent 7010de0fd3
commit 6f77ae2ecd
9 changed files with 15 additions and 37 deletions

View File

@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=busybox PKG_NAME:=busybox
PKG_VERSION:=1.19.3 PKG_VERSION:=1.19.4
PKG_RELEASE:=10 PKG_RELEASE:=1
PKG_FLAGS:=essential PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.busybox.net/downloads \ PKG_SOURCE_URL:=http://www.busybox.net/downloads \
http://distfiles.gentoo.org/distfiles/ http://distfiles.gentoo.org/distfiles/
PKG_MD5SUM:=c3938e1ac59602387009bbf1dd1af7f6 PKG_MD5SUM:=9c0cae5a0379228e7b55e5b29528df8e
PKG_BUILD_DEPENDS:=BUSYBOX_USE_LIBRPC:librpc PKG_BUILD_DEPENDS:=BUSYBOX_USE_LIBRPC:librpc
PKG_BUILD_PARALLEL:=1 PKG_BUILD_PARALLEL:=1

View File

@ -1,12 +0,0 @@
--- a/loginutils/getty.c
+++ b/loginutils/getty.c
@@ -271,7 +271,9 @@ static void termios_init(int speed)
#ifdef CMSPAR
| CMSPAR /* mark or space parity */
#endif
+#ifdef CBAUD
| CBAUD /* (output) baud rate */
+#endif
#ifdef CBAUDEX
| CBAUDEX /* (output) baud rate */
#endif

View File

@ -1,10 +0,0 @@
--- a/modutils/modinfo.c
+++ b/modutils/modinfo.c
@@ -13,6 +13,7 @@
//config:config MODINFO
//config: bool "modinfo"
//config: default y
+//config: select PLATFORM_LINUX
//config: help
//config: Show information about a Linux Kernel module

View File

@ -222,7 +222,7 @@ Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
h->host = sp + 1; h->host = sp + 1;
} }
@@ -660,12 +665,6 @@ static void download_one_url(const char @@ -661,12 +666,6 @@ static void download_one_url(const char
#if ENABLE_FEATURE_WGET_AUTHENTICATION #if ENABLE_FEATURE_WGET_AUTHENTICATION
if (target.user) { if (target.user) {

View File

@ -1,6 +1,6 @@
--- a/networking/wget.c --- a/networking/wget.c
+++ b/networking/wget.c +++ b/networking/wget.c
@@ -871,7 +871,7 @@ int wget_main(int argc UNUSED_PARAM, cha @@ -873,7 +873,7 @@ int wget_main(int argc UNUSED_PARAM, cha
/* Ignored: */ /* Ignored: */
// "tries\0" Required_argument "t" // "tries\0" Required_argument "t"
/* Ignored (we always use PASV): */ /* Ignored (we always use PASV): */

View File

@ -70,10 +70,11 @@
/* really simple implementation, just count the bits */ /* really simple implementation, just count the bits */
static int mton(uint32_t mask) static int mton(uint32_t mask)
{ {
@@ -232,6 +250,70 @@ static NOINLINE char *xmalloc_optname_op @@ -231,6 +249,70 @@ static NOINLINE char *xmalloc_optname_op
}
return ret; return ret;
} + }
+ case OPTION_6RD: { + case OPTION_6RD: {
+ /* Option binary format: + /* Option binary format:
+ * 0 1 2 3 + * 0 1 2 3
@ -137,7 +138,6 @@
+ } + }
+ +
+ return ret; + return ret;
+ } }
#if ENABLE_FEATURE_UDHCP_RFC3397 #if ENABLE_FEATURE_UDHCP_RFC3397
case OPTION_DNS_STRING: case OPTION_DNS_STRING:
/* unpack option into dest; use ret for prefix (i.e., "optname=") */