mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-28 16:29:43 +02:00
remove 150-crypto.patch which is not needed for .28 as the kernel has lzo compression support
This commit is contained in:
parent
5b2fbd7f57
commit
6fd5c78dcc
@ -1,342 +0,0 @@
|
||||
--- linux-2.6.24.7.old/crypto/Kconfig 2009-04-12 18:05:07.000000000 +0200
|
||||
+++ linux-2.6.24.7/crypto/Kconfig 2009-04-12 18:13:57.000000000 +0200
|
||||
@@ -502,6 +502,14 @@
|
||||
Authenc: Combined mode wrapper for IPsec.
|
||||
This is required for IPSec.
|
||||
|
||||
+config CRYPTO_LZO
|
||||
+ tristate "LZO compression algorithm"
|
||||
+ select CRYPTO_ALGAPI
|
||||
+ select LZO_COMPRESS
|
||||
+ select LZO_DECOMPRESS
|
||||
+ help
|
||||
+ This is the LZO algorithm.
|
||||
+
|
||||
source "drivers/crypto/Kconfig"
|
||||
|
||||
endif # if CRYPTO
|
||||
--- linux-2.6.24.7.old/crypto/Makefile 2008-05-07 01:22:34.000000000 +0200
|
||||
+++ linux-2.6.24.7/crypto/Makefile 2009-04-12 18:13:57.000000000 +0200
|
||||
@@ -51,6 +51,7 @@
|
||||
obj-$(CONFIG_CRYPTO_DEFLATE) += deflate.o
|
||||
obj-$(CONFIG_CRYPTO_MICHAEL_MIC) += michael_mic.o
|
||||
obj-$(CONFIG_CRYPTO_CRC32C) += crc32c.o
|
||||
+obj-$(CONFIG_CRYPTO_LZO) += lzo.o
|
||||
obj-$(CONFIG_CRYPTO_AUTHENC) += authenc.o
|
||||
|
||||
obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
|
||||
--- linux-2.6.24.7.old/crypto/lzo.c 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ linux-2.6.24.7/crypto/lzo.c 2009-04-12 18:13:57.000000000 +0200
|
||||
@@ -0,0 +1,106 @@
|
||||
+/*
|
||||
+ * Cryptographic API.
|
||||
+ *
|
||||
+ * This program is free software; you can redistribute it and/or modify it
|
||||
+ * under the terms of the GNU General Public License version 2 as published by
|
||||
+ * the Free Software Foundation.
|
||||
+ *
|
||||
+ * This program is distributed in the hope that it will be useful, but WITHOUT
|
||||
+ * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
|
||||
+ * FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
|
||||
+ * more details.
|
||||
+ *
|
||||
+ * You should have received a copy of the GNU General Public License along with
|
||||
+ * this program; if not, write to the Free Software Foundation, Inc., 51
|
||||
+ * Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
|
||||
+ *
|
||||
+ */
|
||||
+
|
||||
+#include <linux/init.h>
|
||||
+#include <linux/module.h>
|
||||
+#include <linux/crypto.h>
|
||||
+#include <linux/vmalloc.h>
|
||||
+#include <linux/lzo.h>
|
||||
+
|
||||
+struct lzo_ctx {
|
||||
+ void *lzo_comp_mem;
|
||||
+};
|
||||
+
|
||||
+static int lzo_init(struct crypto_tfm *tfm)
|
||||
+{
|
||||
+ struct lzo_ctx *ctx = crypto_tfm_ctx(tfm);
|
||||
+
|
||||
+ ctx->lzo_comp_mem = vmalloc(LZO1X_MEM_COMPRESS);
|
||||
+ if (!ctx->lzo_comp_mem)
|
||||
+ return -ENOMEM;
|
||||
+
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
+static void lzo_exit(struct crypto_tfm *tfm)
|
||||
+{
|
||||
+ struct lzo_ctx *ctx = crypto_tfm_ctx(tfm);
|
||||
+
|
||||
+ vfree(ctx->lzo_comp_mem);
|
||||
+}
|
||||
+
|
||||
+static int lzo_compress(struct crypto_tfm *tfm, const u8 *src,
|
||||
+ unsigned int slen, u8 *dst, unsigned int *dlen)
|
||||
+{
|
||||
+ struct lzo_ctx *ctx = crypto_tfm_ctx(tfm);
|
||||
+ size_t tmp_len = *dlen; /* size_t(ulong) <-> uint on 64 bit */
|
||||
+ int err;
|
||||
+
|
||||
+ err = lzo1x_1_compress(src, slen, dst, &tmp_len, ctx->lzo_comp_mem);
|
||||
+
|
||||
+ if (err != LZO_E_OK)
|
||||
+ return -EINVAL;
|
||||
+
|
||||
+ *dlen = tmp_len;
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
+static int lzo_decompress(struct crypto_tfm *tfm, const u8 *src,
|
||||
+ unsigned int slen, u8 *dst, unsigned int *dlen)
|
||||
+{
|
||||
+ int err;
|
||||
+ size_t tmp_len = *dlen; /* size_t(ulong) <-> uint on 64 bit */
|
||||
+
|
||||
+ err = lzo1x_decompress_safe(src, slen, dst, &tmp_len);
|
||||
+
|
||||
+ if (err != LZO_E_OK)
|
||||
+ return -EINVAL;
|
||||
+
|
||||
+ *dlen = tmp_len;
|
||||
+ return 0;
|
||||
+
|
||||
+}
|
||||
+
|
||||
+static struct crypto_alg alg = {
|
||||
+ .cra_name = "lzo",
|
||||
+ .cra_flags = CRYPTO_ALG_TYPE_COMPRESS,
|
||||
+ .cra_ctxsize = sizeof(struct lzo_ctx),
|
||||
+ .cra_module = THIS_MODULE,
|
||||
+ .cra_list = LIST_HEAD_INIT(alg.cra_list),
|
||||
+ .cra_init = lzo_init,
|
||||
+ .cra_exit = lzo_exit,
|
||||
+ .cra_u = { .compress = {
|
||||
+ .coa_compress = lzo_compress,
|
||||
+ .coa_decompress = lzo_decompress } }
|
||||
+};
|
||||
+
|
||||
+static int __init init(void)
|
||||
+{
|
||||
+ return crypto_register_alg(&alg);
|
||||
+}
|
||||
+
|
||||
+static void __exit fini(void)
|
||||
+{
|
||||
+ crypto_unregister_alg(&alg);
|
||||
+}
|
||||
+
|
||||
+module_init(init);
|
||||
+module_exit(fini);
|
||||
+
|
||||
+MODULE_LICENSE("GPL");
|
||||
+MODULE_DESCRIPTION("LZO Compression Algorithm");
|
||||
--- linux-2.6.24.7.old/crypto/tcrypt.c 2008-05-07 01:22:34.000000000 +0200
|
||||
+++ linux-2.6.24.7/crypto/tcrypt.c 2009-04-12 18:13:57.000000000 +0200
|
||||
@@ -78,7 +78,7 @@
|
||||
"twofish", "serpent", "sha384", "sha512", "md4", "aes", "cast6",
|
||||
"arc4", "michael_mic", "deflate", "crc32c", "tea", "xtea",
|
||||
"khazad", "wp512", "wp384", "wp256", "tnepres", "xeta", "fcrypt",
|
||||
- "camellia", "seed", NULL
|
||||
+ "camellia", "seed", "lzo", NULL
|
||||
};
|
||||
|
||||
static void hexdump(unsigned char *buf, unsigned int len)
|
||||
@@ -800,7 +800,8 @@
|
||||
crypto_free_hash(tfm);
|
||||
}
|
||||
|
||||
-static void test_deflate(void)
|
||||
+static void test_comp(char *algo, struct comp_testvec *ctemplate,
|
||||
+ struct comp_testvec *dtemplate, int ctcount, int dtcount)
|
||||
{
|
||||
unsigned int i;
|
||||
char result[COMP_BUF_SIZE];
|
||||
@@ -808,25 +809,26 @@
|
||||
struct comp_testvec *tv;
|
||||
unsigned int tsize;
|
||||
|
||||
- printk("\ntesting deflate compression\n");
|
||||
+ printk("\ntesting %s compression\n", algo);
|
||||
|
||||
- tsize = sizeof (deflate_comp_tv_template);
|
||||
+ tsize = sizeof(struct comp_testvec);
|
||||
+ tsize *= ctcount;
|
||||
if (tsize > TVMEMSIZE) {
|
||||
printk("template (%u) too big for tvmem (%u)\n", tsize,
|
||||
TVMEMSIZE);
|
||||
return;
|
||||
}
|
||||
|
||||
- memcpy(tvmem, deflate_comp_tv_template, tsize);
|
||||
+ memcpy(tvmem, ctemplate, tsize);
|
||||
tv = (void *)tvmem;
|
||||
|
||||
- tfm = crypto_alloc_comp("deflate", 0, CRYPTO_ALG_ASYNC);
|
||||
+ tfm = crypto_alloc_comp(algo, 0, CRYPTO_ALG_ASYNC);
|
||||
if (IS_ERR(tfm)) {
|
||||
- printk("failed to load transform for deflate\n");
|
||||
+ printk("failed to load transform for %s\n", algo);
|
||||
return;
|
||||
}
|
||||
|
||||
- for (i = 0; i < DEFLATE_COMP_TEST_VECTORS; i++) {
|
||||
+ for (i = 0; i < ctcount; i++) {
|
||||
int ilen, ret, dlen = COMP_BUF_SIZE;
|
||||
|
||||
printk("test %u:\n", i + 1);
|
||||
@@ -845,19 +847,20 @@
|
||||
ilen, dlen);
|
||||
}
|
||||
|
||||
- printk("\ntesting deflate decompression\n");
|
||||
+ printk("\ntesting %s decompression\n", algo);
|
||||
|
||||
- tsize = sizeof (deflate_decomp_tv_template);
|
||||
+ tsize = sizeof(struct comp_testvec);
|
||||
+ tsize *= dtcount;
|
||||
if (tsize > TVMEMSIZE) {
|
||||
printk("template (%u) too big for tvmem (%u)\n", tsize,
|
||||
TVMEMSIZE);
|
||||
goto out;
|
||||
}
|
||||
|
||||
- memcpy(tvmem, deflate_decomp_tv_template, tsize);
|
||||
+ memcpy(tvmem, dtemplate, tsize);
|
||||
tv = (void *)tvmem;
|
||||
|
||||
- for (i = 0; i < DEFLATE_DECOMP_TEST_VECTORS; i++) {
|
||||
+ for (i = 0; i < dtcount; i++) {
|
||||
int ilen, ret, dlen = COMP_BUF_SIZE;
|
||||
|
||||
printk("test %u:\n", i + 1);
|
||||
@@ -1057,7 +1060,11 @@
|
||||
test_hash("tgr192", tgr192_tv_template, TGR192_TEST_VECTORS);
|
||||
test_hash("tgr160", tgr160_tv_template, TGR160_TEST_VECTORS);
|
||||
test_hash("tgr128", tgr128_tv_template, TGR128_TEST_VECTORS);
|
||||
- test_deflate();
|
||||
+ test_comp("deflate", deflate_comp_tv_template,
|
||||
+ deflate_decomp_tv_template, DEFLATE_COMP_TEST_VECTORS,
|
||||
+ DEFLATE_DECOMP_TEST_VECTORS);
|
||||
+ test_comp("lzo", lzo_comp_tv_template, lzo_decomp_tv_template,
|
||||
+ LZO_COMP_TEST_VECTORS, LZO_DECOMP_TEST_VECTORS);
|
||||
test_hash("crc32c", crc32c_tv_template, CRC32C_TEST_VECTORS);
|
||||
test_hash("hmac(md5)", hmac_md5_tv_template,
|
||||
HMAC_MD5_TEST_VECTORS);
|
||||
@@ -1167,7 +1174,9 @@
|
||||
break;
|
||||
|
||||
case 13:
|
||||
- test_deflate();
|
||||
+ test_comp("deflate", deflate_comp_tv_template,
|
||||
+ deflate_decomp_tv_template, DEFLATE_COMP_TEST_VECTORS,
|
||||
+ DEFLATE_DECOMP_TEST_VECTORS);
|
||||
break;
|
||||
|
||||
case 14:
|
||||
@@ -1292,6 +1301,11 @@
|
||||
CAMELLIA_CBC_DEC_TEST_VECTORS);
|
||||
break;
|
||||
|
||||
+ case 33:
|
||||
+ test_comp("lzo", lzo_comp_tv_template, lzo_decomp_tv_template,
|
||||
+ LZO_COMP_TEST_VECTORS, LZO_DECOMP_TEST_VECTORS);
|
||||
+ break;
|
||||
+
|
||||
case 100:
|
||||
test_hash("hmac(md5)", hmac_md5_tv_template,
|
||||
HMAC_MD5_TEST_VECTORS);
|
||||
--- linux-2.6.24.7.old/crypto/tcrypt.h 2008-05-07 01:22:34.000000000 +0200
|
||||
+++ linux-2.6.24.7/crypto/tcrypt.h 2009-04-12 18:13:57.000000000 +0200
|
||||
@@ -4408,6 +4408,88 @@
|
||||
};
|
||||
|
||||
/*
|
||||
+ * LZO test vectors (null-terminated strings).
|
||||
+ */
|
||||
+#define LZO_COMP_TEST_VECTORS 2
|
||||
+#define LZO_DECOMP_TEST_VECTORS 2
|
||||
+
|
||||
+static struct comp_testvec lzo_comp_tv_template[] = {
|
||||
+ {
|
||||
+ .inlen = 70,
|
||||
+ .outlen = 46,
|
||||
+ .input = "Join us now and share the software "
|
||||
+ "Join us now and share the software ",
|
||||
+ .output = { 0x00, 0x0d, 0x4a, 0x6f, 0x69, 0x6e, 0x20, 0x75,
|
||||
+ 0x73, 0x20, 0x6e, 0x6f, 0x77, 0x20, 0x61, 0x6e,
|
||||
+ 0x64, 0x20, 0x73, 0x68, 0x61, 0x72, 0x65, 0x20,
|
||||
+ 0x74, 0x68, 0x65, 0x20, 0x73, 0x6f, 0x66, 0x74,
|
||||
+ 0x77, 0x70, 0x01, 0x01, 0x4a, 0x6f, 0x69, 0x6e,
|
||||
+ 0x3d, 0x88, 0x00, 0x11, 0x00, 0x00 },
|
||||
+ }, {
|
||||
+ .inlen = 159,
|
||||
+ .outlen = 133,
|
||||
+ .input = "This document describes a compression method based on the LZO "
|
||||
+ "compression algorithm. This document defines the application of "
|
||||
+ "the LZO algorithm used in UBIFS.",
|
||||
+ .output = { 0x00, 0x2b, 0x54, 0x68, 0x69, 0x73, 0x20, 0x64,
|
||||
+ 0x6f, 0x63, 0x75, 0x6d, 0x65, 0x6e, 0x74, 0x20,
|
||||
+ 0x64, 0x65, 0x73, 0x63, 0x72, 0x69, 0x62, 0x65,
|
||||
+ 0x73, 0x20, 0x61, 0x20, 0x63, 0x6f, 0x6d, 0x70,
|
||||
+ 0x72, 0x65, 0x73, 0x73, 0x69, 0x6f, 0x6e, 0x20,
|
||||
+ 0x6d, 0x65, 0x74, 0x68, 0x6f, 0x64, 0x20, 0x62,
|
||||
+ 0x61, 0x73, 0x65, 0x64, 0x20, 0x6f, 0x6e, 0x20,
|
||||
+ 0x74, 0x68, 0x65, 0x20, 0x4c, 0x5a, 0x4f, 0x2b,
|
||||
+ 0x8c, 0x00, 0x0d, 0x61, 0x6c, 0x67, 0x6f, 0x72,
|
||||
+ 0x69, 0x74, 0x68, 0x6d, 0x2e, 0x20, 0x20, 0x54,
|
||||
+ 0x68, 0x69, 0x73, 0x2a, 0x54, 0x01, 0x02, 0x66,
|
||||
+ 0x69, 0x6e, 0x65, 0x73, 0x94, 0x06, 0x05, 0x61,
|
||||
+ 0x70, 0x70, 0x6c, 0x69, 0x63, 0x61, 0x74, 0x76,
|
||||
+ 0x0a, 0x6f, 0x66, 0x88, 0x02, 0x60, 0x09, 0x27,
|
||||
+ 0xf0, 0x00, 0x0c, 0x20, 0x75, 0x73, 0x65, 0x64,
|
||||
+ 0x20, 0x69, 0x6e, 0x20, 0x55, 0x42, 0x49, 0x46,
|
||||
+ 0x53, 0x2e, 0x11, 0x00, 0x00 },
|
||||
+ },
|
||||
+};
|
||||
+
|
||||
+static struct comp_testvec lzo_decomp_tv_template[] = {
|
||||
+ {
|
||||
+ .inlen = 133,
|
||||
+ .outlen = 159,
|
||||
+ .input = { 0x00, 0x2b, 0x54, 0x68, 0x69, 0x73, 0x20, 0x64,
|
||||
+ 0x6f, 0x63, 0x75, 0x6d, 0x65, 0x6e, 0x74, 0x20,
|
||||
+ 0x64, 0x65, 0x73, 0x63, 0x72, 0x69, 0x62, 0x65,
|
||||
+ 0x73, 0x20, 0x61, 0x20, 0x63, 0x6f, 0x6d, 0x70,
|
||||
+ 0x72, 0x65, 0x73, 0x73, 0x69, 0x6f, 0x6e, 0x20,
|
||||
+ 0x6d, 0x65, 0x74, 0x68, 0x6f, 0x64, 0x20, 0x62,
|
||||
+ 0x61, 0x73, 0x65, 0x64, 0x20, 0x6f, 0x6e, 0x20,
|
||||
+ 0x74, 0x68, 0x65, 0x20, 0x4c, 0x5a, 0x4f, 0x2b,
|
||||
+ 0x8c, 0x00, 0x0d, 0x61, 0x6c, 0x67, 0x6f, 0x72,
|
||||
+ 0x69, 0x74, 0x68, 0x6d, 0x2e, 0x20, 0x20, 0x54,
|
||||
+ 0x68, 0x69, 0x73, 0x2a, 0x54, 0x01, 0x02, 0x66,
|
||||
+ 0x69, 0x6e, 0x65, 0x73, 0x94, 0x06, 0x05, 0x61,
|
||||
+ 0x70, 0x70, 0x6c, 0x69, 0x63, 0x61, 0x74, 0x76,
|
||||
+ 0x0a, 0x6f, 0x66, 0x88, 0x02, 0x60, 0x09, 0x27,
|
||||
+ 0xf0, 0x00, 0x0c, 0x20, 0x75, 0x73, 0x65, 0x64,
|
||||
+ 0x20, 0x69, 0x6e, 0x20, 0x55, 0x42, 0x49, 0x46,
|
||||
+ 0x53, 0x2e, 0x11, 0x00, 0x00 },
|
||||
+ .output = "This document describes a compression method based on the LZO "
|
||||
+ "compression algorithm. This document defines the application of "
|
||||
+ "the LZO algorithm used in UBIFS.",
|
||||
+ }, {
|
||||
+ .inlen = 46,
|
||||
+ .outlen = 70,
|
||||
+ .input = { 0x00, 0x0d, 0x4a, 0x6f, 0x69, 0x6e, 0x20, 0x75,
|
||||
+ 0x73, 0x20, 0x6e, 0x6f, 0x77, 0x20, 0x61, 0x6e,
|
||||
+ 0x64, 0x20, 0x73, 0x68, 0x61, 0x72, 0x65, 0x20,
|
||||
+ 0x74, 0x68, 0x65, 0x20, 0x73, 0x6f, 0x66, 0x74,
|
||||
+ 0x77, 0x70, 0x01, 0x01, 0x4a, 0x6f, 0x69, 0x6e,
|
||||
+ 0x3d, 0x88, 0x00, 0x11, 0x00, 0x00 },
|
||||
+ .output = "Join us now and share the software "
|
||||
+ "Join us now and share the software ",
|
||||
+ },
|
||||
+};
|
||||
+
|
||||
+/*
|
||||
* Michael MIC test vectors from IEEE 802.11i
|
||||
*/
|
||||
#define MICHAEL_MIC_TEST_VECTORS 6
|
Loading…
Reference in New Issue
Block a user