mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-12-26 00:26:47 +02:00
[ar7] refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22769 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
56572f716f
commit
72015e72cf
@ -1,5 +1,5 @@
|
|||||||
--- a/drivers/mtd/ar7part.c-back 2010-01-13 15:58:44.000000000 -0500
|
--- a/drivers/mtd/ar7part.c
|
||||||
+++ b/drivers/mtd/ar7part.c 2010-01-13 16:16:05.000000000 -0500
|
+++ b/drivers/mtd/ar7part.c
|
||||||
@@ -27,12 +27,14 @@
|
@@ -27,12 +27,14 @@
|
||||||
#include <linux/mtd/partitions.h>
|
#include <linux/mtd/partitions.h>
|
||||||
#include <linux/bootmem.h>
|
#include <linux/bootmem.h>
|
||||||
@ -43,8 +43,8 @@
|
|||||||
ar7_parts = kzalloc(sizeof(*ar7_parts) * AR7_PARTS, GFP_KERNEL);
|
ar7_parts = kzalloc(sizeof(*ar7_parts) * AR7_PARTS, GFP_KERNEL);
|
||||||
if (!ar7_parts)
|
if (!ar7_parts)
|
||||||
return -ENOMEM;
|
return -ENOMEM;
|
||||||
--- a/drivers/mtd/Makefile 2010-01-11 14:44:12.000000000 -0500
|
--- a/drivers/mtd/Makefile
|
||||||
+++ a/drivers/mtd/Makefile 2010-02-03 13:44:38.000000000 -0500
|
+++ b/drivers/mtd/Makefile
|
||||||
@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
|
@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
|
||||||
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
||||||
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
||||||
|
@ -54,7 +54,7 @@
|
|||||||
dev->irq = platform_get_irq_byname(pdev, "irq");
|
dev->irq = platform_get_irq_byname(pdev, "irq");
|
||||||
|
|
||||||
dev->netdev_ops = &cpmac_netdev_ops;
|
dev->netdev_ops = &cpmac_netdev_ops;
|
||||||
@@ -1228,7 +1230,7 @@ int __devinit cpmac_init(void)
|
@@ -1229,7 +1231,7 @@ int __devinit cpmac_init(void)
|
||||||
cpmac_mii->reset = cpmac_mdio_reset;
|
cpmac_mii->reset = cpmac_mdio_reset;
|
||||||
cpmac_mii->irq = mii_irqs;
|
cpmac_mii->irq = mii_irqs;
|
||||||
|
|
||||||
@ -63,7 +63,7 @@
|
|||||||
|
|
||||||
if (!cpmac_mii->priv) {
|
if (!cpmac_mii->priv) {
|
||||||
printk(KERN_ERR "Can't ioremap mdio registers\n");
|
printk(KERN_ERR "Can't ioremap mdio registers\n");
|
||||||
@@ -1239,10 +1241,17 @@ int __devinit cpmac_init(void)
|
@@ -1240,10 +1242,17 @@ int __devinit cpmac_init(void)
|
||||||
#warning FIXME: unhardcode gpio&reset bits
|
#warning FIXME: unhardcode gpio&reset bits
|
||||||
ar7_gpio_disable(26);
|
ar7_gpio_disable(26);
|
||||||
ar7_gpio_disable(27);
|
ar7_gpio_disable(27);
|
||||||
@ -83,7 +83,7 @@
|
|||||||
cpmac_mii->reset(cpmac_mii);
|
cpmac_mii->reset(cpmac_mii);
|
||||||
|
|
||||||
for (i = 0; i < 300; i++)
|
for (i = 0; i < 300; i++)
|
||||||
@@ -1257,7 +1266,8 @@ int __devinit cpmac_init(void)
|
@@ -1258,7 +1267,8 @@ int __devinit cpmac_init(void)
|
||||||
mask = 0;
|
mask = 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -78,7 +78,7 @@
|
|||||||
dev_err(&pdev->dev, "no PHY present, falling back to switch mode\n");
|
dev_err(&pdev->dev, "no PHY present, falling back to switch mode\n");
|
||||||
strncpy(mdio_bus_id, "0", MII_BUS_ID_SIZE); /* fixed phys bus */
|
strncpy(mdio_bus_id, "0", MII_BUS_ID_SIZE); /* fixed phys bus */
|
||||||
phy_id = pdev->id;
|
phy_id = pdev->id;
|
||||||
@@ -1268,7 +1264,7 @@ int __devinit cpmac_init(void)
|
@@ -1269,7 +1265,7 @@ int __devinit cpmac_init(void)
|
||||||
}
|
}
|
||||||
|
|
||||||
cpmac_mii->phy_mask = ar7_is_titan()? ~(mask | 0x80000000 | 0x40000000):
|
cpmac_mii->phy_mask = ar7_is_titan()? ~(mask | 0x80000000 | 0x40000000):
|
||||||
|
Loading…
Reference in New Issue
Block a user