mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-27 17:55:55 +02:00
[toolchain/binutils]: remove the CS variant - broken since it's addition
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25648 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a4ccee4866
commit
73008aefda
@ -19,12 +19,6 @@ choice
|
|||||||
depends !avr32 || (avr32 && BROKEN)
|
depends !avr32 || (avr32 && BROKEN)
|
||||||
bool "binutils 2.21"
|
bool "binutils 2.21"
|
||||||
|
|
||||||
config BINUTILS_VERSION_CS
|
|
||||||
depends !avr32
|
|
||||||
depends !ubicom32
|
|
||||||
depends BROKEN
|
|
||||||
bool "binutils 2.19.1+20090205 with CodeSourcery enhancements"
|
|
||||||
|
|
||||||
endchoice
|
endchoice
|
||||||
|
|
||||||
config EXTRA_BINUTILS_CONFIG_OPTIONS
|
config EXTRA_BINUTILS_CONFIG_OPTIONS
|
||||||
@ -40,6 +34,5 @@ config BINUTILS_VERSION
|
|||||||
default "2.19.1" if BINUTILS_VERSION_2_19_1
|
default "2.19.1" if BINUTILS_VERSION_2_19_1
|
||||||
default "2.20.1" if BINUTILS_VERSION_2_20_1
|
default "2.20.1" if BINUTILS_VERSION_2_20_1
|
||||||
default "2.21" if BINUTILS_VERSION_2_21
|
default "2.21" if BINUTILS_VERSION_2_21
|
||||||
default "2.19.1+cs" if BINUTILS_VERSION_CS
|
|
||||||
default "2.19.1" if ubicom32
|
default "2.19.1" if ubicom32
|
||||||
default "2.20.1"
|
default "2.20.1"
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006-2009 OpenWrt.org
|
# Copyright (C) 2006-2011 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -16,13 +16,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|||||||
ifeq ($(PKG_VERSION),2.19.1)
|
ifeq ($(PKG_VERSION),2.19.1)
|
||||||
PKG_MD5SUM:=09a8c5821a2dfdbb20665bc0bd680791
|
PKG_MD5SUM:=09a8c5821a2dfdbb20665bc0bd680791
|
||||||
endif
|
endif
|
||||||
ifeq ($(PKG_VERSION),2.19.1+cs)
|
|
||||||
BIN_VERSION:=20090205
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(BIN_VERSION).tar.bz2
|
|
||||||
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
|
||||||
PKG_MD5SUM:=040740e8c864dd1a15886753f9c0bc0b
|
|
||||||
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/binutils-$(BIN_VERSION)
|
|
||||||
endif
|
|
||||||
ifeq ($(PKG_VERSION),2.20.1)
|
ifeq ($(PKG_VERSION),2.20.1)
|
||||||
PKG_MD5SUM:=9cdfb9d6ec0578c166d3beae5e15c4e5
|
PKG_MD5SUM:=9cdfb9d6ec0578c166d3beae5e15c4e5
|
||||||
endif
|
endif
|
||||||
|
File diff suppressed because it is too large
Load Diff
@ -1,22 +0,0 @@
|
|||||||
--- a/configure
|
|
||||||
+++ b/configure
|
|
||||||
@@ -2330,7 +2330,7 @@ case "${target}" in
|
|
||||||
noconfigdirs="$noconfigdirs target-libffi target-qthreads"
|
|
||||||
libgloss_dir=arm
|
|
||||||
;;
|
|
||||||
- arm*-*-linux-gnueabi)
|
|
||||||
+ arm*-*-linux-*gnueabi)
|
|
||||||
noconfigdirs="$noconfigdirs target-qthreads"
|
|
||||||
case ${with_newlib} in
|
|
||||||
no) noconfigdirs="$noconfigdirs target-newlib target-libgloss"
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -566,7 +566,7 @@ case "${target}" in
|
|
||||||
noconfigdirs="$noconfigdirs target-libffi target-qthreads"
|
|
||||||
libgloss_dir=arm
|
|
||||||
;;
|
|
||||||
- arm*-*-linux-gnueabi)
|
|
||||||
+ arm*-*-linux-*gnueabi)
|
|
||||||
noconfigdirs="$noconfigdirs target-qthreads"
|
|
||||||
case ${with_newlib} in
|
|
||||||
no) noconfigdirs="$noconfigdirs target-newlib target-libgloss"
|
|
@ -1,13 +0,0 @@
|
|||||||
--- a/bfd/elf32-arm.c
|
|
||||||
+++ b/bfd/elf32-arm.c
|
|
||||||
@@ -5476,6 +5476,10 @@ bfd_elf32_arm_init_maps (bfd *abfd)
|
|
||||||
if (! is_arm_elf (abfd))
|
|
||||||
return;
|
|
||||||
|
|
||||||
+ /* PR 7093: Make sure that we are dealing with an arm elf binary. */
|
|
||||||
+ if (! is_arm_elf (abfd))
|
|
||||||
+ return;
|
|
||||||
+
|
|
||||||
if ((abfd->flags & DYNAMIC) != 0)
|
|
||||||
return;
|
|
||||||
|
|
@ -1,38 +0,0 @@
|
|||||||
Source: Khem Raj <raj.khem@gmail.com>
|
|
||||||
Disposition: submit upstream.
|
|
||||||
|
|
||||||
Description:
|
|
||||||
|
|
||||||
We do not need to have the libtool patch anymore for binutils after
|
|
||||||
libtool has been updated upstream it include support for it. However
|
|
||||||
for building gas natively on uclibc systems we have to link it with
|
|
||||||
-lm so that it picks up missing symbols.
|
|
||||||
|
|
||||||
/local/build_area/BUILD/arm_v5t_le_uclibc/binutils-2.17.50/objdir/libiberty/pic/libiberty.a(floatformat.o): In function `floatformat_from_double':
|
|
||||||
floatformat.c:(.text+0x1ec): undefined reference to `frexp'
|
|
||||||
floatformat.c:(.text+0x2f8): undefined reference to `ldexp'
|
|
||||||
/local/build_area/BUILD/arm_v5t_le_uclibc/binutils-2.17.50/objdir/libiberty/pic/libiberty.a(floatformat.o): In function `floatformat_to_double':
|
|
||||||
floatformat.c:(.text+0x38a): undefined reference to `ldexp'
|
|
||||||
floatformat.c:(.text+0x3d2): undefined reference to `ldexp'
|
|
||||||
floatformat.c:(.text+0x43e): undefined reference to `ldexp' floatformat.c:(.text+0x4e2): undefined reference to `ldexp'
|
|
||||||
collect2: ld returned 1 exit status
|
|
||||||
make[4]: *** [as-new] Error 1
|
|
||||||
|
|
||||||
Index: binutils-2.17.50/gas/configure.tgt
|
|
||||||
===================================================================
|
|
||||||
--- binutils-2.17.50.orig/gas/configure.tgt
|
|
||||||
+++ binutils-2.17.50/gas/configure.tgt
|
|
||||||
@@ -415,6 +415,12 @@ case ${generic_target} in
|
|
||||||
*-*-netware) fmt=elf em=netware ;;
|
|
||||||
esac
|
|
||||||
|
|
||||||
+case ${generic_target} in
|
|
||||||
+ arm-*-*uclibc*)
|
|
||||||
+ need_libm=yes
|
|
||||||
+ ;;
|
|
||||||
+esac
|
|
||||||
+
|
|
||||||
case ${cpu_type} in
|
|
||||||
alpha | arm | i386 | ia64 | mips | ns32k | pdp11 | ppc | sparc | z80 | z8k)
|
|
||||||
bfd_gas=yes
|
|
||||||
|
|
@ -1,40 +0,0 @@
|
|||||||
--- a/configure
|
|
||||||
+++ b/configure
|
|
||||||
@@ -2298,7 +2298,7 @@ case "${target}" in
|
|
||||||
am33_2.0-*-linux*)
|
|
||||||
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
||||||
;;
|
|
||||||
- sh-*-linux*)
|
|
||||||
+ sh*-*-linux*)
|
|
||||||
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
||||||
;;
|
|
||||||
sh*-*-pe|mips*-*-pe|*arm-wince-pe)
|
|
||||||
@@ -2632,7 +2632,7 @@ case "${target}" in
|
|
||||||
romp-*-*)
|
|
||||||
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
|
|
||||||
;;
|
|
||||||
- sh-*-* | sh64-*-*)
|
|
||||||
+ sh*-*-* | sh64-*-*)
|
|
||||||
case "${host}" in
|
|
||||||
i[3456789]86-*-vsta) ;; # don't add gprof back in
|
|
||||||
i[3456789]86-*-go32*) ;; # don't add gprof back in
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -534,7 +534,7 @@ case "${target}" in
|
|
||||||
am33_2.0-*-linux*)
|
|
||||||
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
||||||
;;
|
|
||||||
- sh-*-linux*)
|
|
||||||
+ sh*-*-linux*)
|
|
||||||
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
||||||
;;
|
|
||||||
sh*-*-pe|mips*-*-pe|*arm-wince-pe)
|
|
||||||
@@ -868,7 +868,7 @@ case "${target}" in
|
|
||||||
romp-*-*)
|
|
||||||
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
|
|
||||||
;;
|
|
||||||
- sh-*-* | sh64-*-*)
|
|
||||||
+ sh*-*-* | sh64-*-*)
|
|
||||||
case "${host}" in
|
|
||||||
i[[3456789]]86-*-vsta) ;; # don't add gprof back in
|
|
||||||
i[[3456789]]86-*-go32*) ;; # don't add gprof back in
|
|
@ -1,22 +0,0 @@
|
|||||||
--- a/ld/Makefile.am
|
|
||||||
+++ b/ld/Makefile.am
|
|
||||||
@@ -18,7 +18,7 @@ AM_CFLAGS = $(WARN_CFLAGS)
|
|
||||||
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
|
||||||
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
|
||||||
# directives need to be different for native and cross linkers.
|
|
||||||
-scriptdir = $(tooldir)/lib
|
|
||||||
+scriptdir = $(libdir)
|
|
||||||
|
|
||||||
EMUL = @EMUL@
|
|
||||||
EMULATION_OFILES = @EMULATION_OFILES@
|
|
||||||
--- a/ld/Makefile.in
|
|
||||||
+++ b/ld/Makefile.in
|
|
||||||
@@ -304,7 +304,7 @@ AM_CFLAGS = $(WARN_CFLAGS)
|
|
||||||
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
|
||||||
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
|
||||||
# directives need to be different for native and cross linkers.
|
|
||||||
-scriptdir = $(tooldir)/lib
|
|
||||||
+scriptdir = $(libdir)
|
|
||||||
BASEDIR = $(srcdir)/..
|
|
||||||
BFDDIR = $(BASEDIR)/bfd
|
|
||||||
INCDIR = $(BASEDIR)/include
|
|
@ -1,20 +0,0 @@
|
|||||||
--- a/ld/emultempl/elf32.em
|
|
||||||
+++ b/ld/emultempl/elf32.em
|
|
||||||
@@ -1220,6 +1220,8 @@ fragment <<EOF
|
|
||||||
&& command_line.rpath == NULL)
|
|
||||||
{
|
|
||||||
lib_path = (const char *) getenv ("LD_RUN_PATH");
|
|
||||||
+ if ((lib_path) && (strlen (lib_path) == 0))
|
|
||||||
+ lib_path = NULL;
|
|
||||||
if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
|
|
||||||
force))
|
|
||||||
break;
|
|
||||||
@@ -1405,6 +1407,8 @@ gld${EMULATION_NAME}_before_allocation (
|
|
||||||
rpath = command_line.rpath;
|
|
||||||
if (rpath == NULL)
|
|
||||||
rpath = (const char *) getenv ("LD_RUN_PATH");
|
|
||||||
+ if ((rpath) && (strlen (rpath) == 0))
|
|
||||||
+ rpath = NULL;
|
|
||||||
if (! (bfd_elf_size_dynamic_sections
|
|
||||||
(link_info.output_bfd, command_line.soname, rpath,
|
|
||||||
command_line.filter_shlib,
|
|
Loading…
Reference in New Issue
Block a user