1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-11-24 00:07:11 +02:00

kernel: update from version 2.6.32.25 to 2.6.32.27

git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@24490 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
hauke 2010-12-11 17:26:04 +00:00
parent 84a68225e2
commit 7403cc76a9
18 changed files with 21 additions and 21 deletions

View File

@ -17,8 +17,8 @@ endif
ifeq ($(LINUX_VERSION),2.6.31.12)
LINUX_KERNEL_MD5SUM:=517be354b81b780e2f4b2ad614d030de
endif
ifeq ($(LINUX_VERSION),2.6.32.16)
LINUX_KERNEL_MD5SUM:=d94d91ef3be4eb76765401b4fa462759
ifeq ($(LINUX_VERSION),2.6.32.27)
LINUX_KERNEL_MD5SUM:=c8df8bed01a3b7e4ce13563e74181d71
endif
ifeq ($(LINUX_VERSION),2.6.33)
LINUX_KERNEL_MD5SUM:=c3883760b18d50e8d78819c54d579b00

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
BOARD:=adm5120
BOARDNAME:=Infineon/ADMtek ADM5120
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
SUBTARGETS:=router_le router_be
INITRAMFS_EXTRA_FILES:=

View File

@ -11,7 +11,7 @@ BOARD:=ar7
BOARDNAME:=TI AR7
FEATURES:=squashfs jffs2 atm
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=Atheros AR71xx/AR7240/AR913x
FEATURES:=squashfs jffs2 targz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=RMI/AMD AU1x00
FEATURES:=jffs2 usb pci
SUBTARGETS=au1500 au1550
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini yamonenv

View File

@ -10,7 +10,7 @@ ARCH:=avr32
BOARD:=avr32
BOARDNAME:=Atmel AVR32
FEATURES:=squashfs
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
include $(INCLUDE_DIR)/target.mk

View File

@ -11,7 +11,7 @@ BOARD:=brcm47xx
BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb pcmcia
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram

View File

@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
FEATURES:=squashfs jffs2 usb atm pci pcmcia
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=Cobalt Microservers
FEATURES:=targz pci ext2
CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
include $(INCLUDE_DIR)/target.mk

View File

@ -829,7 +829,7 @@
+be done automatically.
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2377,6 +2377,11 @@ T: git git://git.kernel.org/pub/scm/linu
@@ -2383,6 +2383,11 @@ T: git git://git.kernel.org/pub/scm/linu
S: Maintained
F: drivers/media/video/gspca/

View File

@ -68,7 +68,7 @@
* macro override instead of weak attribute alias, to workaround
--- a/kernel/sched.c
+++ b/kernel/sched.c
@@ -6224,6 +6224,7 @@ int can_nice(const struct task_struct *p
@@ -6223,6 +6223,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
capable(CAP_SYS_NICE));
}
@ -96,7 +96,7 @@
* We enter with non-exclusive mmap_sem (to exclude vma changes,
--- a/mm/vmalloc.c
+++ b/mm/vmalloc.c
@@ -1172,6 +1172,7 @@ void unmap_kernel_range(unsigned long ad
@@ -1181,6 +1181,7 @@ void unmap_kernel_range(unsigned long ad
vunmap_page_range(addr, end);
flush_tlb_kernel_range(addr, end);
}
@ -104,7 +104,7 @@
int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
{
@@ -1287,6 +1288,7 @@ struct vm_struct *get_vm_area(unsigned l
@@ -1296,6 +1297,7 @@ struct vm_struct *get_vm_area(unsigned l
return __get_vm_area_node(size, 1, flags, VMALLOC_START, VMALLOC_END,
-1, GFP_KERNEL, __builtin_return_address(0));
}

View File

@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
FEATURES:=squashfs
SUBTARGETS=generic harddisk
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
include $(INCLUDE_DIR)/target.mk

View File

@ -13,7 +13,7 @@ FEATURES:=squashfs
SUBTARGETS=generic harddisk
CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=AMCC/IBM PPC40x
FEATURES:=squashfs
CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=AMCC/IBM PPC44x
FEATURES:=squashfs
CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
include $(INCLUDE_DIR)/target.mk

View File

@ -11,7 +11,7 @@ BOARD:=rb532
BOARDNAME:=Mikrotik RouterBoard 532
FEATURES:=jffs2 pci targz
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532

View File

@ -12,7 +12,7 @@ BOARDNAME:=x86
FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia targz
SUBTARGETS=generic olpc xen_domu ep80579
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
FEATURES:=jffs2 targz ubifs audio
SUBTARGETS:=qi_lb60 n516 n526
LINUX_VERSION:=2.6.32.25
LINUX_VERSION:=2.6.32.27
DEVICE_TYPE=other