mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 19:02:28 +02:00
update mpd to development snapshot,
add shared mp3, ogg/vorbis and flac support (thanks to David Collet) git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2160 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
f248081f4a
commit
74152b6a58
@ -314,6 +314,16 @@ ifneq ($(BR2_PACKAGE_FREERADIUS_MOD_SQL_PGSQL),)
|
|||||||
freeradius-compile: postgresql-compile
|
freeradius-compile: postgresql-compile
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
ifneq ($(BR2_PACKAGE_MPD_MP3),)
|
||||||
|
mpd-compile: libid3tag-compile libmad-compile
|
||||||
|
endif
|
||||||
|
ifneq ($(BR2_PACKAGE_MPD_OGG),)
|
||||||
|
mpd-compile: libvorbisidec-compile
|
||||||
|
endif
|
||||||
|
ifneq ($(BR2_PACKAGE_MPD_FLAC),)
|
||||||
|
mpd-compile: flac-compile
|
||||||
|
endif
|
||||||
|
|
||||||
openvpn-compile: openssl-compile
|
openvpn-compile: openssl-compile
|
||||||
ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
|
ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
|
||||||
openvpn-compile: lzo-compile
|
openvpn-compile: lzo-compile
|
||||||
|
@ -1,19 +1,32 @@
|
|||||||
config BR2_PACKAGE_MPD
|
config BR2_PACKAGE_MPD
|
||||||
tristate "MPD - Music Player Daemon (flac support)"
|
tristate "MPD - Music Player Daemon"
|
||||||
default m if CONFIG_DEVEL
|
default m if CONFIG_DEVEL
|
||||||
help
|
help
|
||||||
MPD is a music player supporting flac, mp3 and ogg.
|
MPD is a music player supporting flac, mp3 and ogg files.
|
||||||
It is typically controlled over a network using one of it's many
|
It is typically controlled over a network using one of it's many
|
||||||
clients including mpc(console), gmpc(gnome), phpmp(php) etc.
|
clients including mpc(console), gmpc(gnome), phpmp(php) etc.
|
||||||
|
|
||||||
config BR2_PACKAGE_MPD_MP3
|
config BR2_PACKAGE_MPD_MP3
|
||||||
bool "MP3 Support - Enable mp3 support (experimental)"
|
bool "MP3 Support - Enable mp3 support"
|
||||||
|
default y
|
||||||
depends BR2_PACKAGE_MPD
|
depends BR2_PACKAGE_MPD
|
||||||
|
select BR2_PACKAGE_LIBMAD
|
||||||
|
select BR2_PACKAGE_LIBID3TAG
|
||||||
help
|
help
|
||||||
Enable builtin mp3 support (mad). Not well tested, may crash your mpd!
|
Enable mp3 support (libmad).
|
||||||
|
|
||||||
config BR2_PACKAGE_MPD_OGG
|
config BR2_PACKAGE_MPD_OGG
|
||||||
bool "OGG Support - Enable ogg support (experimental)"
|
bool "OGG Support - Enable ogg support"
|
||||||
|
default y
|
||||||
depends BR2_PACKAGE_MPD
|
depends BR2_PACKAGE_MPD
|
||||||
|
select BR2_PACKAGE_LIBVORBISIDEC
|
||||||
help
|
help
|
||||||
Enable builtin ogg support (tremor).
|
Enable ogg support (tremor).
|
||||||
|
|
||||||
|
config BR2_PACKAGE_MPD_FLAC
|
||||||
|
bool "FLAC Support - Enable flac support"
|
||||||
|
default n
|
||||||
|
depends BR2_PACKAGE_MPD
|
||||||
|
select BR2_PACKAGE_LIBFLAC
|
||||||
|
help
|
||||||
|
Enable flac support (libflac).
|
||||||
|
@ -3,11 +3,11 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mpd
|
PKG_NAME:=mpd
|
||||||
PKG_VERSION:=-uclinux--1--patch-10.normalperson-05
|
PKG_VERSION:=0.12.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=c707bb24a4acaa7c6a07fd6e4cda1f7c
|
PKG_MD5SUM:=65e62cc813f2186dff0f96f164a853f8
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://mpd.bogomips.org/mpd--uclinux
|
PKG_SOURCE_URL:=http://users.tpg.com.au/davico/openwrt/
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_CAT:=zcat
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
@ -15,32 +15,49 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
|||||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||||
|
|
||||||
PKG_CONFIGURE_OPTIONS := \
|
PKG_CONFIGURE_OPTIONS := \
|
||||||
--disable-http \
|
|
||||||
--with-audio=oss \
|
|
||||||
--disable-alsa \
|
--disable-alsa \
|
||||||
--disable-shout \
|
--disable-shout \
|
||||||
--disable-id3 \
|
|
||||||
--disable-mod \
|
--disable-mod \
|
||||||
--disable-audiofile \
|
--disable-audiofile \
|
||||||
--enable-static --disable-shared \
|
--disable-iconv \
|
||||||
--enable-flac --enable-mpd-flac \
|
--disable-mpc \
|
||||||
--disable-sse --disable-3dnow \
|
--disable-aac \
|
||||||
--enable-uclinux
|
|
||||||
|
|
||||||
ifneq ($(BR2_PACKAGE_MPD_MP3),)
|
ifneq ($(BR2_PACKAGE_MPD_MP3),)
|
||||||
|
PKG_DEPENDS += libid3tag libmad
|
||||||
PKG_CONFIGURE_OPTIONS += \
|
PKG_CONFIGURE_OPTIONS += \
|
||||||
--enable-mp3 --enable-mpd-mad
|
--with-id3tag-includes=$(STAGING_DIR)/usr/include \
|
||||||
|
--with-id3tag-libraries=$(STAGING_DIR)/usr/lib \
|
||||||
|
--with-mad-includes=$(STAGING_DIR)/usr/include \
|
||||||
|
--with-mad-libraries=$(STAGING_DIR)/usr/lib
|
||||||
else
|
else
|
||||||
PKG_CONFIGURE_OPTIONS += --disable-mp3
|
PKG_CONFIGURE_OPTIONS += --disable-id3 --disable-mp3
|
||||||
endif
|
endif
|
||||||
|
|
||||||
ifneq ($(BR2_PACKAGE_MPD_OGG),)
|
ifneq ($(BR2_PACKAGE_MPD_OGG),)
|
||||||
|
PKG_DEPENDS += libvorbisidec
|
||||||
PKG_CONFIGURE_OPTIONS += \
|
PKG_CONFIGURE_OPTIONS += \
|
||||||
--enable-ogg --enable-mpd-ivorbis
|
--with-tremor \
|
||||||
|
--with-tremor-includes=$(STAGING_DIR)/usr/include \
|
||||||
|
--with-tremor-libraries=$(STAGING_DIR)/usr/lib
|
||||||
else
|
else
|
||||||
PKG_CONFIGURE_OPTIONS += --disable-ogg
|
PKG_CONFIGURE_OPTIONS += --disable-ogg
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
ifneq ($(BR2_PACKAGE_MPD_FLAC),)
|
||||||
|
PKG_DEPENDS += libflac
|
||||||
|
PKG_CONFIGURE_OPTIONS += \
|
||||||
|
--with-libFLAC-includes=$(STAGING_DIR)/usr/include \
|
||||||
|
--with-libFLAC-libraries=$(STAGING_DIR)/usr/lib
|
||||||
|
else
|
||||||
|
PKG_CONFIGURE_OPTIONS += --disable-flac
|
||||||
|
endif
|
||||||
|
|
||||||
|
COMMA:= ,
|
||||||
|
EMPTY:=
|
||||||
|
SPACE:= $(EMPTY) $(EMPTY)
|
||||||
|
PKG_DEPENDS:=$(subst $(SPACE),$(COMMA)$(SPACE),$(sort $(PKG_DEPENDS)))
|
||||||
|
|
||||||
include $(TOPDIR)/package/rules.mk
|
include $(TOPDIR)/package/rules.mk
|
||||||
|
|
||||||
$(eval $(call PKG_template,MPD,mpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
$(eval $(call PKG_template,MPD,mpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||||
@ -48,14 +65,28 @@ $(eval $(call PKG_template,MPD,mpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
|||||||
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
|
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
|
||||||
(cd $(PKG_BUILD_DIR); \
|
(cd $(PKG_BUILD_DIR); \
|
||||||
$(TARGET_CONFIGURE_OPTS) \
|
$(TARGET_CONFIGURE_OPTS) \
|
||||||
CFLAGS="$(TARGET_CFLAGS)" \
|
CFLAGS="$(strip $(TARGET_CFLAGS))" \
|
||||||
|
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||||
|
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||||
./configure \
|
./configure \
|
||||||
--target=$(GNU_TARGET_NAME) \
|
--target=$(GNU_TARGET_NAME) \
|
||||||
--host=$(GNU_TARGET_NAME) \
|
--host=$(GNU_TARGET_NAME) \
|
||||||
--build=$(GNU_HOST_NAME) \
|
--build=$(GNU_HOST_NAME) \
|
||||||
--prefix=/usr \
|
--program-prefix="" \
|
||||||
--sysconfdir=/etc \
|
--program-suffix="" \
|
||||||
$(PKG_CONFIGURE_OPTIONS) \
|
--prefix=/usr \
|
||||||
|
--exec-prefix=/usr \
|
||||||
|
--bindir=/usr/bin \
|
||||||
|
--datadir=/usr/share \
|
||||||
|
--includedir=/usr/include \
|
||||||
|
--infodir=/usr/share/info \
|
||||||
|
--libdir=/usr/lib \
|
||||||
|
--libexecdir=/usr/lib \
|
||||||
|
--localstatedir=/var \
|
||||||
|
--mandir=/usr/share/man \
|
||||||
|
--sbindir=/usr/sbin \
|
||||||
|
--sysconfdir=/etc \
|
||||||
|
$(PKG_CONFIGURE_OPTIONS) \
|
||||||
);
|
);
|
||||||
touch $@
|
touch $@
|
||||||
|
|
||||||
@ -73,6 +104,7 @@ $(IPKG_MPD):
|
|||||||
install -d -m0755 $(IDIR_MPD)/etc
|
install -d -m0755 $(IDIR_MPD)/etc
|
||||||
cp -fp $(PKG_INSTALL_DIR)/usr/bin/mpd $(IDIR_MPD)/usr/bin
|
cp -fp $(PKG_INSTALL_DIR)/usr/bin/mpd $(IDIR_MPD)/usr/bin
|
||||||
cp -fp $(PKG_BUILD_DIR)/doc/mpdconf.example $(IDIR_MPD)/etc/mpd.conf
|
cp -fp $(PKG_BUILD_DIR)/doc/mpdconf.example $(IDIR_MPD)/etc/mpd.conf
|
||||||
|
echo "Depends: $(PKG_DEPENDS)" >> $(IDIR_MPD)/CONTROL/control
|
||||||
$(RSTRIP) $(IDIR_MPD)
|
$(RSTRIP) $(IDIR_MPD)
|
||||||
$(IPKG_BUILD) $(IDIR_MPD) $(PACKAGE_DIR)
|
$(IPKG_BUILD) $(IDIR_MPD) $(PACKAGE_DIR)
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
Package: mpd
|
Package: mpd
|
||||||
Priority: optional
|
Priority: optional
|
||||||
Section: net
|
Section: net
|
||||||
Maintainer: David Collett <daveco@users.sourceforge.net>
|
Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, David Collett <daveco@users.sourceforge.net>
|
||||||
Source: http://mpd.wikicities.com/wiki/MusicPlayerDaemonUclinuxBranch
|
Source: http://www.musicpd.org
|
||||||
Description: A music player for flac, mp3 and ogg.
|
Description: A music player for flac, mp3 and ogg.
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
diff -rNu mpd--uclinux--1--patch-10.normalperson-05.OLD/configure mpd--uclinux--1--patch-10.normalperson-05/configure
|
|
||||||
--- mpd--uclinux--1--patch-10.normalperson-05.OLD/configure 2005-07-03 19:00:33.000000000 +1000
|
|
||||||
+++ mpd--uclinux--1--patch-10.normalperson-05/configure 2005-09-11 13:56:23.992755032 +1000
|
|
||||||
@@ -21756,7 +21756,6 @@
|
|
||||||
#define NDEBUG 1
|
|
||||||
_ACEOF
|
|
||||||
|
|
||||||
- CC="arm-elf-gcc"
|
|
||||||
enable_iconv=no
|
|
||||||
enable_http=no
|
|
||||||
enable_ipv6=no
|
|
@ -1,33 +0,0 @@
|
|||||||
diff -rNu mpd--uclinux--1--patch-10.normalperson-05.OLD/src/audio_oss.c mpd--uclinux--1--patch-10.normalperson-05/src/audio_oss.c
|
|
||||||
--- mpd--uclinux--1--patch-10.normalperson-05.OLD/src/audio_oss.c 2005-07-03 21:23:39.000000000 +1000
|
|
||||||
+++ mpd--uclinux--1--patch-10.normalperson-05/src/audio_oss.c 2005-09-11 13:58:44.074459376 +1000
|
|
||||||
@@ -179,7 +179,7 @@
|
|
||||||
copyAudioFormat(&audio_format,audioFormat);
|
|
||||||
|
|
||||||
blockSignals();
|
|
||||||
- audio_device = open("/dev/dsp", O_WRONLY);
|
|
||||||
+ audio_device = open("/dev/sound/dsp", O_WRONLY);
|
|
||||||
|
|
||||||
if (audio_device < 0) err |= 1;
|
|
||||||
|
|
||||||
@@ -199,7 +199,7 @@
|
|
||||||
unblockSignals();
|
|
||||||
|
|
||||||
if (err)
|
|
||||||
- ERROR("Error opening /dev/dsp: 0x%x\n");
|
|
||||||
+ ERROR("Error opening /dev/sound/dsp: 0x%x\n");
|
|
||||||
if (!audio_device)
|
|
||||||
return -1;
|
|
||||||
#endif
|
|
||||||
diff -rNu mpd--uclinux--1--patch-10.normalperson-05.OLD/src/volume.c mpd--uclinux--1--patch-10.normalperson-05/src/volume.c
|
|
||||||
--- mpd--uclinux--1--patch-10.normalperson-05.OLD/src/volume.c 2005-05-05 18:19:03.000000000 +1000
|
|
||||||
+++ mpd--uclinux--1--patch-10.normalperson-05/src/volume.c 2005-09-11 14:04:17.013844896 +1000
|
|
||||||
@@ -41,7 +41,7 @@
|
|
||||||
#define VOLUME_MIXER_TYPE_ALSA 2
|
|
||||||
|
|
||||||
#define VOLUME_MIXER_SOFTWARE_DEFAULT ""
|
|
||||||
-#define VOLUME_MIXER_OSS_DEFAULT "/dev/mixer"
|
|
||||||
+#define VOLUME_MIXER_OSS_DEFAULT "/dev/sound/mixer"
|
|
||||||
#define VOLUME_MIXER_ALSA_DEFAULT "default"
|
|
||||||
#define VOLUME_MIXER_ALSA_CONTROL_DEFAULT "PCM"
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user