mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 23:04:05 +02:00
fix errors in ifxmips .25 bump
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11109 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9a24ac5b8c
commit
77fef3ec17
@ -12,6 +12,7 @@ CONFIG_BASE_SMALL=0
|
||||
# CONFIG_BCM47XX is not set
|
||||
CONFIG_BITREVERSE=y
|
||||
# CONFIG_BT is not set
|
||||
CONFIG_CEVT_R4K=y
|
||||
CONFIG_CLASSIC_RCU=y
|
||||
CONFIG_CMDLINE="console=ttyS0,9600 rootfstype=squashfs,jffs2 init=/etc/preinit"
|
||||
CONFIG_CPU_BIG_ENDIAN=y
|
||||
@ -46,6 +47,7 @@ CONFIG_CPU_SUPPORTS_HIGHMEM=y
|
||||
CONFIG_CRYPTO_AEAD=m
|
||||
CONFIG_CRYPTO_AUTHENC=m
|
||||
CONFIG_CRYPTO_GF128MUL=m
|
||||
CONFIG_CSRC_R4K=y
|
||||
CONFIG_DEVPORT=y
|
||||
# CONFIG_DM9000 is not set
|
||||
CONFIG_DMA_NEED_PCI_MAP_STATE=y
|
||||
@ -65,6 +67,7 @@ CONFIG_HAVE_IDE=y
|
||||
# CONFIG_HAVE_KRETPROBES is not set
|
||||
CONFIG_HAVE_OPROFILE=y
|
||||
CONFIG_HAVE_STD_PC_SERIAL_PORT=y
|
||||
# CONFIG_HIGH_RES_TIMERS is not set
|
||||
# CONFIG_HOSTAP is not set
|
||||
CONFIG_HW_HAS_PCI=y
|
||||
CONFIG_HW_RANDOM=y
|
||||
@ -75,7 +78,14 @@ CONFIG_HW_RANDOM=y
|
||||
# CONFIG_IBM_NEW_EMAC_ZMII is not set
|
||||
# CONFIG_IDE is not set
|
||||
CONFIG_IFXMIPS=y
|
||||
CONFIG_IFXMIPS_ASC_UART=y
|
||||
CONFIG_IFXMIPS_EEPROM=y
|
||||
CONFIG_IFXMIPS_GPIO=y
|
||||
CONFIG_IFXMIPS_LED=y
|
||||
CONFIG_IFXMIPS_MEI=y
|
||||
CONFIG_IFXMIPS_MII0=y
|
||||
CONFIG_IFXMIPS_SSC=y
|
||||
CONFIG_IFXMIPS_WDT=y
|
||||
CONFIG_INITRAMFS_SOURCE=""
|
||||
CONFIG_IRQ_CPU=y
|
||||
CONFIG_KALLSYMS=y
|
||||
@ -126,6 +136,7 @@ CONFIG_MTD_COMPLEX_MAPPINGS=y
|
||||
# CONFIG_MTD_DOC2001 is not set
|
||||
# CONFIG_MTD_DOC2001PLUS is not set
|
||||
CONFIG_MTD_GEN_PROBE=y
|
||||
CONFIG_MTD_IFXMIPS=y
|
||||
# CONFIG_MTD_JEDECPROBE is not set
|
||||
# CONFIG_MTD_MAP_BANK_WIDTH_1 is not set
|
||||
# CONFIG_MTD_MAP_BANK_WIDTH_16 is not set
|
||||
@ -197,7 +208,7 @@ CONFIG_SYS_SUPPORTS_ARBIT_HZ=y
|
||||
CONFIG_SYS_SUPPORTS_BIG_ENDIAN=y
|
||||
# CONFIG_TC35815 is not set
|
||||
# CONFIG_THERMAL is not set
|
||||
CONFIG_TICK_ONESHOT=y
|
||||
# CONFIG_TICK_ONESHOT is not set
|
||||
# CONFIG_TOSHIBA_JMR3927 is not set
|
||||
# CONFIG_TOSHIBA_RBTX4927 is not set
|
||||
# CONFIG_TOSHIBA_RBTX4938 is not set
|
||||
@ -206,7 +217,6 @@ CONFIG_TRAD_SIGNALS=y
|
||||
CONFIG_USB=m
|
||||
# CONFIG_USB_EHCI_HCD is not set
|
||||
# CONFIG_USB_R8A66597_HCD is not set
|
||||
# CONFIG_USB_SERIAL_OTI6858 is not set
|
||||
# CONFIG_USB_UHCI_HCD is not set
|
||||
# CONFIG_VGASTATE is not set
|
||||
# CONFIG_VIA_RHINE is not set
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.25.1/arch/mips/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.25.1.orig/arch/mips/Kconfig 2008-05-10 01:03:55.000000000 +0100
|
||||
+++ linux-2.6.25.1/arch/mips/Kconfig 2008-05-10 01:09:11.000000000 +0100
|
||||
--- linux-2.6.25.1.orig/arch/mips/Kconfig 2008-05-10 01:14:39.000000000 +0100
|
||||
+++ linux-2.6.25.1/arch/mips/Kconfig 2008-05-10 01:29:54.000000000 +0100
|
||||
@@ -78,6 +78,19 @@
|
||||
select SYS_SUPPORTS_LITTLE_ENDIAN
|
||||
select GENERIC_HARDIRQS_NO__DO_IRQ
|
||||
@ -22,10 +22,18 @@ Index: linux-2.6.25.1/arch/mips/Kconfig
|
||||
config MACH_DECSTATION
|
||||
bool "DECstations"
|
||||
select BOOT_ELF32
|
||||
@@ -693,6 +706,7 @@
|
||||
source "arch/mips/tx4927/Kconfig"
|
||||
source "arch/mips/tx4938/Kconfig"
|
||||
source "arch/mips/vr41xx/Kconfig"
|
||||
+source "arch/mips/ifxmips/Kconfig"
|
||||
|
||||
endmenu
|
||||
|
||||
Index: linux-2.6.25.1/arch/mips/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.25.1.orig/arch/mips/Makefile 2008-05-10 01:04:02.000000000 +0100
|
||||
+++ linux-2.6.25.1/arch/mips/Makefile 2008-05-10 01:04:03.000000000 +0100
|
||||
--- linux-2.6.25.1.orig/arch/mips/Makefile 2008-05-10 01:14:49.000000000 +0100
|
||||
+++ linux-2.6.25.1/arch/mips/Makefile 2008-05-10 01:14:49.000000000 +0100
|
||||
@@ -282,6 +282,13 @@
|
||||
cflags-$(CONFIG_MIPS_COBALT) += -Iinclude/asm-mips/mach-cobalt
|
||||
load-$(CONFIG_MIPS_COBALT) += 0xffffffff80080000
|
||||
@ -42,8 +50,8 @@ Index: linux-2.6.25.1/arch/mips/Makefile
|
||||
#
|
||||
Index: linux-2.6.25.1/include/asm-mips/bootinfo.h
|
||||
===================================================================
|
||||
--- linux-2.6.25.1.orig/include/asm-mips/bootinfo.h 2008-05-10 01:03:55.000000000 +0100
|
||||
+++ linux-2.6.25.1/include/asm-mips/bootinfo.h 2008-05-10 01:04:03.000000000 +0100
|
||||
--- linux-2.6.25.1.orig/include/asm-mips/bootinfo.h 2008-05-10 01:14:39.000000000 +0100
|
||||
+++ linux-2.6.25.1/include/asm-mips/bootinfo.h 2008-05-10 01:14:49.000000000 +0100
|
||||
@@ -94,6 +94,12 @@
|
||||
#define MACH_MSP7120_FPGA 5 /* PMC-Sierra MSP7120 Emulation */
|
||||
#define MACH_MSP_OTHER 255 /* PMC-Sierra unknown board type */
|
||||
@ -59,8 +67,8 @@ Index: linux-2.6.25.1/include/asm-mips/bootinfo.h
|
||||
extern char *system_type;
|
||||
Index: linux-2.6.25.1/arch/mips/kernel/traps.c
|
||||
===================================================================
|
||||
--- linux-2.6.25.1.orig/arch/mips/kernel/traps.c 2008-05-10 01:09:32.000000000 +0100
|
||||
+++ linux-2.6.25.1/arch/mips/kernel/traps.c 2008-05-10 01:10:07.000000000 +0100
|
||||
--- linux-2.6.25.1.orig/arch/mips/kernel/traps.c 2008-05-10 01:14:39.000000000 +0100
|
||||
+++ linux-2.6.25.1/arch/mips/kernel/traps.c 2008-05-10 01:14:49.000000000 +0100
|
||||
@@ -1379,6 +1379,7 @@
|
||||
*/
|
||||
if (cpu_has_mips_r2) {
|
||||
|
Loading…
Reference in New Issue
Block a user