mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-28 03:01:53 +02:00
update wpa_supplicant to latest development release (v0.4.5),
add drivers for hostap, madwifi and generic wext. git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2275 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b887b6e4fb
commit
7a33fb1c96
@ -3,9 +3,9 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=wpa_supplicant
|
PKG_NAME:=wpa_supplicant
|
||||||
PKG_VERSION:=0.3.9
|
PKG_VERSION:=0.4.5
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=113873aafc4fcaa0515841a6f0a17fd0
|
PKG_MD5SUM:=28347563119f09fc963bcdf9d16265a3
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
|
PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
@ -24,7 +24,7 @@ $(PKG_BUILD_DIR)/.configured:
|
|||||||
$(PKG_BUILD_DIR)/.built:
|
$(PKG_BUILD_DIR)/.built:
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
$(TARGET_CONFIGURE_OPTS) \
|
$(TARGET_CONFIGURE_OPTS) \
|
||||||
CPPFLAGS="-I$(TOPDIR)/package/openwrt/include -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include/madwifi" \
|
||||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
|
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
|
||||||
OPT_FLAGS="$(TARGET_CFLAGS)" \
|
OPT_FLAGS="$(TARGET_CFLAGS)" \
|
||||||
KERNEL=$(LINUX_DIR) \
|
KERNEL=$(LINUX_DIR) \
|
||||||
|
@ -1,5 +1,8 @@
|
|||||||
# rather important
|
# rather important
|
||||||
CONFIG_DRIVER_BROADCOM=y
|
CONFIG_DRIVER_BROADCOM=y
|
||||||
|
CONFIG_DRIVER_HOSTAP=y
|
||||||
|
CONFIG_DRIVER_MADWIFI=y
|
||||||
|
CONFIG_DRIVER_WEXT=y
|
||||||
CONFIG_IEEE8021X_EAPOL=y
|
CONFIG_IEEE8021X_EAPOL=y
|
||||||
CONFIG_CTRL_IFACE=y
|
CONFIG_CTRL_IFACE=y
|
||||||
|
|
||||||
|
50
package/wpa_supplicant/patches/103-madwifi.patch
Normal file
50
package/wpa_supplicant/patches/103-madwifi.patch
Normal file
@ -0,0 +1,50 @@
|
|||||||
|
diff -ruN wpa_supplicant-0.4.5-old/driver_madwifi.c wpa_supplicant-0.4.5-new/driver_madwifi.c
|
||||||
|
--- wpa_supplicant-0.4.5-old/driver_madwifi.c 2005-09-17 07:36:33.000000000 +0200
|
||||||
|
+++ wpa_supplicant-0.4.5-new/driver_madwifi.c 2005-10-23 14:08:45.000000000 +0200
|
||||||
|
@@ -27,11 +27,19 @@
|
||||||
|
#include "wpa_supplicant.h"
|
||||||
|
#include "wpa.h"
|
||||||
|
|
||||||
|
+#include <sys/types.h>
|
||||||
|
+#include <sys/socket.h>
|
||||||
|
+#include <linux/types.h>
|
||||||
|
+#include <linux/socket.h>
|
||||||
|
+#include <linux/if.h>
|
||||||
|
+#include <stdint.h>
|
||||||
|
+#include <linux/if_packet.h>
|
||||||
|
+#include <linux/netlink.h>
|
||||||
|
+#include <linux/rtnetlink.h>
|
||||||
|
+
|
||||||
|
#include <include/compat.h>
|
||||||
|
#include <net80211/ieee80211.h>
|
||||||
|
#ifdef WME_NUM_AC
|
||||||
|
-/* Assume this is built against BSD branch of madwifi driver. */
|
||||||
|
-#define MADWIFI_BSD
|
||||||
|
#include <net80211/_ieee80211.h>
|
||||||
|
#endif /* WME_NUM_AC */
|
||||||
|
#include <net80211/ieee80211_crypto.h>
|
||||||
|
@@ -78,19 +86,19 @@
|
||||||
|
"ioctl[IEEE80211_IOCTL_SETKEY]",
|
||||||
|
"ioctl[IEEE80211_IOCTL_GETKEY]",
|
||||||
|
"ioctl[IEEE80211_IOCTL_DELKEY]",
|
||||||
|
- NULL,
|
||||||
|
+ "ioctl[IEEE80211_IOCTL_SETWMMPARAMS]",
|
||||||
|
"ioctl[IEEE80211_IOCTL_SETMLME]",
|
||||||
|
- NULL,
|
||||||
|
+ "ioctl[IEEE80211_IOCTL_GETCHANINFO]",
|
||||||
|
"ioctl[IEEE80211_IOCTL_SETOPTIE]",
|
||||||
|
"ioctl[IEEE80211_IOCTL_GETOPTIE]",
|
||||||
|
"ioctl[IEEE80211_IOCTL_ADDMAC]",
|
||||||
|
NULL,
|
||||||
|
"ioctl[IEEE80211_IOCTL_DELMAC]",
|
||||||
|
- NULL,
|
||||||
|
- "ioctl[IEEE80211_IOCTL_CHANLIST]",
|
||||||
|
+ "ioctl[IEEE80211_IOCTL_GETCHANLIST]",
|
||||||
|
+ "ioctl[IEEE80211_IOCTL_SETCHANLIST]",
|
||||||
|
};
|
||||||
|
if (IEEE80211_IOCTL_SETPARAM <= op &&
|
||||||
|
- op <= IEEE80211_IOCTL_CHANLIST)
|
||||||
|
+ op <= IEEE80211_IOCTL_SETCHANLIST)
|
||||||
|
perror(opnames[op - SIOCIWFIRSTPRIV]);
|
||||||
|
else
|
||||||
|
perror("ioctl[unknown???]");
|
Loading…
Reference in New Issue
Block a user