mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-27 17:55:55 +02:00
carl9170: update to version 1.0.1.1 and fix a compile error
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19691 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
25ca63a87a
commit
7da3062c4a
@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=carl9170
|
||||
PKG_VERSION:=0.9.9.1
|
||||
PKG_VERSION:=1.0.1.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/chr/carl9170/$(PKG_VERSION) \
|
||||
@KERNEL/linux/kernel/people/chr/carl9170/old/$(PKG_VERSION)
|
||||
PKG_MD5SUM:=122610b254125d93c7f64cc559d3341a
|
||||
PKG_MD5SUM:=8abbb4ae09a45a82af6f63cb65c7e2d8
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
13
package/carl9170/patches/120-compile_fix.patch
Normal file
13
package/carl9170/patches/120-compile_fix.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- a/drivers/net/wireless/ath/carl9170/fw.c
|
||||
+++ b/drivers/net/wireless/ath/carl9170/fw.c
|
||||
@@ -185,8 +185,10 @@ static int ar9170_fw_check(struct ar9170
|
||||
if (SUPP(CARL9170FW_WLANTX_CAB))
|
||||
ar->hw->wiphy->interface_modes |= BIT(NL80211_IFTYPE_AP);
|
||||
|
||||
+#ifdef CONFIG_CARL9170_WPS_BUTTON
|
||||
if (!SUPP(CARL9170FW_GPIO_INTERRUPT))
|
||||
ar->has_wps_button = false;
|
||||
+#endif
|
||||
|
||||
#undef SUPPORTED
|
||||
return 0;
|
Loading…
Reference in New Issue
Block a user