1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-12-26 01:18:58 +02:00

madwifi: fix x86_64 compilation

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12574 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2008-09-12 19:55:38 +00:00
parent bd04a159f4
commit 7e7cdddf8d

View File

@ -0,0 +1,16 @@
--- a/scripts/get_arch.mk
+++ b/scripts/get_arch.mk
@@ -36,6 +36,13 @@
$(Cannot determine ARCH)
endif
+# Allow ARCH to be x86
+ifneq (,$(CONFIG_X86))
+ifeq (x86,$(ARCH))
+ARCH-y = $(ARCH)
+endif
+endif
+
# Don't allow ARCH to be overridden by a different value.
ifeq (,$(ARCH))
ARCH = $(ARCH-y)