1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-11-27 19:03:08 +02:00

Merge branch 'xburst' of git@projects.qi-hardware.com:openwrt-xburst into xburst

Conflicts:

	target/linux/xburst/image/Makefile
This commit is contained in:
Lars-Peter Clausen 2010-03-17 15:41:49 +01:00
commit 82aaedbfed
3 changed files with 1066 additions and 10 deletions

View File

@ -6,9 +6,9 @@ From: Xiangfu Liu <xiangfu@sharism.cc>
---
Makefile | 10 +
common/env_common.c | 2
common/env_common.c | 3
common/lcd.c | 45 ++++
common/main.c | 4
common/main.c | 8 +
cpu/mips/Makefile | 5
cpu/mips/cache.S | 280 ++++++++++----------------
cpu/mips/config.mk | 6 -
@ -18,11 +18,12 @@ From: Xiangfu Liu <xiangfu@sharism.cc>
examples/standalone/mips.lds | 2
include/asm-mips/addrspace.h | 2
include/asm-mips/global_data.h | 11 +
include/configs/qi_lb60.h | 4
include/lcd.h | 56 +++++
lib_mips/board.c | 18 +-
lib_mips/bootm.c | 7 +
lib_mips/time.c | 4
17 files changed, 757 insertions(+), 290 deletions(-)
18 files changed, 763 insertions(+), 293 deletions(-)
diff --git a/Makefile b/Makefile
@ -47,15 +48,16 @@ index f06a97c..a318eb4 100644
#########################################################################
diff --git a/common/env_common.c b/common/env_common.c
index 439a4a9..6cfe30b 100644
index 439a4a9..a63a741 100644
--- a/common/env_common.c
+++ b/common/env_common.c
@@ -134,7 +134,7 @@ uchar default_environment[] = {
@@ -134,7 +134,8 @@ uchar default_environment[] = {
"pcidelay=" MK_STR(CONFIG_PCI_BOOTDELAY) "\0"
#endif
#ifdef CONFIG_EXTRA_ENV_SETTINGS
- CONFIG_EXTRA_ENV_SETTINGS
+ "bootargsfromsd=" CONFIG_BOOTARGSFROMSD "\0"
+ "bootcmdfromsd=" CONFIG_BOOTCOMMANDFROMSD "\0"
#endif
"\0"
};
@ -166,7 +168,7 @@ index 4e31618..ddd5aa8 100644
}
diff --git a/common/main.c b/common/main.c
index 10d8904..ff11ad7 100644
index 10d8904..0a0849e 100644
--- a/common/main.c
+++ b/common/main.c
@@ -372,7 +372,9 @@ void main_loop (void)
@ -180,6 +182,17 @@ index 10d8904..ff11ad7 100644
debug ("### main_loop entered: bootdelay=%d\n\n", bootdelay);
# ifdef CONFIG_BOOT_RETRY_TIME
@@ -393,7 +395,9 @@ void main_loop (void)
}
else
#endif /* CONFIG_BOOTCOUNT_LIMIT */
- s = getenv ("bootcmd");
+ s = gd->boot_option == 1 ?
+ getenv ("bootcmdfromsd"):
+ getenv ("bootcmd") ;
debug ("### main_loop: bootcmd=\"%s\"\n", s ? s : "<UNDEFINED>");
diff --git a/cpu/mips/Makefile b/cpu/mips/Makefile
index 28a1cbb..33afb66 100644
--- a/cpu/mips/Makefile
@ -1429,6 +1442,29 @@ index b2c4891..23f597e 100644
unsigned long baudrate;
unsigned long have_console; /* serial_init() was called */
phys_size_t ram_size; /* RAM size */
diff --git a/include/configs/qi_lb60.h b/include/configs/qi_lb60.h
index c3bf9c7..d429eee 100644
--- a/include/configs/qi_lb60.h
+++ b/include/configs/qi_lb60.h
@@ -13,7 +13,6 @@
#ifndef __CONFIG_H
#define __CONFIG_H
-#define DEBUG
#define CONFIG_MIPS32 1 /* MIPS32 CPU core */
#define CONFIG_JzRISC 1 /* JzRISC core */
#define CONFIG_JZSOC 1 /* Jz SoC */
@@ -46,8 +45,9 @@
#define CONFIG_BOOTFILE "uImage" /* file to load */
#define CONFIG_BOOTARGS "mem=32M console=ttyS0,57600n8 ubi.mtd=2 rootfstype=ubifs root=ubi0:rootfs rw rootwait"
#define CONFIG_EXTRA_ENV_SETTINGS 1
-#define CONFIG_BOOTARGSFROMSD "mem=32M console=ttyS0,57600n8 rootfstype=ext2 root=/dev/mmcblk0p1 rw rootwait"
+#define CONFIG_BOOTARGSFROMSD "mem=32M console=ttyS0,57600n8 rootfstype=ext2 root=/dev/mmcblk0p2 rw rootwait"
#define CONFIG_BOOTCOMMAND "nand read 0x80600000 0x400000 0x200000;bootm"
+#define CONFIG_BOOTCOMMANDFROMSD "mmc init; fatload mmc 0 0x80600000 uImage; bootm"
/*
* Command line configuration.
diff --git a/include/lcd.h b/include/lcd.h
index 1f85daa..997e246 100644
--- a/include/lcd.h

File diff suppressed because it is too large Load Diff

View File

@ -1,9 +1,6 @@
ONFIG_BACKLIGHT_CLASS_DEVICE=y
CONFIG_BACKLIGHT_CLASS_DEVICE=y
CONFIG_BACKLIGHT_LCD_SUPPORT=y
CONFIG_BATTERY_JZ4740=y
CONFIG_CHARGER_GPIO=y
CONFIG_FB_JZ4740=y
CONFIG_FONT_MINI_4x6=y
CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_JZ4740_ADC=y
CONFIG_JZ4740_QI_LB60=y
@ -13,7 +10,9 @@ CONFIG_LCD_CLASS_DEVICE=y
CONFIG_LCD_GPM940B0=y
CONFIG_LOGO=y
CONFIG_LOGO_OPENWRT_CLUT224=y
CONFIG_SND_JZ4740_SOC_QI_LB60=y
CONFIG_SPI=y
CONFIG_SPI_BITBANG=y
CONFIG_SPI_GPIO=y
CONFIG_SPI_MASTER=y
CONFIG_USB_JZ4740=y