mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-27 19:37:10 +02:00
kernel: Update to version 2.6.37.6
Thank you Peter Wagner for the patch git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26441 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
530ba0e928
commit
84b3048574
@ -11,7 +11,7 @@ BOARD:=ar7
|
|||||||
BOARDNAME:=TI AR7
|
BOARDNAME:=TI AR7
|
||||||
FEATURES:=squashfs jffs2 atm
|
FEATURES:=squashfs jffs2 atm
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
|
|||||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||||
SUBTARGETS:=generic nand
|
SUBTARGETS:=generic nand
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -11,7 +11,7 @@ BOARD:=atheros
|
|||||||
BOARDNAME:=Atheros AR231x/AR5312
|
BOARDNAME:=Atheros AR231x/AR5312
|
||||||
FEATURES:=squashfs jffs2
|
FEATURES:=squashfs jffs2
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -12,7 +12,7 @@ BOARDNAME:=RMI/AMD AU1x00
|
|||||||
FEATURES:=jffs2 usb pci
|
FEATURES:=jffs2 usb pci
|
||||||
SUBTARGETS=au1500 au1550
|
SUBTARGETS=au1500 au1550
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES += wpad-mini yamonenv
|
DEFAULT_PACKAGES += wpad-mini yamonenv
|
||||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
|
|||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -10,7 +10,7 @@ ARCH:=mips
|
|||||||
BOARD:=brcm63xx
|
BOARD:=brcm63xx
|
||||||
BOARDNAME:=Broadcom BCM63xx
|
BOARDNAME:=Broadcom BCM63xx
|
||||||
FEATURES:=squashfs jffs2 usb atm pci pcmcia
|
FEATURES:=squashfs jffs2 usb atm pci pcmcia
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||||||
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -538,9 +538,9 @@
|
@@ -538,9 +538,9 @@ endif # $(dot-config)
|
||||||
all: vmlinux
|
all: vmlinux
|
||||||
|
|
||||||
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
||||||
@ -12,7 +12,7 @@
|
|||||||
endif
|
endif
|
||||||
|
|
||||||
include $(srctree)/arch/$(SRCARCH)/Makefile
|
include $(srctree)/arch/$(SRCARCH)/Makefile
|
||||||
@@ -595,6 +595,9 @@
|
@@ -595,6 +595,9 @@ endif
|
||||||
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
||||||
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
||||||
|
|
||||||
|
@ -23,7 +23,7 @@
|
|||||||
/* The Mellanox Tavor device gives false positive parity errors
|
/* The Mellanox Tavor device gives false positive parity errors
|
||||||
* Mark this device with a broken_parity_status, to allow
|
* Mark this device with a broken_parity_status, to allow
|
||||||
* PCI scanning code to "skip" this now blacklisted device.
|
* PCI scanning code to "skip" this now blacklisted device.
|
||||||
@@ -1944,7 +1945,9 @@ static void __devinit fixup_rev1_53c810(
|
@@ -1989,7 +1990,9 @@ static void __devinit fixup_rev1_53c810(
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
|
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
|
||||||
@ -33,10 +33,10 @@
|
|||||||
/* Enable 1k I/O space granularity on the Intel P64H2 */
|
/* Enable 1k I/O space granularity on the Intel P64H2 */
|
||||||
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
|
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
|
||||||
{
|
{
|
||||||
@@ -2669,6 +2672,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
|
@@ -2662,6 +2665,7 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_AT
|
||||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x1518, quirk_i82576_sriov);
|
quirk_msi_intx_disable_bug);
|
||||||
|
|
||||||
#endif /* CONFIG_PCI_IOV */
|
#endif /* CONFIG_PCI_MSI */
|
||||||
+#endif /* !CONFIG_PCI_DISABLE_COMMON_QUIRKS */
|
+#endif /* !CONFIG_PCI_DISABLE_COMMON_QUIRKS */
|
||||||
|
|
||||||
/* Allow manual resource allocation for PCI hotplug bridges
|
/* Allow manual resource allocation for PCI hotplug bridges
|
||||||
|
@ -8,16 +8,17 @@
|
|||||||
static int debug;
|
static int debug;
|
||||||
/* initially all NULL */
|
/* initially all NULL */
|
||||||
static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
|
static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
|
||||||
@@ -913,7 +914,7 @@ int usb_serial_probe(struct usb_interfac
|
@@ -912,7 +913,8 @@ int usb_serial_probe(struct usb_interfac
|
||||||
|
goto probe_error;
|
||||||
}
|
}
|
||||||
buffer_size = serial->type->bulk_in_size;
|
buffer_size = max_t(int, serial->type->bulk_in_size,
|
||||||
if (!buffer_size)
|
- le16_to_cpu(endpoint->wMaxPacketSize));
|
||||||
- buffer_size = le16_to_cpu(endpoint->wMaxPacketSize);
|
+ max_t(int, le16_to_cpu(endpoint->wMaxPacketSize),
|
||||||
+ buffer_size = (endpoint->wMaxPacketSize > maxSize) ? endpoint->wMaxPacketSize : maxSize;
|
+ maxSize));
|
||||||
port->bulk_in_size = buffer_size;
|
port->bulk_in_size = buffer_size;
|
||||||
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
|
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
|
||||||
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
|
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
|
||||||
@@ -1392,3 +1393,5 @@ MODULE_LICENSE("GPL");
|
@@ -1391,3 +1393,5 @@ MODULE_LICENSE("GPL");
|
||||||
|
|
||||||
module_param(debug, bool, S_IRUGO | S_IWUSR);
|
module_param(debug, bool, S_IRUGO | S_IWUSR);
|
||||||
MODULE_PARM_DESC(debug, "Debug enabled or not");
|
MODULE_PARM_DESC(debug, "Debug enabled or not");
|
||||||
|
@ -25,7 +25,7 @@
|
|||||||
/**
|
/**
|
||||||
* shmem_file_setup - get an unlinked file living in tmpfs
|
* shmem_file_setup - get an unlinked file living in tmpfs
|
||||||
* @name: name for dentry (to be seen in /proc/<pid>/maps
|
* @name: name for dentry (to be seen in /proc/<pid>/maps
|
||||||
@@ -2780,9 +2791,6 @@ int shmem_zero_setup(struct vm_area_stru
|
@@ -2780,10 +2791,7 @@ int shmem_zero_setup(struct vm_area_stru
|
||||||
if (IS_ERR(file))
|
if (IS_ERR(file))
|
||||||
return PTR_ERR(file);
|
return PTR_ERR(file);
|
||||||
|
|
||||||
@ -34,6 +34,7 @@
|
|||||||
- vma->vm_file = file;
|
- vma->vm_file = file;
|
||||||
- vma->vm_ops = &shmem_vm_ops;
|
- vma->vm_ops = &shmem_vm_ops;
|
||||||
+ shmem_set_file(vma, file);
|
+ shmem_set_file(vma, file);
|
||||||
|
vma->vm_flags |= VM_CAN_NONLINEAR;
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
--- a/fs/file.c
|
--- a/fs/file.c
|
||||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Freescale i.MX21
|
|||||||
FEATURES:=jffs2 broken
|
FEATURES:=jffs2 broken
|
||||||
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
DEVICE_TYPE=phone
|
DEVICE_TYPE=phone
|
||||||
|
|
||||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Intel IOP32x
|
|||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
SUBTARGETS=generic harddisk
|
SUBTARGETS=generic harddisk
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Marvell Kirkwood
|
|||||||
FEATURES:=targz usb jffs2
|
FEATURES:=targz usb jffs2
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Lantiq GPON/XWAY
|
|||||||
FEATURES:=squashfs jffs2
|
FEATURES:=squashfs jffs2
|
||||||
SUBTARGETS:=falcon xway
|
SUBTARGETS:=falcon xway
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||||
|
|
||||||
|
@ -12,7 +12,7 @@ CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
|||||||
SUBTARGETS:=le be
|
SUBTARGETS:=le be
|
||||||
INITRAMFS_EXTRA_FILES:=
|
INITRAMFS_EXTRA_FILES:=
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Octeon
|
|||||||
FEATURES:=squashfs jffs2 pci usb
|
FEATURES:=squashfs jffs2 pci usb
|
||||||
CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
|
|||||||
CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -fno-caller-saves
|
CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -fno-caller-saves
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Marvell/Intel PXA2xx
|
|||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x
|
|||||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES+=kmod-leds-gpio wpad-mini
|
DEFAULT_PACKAGES+=kmod-leds-gpio wpad-mini
|
||||||
|
@ -12,7 +12,7 @@ BOARDNAME:=ARM Ltd. Realview board (qemu)
|
|||||||
FEATURES:=squashfs jffs2 fpu
|
FEATURES:=squashfs jffs2 fpu
|
||||||
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
|
|||||||
CFLAGS:=-Os -pipe -march=sb1 -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=sb1 -fno-caller-saves
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
|||||||
FEATURES:=ext4 audio
|
FEATURES:=ext4 audio
|
||||||
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
|
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
|
|||||||
FEATURES:=jffs2 targz ubifs audio
|
FEATURES:=jffs2 targz ubifs audio
|
||||||
SUBTARGETS:=qi_lb60 n516 n526 id800wt
|
SUBTARGETS:=qi_lb60 n516 n526 id800wt
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.37.4
|
LINUX_VERSION:=2.6.37.6
|
||||||
|
|
||||||
DEVICE_TYPE=other
|
DEVICE_TYPE=other
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user