mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 22:34:04 +02:00
kernel: update linux 3.6 to 3.6.10
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34639 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e2f1cef21f
commit
8c399739ca
@ -5,8 +5,8 @@ LINUX_RELEASE?=1
|
||||
ifeq ($(LINUX_VERSION),3.3.8)
|
||||
LINUX_KERNEL_MD5SUM:=f1058f64eed085deb44f10cee8541d50
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.6.9)
|
||||
LINUX_KERNEL_MD5SUM:=f77bac0a8f499f221d13a69317145610
|
||||
ifeq ($(LINUX_VERSION),3.6.10)
|
||||
LINUX_KERNEL_MD5SUM:=a8c2dcd268d3ca2b81908990abd5d382
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.7)
|
||||
LINUX_KERNEL_MD5SUM:=21223369d682bcf44bcdfe1521095983
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
|
||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||
SUBTARGETS:=generic nand
|
||||
|
||||
LINUX_VERSION:=3.6.9
|
||||
LINUX_VERSION:=3.6.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -10,7 +10,7 @@ ARCH:=mips
|
||||
BOARD:=brcm63xx
|
||||
BOARDNAME:=Broadcom BCM63xx
|
||||
FEATURES:=squashfs jffs2 usb atm pci pcmcia
|
||||
LINUX_VERSION:=3.6.9
|
||||
LINUX_VERSION:=3.6.10
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb display sound
|
||||
CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.6.9
|
||||
LINUX_VERSION:=3.6.10
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
@ -146,25 +146,7 @@ Date: Wed Nov 21 10:27:19 2012 +0000
|
||||
|
||||
cp_reset_hw(cp);
|
||||
|
||||
@@ -979,17 +1017,6 @@ static void cp_init_hw (struct cp_privat
|
||||
cpw32_f (MAC0 + 0, le32_to_cpu (*(__le32 *) (dev->dev_addr + 0)));
|
||||
cpw32_f (MAC0 + 4, le32_to_cpu (*(__le32 *) (dev->dev_addr + 4)));
|
||||
|
||||
- cpw32_f(HiTxRingAddr, 0);
|
||||
- cpw32_f(HiTxRingAddr + 4, 0);
|
||||
-
|
||||
- ring_dma = cp->ring_dma;
|
||||
- cpw32_f(RxRingAddr, ring_dma & 0xffffffff);
|
||||
- cpw32_f(RxRingAddr + 4, (ring_dma >> 16) >> 16);
|
||||
-
|
||||
- ring_dma += sizeof(struct cp_desc) * CP_RX_RING_SIZE;
|
||||
- cpw32_f(TxRingAddr, ring_dma & 0xffffffff);
|
||||
- cpw32_f(TxRingAddr + 4, (ring_dma >> 16) >> 16);
|
||||
-
|
||||
cp_start_hw(cp);
|
||||
cpw8(TxThresh, 0x06); /* XXX convert magic num to a constant */
|
||||
|
||||
@@ -1192,6 +1219,7 @@ static void cp_tx_timeout(struct net_dev
|
||||
@@ -1192,6 +1230,7 @@ static void cp_tx_timeout(struct net_dev
|
||||
cp_clean_rings(cp);
|
||||
rc = cp_init_rings(cp);
|
||||
cp_start_hw(cp);
|
||||
|
@ -13,13 +13,11 @@ Signed-off-by: Mark Brown <broonie@opensource.wolfsonmicro.com>
|
||||
sound/soc/Makefile | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/sound/soc/Makefile b/sound/soc/Makefile
|
||||
index bcbf1d0..99f32f7 100644
|
||||
--- a/sound/soc/Makefile
|
||||
+++ b/sound/soc/Makefile
|
||||
@@ -1,8 +1,9 @@
|
||||
snd-soc-core-objs := soc-core.o soc-dapm.o soc-jack.o soc-cache.o soc-utils.o
|
||||
snd-soc-core-objs += soc-pcm.o soc-compress.o soc-io.o
|
||||
snd-soc-core-objs += soc-pcm.o soc-io.o
|
||||
|
||||
-snd-soc-dmaengine-pcm-objs := soc-dmaengine-pcm.o
|
||||
-obj-$(CONFIG_SND_SOC_DMAENGINE_PCM) += snd-soc-dmaengine-pcm.o
|
||||
@ -29,6 +27,3 @@ index bcbf1d0..99f32f7 100644
|
||||
|
||||
obj-$(CONFIG_SND_SOC) += snd-soc-core.o
|
||||
obj-$(CONFIG_SND_SOC) += codecs/
|
||||
--
|
||||
1.7.10.4
|
||||
|
||||
|
@ -16,8 +16,6 @@ Dmitry, can you try to push this to Linus before 3.7 final? Thank you
|
||||
drivers/input/matrix-keymap.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/drivers/input/matrix-keymap.c b/drivers/input/matrix-keymap.c
|
||||
index 443ad64b..d88d9be 100644
|
||||
--- a/drivers/input/matrix-keymap.c
|
||||
+++ b/drivers/input/matrix-keymap.c
|
||||
@@ -23,6 +23,7 @@
|
||||
@ -28,12 +26,9 @@ index 443ad64b..d88d9be 100644
|
||||
#include <linux/input/matrix_keypad.h>
|
||||
|
||||
static bool matrix_keypad_map_key(struct input_dev *input_dev,
|
||||
@@ -161,3 +162,5 @@ int matrix_keypad_build_keymap(const struct matrix_keymap_data *keymap_data,
|
||||
@@ -161,3 +162,5 @@ int matrix_keypad_build_keymap(const str
|
||||
return 0;
|
||||
}
|
||||
EXPORT_SYMBOL(matrix_keypad_build_keymap);
|
||||
+
|
||||
+MODULE_LICENSE("GPL");
|
||||
--
|
||||
1.7.10.4
|
||||
|
||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=danube ar9 vr9 falcon svip_be
|
||||
LINUX_VERSION:=3.3.8
|
||||
|
||||
#SUBTARGETS=xway ase
|
||||
#LINUX_VERSION:=3.6.9
|
||||
#LINUX_VERSION:=3.6.10
|
||||
|
||||
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||
|
||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=le be
|
||||
INITRAMFS_EXTRA_FILES:=
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.6.9
|
||||
LINUX_VERSION:=3.6.10
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
|
||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||
FEATURES:=squashfs
|
||||
|
||||
LINUX_VERSION:=3.6.9
|
||||
LINUX_VERSION:=3.6.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES+=\
|
||||
|
@ -11,7 +11,7 @@ BOARD:=sparc
|
||||
BOARDNAME:=Sun UltraSPARC
|
||||
FEATURES+=fpu tgz jffs2 ext4 squashfs
|
||||
|
||||
LINUX_VERSION:=3.6.9
|
||||
LINUX_VERSION:=3.6.10
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
||||
FEATURES:=ext4 audio
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.6.9
|
||||
LINUX_VERSION:=3.6.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
|
||||
kmod-cpu-msr \
|
||||
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
|
||||
hwclock wpad flashrom tc
|
||||
LINUX_VERSION:=3.6.9
|
||||
LINUX_VERSION:=3.6.10
|
||||
CS5535_MASK:=0x0E000048
|
||||
|
||||
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
||||
|
Loading…
Reference in New Issue
Block a user