mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 00:30:16 +02:00
[tools] e2fsprogs: update to 1.42.3
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32142 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b3174b6800
commit
8ff82a78ac
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2010 OpenWrt.org
|
||||
# Copyright (C) 2010-2012 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,8 +8,8 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=e2fsprogs
|
||||
PKG_VERSION:=1.41.13
|
||||
PKG_MD5SUM:=7508a192c7a9471e2128424f4eafac1c
|
||||
PKG_VERSION:=1.42.3
|
||||
PKG_MD5SUM:=73431146f58d40fe1375aba2060f0da8
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/e2fsck/e2fsck.h
|
||||
+++ b/e2fsck/e2fsck.h
|
||||
@@ -65,7 +65,7 @@
|
||||
@@ -73,7 +73,7 @@
|
||||
* Exit codes used by fsck-type programs
|
||||
*/
|
||||
#define FSCK_OK 0 /* No errors */
|
||||
|
@ -1,18 +0,0 @@
|
||||
--- a/lib/ext2fs/tdb.c
|
||||
+++ b/lib/ext2fs/tdb.c
|
||||
@@ -29,6 +29,7 @@ Last Changed Date: 2007-06-22 13:36:10 -
|
||||
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||
*/
|
||||
|
||||
+#include <sys/file.h>
|
||||
#ifdef CONFIG_STAND_ALONE
|
||||
#define HAVE_MMAP
|
||||
#define HAVE_STRDUP
|
||||
@@ -55,7 +56,6 @@ Last Changed Date: 2007-06-22 13:36:10 -
|
||||
#include <utime.h>
|
||||
#endif
|
||||
#include <sys/stat.h>
|
||||
-#include <sys/file.h>
|
||||
#include <fcntl.h>
|
||||
|
||||
#ifdef HAVE_SYS_MMAN_H
|
@ -1,36 +0,0 @@
|
||||
--- a/lib/ext2fs/unix_io.c
|
||||
+++ b/lib/ext2fs/unix_io.c
|
||||
@@ -428,6 +428,7 @@ static errcode_t unix_open(const char *n
|
||||
struct unix_private_data *data = NULL;
|
||||
errcode_t retval;
|
||||
int open_flags;
|
||||
+ int f_nocache = 0;
|
||||
struct stat st;
|
||||
#ifdef __linux__
|
||||
struct utsname ut;
|
||||
@@ -464,7 +465,11 @@ static errcode_t unix_open(const char *n
|
||||
if (flags & IO_FLAG_EXCLUSIVE)
|
||||
open_flags |= O_EXCL;
|
||||
if (flags & IO_FLAG_DIRECT_IO)
|
||||
+#if !defined(O_DIRECT) && defined(F_NOCACHE)
|
||||
+ f_nocache = F_NOCACHE;
|
||||
+#else
|
||||
open_flags |= O_DIRECT;
|
||||
+#endif
|
||||
data->flags = flags;
|
||||
|
||||
#ifdef HAVE_OPEN64
|
||||
@@ -477,6 +482,13 @@ static errcode_t unix_open(const char *n
|
||||
goto cleanup;
|
||||
}
|
||||
|
||||
+ if (f_nocache) {
|
||||
+ if (fcntl(data->dev, f_nocache, 1) < 0) {
|
||||
+ retval = errno;
|
||||
+ goto cleanup;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
#ifdef BLKSSZGET
|
||||
if (flags & IO_FLAG_DIRECT_IO) {
|
||||
if (ioctl(data->dev, BLKSSZGET, &data->align) != 0)
|
@ -1,26 +0,0 @@
|
||||
From: Theodore Ts'o <tytso@mit.edu>
|
||||
Date: Fri, 17 Dec 2010 03:11:43 +0000 (-0500)
|
||||
Subject: libext2fs: Fix compile bug on big-endian architectures
|
||||
X-Git-Url: http://git.kernel.org/?p=fs%2Fext2%2Fe2fsprogs.git;a=commitdiff_plain;h=9098c986b64bb65a2b7fcd2724a400ba1f451f6b
|
||||
|
||||
libext2fs: Fix compile bug on big-endian architectures
|
||||
|
||||
Addresses-Sourceforge-Bug: #3138115
|
||||
|
||||
Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
|
||||
---
|
||||
|
||||
diff --git a/lib/ext2fs/swapfs.c b/lib/ext2fs/swapfs.c
|
||||
index 6f6cec2..12427e0 100644
|
||||
--- a/lib/ext2fs/swapfs.c
|
||||
+++ b/lib/ext2fs/swapfs.c
|
||||
@@ -72,7 +72,7 @@ void ext2fs_swap_super(struct ext2_super_block * sb)
|
||||
sb->s_flags = ext2fs_swab32(sb->s_flags);
|
||||
sb->s_kbytes_written = ext2fs_swab64(sb->s_kbytes_written);
|
||||
sb->s_snapshot_inum = ext2fs_swab32(sb->s_snapshot_inum);
|
||||
- sb->s_snapshot_id = ext2fs_swab32(s_snapshot_id);
|
||||
+ sb->s_snapshot_id = ext2fs_swab32(sb->s_snapshot_id);
|
||||
sb->s_snapshot_r_blocks_count =
|
||||
ext2fs_swab64(sb->s_snapshot_r_blocks_count);
|
||||
sb->s_snapshot_list = ext2fs_swab32(sb->s_snapshot_list);
|
||||
|
@ -1,31 +0,0 @@
|
||||
--- a/lib/ext2fs/ext2fs.h
|
||||
+++ b/lib/ext2fs/ext2fs.h
|
||||
@@ -1212,7 +1212,26 @@
|
||||
|
||||
if (align == 0)
|
||||
align = 8;
|
||||
- if (retval = posix_memalign((void **) ptr, align, size)) {
|
||||
+#ifdef HAVE_POSIX_MEMALIGN
|
||||
+ retval = posix_memalign((void **)ptr, align, size);
|
||||
+#else
|
||||
+#ifdef HAVE_MEMALIGN
|
||||
+ if ((*(void **)ptr = (void *)memalign(align, size)) == NULL)
|
||||
+ retval = errno;
|
||||
+ else
|
||||
+ retval = 0;
|
||||
+#else
|
||||
+#ifdef HAVE_VALLOC
|
||||
+ if ((*(void **)ptr = valloc(size)) == NULL)
|
||||
+ retval = errno;
|
||||
+ else
|
||||
+ retval = 0;
|
||||
+#else
|
||||
+# error "Impossible to allocate aligned memory!"
|
||||
+#endif /* HAVE_VALLOC */
|
||||
+#endif /* HAVE_MEMALIGN */
|
||||
+#endif /* HAVE_POSIX_MEMALIGN */
|
||||
+ if (retval) {
|
||||
if (retval == ENOMEM)
|
||||
return EXT2_ET_NO_MEMORY;
|
||||
return retval;
|
||||
--
|
Loading…
Reference in New Issue
Block a user