1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-11-23 23:32:49 +02:00

[package] opkg: update to r513, move lock-file to /var/lock and drop cleanup patch - went upstream

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19061 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2010-01-07 12:37:49 +00:00
parent af7936637c
commit 936485f730
8 changed files with 16 additions and 50 deletions

View File

@ -1,5 +1,5 @@
# #
# Copyright (C) 2006-2009 OpenWrt.org # Copyright (C) 2006-2010 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -8,9 +8,9 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=opkg PKG_NAME:=opkg
PKG_REV:=503 PKG_REV:=513
PKG_VERSION:=$(PKG_REV) PKG_VERSION:=$(PKG_REV)
PKG_RELEASE:=2 PKG_RELEASE:=1
PKG_SOURCE_PROTO:=svn PKG_SOURCE_PROTO:=svn
PKG_SOURCE_VERSION:=$(PKG_REV) PKG_SOURCE_VERSION:=$(PKG_REV)
@ -47,7 +47,8 @@ EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
CONFIGURE_ARGS += \ CONFIGURE_ARGS += \
--disable-curl \ --disable-curl \
--disable-gpg \ --disable-gpg \
--with-ipkgetcdir=/etc --with-opkgetcdir=/etc \
--with-opkglockfile=/var/lock/opkg.lock
define Build/Configure define Build/Configure
(cd $(PKG_BUILD_DIR); \ (cd $(PKG_BUILD_DIR); \

View File

@ -6,8 +6,8 @@ Signed-off-by: Nicolas Thill <nico@openwrt.org>
--- a/libopkg/opkg_conf.c --- a/libopkg/opkg_conf.c
+++ b/libopkg/opkg_conf.c +++ b/libopkg/opkg_conf.c
@@ -58,6 +58,7 @@ @@ -62,6 +62,7 @@
{ "noaction", OPKG_OPT_TYPE_BOOL, &_conf.noaction }, { "download_only", OPKG_OPT_TYPE_BOOL, &_conf.download_only },
{ "nodeps", OPKG_OPT_TYPE_BOOL, &_conf.nodeps }, { "nodeps", OPKG_OPT_TYPE_BOOL, &_conf.nodeps },
{ "offline_root", OPKG_OPT_TYPE_STRING, &_conf.offline_root }, { "offline_root", OPKG_OPT_TYPE_STRING, &_conf.offline_root },
+ { "overlay_root", OPKG_OPT_TYPE_STRING, &_conf.overlay_root }, + { "overlay_root", OPKG_OPT_TYPE_STRING, &_conf.overlay_root },
@ -16,7 +16,7 @@ Signed-off-by: Nicolas Thill <nico@openwrt.org>
{ "query-all", OPKG_OPT_TYPE_BOOL, &_conf.query_all }, { "query-all", OPKG_OPT_TYPE_BOOL, &_conf.query_all },
--- a/libopkg/opkg_conf.h --- a/libopkg/opkg_conf.h
+++ b/libopkg/opkg_conf.h +++ b/libopkg/opkg_conf.h
@@ -74,6 +74,7 @@ @@ -76,6 +76,7 @@
int check_signature; int check_signature;
int nodeps; /* do not follow dependences */ int nodeps; /* do not follow dependences */
char *offline_root; char *offline_root;

View File

@ -12,9 +12,9 @@
+++ b/libopkg/Makefile.am +++ b/libopkg/Makefile.am
@@ -1,5 +1,5 @@ @@ -1,5 +1,5 @@
- -
-AM_CFLAGS=-Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DOPKGETCDIR=\"@opkgetcdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS) $(PATHFINDER_CFLAGS) -AM_CFLAGS=-Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DOPKGETCDIR=\"@opkgetcdir@\" -DOPKGLOCKFILE=\"@opkglockfile@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS) $(PATHFINDER_CFLAGS)
+HOST_CPU=@host_cpu@ +HOST_CPU=@host_cpu@
+AM_CFLAGS=-Wall -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DOPKGETCDIR=\"@opkgetcdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS) $(PATHFINDER_CFLAGS) +AM_CFLAGS=-Wall -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DOPKGETCDIR=\"@opkgetcdir@\" -DOPKGLOCKFILE=\"@opkglockfile@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS) $(PATHFINDER_CFLAGS)
libopkg_includedir=$(includedir)/libopkg libopkg_includedir=$(includedir)/libopkg
libopkg_include_HEADERS= *.h libopkg_include_HEADERS= *.h

View File

@ -1,6 +1,6 @@
--- a/libopkg/Makefile.am --- a/libopkg/Makefile.am
+++ b/libopkg/Makefile.am +++ b/libopkg/Makefile.am
@@ -36,16 +36,10 @@ @@ -35,16 +35,10 @@
opkg_util_sources += sha256.c sha256.h opkg_util_sources += sha256.c sha256.h
endif endif

View File

@ -1,6 +1,6 @@
--- a/libopkg/opkg_cmd.c --- a/libopkg/opkg_cmd.c
+++ b/libopkg/opkg_cmd.c +++ b/libopkg/opkg_cmd.c
@@ -495,17 +495,6 @@ @@ -498,17 +498,6 @@
opkg_install_by_name(arg); opkg_install_by_name(arg);
} }
} }
@ -18,7 +18,7 @@
} }
opkg_configure_packages(NULL); opkg_configure_packages(NULL);
@@ -1163,7 +1152,7 @@ @@ -1166,7 +1155,7 @@
array for easier maintenance */ array for easier maintenance */
static opkg_cmd_t cmds[] = { static opkg_cmd_t cmds[] = {
{"update", 0, (opkg_cmd_fun_t)opkg_update_cmd, PFM_DESCRIPTION|PFM_SOURCE}, {"update", 0, (opkg_cmd_fun_t)opkg_update_cmd, PFM_DESCRIPTION|PFM_SOURCE},

View File

@ -1,6 +1,6 @@
--- a/libopkg/opkg_cmd.c --- a/libopkg/opkg_cmd.c
+++ b/libopkg/opkg_cmd.c +++ b/libopkg/opkg_cmd.c
@@ -735,49 +735,6 @@ @@ -738,49 +738,6 @@
} }
static int static int
@ -50,7 +50,7 @@
opkg_files_cmd(int argc, char **argv) opkg_files_cmd(int argc, char **argv)
{ {
pkg_t *pkg; pkg_t *pkg;
@@ -1159,7 +1116,6 @@ @@ -1162,7 +1119,6 @@
{"list_upgradable", 0, (opkg_cmd_fun_t)opkg_list_upgradable_cmd, PFM_SOURCE}, {"list_upgradable", 0, (opkg_cmd_fun_t)opkg_list_upgradable_cmd, PFM_SOURCE},
{"list-upgradable", 0, (opkg_cmd_fun_t)opkg_list_upgradable_cmd, PFM_SOURCE}, {"list-upgradable", 0, (opkg_cmd_fun_t)opkg_list_upgradable_cmd, PFM_SOURCE},
{"info", 0, (opkg_cmd_fun_t)opkg_info_cmd, 0}, {"info", 0, (opkg_cmd_fun_t)opkg_info_cmd, 0},

View File

@ -1,6 +1,6 @@
--- a/src/opkg-cl.c --- a/src/opkg-cl.c
+++ b/src/opkg-cl.c +++ b/src/opkg-cl.c
@@ -169,7 +169,10 @@ @@ -172,7 +172,10 @@
printf("Confusion: getopt_long returned %d\n", c); printf("Confusion: getopt_long returned %d\n", c);
} }
} }

View File

@ -1,35 +0,0 @@
--- a/src/opkg-cl.c
+++ b/src/opkg-cl.c
@@ -263,7 +263,7 @@
int
main(int argc, char *argv[])
{
- int opts;
+ int opts, err = -1;
char *cmd_name;
opkg_cmd_t *cmd;
int nocheckfordirorfile = 0;
@@ -327,15 +327,8 @@
usage();
}
- if (opkg_cmd_exec(cmd, argc - opts, (const char **) (argv + opts)))
- goto err2;
+ err = opkg_cmd_exec(cmd, argc - opts, (const char **) (argv + opts));
- print_error_list();
- free_error_list();
-
- return 0;
-
-err2:
#ifdef HAVE_CURL
opkg_curl_cleanup();
#endif
@@ -346,5 +339,5 @@
print_error_list();
free_error_list();
- return -1;
+ return err;
}