mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 22:34:04 +02:00
[tools] gmp: update to 5.0.4
Signed-off-by: Luka Perkov <openwrt@lukaperkov.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31169 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8192e994f9
commit
957731ef89
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2009 -2010 OpenWrt.org
|
# Copyright (C) 2009-2012 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -7,11 +7,11 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=gmp
|
PKG_NAME:=gmp
|
||||||
PKG_VERSION:=5.0.1
|
PKG_VERSION:=5.0.4
|
||||||
|
|
||||||
PKG_SOURCE_URL:=@GNU/gmp/
|
PKG_SOURCE_URL:=@GNU/gmp/
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_MD5SUM:=6bac6df75c192a13419dfd71d19240a7
|
PKG_MD5SUM:=0881f4ff2617226c673fc534ac39d448
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
|
||||||
|
@ -1,8 +1,6 @@
|
|||||||
Index: gmp-5.0.1/longlong.h
|
--- a/longlong.h
|
||||||
===================================================================
|
+++ b/longlong.h
|
||||||
--- gmp-5.0.1.orig/longlong.h
|
@@ -994,8 +994,10 @@ extern UWtype __MPN(udiv_qrnnd) _PROTO (
|
||||||
+++ gmp-5.0.1/longlong.h
|
|
||||||
@@ -849,8 +849,10 @@ extern UWtype __MPN(udiv_qrnnd) _PROTO (
|
|
||||||
count is only an int. */
|
count is only an int. */
|
||||||
#define count_trailing_zeros(count, x) \
|
#define count_trailing_zeros(count, x) \
|
||||||
do { \
|
do { \
|
||||||
|
@ -1,7 +1,6 @@
|
|||||||
diff -rdup gmp-5.0.1.oorig/acinclude.m4 gmp-5.0.1/acinclude.m4
|
--- a/acinclude.m4
|
||||||
--- gmp-5.0.1.oorig/acinclude.m4 2010-02-06 13:43:13.000000000 +0100
|
+++ b/acinclude.m4
|
||||||
+++ gmp-5.0.1/acinclude.m4 2010-02-08 17:19:44.000000000 +0100
|
@@ -30,29 +30,29 @@ dnl a_out.exe - OpenVMS DEC C called
|
||||||
@@ -30,23 +30,23 @@ dnl a_out.exe - OpenVMS DEC C called
|
|
||||||
dnl conftest.exe - various DOS compilers
|
dnl conftest.exe - various DOS compilers
|
||||||
|
|
||||||
|
|
||||||
@ -21,16 +20,24 @@ diff -rdup gmp-5.0.1.oorig/acinclude.m4 gmp-5.0.1/acinclude.m4
|
|||||||
+define([POWERPC64_PATTERN],
|
+define([POWERPC64_PATTERN],
|
||||||
[[powerpc64-*-* | powerpc64le-*-* | powerpc620-*-* | powerpc630-*-* | powerpc970-*-* | power[3-9]-*-*]])
|
[[powerpc64-*-* | powerpc64le-*-* | powerpc620-*-* | powerpc630-*-* | powerpc970-*-* | power[3-9]-*-*]])
|
||||||
|
|
||||||
|
-define(S390_PATTERN,
|
||||||
|
+define([S390_PATTERN],
|
||||||
|
[[s390-*-* | z900esa-*-* | z990esa-*-* | z9esa-*-* | z10esa-*-* | z196esa-*-*]])
|
||||||
|
|
||||||
|
-define(S390X_PATTERN,
|
||||||
|
+define([S390X_PATTERN],
|
||||||
|
[[s390x-*-* | z900-*-* | z990-*-* | z9-*-* | z10-*-* | z196-*-*]])
|
||||||
|
|
||||||
-define(X86_PATTERN,
|
-define(X86_PATTERN,
|
||||||
+define([X86_PATTERN],
|
+define([X86_PATTERN],
|
||||||
[[i?86*-*-* | k[5-8]*-*-* | pentium*-*-* | athlon-*-* | viac3*-*-* | geode*-*-* | atom-*-*]])
|
[[i?86*-*-* | k[5-8]*-*-* | pentium*-*-* | athlon-*-* | viac3*-*-* | geode*-*-* | atom-*-*]])
|
||||||
|
|
||||||
-define(X86_64_PATTERN,
|
-define(X86_64_PATTERN,
|
||||||
+define([X86_64_PATTERN],
|
+define([X86_64_PATTERN],
|
||||||
[[athlon64-*-* | pentium4-*-* | atom-*-* | core2-*-* | corei-*-* | x86_64-*-* | nano-*-*]])
|
[[athlon64-*-* | k8-*-* | k10-*-* | bobcat-*-* | bulldozer-*-* | pentium4-*-* | atom-*-* | core2-*-* | corei*-*-* | x86_64-*-* | nano-*-*]])
|
||||||
|
|
||||||
dnl GMP_FAT_SUFFIX(DSTVAR, DIRECTORY)
|
dnl GMP_FAT_SUFFIX(DSTVAR, DIRECTORY)
|
||||||
@@ -64,7 +64,7 @@ dnl x86 -> x86
|
@@ -70,7 +70,7 @@ dnl x86 -> x86
|
||||||
dnl x86/k6 -> k6
|
dnl x86/k6 -> k6
|
||||||
dnl x86/k6/mmx -> k6_mmx
|
dnl x86/k6/mmx -> k6_mmx
|
||||||
|
|
||||||
@ -39,7 +46,7 @@ diff -rdup gmp-5.0.1.oorig/acinclude.m4 gmp-5.0.1/acinclude.m4
|
|||||||
[[$1=`echo $2 | sed -e '/\//s:^[^/]*/::' -e 's:[\\/]:_:g'`]])
|
[[$1=`echo $2 | sed -e '/\//s:^[^/]*/::' -e 's:[\\/]:_:g'`]])
|
||||||
|
|
||||||
|
|
||||||
@@ -73,7 +73,7 @@ dnl ----------------------------------
|
@@ -79,7 +79,7 @@ dnl ----------------------------------
|
||||||
dnl Emit code to remove any occurrence of ITEM from $LISTVAR. ITEM can be a
|
dnl Emit code to remove any occurrence of ITEM from $LISTVAR. ITEM can be a
|
||||||
dnl shell expression like $foo if desired.
|
dnl shell expression like $foo if desired.
|
||||||
|
|
||||||
@ -48,7 +55,7 @@ diff -rdup gmp-5.0.1.oorig/acinclude.m4 gmp-5.0.1/acinclude.m4
|
|||||||
[remove_from_list_tmp=
|
[remove_from_list_tmp=
|
||||||
for remove_from_list_i in $[][$1]; do
|
for remove_from_list_i in $[][$1]; do
|
||||||
if test $remove_from_list_i = [$2]; then :;
|
if test $remove_from_list_i = [$2]; then :;
|
||||||
@@ -89,12 +89,12 @@ dnl GMP_STRIP_PATH(subdir)
|
@@ -95,12 +95,12 @@ dnl GMP_STRIP_PATH(subdir)
|
||||||
dnl ----------------------
|
dnl ----------------------
|
||||||
dnl Strip entries */subdir from $path and $fat_path.
|
dnl Strip entries */subdir from $path and $fat_path.
|
||||||
|
|
||||||
@ -63,7 +70,7 @@ diff -rdup gmp-5.0.1.oorig/acinclude.m4 gmp-5.0.1/acinclude.m4
|
|||||||
[tmp_path=
|
[tmp_path=
|
||||||
for i in $[][$1]; do
|
for i in $[][$1]; do
|
||||||
case $i in
|
case $i in
|
||||||
@@ -115,7 +115,7 @@ dnl
|
@@ -121,7 +121,7 @@ dnl
|
||||||
dnl Dummy value for GMP_LIMB_BITS is enough
|
dnl Dummy value for GMP_LIMB_BITS is enough
|
||||||
dnl for all current configure-time uses of gmp.h.
|
dnl for all current configure-time uses of gmp.h.
|
||||||
|
|
||||||
@ -72,7 +79,7 @@ diff -rdup gmp-5.0.1.oorig/acinclude.m4 gmp-5.0.1/acinclude.m4
|
|||||||
[[#define __GMP_WITHIN_CONFIGURE 1 /* ignore template stuff */
|
[[#define __GMP_WITHIN_CONFIGURE 1 /* ignore template stuff */
|
||||||
#define GMP_NAIL_BITS $GMP_NAIL_BITS
|
#define GMP_NAIL_BITS $GMP_NAIL_BITS
|
||||||
#define GMP_LIMB_BITS 123
|
#define GMP_LIMB_BITS 123
|
||||||
@@ -130,7 +130,7 @@ dnl Expand at autoconf time to the valu
|
@@ -136,7 +136,7 @@ dnl Expand at autoconf time to the valu
|
||||||
dnl FILE. The regexps here aren't very rugged, but are enough for gmp.
|
dnl FILE. The regexps here aren't very rugged, but are enough for gmp.
|
||||||
dnl /dev/null as a parameter prevents a hang if $2 is accidentally omitted.
|
dnl /dev/null as a parameter prevents a hang if $2 is accidentally omitted.
|
||||||
|
|
||||||
@ -81,7 +88,7 @@ diff -rdup gmp-5.0.1.oorig/acinclude.m4 gmp-5.0.1/acinclude.m4
|
|||||||
[patsubst(patsubst(
|
[patsubst(patsubst(
|
||||||
esyscmd([grep "^#define $1 " $2 /dev/null 2>/dev/null]),
|
esyscmd([grep "^#define $1 " $2 /dev/null 2>/dev/null]),
|
||||||
[^.*$1[ ]+],[]),
|
[^.*$1[ ]+],[]),
|
||||||
@@ -144,7 +144,7 @@ dnl The gmp version number, extracted f
|
@@ -150,7 +150,7 @@ dnl The gmp version number, extracted f
|
||||||
dnl autoconf time. Two digits like 3.0 if patchlevel <= 0, or three digits
|
dnl autoconf time. Two digits like 3.0 if patchlevel <= 0, or three digits
|
||||||
dnl like 3.0.1 if patchlevel > 0.
|
dnl like 3.0.1 if patchlevel > 0.
|
||||||
|
|
||||||
@ -90,7 +97,7 @@ diff -rdup gmp-5.0.1.oorig/acinclude.m4 gmp-5.0.1/acinclude.m4
|
|||||||
[GMP_HEADER_GETVAL(__GNU_MP_VERSION,gmp-h.in)[]dnl
|
[GMP_HEADER_GETVAL(__GNU_MP_VERSION,gmp-h.in)[]dnl
|
||||||
.GMP_HEADER_GETVAL(__GNU_MP_VERSION_MINOR,gmp-h.in)[]dnl
|
.GMP_HEADER_GETVAL(__GNU_MP_VERSION_MINOR,gmp-h.in)[]dnl
|
||||||
.GMP_HEADER_GETVAL(__GNU_MP_VERSION_PATCHLEVEL,gmp-h.in)])
|
.GMP_HEADER_GETVAL(__GNU_MP_VERSION_PATCHLEVEL,gmp-h.in)])
|
||||||
@@ -1506,7 +1506,9 @@ esac
|
@@ -1512,7 +1512,9 @@ esac
|
||||||
echo ["define(<CONFIG_TOP_SRCDIR>,<\`$tmp'>)"] >>$gmp_tmpconfigm4
|
echo ["define(<CONFIG_TOP_SRCDIR>,<\`$tmp'>)"] >>$gmp_tmpconfigm4
|
||||||
|
|
||||||
# All CPUs use asm-defs.m4
|
# All CPUs use asm-defs.m4
|
||||||
@ -101,12 +108,11 @@ diff -rdup gmp-5.0.1.oorig/acinclude.m4 gmp-5.0.1/acinclude.m4
|
|||||||
])
|
])
|
||||||
|
|
||||||
|
|
||||||
diff -rdup gmp-5.0.1.oorig/configure.in gmp-5.0.1/configure.in
|
--- a/configure.in
|
||||||
--- gmp-5.0.1.oorig/configure.in 2010-02-06 13:43:13.000000000 +0100
|
+++ b/configure.in
|
||||||
+++ gmp-5.0.1/configure.in 2010-02-08 17:18:30.000000000 +0100
|
|
||||||
@@ -29,12 +29,6 @@ AC_REVISION($Revision$)
|
@@ -29,12 +29,6 @@ AC_REVISION($Revision$)
|
||||||
AC_PREREQ(2.59)
|
AC_PREREQ(2.59)
|
||||||
AC_INIT(GNU MP, GMP_VERSION, gmp-bugs@gmplib.org, gmp)
|
AC_INIT(GNU MP, GMP_VERSION, [gmp-bugs@gmplib.org, see http://gmplib.org/manual/Reporting-Bugs.html], gmp)
|
||||||
AC_CONFIG_SRCDIR(gmp-impl.h)
|
AC_CONFIG_SRCDIR(gmp-impl.h)
|
||||||
-m4_pattern_forbid([^[ \t]*GMP_])
|
-m4_pattern_forbid([^[ \t]*GMP_])
|
||||||
-m4_pattern_allow(GMP_LDFLAGS)
|
-m4_pattern_allow(GMP_LDFLAGS)
|
||||||
@ -117,7 +123,7 @@ diff -rdup gmp-5.0.1.oorig/configure.in gmp-5.0.1/configure.in
|
|||||||
|
|
||||||
# If --target is not used then $target_alias is empty, but if say
|
# If --target is not used then $target_alias is empty, but if say
|
||||||
# "./configure athlon-pc-freebsd3.5" is used, then all three of
|
# "./configure athlon-pc-freebsd3.5" is used, then all three of
|
||||||
@@ -303,7 +297,7 @@ AH_VERBATIM([HAVE_HOST_CPU_1],
|
@@ -311,7 +305,7 @@ AH_VERBATIM([HAVE_HOST_CPU_1],
|
||||||
# After GMP specific searches and tests, the standard autoconf AC_PROG_CC is
|
# After GMP specific searches and tests, the standard autoconf AC_PROG_CC is
|
||||||
# called. User selections of CC etc are respected.
|
# called. User selections of CC etc are respected.
|
||||||
#
|
#
|
||||||
@ -126,7 +132,7 @@ diff -rdup gmp-5.0.1.oorig/configure.in gmp-5.0.1/configure.in
|
|||||||
# pre-testing, since they of course depend on AC_PROG_CC, and also some of
|
# pre-testing, since they of course depend on AC_PROG_CC, and also some of
|
||||||
# them cache their results, which is not wanted.
|
# them cache their results, which is not wanted.
|
||||||
#
|
#
|
||||||
@@ -395,7 +389,7 @@ abilist="standard"
|
@@ -403,7 +397,7 @@ abilist="standard"
|
||||||
# FIXME: We'd like to prefer an ANSI compiler, perhaps by preferring
|
# FIXME: We'd like to prefer an ANSI compiler, perhaps by preferring
|
||||||
# c89 over cc here. But note that on HP-UX c89 provides a castrated
|
# c89 over cc here. But note that on HP-UX c89 provides a castrated
|
||||||
# environment, and would want to be excluded somehow. Maybe
|
# environment, and would want to be excluded somehow. Maybe
|
||||||
@ -135,7 +141,7 @@ diff -rdup gmp-5.0.1.oorig/configure.in gmp-5.0.1/configure.in
|
|||||||
# we don't need to worry.
|
# we don't need to worry.
|
||||||
#
|
#
|
||||||
cclist="gcc cc"
|
cclist="gcc cc"
|
||||||
@@ -1580,7 +1574,7 @@ esac
|
@@ -1666,7 +1660,7 @@ esac
|
||||||
CFLAGS_or_unset=${CFLAGS-'(unset)'}
|
CFLAGS_or_unset=${CFLAGS-'(unset)'}
|
||||||
CPPFLAGS_or_unset=${CPPFLAGS-'(unset)'}
|
CPPFLAGS_or_unset=${CPPFLAGS-'(unset)'}
|
||||||
|
|
||||||
@ -144,7 +150,7 @@ diff -rdup gmp-5.0.1.oorig/configure.in gmp-5.0.1/configure.in
|
|||||||
User:
|
User:
|
||||||
ABI=$ABI
|
ABI=$ABI
|
||||||
CC=$CC
|
CC=$CC
|
||||||
@@ -1987,7 +1981,6 @@ AC_SUBST(DEFN_LONG_LONG_LIMB)
|
@@ -2073,7 +2067,6 @@ AC_SUBST(DEFN_LONG_LONG_LIMB)
|
||||||
|
|
||||||
# The C compiler and preprocessor, put into ANSI mode if possible.
|
# The C compiler and preprocessor, put into ANSI mode if possible.
|
||||||
AC_PROG_CC
|
AC_PROG_CC
|
||||||
@ -152,7 +158,7 @@ diff -rdup gmp-5.0.1.oorig/configure.in gmp-5.0.1/configure.in
|
|||||||
AC_PROG_CPP
|
AC_PROG_CPP
|
||||||
GMP_H_ANSI
|
GMP_H_ANSI
|
||||||
|
|
||||||
@@ -2010,11 +2003,11 @@ AC_SUBST(CCAS)
|
@@ -2096,11 +2089,11 @@ AC_SUBST(CCAS)
|
||||||
|
|
||||||
# The C++ compiler, if desired.
|
# The C++ compiler, if desired.
|
||||||
want_cxx=no
|
want_cxx=no
|
||||||
@ -166,7 +172,7 @@ diff -rdup gmp-5.0.1.oorig/configure.in gmp-5.0.1/configure.in
|
|||||||
cxxflags_ac_prog_cxx=$CXXFLAGS
|
cxxflags_ac_prog_cxx=$CXXFLAGS
|
||||||
cxxflags_list=ac_prog_cxx
|
cxxflags_list=ac_prog_cxx
|
||||||
|
|
||||||
@@ -2120,7 +2113,7 @@ case $host in
|
@@ -2206,7 +2199,7 @@ case $host in
|
||||||
esac
|
esac
|
||||||
|
|
||||||
|
|
||||||
@ -175,7 +181,7 @@ diff -rdup gmp-5.0.1.oorig/configure.in gmp-5.0.1/configure.in
|
|||||||
Decided:
|
Decided:
|
||||||
ABI=$ABI
|
ABI=$ABI
|
||||||
CC=$CC
|
CC=$CC
|
||||||
@@ -3376,7 +3369,7 @@ GMP_FINISH
|
@@ -3465,7 +3458,7 @@ GMP_FINISH
|
||||||
# FIXME: Upcoming version of autoconf/automake may not like broken lines.
|
# FIXME: Upcoming version of autoconf/automake may not like broken lines.
|
||||||
# Right now automake isn't accepting the new AC_CONFIG_FILES scheme.
|
# Right now automake isn't accepting the new AC_CONFIG_FILES scheme.
|
||||||
|
|
||||||
@ -184,7 +190,7 @@ diff -rdup gmp-5.0.1.oorig/configure.in gmp-5.0.1/configure.in
|
|||||||
mpbsd/Makefile mpf/Makefile mpn/Makefile mpq/Makefile \
|
mpbsd/Makefile mpf/Makefile mpn/Makefile mpq/Makefile \
|
||||||
mpz/Makefile printf/Makefile scanf/Makefile cxx/Makefile \
|
mpz/Makefile printf/Makefile scanf/Makefile cxx/Makefile \
|
||||||
tests/Makefile tests/devel/Makefile tests/mpbsd/Makefile \
|
tests/Makefile tests/devel/Makefile tests/mpbsd/Makefile \
|
||||||
@@ -3385,4 +3378,5 @@ AC_OUTPUT(Makefile \
|
@@ -3474,4 +3467,5 @@ AC_OUTPUT(Makefile \
|
||||||
tests/cxx/Makefile \
|
tests/cxx/Makefile \
|
||||||
doc/Makefile tune/Makefile \
|
doc/Makefile tune/Makefile \
|
||||||
demos/Makefile demos/calc/Makefile demos/expr/Makefile \
|
demos/Makefile demos/calc/Makefile demos/expr/Makefile \
|
||||||
|
Loading…
Reference in New Issue
Block a user