1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-06-28 18:35:26 +03:00

[package] mountd: add "-f" option to not daemonize mountd, use service wrappers in init script

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33378 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2012-09-12 10:09:55 +00:00
parent c96bed78c2
commit 95cfc6ea8c
3 changed files with 24 additions and 4 deletions

View File

@ -1,11 +1,11 @@
# Copyright (C) 2009-2011 OpenWrt.org
# Copyright (C) 2009-2012 OpenWrt.org
# All rights reserved.
include $(TOPDIR)/rules.mk
PKG_NAME:=mountd
PKG_VERSION:=0.1
PKG_RELEASE:=5
PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources

View File

@ -1,12 +1,19 @@
#!/bin/sh /etc/rc.common
START=80
SERVICE_DAEMONIZE=1
SERVICE_WRITE_PID=1
SERVICE_PID_FILE=/var/run/mountd.pid
MOUNTD_BIN=/sbin/mountd
start()
{
/sbin/mountd
service_start $MOUNTD_BIN -f
}
stop()
{
killall mountd
service_stop $MOUNTD_BIN
}

View File

@ -0,0 +1,13 @@
--- a/main.c
+++ b/main.c
@@ -13,7 +13,9 @@
int main(int argc, char *argv[])
{
- daemon(0,0);
+ if ((argc < 2) || strcmp(argv[1], "-f"))
+ daemon(0,0);
+
daemonize = 1;
log_start();
log_printf("Starting OpenWrt (auto)mountd V1\n");