mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 14:43:07 +02:00
Create iptraf directories
Build mod_webdav for lighttpd Fix libtool patch git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3661 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
56ccdab3fd
commit
97ab85558c
@ -42,7 +42,7 @@ libnids-compile: libnet-compile
|
|||||||
libvorbis-compile: libogg-compile
|
libvorbis-compile: libogg-compile
|
||||||
libxml2-compile: zlib-compile
|
libxml2-compile: zlib-compile
|
||||||
libxslt-compile: libxml2-compile
|
libxslt-compile: libxml2-compile
|
||||||
lighttpd-compile: openssl-compile pcre-compile
|
lighttpd-compile: openssl-compile pcre-compile libxml2-compile sqlite-compile
|
||||||
logrotate-compile: popt-compile
|
logrotate-compile: popt-compile
|
||||||
madplay-compile: libid3tag-compile libmad-compile
|
madplay-compile: libid3tag-compile libmad-compile
|
||||||
miax-compile: bluez-libs-compile
|
miax-compile: bluez-libs-compile
|
||||||
|
@ -36,7 +36,9 @@ $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
|
|||||||
touch $@
|
touch $@
|
||||||
|
|
||||||
$(IPKG_IPTRAF):
|
$(IPKG_IPTRAF):
|
||||||
install -d -m0755 $(IDIR_IPTRAF)/usr/bin
|
install -d -m0755 $(IDIR_IPTRAF)/usr/bin \
|
||||||
|
$(IDIR_IPTRAF)/var/run/iptraf \
|
||||||
|
$(IDIR_IPTRAF)/var/lib/iptraf
|
||||||
install -m0755 $(PKG_BUILD_DIR)/src/iptraf $(IDIR_IPTRAF)/usr/bin/
|
install -m0755 $(PKG_BUILD_DIR)/src/iptraf $(IDIR_IPTRAF)/usr/bin/
|
||||||
$(RSTRIP) $(IDIR_IPTRAF)
|
$(RSTRIP) $(IDIR_IPTRAF)
|
||||||
$(IPKG_BUILD) $(IDIR_IPTRAF) $(PACKAGE_DIR)
|
$(IPKG_BUILD) $(IDIR_IPTRAF) $(PACKAGE_DIR)
|
||||||
|
@ -0,0 +1,15 @@
|
|||||||
|
diff -urN libtool-1.5.14/libltdl/acinclude.m4 libtool-1.5.14.new/libltdl/acinclude.m4
|
||||||
|
--- libtool-1.5.14/libltdl/acinclude.m4 2005-02-12 13:20:02.000000000 +0100
|
||||||
|
+++ libtool-1.5.14.new/libltdl/acinclude.m4 2006-04-16 11:22:03.000000000 +0200
|
||||||
|
@@ -6228,10 +6228,9 @@
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
])
|
||||||
|
-if test "$libltdl_cv_sys_dlopen_deplibs" != yes; then
|
||||||
|
+AC_DEFUN([AC_LTDL_SYS_DLOPEN_DEPLIBS],
|
||||||
|
AC_DEFINE([LTDL_DLOPEN_DEPLIBS], [1],
|
||||||
|
[Define if the OS needs help to load dependent libraries for dlopen().])
|
||||||
|
-fi
|
||||||
|
])# AC_LTDL_SYS_DLOPEN_DEPLIBS
|
||||||
|
|
||||||
|
|
@ -42,6 +42,7 @@ $(eval $(call PKG_template,LIGHTTPD_MOD_SIMPLE_VHOST,lighttpd-mod-simple-vhost,$
|
|||||||
$(eval $(call PKG_template,LIGHTTPD_MOD_SSI,lighttpd-mod-ssi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
$(eval $(call PKG_template,LIGHTTPD_MOD_SSI,lighttpd-mod-ssi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||||
$(eval $(call PKG_template,LIGHTTPD_MOD_STATUS,lighttpd-mod-status,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
$(eval $(call PKG_template,LIGHTTPD_MOD_STATUS,lighttpd-mod-status,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||||
$(eval $(call PKG_template,LIGHTTPD_MOD_USERTRACK,lighttpd-mod-usertrack,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
$(eval $(call PKG_template,LIGHTTPD_MOD_USERTRACK,lighttpd-mod-usertrack,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||||
|
$(eval $(call PKG_template,LIGHTTPD_MOD_WEBDAV,lighttpd-mod-webdav,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||||
|
|
||||||
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_ACCESSLOG,accesslog))
|
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_ACCESSLOG,accesslog))
|
||||||
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_ALIAS,alias))
|
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_ALIAS,alias))
|
||||||
@ -58,6 +59,7 @@ $(eval $(call PKG_mod_template,LIGHTTPD_MOD_SIMPLE_VHOST,simple_vhost))
|
|||||||
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_SSI,ssi))
|
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_SSI,ssi))
|
||||||
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_STATUS,status))
|
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_STATUS,status))
|
||||||
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_USERTRACK,usertrack))
|
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_USERTRACK,usertrack))
|
||||||
|
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_WEBDAV,webdav))
|
||||||
|
|
||||||
$(PKG_BUILD_DIR)/.configured:
|
$(PKG_BUILD_DIR)/.configured:
|
||||||
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
|
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
|
||||||
@ -101,7 +103,7 @@ $(PKG_BUILD_DIR)/.configured:
|
|||||||
--with-openssl="$(STAGING_DIR)/usr" \
|
--with-openssl="$(STAGING_DIR)/usr" \
|
||||||
--with-pcre \
|
--with-pcre \
|
||||||
--without-valgrind \
|
--without-valgrind \
|
||||||
--without-webdav-props \
|
--with-webdav-props \
|
||||||
)
|
)
|
||||||
touch $@
|
touch $@
|
||||||
|
|
||||||
@ -109,6 +111,7 @@ $(PKG_BUILD_DIR)/.built:
|
|||||||
rm -rf $(PKG_INSTALL_DIR)
|
rm -rf $(PKG_INSTALL_DIR)
|
||||||
mkdir -p $(PKG_INSTALL_DIR)
|
mkdir -p $(PKG_INSTALL_DIR)
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
STAGING_DIR=$(STAGING_DIR) \
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
all install
|
all install
|
||||||
touch $@
|
touch $@
|
||||||
|
@ -0,0 +1,5 @@
|
|||||||
|
Package: lighttpd-mod-webdav
|
||||||
|
Priority: optional
|
||||||
|
Section: net
|
||||||
|
Description: a webdav module for lighttpd
|
||||||
|
Depends: lighttpd, libxml2, sqlite
|
12
openwrt/package/lighttpd/patches/501-libxml2_includes.patch
Normal file
12
openwrt/package/lighttpd/patches/501-libxml2_includes.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -urN lighttpd-1.4.11/src/Makefile.in lighttpd-1.4.11.new/src/Makefile.in
|
||||||
|
--- lighttpd-1.4.11/src/Makefile.in 2006-03-07 13:21:02.000000000 +0100
|
||||||
|
+++ lighttpd-1.4.11.new/src/Makefile.in 2006-04-17 00:16:12.000000000 +0200
|
||||||
|
@@ -409,7 +409,7 @@
|
||||||
|
STRIP = @STRIP@
|
||||||
|
U = @U@
|
||||||
|
VERSION = @VERSION@
|
||||||
|
-XML_CFLAGS = @XML_CFLAGS@
|
||||||
|
+XML_CFLAGS = -I$(STAGING_DIR)/usr/include/libxml2
|
||||||
|
XML_LIBS = @XML_LIBS@
|
||||||
|
Z_LIB = @Z_LIB@
|
||||||
|
ac_ct_AR = @ac_ct_AR@
|
Loading…
Reference in New Issue
Block a user