mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 08:41:53 +02:00
[ppc40x] cleanup magicbox patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16905 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9c0e4a40eb
commit
99999a9775
@ -1,6 +1,6 @@
|
|||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/arch/powerpc/boot/cuboot-magicboxv1.c
|
+++ b/arch/powerpc/boot/cuboot-magicboxv1.c
|
||||||
@@ -0,0 +1,40 @@
|
@@ -0,0 +1,41 @@
|
||||||
+/*
|
+/*
|
||||||
+ * Old U-boot compatibility for Magicbox v1
|
+ * Old U-boot compatibility for Magicbox v1
|
||||||
+ *
|
+ *
|
||||||
@ -41,6 +41,7 @@
|
|||||||
+ fdt_init(_dtb_start);
|
+ fdt_init(_dtb_start);
|
||||||
+ serial_console_init();
|
+ serial_console_init();
|
||||||
+}
|
+}
|
||||||
|
+
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/arch/powerpc/boot/dts/magicboxv1.dts
|
+++ b/arch/powerpc/boot/dts/magicboxv1.dts
|
||||||
@@ -0,0 +1,217 @@
|
@@ -0,0 +1,217 @@
|
||||||
@ -263,7 +264,7 @@
|
|||||||
+};
|
+};
|
||||||
--- a/arch/powerpc/boot/Makefile
|
--- a/arch/powerpc/boot/Makefile
|
||||||
+++ b/arch/powerpc/boot/Makefile
|
+++ b/arch/powerpc/boot/Makefile
|
||||||
@@ -75,7 +75,7 @@ src-plat := of.c cuboot-52xx.c cuboot-82
|
@@ -75,7 +75,7 @@
|
||||||
cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \
|
cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \
|
||||||
cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \
|
cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \
|
||||||
virtex405-head.S virtex.c redboot-83xx.c cuboot-sam440ep.c \
|
virtex405-head.S virtex.c redboot-83xx.c cuboot-sam440ep.c \
|
||||||
@ -272,7 +273,7 @@
|
|||||||
src-boot := $(src-wlib) $(src-plat) empty.c
|
src-boot := $(src-wlib) $(src-plat) empty.c
|
||||||
|
|
||||||
src-boot := $(addprefix $(obj)/, $(src-boot))
|
src-boot := $(addprefix $(obj)/, $(src-boot))
|
||||||
@@ -192,6 +192,7 @@ image-$(CONFIG_DEFAULT_UIMAGE) += uImag
|
@@ -192,6 +192,7 @@
|
||||||
image-$(CONFIG_EP405) += dtbImage.ep405
|
image-$(CONFIG_EP405) += dtbImage.ep405
|
||||||
image-$(CONFIG_WALNUT) += treeImage.walnut
|
image-$(CONFIG_WALNUT) += treeImage.walnut
|
||||||
image-$(CONFIG_ACADIA) += cuImage.acadia
|
image-$(CONFIG_ACADIA) += cuImage.acadia
|
||||||
@ -282,7 +283,7 @@
|
|||||||
image-$(CONFIG_EBONY) += treeImage.ebony cuImage.ebony
|
image-$(CONFIG_EBONY) += treeImage.ebony cuImage.ebony
|
||||||
--- a/arch/powerpc/platforms/40x/Kconfig
|
--- a/arch/powerpc/platforms/40x/Kconfig
|
||||||
+++ b/arch/powerpc/platforms/40x/Kconfig
|
+++ b/arch/powerpc/platforms/40x/Kconfig
|
||||||
@@ -49,6 +49,16 @@ config KILAUEA
|
@@ -49,6 +49,16 @@
|
||||||
help
|
help
|
||||||
This option enables support for the AMCC PPC405EX evaluation board.
|
This option enables support for the AMCC PPC405EX evaluation board.
|
||||||
|
|
||||||
@ -301,13 +302,13 @@
|
|||||||
depends on 40x
|
depends on 40x
|
||||||
--- a/arch/powerpc/platforms/40x/ppc40x_simple.c
|
--- a/arch/powerpc/platforms/40x/ppc40x_simple.c
|
||||||
+++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
|
+++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
|
||||||
@@ -51,7 +51,8 @@ machine_device_initcall(ppc40x_simple, p
|
@@ -51,7 +51,8 @@
|
||||||
* board.c file for it rather than adding it to this list.
|
* board.c file for it rather than adding it to this list.
|
||||||
*/
|
*/
|
||||||
static char *board[] __initdata = {
|
static char *board[] __initdata = {
|
||||||
- "amcc,acadia"
|
- "amcc,acadia"
|
||||||
+ "amcc,acadia",
|
+ "amcc,acadia",
|
||||||
+ "magicboxv1"
|
+ "magicboxv1",
|
||||||
};
|
};
|
||||||
|
|
||||||
static int __init ppc40x_probe(void)
|
static int __init ppc40x_probe(void)
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/arch/powerpc/boot/cuboot-magicboxv2.c
|
+++ b/arch/powerpc/boot/cuboot-magicboxv2.c
|
||||||
@@ -0,0 +1,40 @@
|
@@ -0,0 +1,41 @@
|
||||||
+/*
|
+/*
|
||||||
+ * Old U-boot compatibility for Magicbox v2
|
+ * Old U-boot compatibility for Magicbox v2
|
||||||
+ *
|
+ *
|
||||||
@ -41,6 +41,7 @@
|
|||||||
+ fdt_init(_dtb_start);
|
+ fdt_init(_dtb_start);
|
||||||
+ serial_console_init();
|
+ serial_console_init();
|
||||||
+}
|
+}
|
||||||
|
+
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/arch/powerpc/boot/dts/magicboxv2.dts
|
+++ b/arch/powerpc/boot/dts/magicboxv2.dts
|
||||||
@@ -0,0 +1,250 @@
|
@@ -0,0 +1,250 @@
|
||||||
@ -296,7 +297,7 @@
|
|||||||
+};
|
+};
|
||||||
--- a/arch/powerpc/boot/Makefile
|
--- a/arch/powerpc/boot/Makefile
|
||||||
+++ b/arch/powerpc/boot/Makefile
|
+++ b/arch/powerpc/boot/Makefile
|
||||||
@@ -75,7 +75,8 @@ src-plat := of.c cuboot-52xx.c cuboot-82
|
@@ -75,7 +75,8 @@
|
||||||
cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \
|
cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \
|
||||||
cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \
|
cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \
|
||||||
virtex405-head.S virtex.c redboot-83xx.c cuboot-sam440ep.c \
|
virtex405-head.S virtex.c redboot-83xx.c cuboot-sam440ep.c \
|
||||||
@ -306,7 +307,7 @@
|
|||||||
src-boot := $(src-wlib) $(src-plat) empty.c
|
src-boot := $(src-wlib) $(src-plat) empty.c
|
||||||
|
|
||||||
src-boot := $(addprefix $(obj)/, $(src-boot))
|
src-boot := $(addprefix $(obj)/, $(src-boot))
|
||||||
@@ -193,6 +194,7 @@ image-$(CONFIG_EP405) += dtbImage.ep40
|
@@ -193,6 +194,7 @@
|
||||||
image-$(CONFIG_WALNUT) += treeImage.walnut
|
image-$(CONFIG_WALNUT) += treeImage.walnut
|
||||||
image-$(CONFIG_ACADIA) += cuImage.acadia
|
image-$(CONFIG_ACADIA) += cuImage.acadia
|
||||||
image-$(CONFIG_MAGICBOXV1) += cuImage.magicboxv1
|
image-$(CONFIG_MAGICBOXV1) += cuImage.magicboxv1
|
||||||
@ -316,7 +317,7 @@
|
|||||||
image-$(CONFIG_EBONY) += treeImage.ebony cuImage.ebony
|
image-$(CONFIG_EBONY) += treeImage.ebony cuImage.ebony
|
||||||
--- a/arch/powerpc/platforms/40x/Kconfig
|
--- a/arch/powerpc/platforms/40x/Kconfig
|
||||||
+++ b/arch/powerpc/platforms/40x/Kconfig
|
+++ b/arch/powerpc/platforms/40x/Kconfig
|
||||||
@@ -59,6 +59,16 @@ config MAGICBOXV1
|
@@ -59,6 +59,16 @@
|
||||||
help
|
help
|
||||||
This option enables support for the Magicbox v1 board.
|
This option enables support for the Magicbox v1 board.
|
||||||
|
|
||||||
@ -335,12 +336,10 @@
|
|||||||
depends on 40x
|
depends on 40x
|
||||||
--- a/arch/powerpc/platforms/40x/ppc40x_simple.c
|
--- a/arch/powerpc/platforms/40x/ppc40x_simple.c
|
||||||
+++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
|
+++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
|
||||||
@@ -52,7 +52,8 @@ machine_device_initcall(ppc40x_simple, p
|
@@ -53,6 +53,7 @@
|
||||||
*/
|
|
||||||
static char *board[] __initdata = {
|
static char *board[] __initdata = {
|
||||||
"amcc,acadia",
|
"amcc,acadia",
|
||||||
- "magicboxv1"
|
"magicboxv1",
|
||||||
+ "magicboxv1",
|
|
||||||
+ "magicboxv2",
|
+ "magicboxv2",
|
||||||
};
|
};
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user