mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 06:20:16 +02:00
refresh generic 2.6.28 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15578 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
7f7a85d641
commit
9a9ece5346
@ -16,7 +16,7 @@
|
|||||||
+#endif /* _XT_LAYER7_H */
|
+#endif /* _XT_LAYER7_H */
|
||||||
--- a/include/net/netfilter/nf_conntrack.h
|
--- a/include/net/netfilter/nf_conntrack.h
|
||||||
+++ b/include/net/netfilter/nf_conntrack.h
|
+++ b/include/net/netfilter/nf_conntrack.h
|
||||||
@@ -118,6 +118,22 @@
|
@@ -118,6 +118,22 @@ struct nf_conn
|
||||||
u_int32_t secmark;
|
u_int32_t secmark;
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -41,7 +41,7 @@
|
|||||||
|
|
||||||
--- a/net/netfilter/Kconfig
|
--- a/net/netfilter/Kconfig
|
||||||
+++ b/net/netfilter/Kconfig
|
+++ b/net/netfilter/Kconfig
|
||||||
@@ -795,6 +795,27 @@
|
@@ -795,6 +795,27 @@ config NETFILTER_XT_MATCH_STATE
|
||||||
|
|
||||||
To compile it as a module, choose M here. If unsure, say N.
|
To compile it as a module, choose M here. If unsure, say N.
|
||||||
|
|
||||||
@ -71,7 +71,7 @@
|
|||||||
depends on NETFILTER_ADVANCED
|
depends on NETFILTER_ADVANCED
|
||||||
--- a/net/netfilter/Makefile
|
--- a/net/netfilter/Makefile
|
||||||
+++ b/net/netfilter/Makefile
|
+++ b/net/netfilter/Makefile
|
||||||
@@ -84,6 +84,7 @@
|
@@ -84,6 +84,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
|
||||||
obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
|
obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
|
||||||
obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o
|
obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o
|
||||||
obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
|
obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
|
||||||
@ -81,7 +81,7 @@
|
|||||||
obj-$(CONFIG_NETFILTER_XT_MATCH_TCPMSS) += xt_tcpmss.o
|
obj-$(CONFIG_NETFILTER_XT_MATCH_TCPMSS) += xt_tcpmss.o
|
||||||
--- a/net/netfilter/nf_conntrack_core.c
|
--- a/net/netfilter/nf_conntrack_core.c
|
||||||
+++ b/net/netfilter/nf_conntrack_core.c
|
+++ b/net/netfilter/nf_conntrack_core.c
|
||||||
@@ -201,6 +201,14 @@
|
@@ -201,6 +201,14 @@ destroy_conntrack(struct nf_conntrack *n
|
||||||
* too. */
|
* too. */
|
||||||
nf_ct_remove_expectations(ct);
|
nf_ct_remove_expectations(ct);
|
||||||
|
|
||||||
@ -98,7 +98,7 @@
|
|||||||
BUG_ON(hlist_unhashed(&ct->tuplehash[IP_CT_DIR_ORIGINAL].hnode));
|
BUG_ON(hlist_unhashed(&ct->tuplehash[IP_CT_DIR_ORIGINAL].hnode));
|
||||||
--- a/net/netfilter/nf_conntrack_standalone.c
|
--- a/net/netfilter/nf_conntrack_standalone.c
|
||||||
+++ b/net/netfilter/nf_conntrack_standalone.c
|
+++ b/net/netfilter/nf_conntrack_standalone.c
|
||||||
@@ -165,6 +165,12 @@
|
@@ -165,6 +165,12 @@ static int ct_seq_show(struct seq_file *
|
||||||
return -ENOSPC;
|
return -ENOSPC;
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/include/linux/netfilter/xt_layer7.h
|
--- a/include/linux/netfilter/xt_layer7.h
|
||||||
+++ b/include/linux/netfilter/xt_layer7.h
|
+++ b/include/linux/netfilter/xt_layer7.h
|
||||||
@@ -8,6 +8,7 @@
|
@@ -8,6 +8,7 @@ struct xt_layer7_info {
|
||||||
char protocol[MAX_PROTOCOL_LEN];
|
char protocol[MAX_PROTOCOL_LEN];
|
||||||
char pattern[MAX_PATTERN_LEN];
|
char pattern[MAX_PATTERN_LEN];
|
||||||
u_int8_t invert;
|
u_int8_t invert;
|
||||||
@ -10,7 +10,7 @@
|
|||||||
#endif /* _XT_LAYER7_H */
|
#endif /* _XT_LAYER7_H */
|
||||||
--- a/net/netfilter/xt_layer7.c
|
--- a/net/netfilter/xt_layer7.c
|
||||||
+++ b/net/netfilter/xt_layer7.c
|
+++ b/net/netfilter/xt_layer7.c
|
||||||
@@ -314,33 +314,35 @@
|
@@ -314,33 +314,35 @@ static int match_no_append(struct nf_con
|
||||||
}
|
}
|
||||||
|
|
||||||
/* add the new app data to the conntrack. Return number of bytes added. */
|
/* add the new app data to the conntrack. Return number of bytes added. */
|
||||||
@ -60,7 +60,7 @@
|
|||||||
|
|
||||||
return length;
|
return length;
|
||||||
}
|
}
|
||||||
@@ -438,7 +440,7 @@
|
@@ -438,7 +440,7 @@ match(const struct sk_buff *skbin,
|
||||||
|
|
||||||
enum ip_conntrack_info master_ctinfo, ctinfo;
|
enum ip_conntrack_info master_ctinfo, ctinfo;
|
||||||
struct nf_conn *master_conntrack, *conntrack;
|
struct nf_conn *master_conntrack, *conntrack;
|
||||||
@ -69,7 +69,7 @@
|
|||||||
unsigned int pattern_result, appdatalen;
|
unsigned int pattern_result, appdatalen;
|
||||||
regexp * comppattern;
|
regexp * comppattern;
|
||||||
|
|
||||||
@@ -466,8 +468,8 @@
|
@@ -466,8 +468,8 @@ match(const struct sk_buff *skbin,
|
||||||
master_conntrack = master_ct(master_conntrack);
|
master_conntrack = master_ct(master_conntrack);
|
||||||
|
|
||||||
/* if we've classified it or seen too many packets */
|
/* if we've classified it or seen too many packets */
|
||||||
@ -80,7 +80,7 @@
|
|||||||
|
|
||||||
pattern_result = match_no_append(conntrack, master_conntrack,
|
pattern_result = match_no_append(conntrack, master_conntrack,
|
||||||
ctinfo, master_ctinfo, info);
|
ctinfo, master_ctinfo, info);
|
||||||
@@ -500,6 +502,25 @@
|
@@ -500,6 +502,25 @@ match(const struct sk_buff *skbin,
|
||||||
/* the return value gets checked later, when we're ready to use it */
|
/* the return value gets checked later, when we're ready to use it */
|
||||||
comppattern = compile_and_cache(info->pattern, info->protocol);
|
comppattern = compile_and_cache(info->pattern, info->protocol);
|
||||||
|
|
||||||
|
@ -27,7 +27,7 @@
|
|||||||
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
|
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
|
||||||
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
|
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
|
||||||
.features = RTL_FEATURE_MSI
|
.features = RTL_FEATURE_MSI
|
||||||
@@ -3554,10 +3554,12 @@ static irqreturn_t rtl8169_interrupt(int
|
@@ -3555,10 +3555,12 @@ static irqreturn_t rtl8169_interrupt(int
|
||||||
goto out;
|
goto out;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -67,7 +67,7 @@
|
|||||||
* macro override instead of weak attribute alias, to workaround
|
* macro override instead of weak attribute alias, to workaround
|
||||||
--- a/kernel/sched.c
|
--- a/kernel/sched.c
|
||||||
+++ b/kernel/sched.c
|
+++ b/kernel/sched.c
|
||||||
@@ -5015,6 +5015,7 @@ int can_nice(const struct task_struct *p
|
@@ -5064,6 +5064,7 @@ int can_nice(const struct task_struct *p
|
||||||
return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
|
return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
|
||||||
capable(CAP_SYS_NICE));
|
capable(CAP_SYS_NICE));
|
||||||
}
|
}
|
||||||
|
Loading…
Reference in New Issue
Block a user