1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-10-01 12:23:50 +03:00

generic: add driver for the the RTL8367R{B,-VB} switches

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33839 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2012-10-18 07:22:56 +00:00
parent 8691e346bf
commit 9f961949b6
4 changed files with 1571 additions and 0 deletions

View File

@ -2323,6 +2323,7 @@ CONFIG_RTC_LIB=y
# CONFIG_RTL8366_SMI is not set
# CONFIG_RTL8366_SMI_DEBUG_FS is not set
# CONFIG_RTL8367_PHY is not set
# CONFIG_RTL8367B_PHY is not set
# CONFIG_RTS_PSTOR is not set
CONFIG_RT_MUTEXES=y
# CONFIG_RT_MUTEX_TESTER is not set

File diff suppressed because it is too large Load Diff

View File

@ -12,6 +12,7 @@
#define _RTL8367_H
#define RTL8367_DRIVER_NAME "rtl8367"
#define RTL8367B_DRIVER_NAME "rtl8367b"
enum rtl8367_port_speed {
RTL8367_PORT_SPEED_10 = 0,

View File

@ -0,0 +1,23 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -199,6 +199,10 @@ config RTL8367_PHY
tristate "Driver for the Realtek RTL8367R/M switches"
select SWCONFIG
+config RTL8367B_PHY
+ tristate "Driver fot the Realtek RTL8367R-VB switch"
+ select SWCONFIG
+
endif # RTL8366_SMI
endif # PHYLIB
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -26,6 +26,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_MICREL_PHY) += micrel.o
obj-$(CONFIG_FIXED_PHY) += fixed.o