mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 00:07:11 +02:00
eglibc: remove old versions
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27360 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0b9131c9b9
commit
9fe98cb022
@ -5,25 +5,6 @@ choice
|
|||||||
help
|
help
|
||||||
Select the version of eglibc you wish to use.
|
Select the version of eglibc you wish to use.
|
||||||
|
|
||||||
config EGLIBC_VERSION_2_6
|
|
||||||
bool "eglibc 2.6"
|
|
||||||
|
|
||||||
config EGLIBC_VERSION_2_7
|
|
||||||
bool "eglibc 2.7"
|
|
||||||
|
|
||||||
config EGLIBC_VERSION_2_8
|
|
||||||
bool "eglibc 2.8"
|
|
||||||
|
|
||||||
config EGLIBC_VERSION_2_9
|
|
||||||
bool "eglibc 2.9"
|
|
||||||
|
|
||||||
config EGLIBC_VERSION_2_10
|
|
||||||
bool "eglibc 2.10"
|
|
||||||
|
|
||||||
config EGLIBC_VERSION_2_11
|
|
||||||
bool "eglibc 2.11"
|
|
||||||
depends !GCC_VERSION_LLVM
|
|
||||||
|
|
||||||
config EGLIBC_VERSION_2_12
|
config EGLIBC_VERSION_2_12
|
||||||
bool "eglibc 2.12"
|
bool "eglibc 2.12"
|
||||||
depends !GCC_VERSION_LLVM
|
depends !GCC_VERSION_LLVM
|
||||||
@ -41,12 +22,6 @@ config EGLIBC_REVISION
|
|||||||
string
|
string
|
||||||
prompt "eglibc revision"
|
prompt "eglibc revision"
|
||||||
depends on TOOLCHAINOPTS && USE_EGLIBC
|
depends on TOOLCHAINOPTS && USE_EGLIBC
|
||||||
default "5887" if EGLIBC_VERSION_2_6
|
|
||||||
default "8588" if EGLIBC_VERSION_2_7
|
|
||||||
default "8587" if EGLIBC_VERSION_2_8
|
|
||||||
default "10153" if EGLIBC_VERSION_2_9
|
|
||||||
default "10152" if EGLIBC_VERSION_2_10
|
|
||||||
default "10454" if EGLIBC_VERSION_2_11
|
|
||||||
default "10495" if EGLIBC_VERSION_2_12
|
default "10495" if EGLIBC_VERSION_2_12
|
||||||
default "13055" if EGLIBC_VERSION_2_13
|
default "13055" if EGLIBC_VERSION_2_13
|
||||||
default "HEAD" if EGLIBC_VERSION_TRUNK
|
default "HEAD" if EGLIBC_VERSION_TRUNK
|
||||||
|
@ -1,12 +1,6 @@
|
|||||||
config EGLIBC_VERSION
|
config EGLIBC_VERSION
|
||||||
string
|
string
|
||||||
depends on USE_EGLIBC
|
depends on USE_EGLIBC
|
||||||
default "2.6.1" if EGLIBC_VERSION_2_6
|
|
||||||
default "2.7" if EGLIBC_VERSION_2_7
|
|
||||||
default "2.8" if EGLIBC_VERSION_2_8
|
|
||||||
default "2.9" if EGLIBC_VERSION_2_9
|
|
||||||
default "2.10.2" if EGLIBC_VERSION_2_10
|
|
||||||
default "2.11.1" if EGLIBC_VERSION_2_11
|
|
||||||
default "2.12" if EGLIBC_VERSION_2_12
|
default "2.12" if EGLIBC_VERSION_2_12
|
||||||
default "2.13" if EGLIBC_VERSION_2_13
|
default "2.13" if EGLIBC_VERSION_2_13
|
||||||
default "trunk"
|
default "trunk"
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
diff -ruN eglibc-2.6-orig/ports/sysdeps/unix/sysv/linux/arm/ioperm.c eglibc-2.6/ports/sysdeps/unix/sysv/linux/arm/ioperm.c
|
|
||||||
--- eglibc-2.6-orig/ports/sysdeps/unix/sysv/linux/arm/ioperm.c 2006-08-17 03:23:58.000000000 +0200
|
|
||||||
+++ eglibc-2.6/ports/sysdeps/unix/sysv/linux/arm/ioperm.c 2008-11-04 16:21:04.000000000 +0100
|
|
||||||
@@ -45,7 +45,6 @@
|
|
||||||
#include <sys/mman.h>
|
|
||||||
|
|
||||||
#include <linux/version.h>
|
|
||||||
-#include <asm/page.h>
|
|
||||||
#include <sys/sysctl.h>
|
|
||||||
|
|
||||||
#define PATH_ARM_SYSTYPE "/etc/arm_systype"
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -ruN eglibc-2.7-orig/ports/sysdeps/unix/sysv/linux/arm/ioperm.c eglibc-2.7/ports/sysdeps/unix/sysv/linux/arm/ioperm.c
|
|
||||||
--- eglibc-2.7-orig/ports/sysdeps/unix/sysv/linux/arm/ioperm.c 2006-08-17 03:23:58.000000000 +0200
|
|
||||||
+++ eglibc-2.7/ports/sysdeps/unix/sysv/linux/arm/ioperm.c 2008-11-04 16:12:24.375864916 +0100
|
|
||||||
@@ -45,7 +45,6 @@
|
|
||||||
#include <sys/mman.h>
|
|
||||||
|
|
||||||
#include <linux/version.h>
|
|
||||||
-#include <asm/page.h>
|
|
||||||
#include <sys/sysctl.h>
|
|
||||||
|
|
||||||
#define PATH_ARM_SYSTYPE "/etc/arm_systype"
|
|
@ -1,13 +0,0 @@
|
|||||||
diff -ruN eglibc-2.7-orig/ports/sysdeps/unix/sysv/linux/arm/nptl/sysdep-cancel.h eglibc-2.7/ports/sysdeps/unix/sysv/linux/arm/nptl/sysdep-cancel.h
|
|
||||||
--- eglibc-2.7-orig/ports/sysdeps/unix/sysv/linux/arm/nptl/sysdep-cancel.h 2007-06-06 19:48:04.000000000 +0200
|
|
||||||
+++ eglibc-2.7/ports/sysdeps/unix/sysv/linux/arm/nptl/sysdep-cancel.h 2008-11-04 16:48:29.000000000 +0100
|
|
||||||
@@ -73,6 +73,9 @@
|
|
||||||
# define DOCARGS_5 DOCARGS_4
|
|
||||||
# define UNDOCARGS_5 UNDOCARGS_4
|
|
||||||
|
|
||||||
+# define DOCARGS_6 DOCARGS_5
|
|
||||||
+# define UNDOCARGS_6 UNDOCARGS_5
|
|
||||||
+
|
|
||||||
# ifdef IS_IN_libpthread
|
|
||||||
# define CENABLE bl PLTJMP(__pthread_enable_asynccancel)
|
|
||||||
# define CDISABLE bl PLTJMP(__pthread_disable_asynccancel)
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -ruN eglibc-2.7-orig/ports/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h eglibc-2.7/ports/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h
|
|
||||||
--- eglibc-2.7-orig/ports/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h 2007-09-12 18:26:54.000000000 +0200
|
|
||||||
+++ eglibc-2.7/ports/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h 2008-11-04 17:11:21.000000000 +0100
|
|
||||||
@@ -25,6 +25,7 @@
|
|
||||||
#include <atomic.h>
|
|
||||||
#include <sysdep.h>
|
|
||||||
#include <kernel-features.h>
|
|
||||||
+#include <tls.h>
|
|
||||||
|
|
||||||
#define FUTEX_WAIT 0
|
|
||||||
#define FUTEX_WAKE 1
|
|
@ -1,57 +0,0 @@
|
|||||||
--- a/libc/sunrpc/rpc/types.h
|
|
||||||
+++ b/libc/sunrpc/rpc/types.h
|
|
||||||
@@ -68,6 +68,7 @@ typedef unsigned long rpcport_t;
|
|
||||||
#include <sys/types.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+#if !defined(_CROSS_RPCGEN_) || !defined(__APPLE__)
|
|
||||||
#ifndef __u_char_defined
|
|
||||||
typedef __u_char u_char;
|
|
||||||
typedef __u_short u_short;
|
|
||||||
@@ -83,6 +84,7 @@ typedef __daddr_t daddr_t;
|
|
||||||
typedef __caddr_t caddr_t;
|
|
||||||
# define __daddr_t_defined
|
|
||||||
#endif
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#include <sys/time.h>
|
|
||||||
#include <sys/param.h>
|
|
||||||
--- a/libc/sunrpc/rpc_main.c
|
|
||||||
+++ b/libc/sunrpc/rpc_main.c
|
|
||||||
@@ -40,7 +40,11 @@
|
|
||||||
#include <stdio.h>
|
|
||||||
#include <string.h>
|
|
||||||
#include <unistd.h>
|
|
||||||
+#ifdef _CROSS_RPCGEN_
|
|
||||||
+#define gettext(X) (X)
|
|
||||||
+#else
|
|
||||||
#include <libintl.h>
|
|
||||||
+#endif
|
|
||||||
#include <ctype.h>
|
|
||||||
#include <sys/types.h>
|
|
||||||
#include <sys/param.h>
|
|
||||||
--- a/libc/sunrpc/rpc_scan.c
|
|
||||||
+++ b/libc/sunrpc/rpc_scan.c
|
|
||||||
@@ -39,7 +39,11 @@
|
|
||||||
#include <stdio.h>
|
|
||||||
#include <ctype.h>
|
|
||||||
#include <string.h>
|
|
||||||
+#ifdef _CROSS_RPCGEN_
|
|
||||||
+#define gettext(X) (X)
|
|
||||||
+#else
|
|
||||||
#include <libintl.h>
|
|
||||||
+#endif
|
|
||||||
#include "rpc_scan.h"
|
|
||||||
#include "rpc_parse.h"
|
|
||||||
#include "rpc_util.h"
|
|
||||||
--- a/libc/timezone/Makefile
|
|
||||||
+++ b/libc/timezone/Makefile
|
|
||||||
@@ -181,7 +181,7 @@ zic-objs = zic.o ialloc.o scheck.o
|
|
||||||
$(objpfx)zic: $(addprefix $(objpfx), $(zic-objs))
|
|
||||||
|
|
||||||
$(addprefix $(objpfx)cross-,$(zic-objs)): $(objpfx)cross-%.o: %.c
|
|
||||||
- gcc $< -c $(OUTPUT_OPTION) $(CFLAGS-$*.c) $(CPPFLAGS-$*) \
|
|
||||||
+ gcc $< -c $(OUTPUT_OPTION) $(filter-out -DHAVE_GETTEXT,$(CFLAGS-$*.c)) $(CPPFLAGS-$*) \
|
|
||||||
$(compile-mkdep-flags)
|
|
||||||
|
|
||||||
$(objpfx)cross-zic: $(addprefix $(objpfx)cross-,$(zic-objs))
|
|
@ -1,13 +0,0 @@
|
|||||||
diff -ruN eglibc-2.7-orig/ports/sysdeps/unix/sysv/linux/arm/nptl/sysdep-cancel.h eglibc-2.7/ports/sysdeps/unix/sysv/linux/arm/nptl/sysdep-cancel.h
|
|
||||||
--- eglibc-2.7-orig/ports/sysdeps/unix/sysv/linux/arm/nptl/sysdep-cancel.h 2007-06-06 19:48:04.000000000 +0200
|
|
||||||
+++ eglibc-2.7/ports/sysdeps/unix/sysv/linux/arm/nptl/sysdep-cancel.h 2008-11-04 16:48:29.000000000 +0100
|
|
||||||
@@ -73,6 +73,9 @@
|
|
||||||
# define DOCARGS_5 DOCARGS_4
|
|
||||||
# define UNDOCARGS_5 UNDOCARGS_4
|
|
||||||
|
|
||||||
+# define DOCARGS_6 DOCARGS_5
|
|
||||||
+# define UNDOCARGS_6 UNDOCARGS_5
|
|
||||||
+
|
|
||||||
# ifdef IS_IN_libpthread
|
|
||||||
# define CENABLE bl PLTJMP(__pthread_enable_asynccancel)
|
|
||||||
# define CDISABLE bl PLTJMP(__pthread_disable_asynccancel)
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -ruN eglibc-2.7-orig/ports/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h eglibc-2.7/ports/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h
|
|
||||||
--- eglibc-2.7-orig/ports/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h 2007-09-12 18:26:54.000000000 +0200
|
|
||||||
+++ eglibc-2.7/ports/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h 2008-11-04 17:11:21.000000000 +0100
|
|
||||||
@@ -25,6 +25,7 @@
|
|
||||||
#include <atomic.h>
|
|
||||||
#include <sysdep.h>
|
|
||||||
#include <kernel-features.h>
|
|
||||||
+#include <tls.h>
|
|
||||||
|
|
||||||
#define FUTEX_WAIT 0
|
|
||||||
#define FUTEX_WAKE 1
|
|
@ -1,71 +0,0 @@
|
|||||||
--- a/libc/sunrpc/rpc/types.h
|
|
||||||
+++ b/libc/sunrpc/rpc/types.h
|
|
||||||
@@ -68,6 +68,7 @@ typedef unsigned long rpcport_t;
|
|
||||||
#include <sys/types.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+#if !defined(_CROSS_RPCGEN_) || !defined(__APPLE__)
|
|
||||||
#ifndef __u_char_defined
|
|
||||||
typedef __u_char u_char;
|
|
||||||
typedef __u_short u_short;
|
|
||||||
@@ -83,6 +84,7 @@ typedef __daddr_t daddr_t;
|
|
||||||
typedef __caddr_t caddr_t;
|
|
||||||
# define __daddr_t_defined
|
|
||||||
#endif
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#include <sys/time.h>
|
|
||||||
#include <sys/param.h>
|
|
||||||
--- a/libc/sunrpc/rpc_main.c
|
|
||||||
+++ b/libc/sunrpc/rpc_main.c
|
|
||||||
@@ -40,7 +40,11 @@
|
|
||||||
#include <stdio.h>
|
|
||||||
#include <string.h>
|
|
||||||
#include <unistd.h>
|
|
||||||
+#ifdef _CROSS_RPCGEN_
|
|
||||||
+#define gettext(X) (X)
|
|
||||||
+#else
|
|
||||||
#include <libintl.h>
|
|
||||||
+#endif
|
|
||||||
#include <ctype.h>
|
|
||||||
#include <sys/types.h>
|
|
||||||
#include <sys/param.h>
|
|
||||||
@@ -998,9 +1002,10 @@ mkfile_output (struct commandline *cmd)
|
|
||||||
abort ();
|
|
||||||
temp = rindex (cmd->infile, '.');
|
|
||||||
cp = stpcpy (mkfilename, "Makefile.");
|
|
||||||
- if (temp != NULL)
|
|
||||||
- *((char *) stpncpy (cp, cmd->infile, temp - cmd->infile)) = '\0';
|
|
||||||
- else
|
|
||||||
+ if (temp != NULL) {
|
|
||||||
+ strncpy (cp, cmd->infile, temp - cmd->infile);
|
|
||||||
+ cp[temp - cmd->infile - 1] = '\0';
|
|
||||||
+ } else
|
|
||||||
stpcpy (cp, cmd->infile);
|
|
||||||
|
|
||||||
}
|
|
||||||
--- a/libc/sunrpc/rpc_scan.c
|
|
||||||
+++ b/libc/sunrpc/rpc_scan.c
|
|
||||||
@@ -39,7 +39,11 @@
|
|
||||||
#include <stdio.h>
|
|
||||||
#include <ctype.h>
|
|
||||||
#include <string.h>
|
|
||||||
+#ifdef _CROSS_RPCGEN_
|
|
||||||
+#define gettext(X) (X)
|
|
||||||
+#else
|
|
||||||
#include <libintl.h>
|
|
||||||
+#endif
|
|
||||||
#include "rpc_scan.h"
|
|
||||||
#include "rpc_parse.h"
|
|
||||||
#include "rpc_util.h"
|
|
||||||
--- a/libc/timezone/Makefile
|
|
||||||
+++ b/libc/timezone/Makefile
|
|
||||||
@@ -181,7 +181,7 @@ zic-objs = zic.o ialloc.o scheck.o
|
|
||||||
$(objpfx)zic: $(addprefix $(objpfx), $(zic-objs))
|
|
||||||
|
|
||||||
$(addprefix $(objpfx)cross-,$(zic-objs)): $(objpfx)cross-%.o: %.c
|
|
||||||
- gcc $< -c $(OUTPUT_OPTION) $(CFLAGS-$*.c) $(CPPFLAGS-$*) \
|
|
||||||
+ gcc $< -c $(OUTPUT_OPTION) $(filter-out -DHAVE_GETTEXT,$(CFLAGS-$*.c)) $(CPPFLAGS-$*) \
|
|
||||||
-DCROSS_ZIC $(compile-mkdep-flags)
|
|
||||||
|
|
||||||
$(objpfx)cross-zic: $(addprefix $(objpfx)cross-,$(zic-objs))
|
|
@ -1,14 +0,0 @@
|
|||||||
http://sourceware.org/bugzilla/show_bug.cgi?id=7048
|
|
||||||
|
|
||||||
--- a/libc/sysdeps/i386/dl-tlsdesc.S
|
|
||||||
+++ b/libc/sysdeps/i386/dl-tlsdesc.S
|
|
||||||
@@ -128,8 +128,7 @@
|
|
||||||
.Lslow:
|
|
||||||
cfi_adjust_cfa_offset (28)
|
|
||||||
movl %ebx, 16(%esp)
|
|
||||||
- call __i686.get_pc_thunk.bx
|
|
||||||
- addl $_GLOBAL_OFFSET_TABLE_, %ebx
|
|
||||||
+ LOAD_PIC_REG(bx)
|
|
||||||
call ___tls_get_addr@PLT
|
|
||||||
movl 16(%esp), %ebx
|
|
||||||
jmp .Lret
|
|
Loading…
Reference in New Issue
Block a user