1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-12-25 20:05:31 +02:00

hostapd: update to 20100418 (0.7.2)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21142 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2010-04-24 17:24:07 +00:00
parent f3669abf11
commit ad35c2c69e
9 changed files with 43 additions and 43 deletions

View File

@ -8,9 +8,9 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd PKG_NAME:=hostapd
PKG_VERSION:=20100309 PKG_VERSION:=20100418
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_REV:=7b90c16aa9ca377b1a6d160c1ba0f2bd304f7e2f PKG_REV:=0b86f67a2970403d1b1b6d34ce49f5485ef5dbb3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=git://w1.fi/srv/git/hostap.git PKG_SOURCE_URL:=git://w1.fi/srv/git/hostap.git

View File

@ -1,6 +1,6 @@
--- a/src/ap/hostapd.c --- a/src/ap/hostapd.c
+++ b/src/ap/hostapd.c +++ b/src/ap/hostapd.c
@@ -650,7 +650,6 @@ static int setup_interface(struct hostap @@ -659,7 +659,6 @@ static int setup_interface(struct hostap
country[3] = '\0'; country[3] = '\0';
if (hostapd_set_country(hapd, country) < 0) { if (hostapd_set_country(hapd, country) < 0) {
wpa_printf(MSG_ERROR, "Failed to set country code"); wpa_printf(MSG_ERROR, "Failed to set country code");

View File

@ -1,6 +1,6 @@
--- a/src/ap/hostapd.h --- a/src/ap/hostapd.h
+++ b/src/ap/hostapd.h +++ b/src/ap/hostapd.h
@@ -238,6 +238,7 @@ struct hostapd_iface { @@ -245,6 +245,7 @@ struct hostapd_iface {
int (*for_each_interface)(struct hapd_interfaces *interfaces, int (*for_each_interface)(struct hapd_interfaces *interfaces,
int (*cb)(struct hostapd_iface *iface, int (*cb)(struct hostapd_iface *iface,
void *ctx), void *ctx); void *ctx), void *ctx);
@ -10,7 +10,7 @@
/* hostapd.c */ /* hostapd.c */
--- a/src/ap/hostapd.c --- a/src/ap/hostapd.c
+++ b/src/ap/hostapd.c +++ b/src/ap/hostapd.c
@@ -746,6 +746,9 @@ int hostapd_setup_interface_complete(str @@ -754,6 +754,9 @@ int hostapd_setup_interface_complete(str
wpa_printf(MSG_DEBUG, "%s: Setup of interface done.", wpa_printf(MSG_DEBUG, "%s: Setup of interface done.",
iface->bss[0]->conf->iface); iface->bss[0]->conf->iface);
@ -55,7 +55,7 @@
hapd_iface->reload_config = hostapd_reload_config; hapd_iface->reload_config = hostapd_reload_config;
hapd_iface->config_read_cb = hostapd_config_read; hapd_iface->config_read_cb = hostapd_config_read;
hapd_iface->config_fname = os_strdup(config_file); hapd_iface->config_fname = os_strdup(config_file);
@@ -390,7 +402,7 @@ static int hostapd_global_init(struct ha @@ -391,7 +403,7 @@ static int hostapd_global_init(struct ha
} }
@ -64,7 +64,7 @@
{ {
#ifdef EAP_SERVER_TNC #ifdef EAP_SERVER_TNC
tncs_global_deinit(); tncs_global_deinit();
@@ -408,8 +420,7 @@ static void hostapd_global_deinit(const @@ -409,8 +421,7 @@ static void hostapd_global_deinit(const
} }
@ -74,7 +74,7 @@
{ {
#ifdef EAP_SERVER_TNC #ifdef EAP_SERVER_TNC
int tnc = 0; int tnc = 0;
@@ -430,11 +441,6 @@ static int hostapd_global_run(struct hap @@ -431,11 +442,6 @@ static int hostapd_global_run(struct hap
} }
#endif /* EAP_SERVER_TNC */ #endif /* EAP_SERVER_TNC */
@ -86,7 +86,7 @@
eloop_run(); eloop_run();
return 0; return 0;
@@ -478,8 +484,7 @@ int main(int argc, char *argv[]) @@ -479,8 +485,7 @@ int main(int argc, char *argv[])
struct hapd_interfaces interfaces; struct hapd_interfaces interfaces;
int ret = 1; int ret = 1;
size_t i; size_t i;
@ -96,7 +96,7 @@
if (os_program_init()) if (os_program_init())
return -1; return -1;
@@ -544,7 +549,7 @@ int main(int argc, char *argv[]) @@ -545,7 +550,7 @@ int main(int argc, char *argv[])
goto out; goto out;
} }
@ -105,7 +105,7 @@
goto out; goto out;
ret = 0; ret = 0;
@@ -555,7 +560,7 @@ int main(int argc, char *argv[]) @@ -556,7 +561,7 @@ int main(int argc, char *argv[])
hostapd_interface_deinit_free(interfaces.iface[i]); hostapd_interface_deinit_free(interfaces.iface[i]);
os_free(interfaces.iface); os_free(interfaces.iface);
@ -116,7 +116,7 @@
os_program_deinit(); os_program_deinit();
--- a/hostapd/config_file.c --- a/hostapd/config_file.c
+++ b/hostapd/config_file.c +++ b/hostapd/config_file.c
@@ -1855,6 +1855,8 @@ struct hostapd_config * hostapd_config_r @@ -1857,6 +1857,8 @@ struct hostapd_config * hostapd_config_r
} }
#endif /* CONFIG_IEEE80211W */ #endif /* CONFIG_IEEE80211W */
#ifdef CONFIG_IEEE80211N #ifdef CONFIG_IEEE80211N
@ -127,7 +127,7 @@
} else if (os_strcmp(buf, "ht_capab") == 0) { } else if (os_strcmp(buf, "ht_capab") == 0) {
--- a/src/ap/ap_config.h --- a/src/ap/ap_config.h
+++ b/src/ap/ap_config.h +++ b/src/ap/ap_config.h
@@ -366,6 +366,7 @@ struct hostapd_config { @@ -369,6 +369,7 @@ struct hostapd_config {
int ht_op_mode_fixed; int ht_op_mode_fixed;
u16 ht_capab; u16 ht_capab;

View File

@ -26,7 +26,7 @@
LIBS += $(DRV_AP_LIBS) LIBS += $(DRV_AP_LIBS)
ifdef CONFIG_L2_PACKET ifdef CONFIG_L2_PACKET
@@ -738,6 +743,12 @@ install: all @@ -739,6 +744,12 @@ install: all
BCHECK=../src/drivers/build.hostapd BCHECK=../src/drivers/build.hostapd
@ -39,7 +39,7 @@
hostapd: $(BCHECK) $(OBJS) hostapd: $(BCHECK) $(OBJS)
$(CC) $(LDFLAGS) -o hostapd $(OBJS) $(LIBS) $(CC) $(LDFLAGS) -o hostapd $(OBJS) $(LIBS)
@@ -776,6 +787,12 @@ HOBJS += ../src/crypto/aes-internal.o @@ -777,6 +788,12 @@ HOBJS += ../src/crypto/aes-internal.o
HOBJS += ../src/crypto/aes-internal-enc.o HOBJS += ../src/crypto/aes-internal-enc.o
endif endif
@ -86,7 +86,7 @@
endif endif
ifdef NEED_RSN_AUTHENTICATOR ifdef NEED_RSN_AUTHENTICATOR
@@ -1261,6 +1272,12 @@ BCHECK=../src/drivers/build.wpa_supplica @@ -1262,6 +1273,12 @@ BCHECK=../src/drivers/build.wpa_supplica
wpa_priv: $(BCHECK) $(OBJS_priv) wpa_priv: $(BCHECK) $(OBJS_priv)
$(LDO) $(LDFLAGS) -o wpa_priv $(OBJS_priv) $(LIBS) $(LDO) $(LDFLAGS) -o wpa_priv $(OBJS_priv) $(LIBS)
@ -99,7 +99,7 @@
wpa_supplicant: .config $(BCHECK) $(OBJS) $(EXTRA_progs) wpa_supplicant: .config $(BCHECK) $(OBJS) $(EXTRA_progs)
$(LDO) $(LDFLAGS) -o wpa_supplicant $(OBJS) $(LIBS) $(EXTRALIBS) $(LDO) $(LDFLAGS) -o wpa_supplicant $(OBJS) $(LIBS) $(EXTRALIBS)
@@ -1320,6 +1337,12 @@ endif @@ -1321,6 +1338,12 @@ endif
$(Q)$(CC) -c -o $@ $(CFLAGS) $< $(Q)$(CC) -c -o $@ $(CFLAGS) $<
@$(E) " CC " $< @$(E) " CC " $<
@ -114,7 +114,7 @@
wpa_cli.exe: wpa_cli wpa_cli.exe: wpa_cli
--- a/src/drivers/driver.h --- a/src/drivers/driver.h
+++ b/src/drivers/driver.h +++ b/src/drivers/driver.h
@@ -2413,8 +2413,8 @@ union wpa_event_data { @@ -2449,8 +2449,8 @@ union wpa_event_data {
* Driver wrapper code should call this function whenever an event is received * Driver wrapper code should call this function whenever an event is received
* from the driver. * from the driver.
*/ */
@ -127,7 +127,7 @@
/* /*
--- a/src/ap/drv_callbacks.c --- a/src/ap/drv_callbacks.c
+++ b/src/ap/drv_callbacks.c +++ b/src/ap/drv_callbacks.c
@@ -337,8 +337,8 @@ static void hostapd_event_eapol_rx(struc @@ -375,8 +375,8 @@ static void hostapd_event_eapol_rx(struc
} }
@ -138,7 +138,7 @@
{ {
struct hostapd_data *hapd = ctx; struct hostapd_data *hapd = ctx;
@@ -415,5 +415,6 @@ void wpa_supplicant_event(void *ctx, enu @@ -453,5 +453,6 @@ void wpa_supplicant_event(void *ctx, enu
break; break;
} }
} }
@ -169,8 +169,8 @@
for (;;) { for (;;) {
--- a/wpa_supplicant/events.c --- a/wpa_supplicant/events.c
+++ b/wpa_supplicant/events.c +++ b/wpa_supplicant/events.c
@@ -1506,8 +1506,8 @@ static void wpa_supplicant_event_ibss_rs @@ -1577,8 +1577,8 @@ static void ft_rx_action(struct wpa_supp
#endif /* CONFIG_IBSS_RSN */ #endif /* CONFIG_IEEE80211R */
-void wpa_supplicant_event(void *ctx, enum wpa_event_type event, -void wpa_supplicant_event(void *ctx, enum wpa_event_type event,
@ -179,10 +179,10 @@
+ union wpa_event_data *data) + union wpa_event_data *data)
{ {
struct wpa_supplicant *wpa_s = ctx; struct wpa_supplicant *wpa_s = ctx;
u16 reason_code = 0;
--- a/wpa_supplicant/wpa_supplicant.c --- a/wpa_supplicant/wpa_supplicant.c
+++ b/wpa_supplicant/wpa_supplicant.c +++ b/wpa_supplicant/wpa_supplicant.c
@@ -2215,6 +2215,9 @@ struct wpa_supplicant * wpa_supplicant_g @@ -2223,6 +2223,9 @@ struct wpa_supplicant * wpa_supplicant_g
return NULL; return NULL;
} }
@ -192,7 +192,7 @@
/** /**
* wpa_supplicant_init - Initialize %wpa_supplicant * wpa_supplicant_init - Initialize %wpa_supplicant
@@ -2233,6 +2236,7 @@ struct wpa_global * wpa_supplicant_init( @@ -2241,6 +2244,7 @@ struct wpa_global * wpa_supplicant_init(
if (params == NULL) if (params == NULL)
return NULL; return NULL;
@ -202,7 +202,7 @@
wpa_debug_open_syslog(); wpa_debug_open_syslog();
--- a/hostapd/main.c --- a/hostapd/main.c
+++ b/hostapd/main.c +++ b/hostapd/main.c
@@ -478,6 +478,9 @@ static void usage(void) @@ -479,6 +479,9 @@ static void usage(void)
exit(1); exit(1);
} }
@ -212,7 +212,7 @@
int main(int argc, char *argv[]) int main(int argc, char *argv[])
{ {
@@ -489,6 +492,7 @@ int main(int argc, char *argv[]) @@ -490,6 +493,7 @@ int main(int argc, char *argv[])
if (os_program_init()) if (os_program_init())
return -1; return -1;

View File

@ -8,7 +8,7 @@
size_t max_ssids; size_t max_ssids;
enum wpa_states prev_state; enum wpa_states prev_state;
@@ -310,6 +311,16 @@ static void wpa_supplicant_scan(void *el @@ -311,6 +312,16 @@ static void wpa_supplicant_scan(void *el
wpa_s->wpa_state == WPA_INACTIVE) wpa_s->wpa_state == WPA_INACTIVE)
wpa_supplicant_set_state(wpa_s, WPA_SCANNING); wpa_supplicant_set_state(wpa_s, WPA_SCANNING);
@ -25,7 +25,7 @@
/* Find the starting point from which to continue scanning */ /* Find the starting point from which to continue scanning */
ssid = wpa_s->conf->ssid; ssid = wpa_s->conf->ssid;
if (wpa_s->prev_scan_ssid != WILDCARD_SSID_SCAN) { if (wpa_s->prev_scan_ssid != WILDCARD_SSID_SCAN) {
@@ -371,6 +382,9 @@ static void wpa_supplicant_scan(void *el @@ -374,6 +385,9 @@ static void wpa_supplicant_scan(void *el
int_array_sort_unique(params.freqs); int_array_sort_unique(params.freqs);
} }

View File

@ -1,11 +1,11 @@
--- a/wpa_supplicant/events.c --- a/wpa_supplicant/events.c
+++ b/wpa_supplicant/events.c +++ b/wpa_supplicant/events.c
@@ -924,7 +924,7 @@ static void wpa_supplicant_event_scan_re @@ -958,7 +958,7 @@ static void wpa_supplicant_event_scan_re
wpa_printf(MSG_DEBUG, "Setup a new network"); wpa_printf(MSG_DEBUG, "Setup a new network");
wpa_supplicant_associate(wpa_s, NULL, ssid); wpa_supplicant_associate(wpa_s, NULL, ssid);
} else } else {
- wpa_supplicant_req_new_scan(wpa_s, 5); - int timeout_sec = 5;
+ wpa_supplicant_req_new_scan(wpa_s, 0); + int timeout_sec = 0;
} int timeout_usec = 0;
} wpa_supplicant_req_new_scan(wpa_s, timeout_sec,
#endif /* CONFIG_NO_SCAN_PROCESSING */ timeout_usec);

View File

@ -1,6 +1,6 @@
--- a/src/drivers/driver_nl80211.c --- a/src/drivers/driver_nl80211.c
+++ b/src/drivers/driver_nl80211.c +++ b/src/drivers/driver_nl80211.c
@@ -4435,9 +4435,11 @@ static int i802_set_wds_sta(void *priv, @@ -4576,9 +4576,11 @@ static int i802_set_wds_sta(void *priv,
wpa_printf(MSG_DEBUG, "nl80211: Set WDS STA addr=" MACSTR wpa_printf(MSG_DEBUG, "nl80211: Set WDS STA addr=" MACSTR
" aid=%d val=%d name=%s", MAC2STR(addr), aid, val, name); " aid=%d val=%d name=%s", MAC2STR(addr), aid, val, name);
if (val) { if (val) {
@ -16,7 +16,7 @@
} else { } else {
--- a/src/ap/ieee802_11.c --- a/src/ap/ieee802_11.c
+++ b/src/ap/ieee802_11.c +++ b/src/ap/ieee802_11.c
@@ -1559,6 +1559,9 @@ static void handle_assoc_cb(struct hosta @@ -1614,6 +1614,9 @@ static void handle_assoc_cb(struct hosta
"Could not add STA to kernel driver"); "Could not add STA to kernel driver");
} }

View File

@ -21,7 +21,7 @@
/* clear to get error below if setting is invalid */ /* clear to get error below if setting is invalid */
--- a/src/drivers/driver_nl80211.c --- a/src/drivers/driver_nl80211.c
+++ b/src/drivers/driver_nl80211.c +++ b/src/drivers/driver_nl80211.c
@@ -4425,7 +4425,8 @@ static int i802_set_sta_vlan(void *priv, @@ -4566,7 +4566,8 @@ static int i802_set_sta_vlan(void *priv,
} }
@ -31,7 +31,7 @@
{ {
struct i802_bss *bss = priv; struct i802_bss *bss = priv;
struct wpa_driver_nl80211_data *drv = bss->drv; struct wpa_driver_nl80211_data *drv = bss->drv;
@@ -4439,6 +4440,10 @@ static int i802_set_wds_sta(void *priv, @@ -4580,6 +4581,10 @@ static int i802_set_wds_sta(void *priv,
if (nl80211_create_iface(drv, name, NL80211_IFTYPE_AP_VLAN, if (nl80211_create_iface(drv, name, NL80211_IFTYPE_AP_VLAN,
NULL, 1) < 0) NULL, 1) < 0)
return -1; return -1;
@ -44,7 +44,7 @@
return i802_set_sta_vlan(priv, addr, name, 0); return i802_set_sta_vlan(priv, addr, name, 0);
--- a/src/ap/ap_drv_ops.c --- a/src/ap/ap_drv_ops.c
+++ b/src/ap/ap_drv_ops.c +++ b/src/ap/ap_drv_ops.c
@@ -253,9 +253,15 @@ static int hostapd_vlan_if_remove(struct @@ -265,9 +265,15 @@ static int hostapd_vlan_if_remove(struct
static int hostapd_set_wds_sta(struct hostapd_data *hapd, const u8 *addr, static int hostapd_set_wds_sta(struct hostapd_data *hapd, const u8 *addr,
int aid, int val) int aid, int val)
{ {
@ -63,7 +63,7 @@
--- a/src/drivers/driver.h --- a/src/drivers/driver.h
+++ b/src/drivers/driver.h +++ b/src/drivers/driver.h
@@ -1610,7 +1610,8 @@ struct wpa_driver_ops { @@ -1622,7 +1622,8 @@ struct wpa_driver_ops {
* @val: 1 = bind to 4-address WDS; 0 = unbind * @val: 1 = bind to 4-address WDS; 0 = unbind
* Returns: 0 on success, -1 on failure * Returns: 0 on success, -1 on failure
*/ */

View File

@ -1,6 +1,6 @@
--- a/src/ap/hostapd.c --- a/src/ap/hostapd.c
+++ b/src/ap/hostapd.c +++ b/src/ap/hostapd.c
@@ -707,6 +707,16 @@ int hostapd_setup_interface_complete(str @@ -715,6 +715,16 @@ int hostapd_setup_interface_complete(str
} }
} }