mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-27 21:44:04 +02:00
[tools] genext2fs: update to 1.4.1
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14536 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9b5cb23ad9
commit
add93b4d50
@ -90,7 +90,7 @@ ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
|
|||||||
E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
|
E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
|
||||||
|
|
||||||
define Image/mkfs/ext2
|
define Image/mkfs/ext2
|
||||||
$(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -I $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext2
|
$(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext2
|
||||||
$(call Image/Build,ext2)
|
$(call Image/Build,ext2)
|
||||||
endef
|
endef
|
||||||
endif
|
endif
|
||||||
|
@ -9,12 +9,11 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=genext2fs
|
PKG_NAME:=genext2fs
|
||||||
PKG_VERSION:=1.4rc1
|
PKG_VERSION:=1.4.1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://superb-west.dl.sourceforge.net/sourceforge/
|
PKG_SOURCE_URL:=@SF/genext2fs
|
||||||
PKG_MD5SUM:=664431bf6737df1c265500e1f0b5d40c
|
PKG_MD5SUM:=b7b6361bcce2cedff1ae437fadafe53b
|
||||||
PKG_CAT:=zcat
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
|
||||||
|
@ -1,52 +0,0 @@
|
|||||||
diff -urN genext2fs-1.4rc1/genext2fs.c genext2fs-1.4rc1.new/genext2fs.c
|
|
||||||
--- genext2fs-1.4rc1/genext2fs.c 2005-05-17 18:29:10.000000000 +0200
|
|
||||||
+++ genext2fs-1.4rc1.new/genext2fs.c 2007-01-03 15:21:16.000000000 +0100
|
|
||||||
@@ -243,48 +243,6 @@
|
|
||||||
}
|
|
||||||
#endif // defined SNPRINTF_STORAGE_CLASS
|
|
||||||
|
|
||||||
-#if defined(__APPLE__) && defined(__GNUC__)
|
|
||||||
-// getline() replacement for Darwin, might work on other systems
|
|
||||||
-// written according to the getline man page included with Debian Linux
|
|
||||||
-ssize_t
|
|
||||||
-getline(char **lineptr, size_t *n, FILE *stream)
|
|
||||||
-{
|
|
||||||
- char *buf = *lineptr; // could be NULL, in which case we allocate
|
|
||||||
- size_t bufsize = *n; // current buffer size, adjust if we (re)alloc
|
|
||||||
-
|
|
||||||
- char *temp = NULL;
|
|
||||||
- size_t tempsize = 0;
|
|
||||||
-
|
|
||||||
- // temp is not a C string and we don't own the buffer it points into
|
|
||||||
- // must copy into a malloced buffer and NULL terminate
|
|
||||||
- temp = fgetln(stream, &tempsize);
|
|
||||||
- if(!temp) return -1;
|
|
||||||
-
|
|
||||||
- tempsize++; // adjust for NULL terminator
|
|
||||||
- if(buf) {
|
|
||||||
- // check if we have to reallocate
|
|
||||||
- if(bufsize < tempsize) {
|
|
||||||
- bufsize = tempsize;
|
|
||||||
- buf = (char*)realloc(buf, tempsize);
|
|
||||||
- if(!buf) return -1;
|
|
||||||
- }
|
|
||||||
- } else {
|
|
||||||
- bufsize = tempsize;
|
|
||||||
- buf = (char*)malloc(bufsize);
|
|
||||||
- if(!buf) return -1;
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
- memcpy(buf, temp, tempsize-1);
|
|
||||||
- buf[tempsize-1] = '\0';
|
|
||||||
-
|
|
||||||
- // give new pointer and size back, nondestructive if we didn't change anything..
|
|
||||||
- *n = bufsize;
|
|
||||||
- *lineptr = buf;
|
|
||||||
-
|
|
||||||
- return (ssize_t)(tempsize-1); // don't include the NULL terminator, per getline man page
|
|
||||||
-}
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
// Convert a numerical string to a float, and multiply the result by an
|
|
||||||
// SI-style multiplier if provided; supported multipliers are Ki, Mi, Gi, k, M
|
|
||||||
// and G.
|
|
Loading…
Reference in New Issue
Block a user