mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2025-02-17 15:24:43 +02:00
lua: Fixed some cross-platform issues for PPC (and probably other architectures)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11608 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b6fb9a7180
commit
adde7768a2
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=lua
|
PKG_NAME:=lua
|
||||||
PKG_VERSION:=5.1.3
|
PKG_VERSION:=5.1.3
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
|
PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
|
||||||
@ -96,7 +96,7 @@ define Build/Compile
|
|||||||
AR="$(TARGET_CROSS)ar rcu" \
|
AR="$(TARGET_CROSS)ar rcu" \
|
||||||
RANLIB="$(TARGET_CROSS)ranlib" \
|
RANLIB="$(TARGET_CROSS)ranlib" \
|
||||||
INSTALL_ROOT=/usr \
|
INSTALL_ROOT=/usr \
|
||||||
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
|
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -fPIC" \
|
||||||
MYLDFLAGS="$(TARGET_LDFLAGS)" \
|
MYLDFLAGS="$(TARGET_LDFLAGS)" \
|
||||||
PKG_VERSION=$(PKG_VERSION) \
|
PKG_VERSION=$(PKG_VERSION) \
|
||||||
all linux
|
all linux
|
||||||
|
13
package/lua/patches/015-lnum-ppc-compat.patch
Normal file
13
package/lua/patches/015-lnum-ppc-compat.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Index: lua-5.1.3/src/lua.h
|
||||||
|
===================================================================
|
||||||
|
--- lua-5.1.3.orig/src/lua.h 2008-06-29 11:45:55.000000000 +0200
|
||||||
|
+++ lua-5.1.3/src/lua.h 2008-06-29 11:46:28.000000000 +0200
|
||||||
|
@@ -79,7 +79,7 @@
|
||||||
|
* not acceptable for 5.1, maybe 5.2 onwards?
|
||||||
|
* 9: greater than existing (5.1) type values.
|
||||||
|
*/
|
||||||
|
-#define LUA_TINT (-2)
|
||||||
|
+#define LUA_TINT 9
|
||||||
|
|
||||||
|
#define LUA_TNIL 0
|
||||||
|
#define LUA_TBOOLEAN 1
|
13
tools/lua/patches/015-lnum-ppc-compat.patch
Normal file
13
tools/lua/patches/015-lnum-ppc-compat.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Index: lua-5.1.3/src/lua.h
|
||||||
|
===================================================================
|
||||||
|
--- lua-5.1.3.orig/src/lua.h 2008-06-29 11:45:55.000000000 +0200
|
||||||
|
+++ lua-5.1.3/src/lua.h 2008-06-29 11:46:28.000000000 +0200
|
||||||
|
@@ -79,7 +79,7 @@
|
||||||
|
* not acceptable for 5.1, maybe 5.2 onwards?
|
||||||
|
* 9: greater than existing (5.1) type values.
|
||||||
|
*/
|
||||||
|
-#define LUA_TINT (-2)
|
||||||
|
+#define LUA_TINT 9
|
||||||
|
|
||||||
|
#define LUA_TNIL 0
|
||||||
|
#define LUA_TBOOLEAN 1
|
Loading…
x
Reference in New Issue
Block a user