mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-26 05:25:21 +02:00
add socat package,
remove samba dependency on cups. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2076 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
12ff5c5c5b
commit
af136d922a
@ -108,6 +108,7 @@ source "package/shat/Config.in"
|
|||||||
source "package/siproxd/Config.in"
|
source "package/siproxd/Config.in"
|
||||||
source "package/sipsak/Config.in"
|
source "package/sipsak/Config.in"
|
||||||
source "package/snort/Config.in"
|
source "package/snort/Config.in"
|
||||||
|
source "package/socat/Config.in"
|
||||||
source "package/ssmtp/Config.in"
|
source "package/ssmtp/Config.in"
|
||||||
source "package/srelay/Config.in"
|
source "package/srelay/Config.in"
|
||||||
source "package/tcpdump/Config.in"
|
source "package/tcpdump/Config.in"
|
||||||
|
@ -166,6 +166,7 @@ package-$(BR2_PACKAGE_SHFS) += shfs
|
|||||||
package-$(BR2_PACKAGE_SIPROXD) += siproxd
|
package-$(BR2_PACKAGE_SIPROXD) += siproxd
|
||||||
package-$(BR2_PACKAGE_SIPSAK) += sipsak
|
package-$(BR2_PACKAGE_SIPSAK) += sipsak
|
||||||
package-$(BR2_PACKAGE_SNORT) += snort
|
package-$(BR2_PACKAGE_SNORT) += snort
|
||||||
|
package-$(BR2_PACKAGE_SOCAT) += socat
|
||||||
package-$(BR2_PACKAGE_SPEEX) += speex
|
package-$(BR2_PACKAGE_SPEEX) += speex
|
||||||
package-$(BR2_PACKAGE_SQLITE) += sqlite
|
package-$(BR2_PACKAGE_SQLITE) += sqlite
|
||||||
package-$(BR2_PACKAGE_SQLITE2) += sqlite2
|
package-$(BR2_PACKAGE_SQLITE2) += sqlite2
|
||||||
@ -270,10 +271,10 @@ endif
|
|||||||
rrdtool-compile: cgilib-compile freetype-compile libart-compile libpng-compile
|
rrdtool-compile: cgilib-compile freetype-compile libart-compile libpng-compile
|
||||||
rrdtool1-compile: zlib-compile
|
rrdtool1-compile: zlib-compile
|
||||||
rsync-compile: popt-compile
|
rsync-compile: popt-compile
|
||||||
samba-compile: cups-compile
|
|
||||||
screen-compile: ncurses-compile
|
screen-compile: ncurses-compile
|
||||||
siproxd-compile: libosip2-compile
|
siproxd-compile: libosip2-compile
|
||||||
sipsak-compile: openssl-compile
|
sipsak-compile: openssl-compile
|
||||||
|
socat-compile: openssl-compile
|
||||||
sqlite-compile: ncurses-compile readline-compile
|
sqlite-compile: ncurses-compile readline-compile
|
||||||
sqlite2-compile: ncurses-compile readline-compile
|
sqlite2-compile: ncurses-compile readline-compile
|
||||||
tcpdump-compile: libpcap-compile
|
tcpdump-compile: libpcap-compile
|
||||||
|
17
openwrt/package/socat/Config.in
Normal file
17
openwrt/package/socat/Config.in
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
config BR2_PACKAGE_SIPSAK
|
||||||
|
tristate "socat - A multipurpose relay (SOcket CAT)"
|
||||||
|
default m if CONFIG_DEVEL
|
||||||
|
select BR2_PACKAGE_LIBOPENSSL
|
||||||
|
select BR2_PACKAGE_LIBPTHREAD
|
||||||
|
help
|
||||||
|
SoCat (for SOcket CAT) establishes two bidirectional byte streams and
|
||||||
|
transfers data between them.
|
||||||
|
Data channels may be files, pipes, devices (terminal or modem, etc.), or
|
||||||
|
sockets (Unix, IPv4, IPv6, raw, UDP, TCP, SSL). It provides forking,
|
||||||
|
logging and tracing, different modes for interprocess communication and
|
||||||
|
many more options.
|
||||||
|
|
||||||
|
http://www.dest-unreach.org/socat/
|
||||||
|
|
||||||
|
Depends: openssl
|
||||||
|
|
65
openwrt/package/socat/Makefile
Normal file
65
openwrt/package/socat/Makefile
Normal file
@ -0,0 +1,65 @@
|
|||||||
|
# $Id$
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=socat
|
||||||
|
PKG_VERSION:=1.4.3.0
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
PKG_MD5SUM:=ce574e75c2fda4456e8efd4efb86ec5e
|
||||||
|
|
||||||
|
PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download/
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
PKG_CAT:=bzcat
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.4
|
||||||
|
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||||
|
|
||||||
|
include $(TOPDIR)/package/rules.mk
|
||||||
|
|
||||||
|
$(eval $(call PKG_template,SOCAT,socat,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||||
|
|
||||||
|
$(PKG_BUILD_DIR)/.configured:
|
||||||
|
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
|
||||||
|
$(TARGET_CONFIGURE_OPTS) \
|
||||||
|
CFLAGS="$(TARGET_CFLAGS)" \
|
||||||
|
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||||
|
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||||
|
./configure \
|
||||||
|
--target=$(GNU_TARGET_NAME) \
|
||||||
|
--host=$(GNU_TARGET_NAME) \
|
||||||
|
--build=$(GNU_HOST_NAME) \
|
||||||
|
--program-prefix="" \
|
||||||
|
--program-suffix="" \
|
||||||
|
--prefix=/usr \
|
||||||
|
--exec-prefix=/usr \
|
||||||
|
--bindir=/usr/bin \
|
||||||
|
--datadir=/usr/share \
|
||||||
|
--includedir=/usr/include \
|
||||||
|
--infodir=/usr/share/info \
|
||||||
|
--libdir=/usr/lib \
|
||||||
|
--libexecdir=/usr/lib \
|
||||||
|
--localstatedir=/var \
|
||||||
|
--mandir=/usr/share/man \
|
||||||
|
--sbindir=/usr/sbin \
|
||||||
|
--sysconfdir=/etc \
|
||||||
|
$(DISABLE_LARGEFILE) \
|
||||||
|
$(DISABLE_NLS) \
|
||||||
|
--disable-libwrap \
|
||||||
|
--disable-readline \
|
||||||
|
)
|
||||||
|
touch $@
|
||||||
|
|
||||||
|
$(PKG_BUILD_DIR)/.built:
|
||||||
|
rm -rf $(PKG_INSTALL_DIR)
|
||||||
|
mkdir -p $(PKG_INSTALL_DIR)
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
|
all install
|
||||||
|
touch $@
|
||||||
|
|
||||||
|
$(IPKG_SOCAT):
|
||||||
|
install -d -m0755 $(IDIR_SOCAT)/usr/bin
|
||||||
|
cp -fpR $(PKG_INSTALL_DIR)/usr/bin/socat $(IDIR_SOCAT)/usr/bin/
|
||||||
|
$(RSTRIP) $(IDIR_SOCAT)
|
||||||
|
$(IPKG_BUILD) $(IDIR_SOCAT) $(PACKAGE_DIR)
|
||||||
|
|
13
openwrt/package/socat/ipkg/socat.control
Normal file
13
openwrt/package/socat/ipkg/socat.control
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Package: socat
|
||||||
|
Priority: optional
|
||||||
|
Section: net
|
||||||
|
Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Florian Fainelli <florian@alphacore.net>
|
||||||
|
Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/socat/
|
||||||
|
Depends: libpthread, libopenssl
|
||||||
|
Description: A multipurpose relay (SOcket CAT).
|
||||||
|
SoCat (for SOcket CAT) establishes two bidirectional byte streams and
|
||||||
|
transfers data between them.
|
||||||
|
Data channels may be files, pipes, devices (terminal or modem, etc.), or
|
||||||
|
sockets (Unix, IPv4, IPv6, raw, UDP, TCP, SSL). It provides forking,
|
||||||
|
logging and tracing, different modes for interprocess communication and
|
||||||
|
many more options.
|
13
openwrt/package/socat/patches/501-honor_ldflags.patch
Normal file
13
openwrt/package/socat/patches/501-honor_ldflags.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff -ruN socat-1.4-old/Makefile.in socat-1.4-new/Makefile.in
|
||||||
|
--- socat-1.4-old/Makefile.in 2005-09-10 22:09:11.000000000 +0200
|
||||||
|
+++ socat-1.4-new/Makefile.in 2005-10-08 17:12:45.000000000 +0200
|
||||||
|
@@ -36,7 +36,8 @@
|
||||||
|
|
||||||
|
#0 CFLAGS = @CFLAGS@ $(CCOPTS) $(DEFS) $(INCLS)
|
||||||
|
CFLAGS = @CFLAGS@ $(CCOPTS) $(DEFS) $(CPPFLAGS)
|
||||||
|
-CLIBS = $(LIBS)
|
||||||
|
+LDFLAGS = @LDFLAGS@
|
||||||
|
+CLIBS = $(LDFLAGS) $(LIBS)
|
||||||
|
#CLIBS = $(LIBS) -lm -lefence
|
||||||
|
XIOSRCS = xioinitialize.c xiohelp.c xioparam.c xiodiag.c xioopen.c xioopts.c \
|
||||||
|
xiosignal.c xiosigchld.c xioread.c xiowrite.c \
|
Loading…
Reference in New Issue
Block a user