1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-11-24 09:42:49 +02:00

Upgrade to openswan-2.4.6, fix showhostkey script (closes #444), *should* fix #647, #671

git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4632 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2006-08-22 14:21:30 +00:00
parent eb3a7eb2fc
commit b1b6b493bc
3 changed files with 2 additions and 50 deletions

View File

@ -10,9 +10,9 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=openswan PKG_NAME:=openswan
PKG_VERSION:=2.4.5 PKG_VERSION:=2.4.6
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_MD5SUM:=a9a8e88313faceebfc5ceb1a9da9a3c4 PKG_MD5SUM:=b34d71ca49dedad017879b0e912d40dd
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION) PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=http://www.openswan.org/download PKG_SOURCE_URL:=http://www.openswan.org/download

View File

@ -1,11 +0,0 @@
diff -Nur openswan-2.4.5rc5/linux/net/ipsec/ipsec_tunnel.c openswan-2.4.5rc5.patched/linux/net/ipsec/ipsec_tunnel.c
--- openswan-2.4.5rc5/linux/net/ipsec/ipsec_tunnel.c 2005-11-22 05:11:52.000000000 +0100
+++ openswan-2.4.5rc5.patched/linux/net/ipsec/ipsec_tunnel.c 2006-03-29 01:13:35.000000000 +0200
@@ -33,6 +33,7 @@
#include <linux/types.h> /* size_t */
#include <linux/interrupt.h> /* mark_bh */
+#include <net/arp.h>
#include <net/tcp.h>
#include <net/udp.h>
#include <linux/skbuff.h>

View File

@ -1,37 +0,0 @@
diff -ruN openswan-2.4.5-old/linux/net/ipsec/aes/ipsec_alg_aes.c openswan-2.4.5-new/linux/net/ipsec/aes/ipsec_alg_aes.c
--- openswan-2.4.5-old/linux/net/ipsec/aes/ipsec_alg_aes.c 2005-05-20 18:48:55.000000000 +0200
+++ openswan-2.4.5-new/linux/net/ipsec/aes/ipsec_alg_aes.c 2006-06-20 00:17:57.000000000 +0200
@@ -59,12 +59,20 @@
static int keymaxbits=0;
#if defined(CONFIG_KLIPS_ENC_AES_MODULE)
MODULE_AUTHOR("JuanJo Ciarlante <jjo-ipsec@mendoza.gov.ar>");
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,5,52)
+module_param(debug_aes, int, 0);
+module_param(test_aes, int, 0);
+module_param(excl_aes, int, 0);
+module_param(keyminbits, int, 0);
+module_param(keymaxbits, int, 0);
+#else
MODULE_PARM(debug_aes, "i");
MODULE_PARM(test_aes, "i");
MODULE_PARM(excl_aes, "i");
MODULE_PARM(keyminbits, "i");
MODULE_PARM(keymaxbits, "i");
#endif
+#endif
#if CONFIG_KLIPS_ENC_AES_MAC
#include "crypto/aes_xcbc_mac.h"
@@ -79,8 +87,12 @@
#else
static int auth_id=9;
#endif
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,5,52)
+module_param(auth_id, int, 0);
+#else
MODULE_PARM(auth_id, "i");
#endif
+#endif
#define ESP_AES 12 /* truely _constant_ :) */