mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 23:16:16 +02:00
kernel: update linux 3.6 to 3.6.7
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34227 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
777a1e41d4
commit
b270e13375
@ -5,8 +5,8 @@ LINUX_RELEASE?=1
|
|||||||
ifeq ($(LINUX_VERSION),3.3.8)
|
ifeq ($(LINUX_VERSION),3.3.8)
|
||||||
LINUX_KERNEL_MD5SUM:=21068f0fd262b9b3670947f7892e1d6b
|
LINUX_KERNEL_MD5SUM:=21068f0fd262b9b3670947f7892e1d6b
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),3.6.6)
|
ifeq ($(LINUX_VERSION),3.6.7)
|
||||||
LINUX_KERNEL_MD5SUM:=64a274af6e3a9268b4c67b0b51e51565
|
LINUX_KERNEL_MD5SUM:=7c959e3e0b6559ca3f1b7bf86fdc6370
|
||||||
endif
|
endif
|
||||||
|
|
||||||
# disable the md5sum check for unknown kernel versions
|
# disable the md5sum check for unknown kernel versions
|
||||||
|
@ -10,7 +10,7 @@ ARCH:=mips
|
|||||||
BOARD:=brcm63xx
|
BOARD:=brcm63xx
|
||||||
BOARDNAME:=Broadcom BCM63xx
|
BOARDNAME:=Broadcom BCM63xx
|
||||||
FEATURES:=squashfs jffs2 usb atm pci pcmcia
|
FEATURES:=squashfs jffs2 usb atm pci pcmcia
|
||||||
LINUX_VERSION:=3.6.6
|
LINUX_VERSION:=3.6.7
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
@ -23,7 +23,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
|
|||||||
.width = 2,
|
.width = 2,
|
||||||
--- a/drivers/mtd/redboot.c
|
--- a/drivers/mtd/redboot.c
|
||||||
+++ b/drivers/mtd/redboot.c
|
+++ b/drivers/mtd/redboot.c
|
||||||
@@ -75,6 +75,7 @@ static int parse_redboot_partitions(stru
|
@@ -72,6 +72,7 @@ static int parse_redboot_partitions(stru
|
||||||
int nulllen = 0;
|
int nulllen = 0;
|
||||||
int numslots;
|
int numslots;
|
||||||
unsigned long offset;
|
unsigned long offset;
|
||||||
@ -31,7 +31,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
|
|||||||
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
|
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
|
||||||
static char nullstring[] = "unallocated";
|
static char nullstring[] = "unallocated";
|
||||||
#endif
|
#endif
|
||||||
@@ -179,6 +180,16 @@ static int parse_redboot_partitions(stru
|
@@ -176,6 +177,16 @@ static int parse_redboot_partitions(stru
|
||||||
goto out;
|
goto out;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -48,7 +48,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
|
|||||||
for (i = 0; i < numslots; i++) {
|
for (i = 0; i < numslots; i++) {
|
||||||
struct fis_list *new_fl, **prev;
|
struct fis_list *new_fl, **prev;
|
||||||
|
|
||||||
@@ -199,10 +210,10 @@ static int parse_redboot_partitions(stru
|
@@ -196,10 +207,10 @@ static int parse_redboot_partitions(stru
|
||||||
goto out;
|
goto out;
|
||||||
}
|
}
|
||||||
new_fl->img = &buf[i];
|
new_fl->img = &buf[i];
|
||||||
|
@ -49,7 +49,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
|
|||||||
reg &= ~USBH_PRIV_SWAP_EHCI_DATA_MASK;
|
reg &= ~USBH_PRIV_SWAP_EHCI_DATA_MASK;
|
||||||
--- a/drivers/usb/host/ohci-bcm63xx.c
|
--- a/drivers/usb/host/ohci-bcm63xx.c
|
||||||
+++ b/drivers/usb/host/ohci-bcm63xx.c
|
+++ b/drivers/usb/host/ohci-bcm63xx.c
|
||||||
@@ -94,7 +94,7 @@ static int __devinit ohci_hcd_bcm63xx_dr
|
@@ -95,7 +95,7 @@ static int __devinit ohci_hcd_bcm63xx_dr
|
||||||
bcm_rset_writel(RSET_USBH_PRIV, 0x1c0020,
|
bcm_rset_writel(RSET_USBH_PRIV, 0x1c0020,
|
||||||
USBH_PRIV_TEST_6358_REG);
|
USBH_PRIV_TEST_6358_REG);
|
||||||
|
|
||||||
|
@ -73,7 +73,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
|
|||||||
reg &= ~USBH_PRIV_SWAP_EHCI_DATA_MASK;
|
reg &= ~USBH_PRIV_SWAP_EHCI_DATA_MASK;
|
||||||
--- a/drivers/usb/host/ohci-bcm63xx.c
|
--- a/drivers/usb/host/ohci-bcm63xx.c
|
||||||
+++ b/drivers/usb/host/ohci-bcm63xx.c
|
+++ b/drivers/usb/host/ohci-bcm63xx.c
|
||||||
@@ -94,7 +94,7 @@ static int __devinit ohci_hcd_bcm63xx_dr
|
@@ -95,7 +95,7 @@ static int __devinit ohci_hcd_bcm63xx_dr
|
||||||
bcm_rset_writel(RSET_USBH_PRIV, 0x1c0020,
|
bcm_rset_writel(RSET_USBH_PRIV, 0x1c0020,
|
||||||
USBH_PRIV_TEST_6358_REG);
|
USBH_PRIV_TEST_6358_REG);
|
||||||
|
|
||||||
|
3589
target/linux/generic/config-3.6.new
Normal file
3589
target/linux/generic/config-3.6.new
Normal file
File diff suppressed because it is too large
Load Diff
@ -1,6 +1,6 @@
|
|||||||
--- a/net/netlink/af_netlink.c
|
--- a/net/netlink/af_netlink.c
|
||||||
+++ b/net/netlink/af_netlink.c
|
+++ b/net/netlink/af_netlink.c
|
||||||
@@ -882,25 +882,7 @@ void netlink_detachskb(struct sock *sk,
|
@@ -893,25 +893,7 @@ void netlink_detachskb(struct sock *sk,
|
||||||
|
|
||||||
static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
|
static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
|
||||||
{
|
{
|
||||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=danube ar9 vr9 falcon svip_be
|
|||||||
LINUX_VERSION:=3.3.8
|
LINUX_VERSION:=3.3.8
|
||||||
|
|
||||||
#SUBTARGETS=xway ase
|
#SUBTARGETS=xway ase
|
||||||
#LINUX_VERSION:=3.6.6
|
#LINUX_VERSION:=3.6.7
|
||||||
|
|
||||||
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=le be
|
|||||||
INITRAMFS_EXTRA_FILES:=
|
INITRAMFS_EXTRA_FILES:=
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.6.6
|
LINUX_VERSION:=3.6.7
|
||||||
|
|
||||||
DEVICE_TYPE:=developerboard
|
DEVICE_TYPE:=developerboard
|
||||||
|
|
||||||
|
@ -21,11 +21,9 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
|
|||||||
arch/mips/mti-malta/malta-platform.c | 2 +-
|
arch/mips/mti-malta/malta-platform.c | 2 +-
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/arch/mips/mti-malta/malta-platform.c b/arch/mips/mti-malta/malta-platform.c
|
|
||||||
index a8beca8..a906153 100644
|
|
||||||
--- a/arch/mips/mti-malta/malta-platform.c
|
--- a/arch/mips/mti-malta/malta-platform.c
|
||||||
+++ b/arch/mips/mti-malta/malta-platform.c
|
+++ b/arch/mips/mti-malta/malta-platform.c
|
||||||
@@ -47,7 +47,7 @@ static struct plat_serial8250_port uart8250_data[] = {
|
@@ -48,7 +48,7 @@ static struct plat_serial8250_port uart8
|
||||||
SMC_PORT(0x2F8, 3),
|
SMC_PORT(0x2F8, 3),
|
||||||
{
|
{
|
||||||
.mapbase = 0x1f000900, /* The CBUS UART */
|
.mapbase = 0x1f000900, /* The CBUS UART */
|
||||||
@ -34,6 +32,3 @@ index a8beca8..a906153 100644
|
|||||||
.uartclk = 3686400, /* Twice the usual clk! */
|
.uartclk = 3686400, /* Twice the usual clk! */
|
||||||
.iotype = UPIO_MEM32,
|
.iotype = UPIO_MEM32,
|
||||||
.flags = CBUS_UART_FLAGS,
|
.flags = CBUS_UART_FLAGS,
|
||||||
--
|
|
||||||
1.7.11.7
|
|
||||||
|
|
||||||
|
@ -11,8 +11,6 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
|
|||||||
arch/mips/mti-malta/malta-platform.c | 1 +
|
arch/mips/mti-malta/malta-platform.c | 1 +
|
||||||
1 file changed, 1 insertion(+)
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
diff --git a/arch/mips/mti-malta/malta-platform.c b/arch/mips/mti-malta/malta-platform.c
|
|
||||||
index c154181..7473217 100644
|
|
||||||
--- a/arch/mips/mti-malta/malta-platform.c
|
--- a/arch/mips/mti-malta/malta-platform.c
|
||||||
+++ b/arch/mips/mti-malta/malta-platform.c
|
+++ b/arch/mips/mti-malta/malta-platform.c
|
||||||
@@ -29,6 +29,7 @@
|
@@ -29,6 +29,7 @@
|
||||||
@ -23,6 +21,3 @@ index c154181..7473217 100644
|
|||||||
#include <mtd/mtd-abi.h>
|
#include <mtd/mtd-abi.h>
|
||||||
|
|
||||||
#define SMC_PORT(base, int) \
|
#define SMC_PORT(base, int) \
|
||||||
--
|
|
||||||
1.7.11.7
|
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
|
|||||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
|
|
||||||
LINUX_VERSION:=3.6.6
|
LINUX_VERSION:=3.6.7
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES+=\
|
DEFAULT_PACKAGES+=\
|
||||||
|
@ -1,7 +1,5 @@
|
|||||||
Index: linux-3.6.6/drivers/mtd/chips/cfi_cmdset_0002.c
|
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||||
===================================================================
|
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||||
--- linux-3.6.6.orig/drivers/mtd/chips/cfi_cmdset_0002.c
|
|
||||||
+++ linux-3.6.6/drivers/mtd/chips/cfi_cmdset_0002.c
|
|
||||||
@@ -39,7 +39,7 @@
|
@@ -39,7 +39,7 @@
|
||||||
#include <linux/mtd/xip.h>
|
#include <linux/mtd/xip.h>
|
||||||
|
|
||||||
|
@ -11,7 +11,7 @@ BOARD:=sparc
|
|||||||
BOARDNAME:=Sun UltraSPARC
|
BOARDNAME:=Sun UltraSPARC
|
||||||
FEATURES+=fpu tgz jffs2 ext4 squashfs
|
FEATURES+=fpu tgz jffs2 ext4 squashfs
|
||||||
|
|
||||||
LINUX_VERSION:=3.6.6
|
LINUX_VERSION:=3.6.7
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
|||||||
FEATURES:=ext4 audio
|
FEATURES:=ext4 audio
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.6.6
|
LINUX_VERSION:=3.6.7
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -3,7 +3,7 @@ or as a module
|
|||||||
|
|
||||||
--- a/lib/Kconfig
|
--- a/lib/Kconfig
|
||||||
+++ b/lib/Kconfig
|
+++ b/lib/Kconfig
|
||||||
@@ -108,7 +108,7 @@ config ZLIB_INFLATE
|
@@ -178,7 +178,7 @@ config ZLIB_INFLATE
|
||||||
tristate
|
tristate
|
||||||
|
|
||||||
config ZLIB_DEFLATE
|
config ZLIB_DEFLATE
|
||||||
|
Loading…
Reference in New Issue
Block a user