mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-05 10:49:42 +02:00
kernel: reorganize 2.6.39 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26691 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
5ed970594e
commit
b2cab73a78
@ -1,35 +0,0 @@
|
|||||||
--- a/drivers/mtd/devices/block2mtd.c
|
|
||||||
+++ b/drivers/mtd/devices/block2mtd.c
|
|
||||||
@@ -264,12 +264,13 @@ static int _open_bdev(struct block2mtd_d
|
|
||||||
bdev = blkdev_get_by_path(dev->devname, mode, dev);
|
|
||||||
#ifndef MODULE
|
|
||||||
if (IS_ERR(bdev)) {
|
|
||||||
+ dev_t devt;
|
|
||||||
|
|
||||||
/* We might not have rootfs mounted at this point. Try
|
|
||||||
to resolve the device name by other means. */
|
|
||||||
|
|
||||||
wait_for_device_probe();
|
|
||||||
- dev_t devt = name_to_dev_t(dev->devname);
|
|
||||||
+ devt = name_to_dev_t(dev->devname);
|
|
||||||
if (devt)
|
|
||||||
bdev = blkdev_get_by_dev(devt, mode, dev);
|
|
||||||
}
|
|
||||||
@@ -330,7 +331,7 @@ static int block2mtd_refresh(struct mtd_
|
|
||||||
_close_bdev(dev);
|
|
||||||
|
|
||||||
/* open the whole disk, issue a partition rescan, then */
|
|
||||||
- bdev = blkdev_get_by_dev(devt, FMODE_WRITE | FMODE_READ);
|
|
||||||
+ bdev = blkdev_get_by_dev(devt, FMODE_WRITE | FMODE_READ, mtd);
|
|
||||||
if (!bdev || !bdev->bd_disk)
|
|
||||||
err = -EINVAL;
|
|
||||||
#ifndef CONFIG_MTD_BLOCK2MTD_MODULE
|
|
||||||
@@ -395,7 +396,7 @@ static struct block2mtd_dev *add_device(
|
|
||||||
dev->mtd.refresh_device = block2mtd_refresh;
|
|
||||||
|
|
||||||
part = kzalloc(sizeof(struct mtd_partition), GFP_KERNEL);
|
|
||||||
- part->name = dev->mtd.name;
|
|
||||||
+ part->name = name;
|
|
||||||
part->offset = 0;
|
|
||||||
part->size = dev->mtd.size;
|
|
||||||
if (add_mtd_partitions(&dev->mtd, part, 1)) {
|
|
@ -1,6 +1,6 @@
|
|||||||
--- a/lib/Kconfig
|
--- a/lib/Kconfig
|
||||||
+++ b/lib/Kconfig
|
+++ b/lib/Kconfig
|
||||||
@@ -206,16 +206,16 @@ config BCH_CONST_T
|
@@ -200,16 +200,16 @@ config BCH_CONST_T
|
||||||
# Textsearch support is select'ed if needed
|
# Textsearch support is select'ed if needed
|
||||||
#
|
#
|
||||||
config TEXTSEARCH
|
config TEXTSEARCH
|
@ -256,296 +256,6 @@
|
|||||||
static DEFINE_SPINLOCK(part_parser_lock);
|
static DEFINE_SPINLOCK(part_parser_lock);
|
||||||
static LIST_HEAD(part_parsers);
|
static LIST_HEAD(part_parsers);
|
||||||
|
|
||||||
--- a/drivers/mtd/devices/block2mtd.c
|
|
||||||
+++ b/drivers/mtd/devices/block2mtd.c
|
|
||||||
@@ -30,6 +30,8 @@ struct block2mtd_dev {
|
|
||||||
struct block_device *blkdev;
|
|
||||||
struct mtd_info mtd;
|
|
||||||
struct mutex write_mutex;
|
|
||||||
+ rwlock_t bdev_mutex;
|
|
||||||
+ char devname[0];
|
|
||||||
};
|
|
||||||
|
|
||||||
|
|
||||||
@@ -82,6 +84,12 @@ static int block2mtd_erase(struct mtd_in
|
|
||||||
size_t len = instr->len;
|
|
||||||
int err;
|
|
||||||
|
|
||||||
+ read_lock(&dev->bdev_mutex);
|
|
||||||
+ if (!dev->blkdev) {
|
|
||||||
+ err = -EINVAL;
|
|
||||||
+ goto done;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
instr->state = MTD_ERASING;
|
|
||||||
mutex_lock(&dev->write_mutex);
|
|
||||||
err = _block2mtd_erase(dev, from, len);
|
|
||||||
@@ -93,6 +101,10 @@ static int block2mtd_erase(struct mtd_in
|
|
||||||
instr->state = MTD_ERASE_DONE;
|
|
||||||
|
|
||||||
mtd_erase_callback(instr);
|
|
||||||
+
|
|
||||||
+done:
|
|
||||||
+ read_unlock(&dev->bdev_mutex);
|
|
||||||
+
|
|
||||||
return err;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -104,10 +116,14 @@ static int block2mtd_read(struct mtd_inf
|
|
||||||
struct page *page;
|
|
||||||
int index = from >> PAGE_SHIFT;
|
|
||||||
int offset = from & (PAGE_SIZE-1);
|
|
||||||
- int cpylen;
|
|
||||||
+ int cpylen, err = 0;
|
|
||||||
+
|
|
||||||
+ read_lock(&dev->bdev_mutex);
|
|
||||||
+ if (!dev->blkdev || (from > mtd->size)) {
|
|
||||||
+ err = -EINVAL;
|
|
||||||
+ goto done;
|
|
||||||
+ }
|
|
||||||
|
|
||||||
- if (from > mtd->size)
|
|
||||||
- return -EINVAL;
|
|
||||||
if (from + len > mtd->size)
|
|
||||||
len = mtd->size - from;
|
|
||||||
|
|
||||||
@@ -122,10 +138,14 @@ static int block2mtd_read(struct mtd_inf
|
|
||||||
len = len - cpylen;
|
|
||||||
|
|
||||||
page = page_read(dev->blkdev->bd_inode->i_mapping, index);
|
|
||||||
- if (!page)
|
|
||||||
- return -ENOMEM;
|
|
||||||
- if (IS_ERR(page))
|
|
||||||
- return PTR_ERR(page);
|
|
||||||
+ if (!page) {
|
|
||||||
+ err = -ENOMEM;
|
|
||||||
+ goto done;
|
|
||||||
+ }
|
|
||||||
+ if (IS_ERR(page)) {
|
|
||||||
+ err = PTR_ERR(page);
|
|
||||||
+ goto done;
|
|
||||||
+ }
|
|
||||||
|
|
||||||
memcpy(buf, page_address(page) + offset, cpylen);
|
|
||||||
page_cache_release(page);
|
|
||||||
@@ -136,7 +156,10 @@ static int block2mtd_read(struct mtd_inf
|
|
||||||
offset = 0;
|
|
||||||
index++;
|
|
||||||
}
|
|
||||||
- return 0;
|
|
||||||
+
|
|
||||||
+done:
|
|
||||||
+ read_unlock(&dev->bdev_mutex);
|
|
||||||
+ return err;
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
||||||
@@ -188,12 +211,22 @@ static int block2mtd_write(struct mtd_in
|
|
||||||
size_t *retlen, const u_char *buf)
|
|
||||||
{
|
|
||||||
struct block2mtd_dev *dev = mtd->priv;
|
|
||||||
- int err;
|
|
||||||
+ int err = 0;
|
|
||||||
+
|
|
||||||
+ read_lock(&dev->bdev_mutex);
|
|
||||||
+ if (!dev->blkdev) {
|
|
||||||
+ err = -EINVAL;
|
|
||||||
+ goto done;
|
|
||||||
+ }
|
|
||||||
|
|
||||||
if (!len)
|
|
||||||
- return 0;
|
|
||||||
- if (to >= mtd->size)
|
|
||||||
- return -ENOSPC;
|
|
||||||
+ goto done;
|
|
||||||
+
|
|
||||||
+ if (to >= mtd->size) {
|
|
||||||
+ err = -ENOSPC;
|
|
||||||
+ goto done;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
if (to + len > mtd->size)
|
|
||||||
len = mtd->size - to;
|
|
||||||
|
|
||||||
@@ -202,6 +235,9 @@ static int block2mtd_write(struct mtd_in
|
|
||||||
mutex_unlock(&dev->write_mutex);
|
|
||||||
if (err > 0)
|
|
||||||
err = 0;
|
|
||||||
+
|
|
||||||
+done:
|
|
||||||
+ read_unlock(&dev->bdev_mutex);
|
|
||||||
return err;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -210,33 +246,109 @@ static int block2mtd_write(struct mtd_in
|
|
||||||
static void block2mtd_sync(struct mtd_info *mtd)
|
|
||||||
{
|
|
||||||
struct block2mtd_dev *dev = mtd->priv;
|
|
||||||
+ read_lock(&dev->bdev_mutex);
|
|
||||||
+ if (dev->blkdev)
|
|
||||||
sync_blockdev(dev->blkdev);
|
|
||||||
+ read_unlock(&dev->bdev_mutex);
|
|
||||||
+
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
||||||
+static int _open_bdev(struct block2mtd_dev *dev)
|
|
||||||
+{
|
|
||||||
+ const fmode_t mode = FMODE_READ | FMODE_WRITE | FMODE_EXCL;
|
|
||||||
+ struct block_device *bdev;
|
|
||||||
+
|
|
||||||
+ /* Get a handle on the device */
|
|
||||||
+ bdev = blkdev_get_by_path(dev->devname, mode, dev);
|
|
||||||
+#ifndef MODULE
|
|
||||||
+ if (IS_ERR(bdev)) {
|
|
||||||
+
|
|
||||||
+ /* We might not have rootfs mounted at this point. Try
|
|
||||||
+ to resolve the device name by other means. */
|
|
||||||
+
|
|
||||||
+ dev_t devt = name_to_dev_t(dev->devname);
|
|
||||||
+ if (devt)
|
|
||||||
+ bdev = blkdev_get_by_dev(devt, mode, dev);
|
|
||||||
+ }
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
+ if (IS_ERR(bdev)) {
|
|
||||||
+ ERROR("error: cannot open device %s", dev->devname);
|
|
||||||
+ return 1;
|
|
||||||
+ }
|
|
||||||
+ dev->blkdev = bdev;
|
|
||||||
+
|
|
||||||
+ if (MAJOR(bdev->bd_dev) == MTD_BLOCK_MAJOR) {
|
|
||||||
+ ERROR("attempting to use an MTD device as a block device");
|
|
||||||
+ return 1;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ return 0;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static void _close_bdev(struct block2mtd_dev *dev)
|
|
||||||
+{
|
|
||||||
+ struct block_device *bdev;
|
|
||||||
+
|
|
||||||
+ if (!dev->blkdev)
|
|
||||||
+ return;
|
|
||||||
+
|
|
||||||
+ bdev = dev->blkdev;
|
|
||||||
+ invalidate_mapping_pages(dev->blkdev->bd_inode->i_mapping, 0, -1);
|
|
||||||
+ blkdev_put(dev->blkdev, FMODE_READ|FMODE_WRITE|FMODE_EXCL);
|
|
||||||
+ dev->blkdev = NULL;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
static void block2mtd_free_device(struct block2mtd_dev *dev)
|
|
||||||
{
|
|
||||||
if (!dev)
|
|
||||||
return;
|
|
||||||
|
|
||||||
kfree(dev->mtd.name);
|
|
||||||
-
|
|
||||||
- if (dev->blkdev) {
|
|
||||||
- invalidate_mapping_pages(dev->blkdev->bd_inode->i_mapping,
|
|
||||||
- 0, -1);
|
|
||||||
- blkdev_put(dev->blkdev, FMODE_READ|FMODE_WRITE|FMODE_EXCL);
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
+ _close_bdev(dev);
|
|
||||||
kfree(dev);
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
||||||
-/* FIXME: ensure that mtd->size % erase_size == 0 */
|
|
||||||
-static struct block2mtd_dev *add_device(char *devname, int erase_size, const char *mtdname)
|
|
||||||
+static int block2mtd_refresh(struct mtd_info *mtd)
|
|
||||||
{
|
|
||||||
- const fmode_t mode = FMODE_READ | FMODE_WRITE | FMODE_EXCL;
|
|
||||||
+ struct block2mtd_dev *dev = mtd->priv;
|
|
||||||
struct block_device *bdev;
|
|
||||||
+ dev_t devt;
|
|
||||||
+ int err = 0;
|
|
||||||
+
|
|
||||||
+ /* no other mtd function can run at this point */
|
|
||||||
+ write_lock(&dev->bdev_mutex);
|
|
||||||
+
|
|
||||||
+ /* get the device number for the whole disk */
|
|
||||||
+ devt = MKDEV(MAJOR(dev->blkdev->bd_dev), 0);
|
|
||||||
+
|
|
||||||
+ /* close the old block device */
|
|
||||||
+ _close_bdev(dev);
|
|
||||||
+
|
|
||||||
+ /* open the whole disk, issue a partition rescan, then */
|
|
||||||
+ bdev = blkdev_get_by_dev(devt, FMODE_WRITE | FMODE_READ);
|
|
||||||
+ if (!bdev || !bdev->bd_disk)
|
|
||||||
+ err = -EINVAL;
|
|
||||||
+#ifndef CONFIG_MTD_BLOCK2MTD_MODULE
|
|
||||||
+ else
|
|
||||||
+ err = rescan_partitions(bdev->bd_disk, bdev);
|
|
||||||
+#endif
|
|
||||||
+ if (bdev)
|
|
||||||
+ blkdev_put(bdev, FMODE_READ|FMODE_WRITE|FMODE_EXCL);
|
|
||||||
+
|
|
||||||
+ /* try to open the partition block device again */
|
|
||||||
+ _open_bdev(dev);
|
|
||||||
+ write_unlock(&dev->bdev_mutex);
|
|
||||||
+
|
|
||||||
+ return err;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+/* FIXME: ensure that mtd->size % erase_size == 0 */
|
|
||||||
+static struct block2mtd_dev *add_device(char *devname, int erase_size, char *mtdname)
|
|
||||||
+{
|
|
||||||
struct block2mtd_dev *dev;
|
|
||||||
struct mtd_partition *part;
|
|
||||||
char *name;
|
|
||||||
@@ -244,36 +356,17 @@ static struct block2mtd_dev *add_device(
|
|
||||||
if (!devname)
|
|
||||||
return NULL;
|
|
||||||
|
|
||||||
- dev = kzalloc(sizeof(struct block2mtd_dev), GFP_KERNEL);
|
|
||||||
+ dev = kzalloc(sizeof(struct block2mtd_dev) + strlen(devname) + 1, GFP_KERNEL);
|
|
||||||
if (!dev)
|
|
||||||
return NULL;
|
|
||||||
|
|
||||||
- /* Get a handle on the device */
|
|
||||||
- bdev = blkdev_get_by_path(devname, mode, dev);
|
|
||||||
-#ifndef MODULE
|
|
||||||
- if (IS_ERR(bdev)) {
|
|
||||||
-
|
|
||||||
- /* We might not have rootfs mounted at this point. Try
|
|
||||||
- to resolve the device name by other means. */
|
|
||||||
+ strcpy(dev->devname, devname);
|
|
||||||
|
|
||||||
- dev_t devt = name_to_dev_t(devname);
|
|
||||||
- if (devt)
|
|
||||||
- bdev = blkdev_get_by_dev(devt, mode, dev);
|
|
||||||
- }
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
- if (IS_ERR(bdev)) {
|
|
||||||
- ERROR("error: cannot open device %s", devname);
|
|
||||||
+ if (_open_bdev(dev))
|
|
||||||
goto devinit_err;
|
|
||||||
- }
|
|
||||||
- dev->blkdev = bdev;
|
|
||||||
-
|
|
||||||
- if (MAJOR(bdev->bd_dev) == MTD_BLOCK_MAJOR) {
|
|
||||||
- ERROR("attempting to use an MTD device as a block device");
|
|
||||||
- goto devinit_err;
|
|
||||||
- }
|
|
||||||
|
|
||||||
mutex_init(&dev->write_mutex);
|
|
||||||
+ rwlock_init(&dev->bdev_mutex);
|
|
||||||
|
|
||||||
/* Setup the MTD structure */
|
|
||||||
/* make the name contain the block device in */
|
|
||||||
@@ -298,6 +391,7 @@ static struct block2mtd_dev *add_device(
|
|
||||||
dev->mtd.read = block2mtd_read;
|
|
||||||
dev->mtd.priv = dev;
|
|
||||||
dev->mtd.owner = THIS_MODULE;
|
|
||||||
+ dev->mtd.refresh_device = block2mtd_refresh;
|
|
||||||
|
|
||||||
part = kzalloc(sizeof(struct mtd_partition), GFP_KERNEL);
|
|
||||||
part->name = dev->mtd.name;
|
|
||||||
--- a/drivers/mtd/mtdchar.c
|
--- a/drivers/mtd/mtdchar.c
|
||||||
+++ b/drivers/mtd/mtdchar.c
|
+++ b/drivers/mtd/mtdchar.c
|
||||||
@@ -841,6 +841,13 @@ static int mtd_ioctl(struct file *file,
|
@@ -841,6 +841,13 @@ static int mtd_ioctl(struct file *file,
|
@ -47,7 +47,7 @@
|
|||||||
|
|
||||||
- if (add_mtd_device(&dev->mtd)) {
|
- if (add_mtd_device(&dev->mtd)) {
|
||||||
+ part = kzalloc(sizeof(struct mtd_partition), GFP_KERNEL);
|
+ part = kzalloc(sizeof(struct mtd_partition), GFP_KERNEL);
|
||||||
+ part->name = dev->mtd.name;
|
+ part->name = name;
|
||||||
+ part->offset = 0;
|
+ part->offset = 0;
|
||||||
+ part->size = dev->mtd.size;
|
+ part->size = dev->mtd.size;
|
||||||
+ if (add_mtd_partitions(&dev->mtd, part, 1)) {
|
+ if (add_mtd_partitions(&dev->mtd, part, 1)) {
|
291
target/linux/generic/patches-2.6.39/441-block2mtd_refresh.patch
Normal file
291
target/linux/generic/patches-2.6.39/441-block2mtd_refresh.patch
Normal file
@ -0,0 +1,291 @@
|
|||||||
|
--- a/drivers/mtd/devices/block2mtd.c
|
||||||
|
+++ b/drivers/mtd/devices/block2mtd.c
|
||||||
|
@@ -30,6 +30,8 @@ struct block2mtd_dev {
|
||||||
|
struct block_device *blkdev;
|
||||||
|
struct mtd_info mtd;
|
||||||
|
struct mutex write_mutex;
|
||||||
|
+ rwlock_t bdev_mutex;
|
||||||
|
+ char devname[0];
|
||||||
|
};
|
||||||
|
|
||||||
|
|
||||||
|
@@ -82,6 +84,12 @@ static int block2mtd_erase(struct mtd_in
|
||||||
|
size_t len = instr->len;
|
||||||
|
int err;
|
||||||
|
|
||||||
|
+ read_lock(&dev->bdev_mutex);
|
||||||
|
+ if (!dev->blkdev) {
|
||||||
|
+ err = -EINVAL;
|
||||||
|
+ goto done;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
instr->state = MTD_ERASING;
|
||||||
|
mutex_lock(&dev->write_mutex);
|
||||||
|
err = _block2mtd_erase(dev, from, len);
|
||||||
|
@@ -93,6 +101,10 @@ static int block2mtd_erase(struct mtd_in
|
||||||
|
instr->state = MTD_ERASE_DONE;
|
||||||
|
|
||||||
|
mtd_erase_callback(instr);
|
||||||
|
+
|
||||||
|
+done:
|
||||||
|
+ read_unlock(&dev->bdev_mutex);
|
||||||
|
+
|
||||||
|
return err;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -104,10 +116,14 @@ static int block2mtd_read(struct mtd_inf
|
||||||
|
struct page *page;
|
||||||
|
int index = from >> PAGE_SHIFT;
|
||||||
|
int offset = from & (PAGE_SIZE-1);
|
||||||
|
- int cpylen;
|
||||||
|
+ int cpylen, err = 0;
|
||||||
|
+
|
||||||
|
+ read_lock(&dev->bdev_mutex);
|
||||||
|
+ if (!dev->blkdev || (from > mtd->size)) {
|
||||||
|
+ err = -EINVAL;
|
||||||
|
+ goto done;
|
||||||
|
+ }
|
||||||
|
|
||||||
|
- if (from > mtd->size)
|
||||||
|
- return -EINVAL;
|
||||||
|
if (from + len > mtd->size)
|
||||||
|
len = mtd->size - from;
|
||||||
|
|
||||||
|
@@ -122,10 +138,14 @@ static int block2mtd_read(struct mtd_inf
|
||||||
|
len = len - cpylen;
|
||||||
|
|
||||||
|
page = page_read(dev->blkdev->bd_inode->i_mapping, index);
|
||||||
|
- if (!page)
|
||||||
|
- return -ENOMEM;
|
||||||
|
- if (IS_ERR(page))
|
||||||
|
- return PTR_ERR(page);
|
||||||
|
+ if (!page) {
|
||||||
|
+ err = -ENOMEM;
|
||||||
|
+ goto done;
|
||||||
|
+ }
|
||||||
|
+ if (IS_ERR(page)) {
|
||||||
|
+ err = PTR_ERR(page);
|
||||||
|
+ goto done;
|
||||||
|
+ }
|
||||||
|
|
||||||
|
memcpy(buf, page_address(page) + offset, cpylen);
|
||||||
|
page_cache_release(page);
|
||||||
|
@@ -136,7 +156,10 @@ static int block2mtd_read(struct mtd_inf
|
||||||
|
offset = 0;
|
||||||
|
index++;
|
||||||
|
}
|
||||||
|
- return 0;
|
||||||
|
+
|
||||||
|
+done:
|
||||||
|
+ read_unlock(&dev->bdev_mutex);
|
||||||
|
+ return err;
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
@@ -188,12 +211,22 @@ static int block2mtd_write(struct mtd_in
|
||||||
|
size_t *retlen, const u_char *buf)
|
||||||
|
{
|
||||||
|
struct block2mtd_dev *dev = mtd->priv;
|
||||||
|
- int err;
|
||||||
|
+ int err = 0;
|
||||||
|
+
|
||||||
|
+ read_lock(&dev->bdev_mutex);
|
||||||
|
+ if (!dev->blkdev) {
|
||||||
|
+ err = -EINVAL;
|
||||||
|
+ goto done;
|
||||||
|
+ }
|
||||||
|
|
||||||
|
if (!len)
|
||||||
|
- return 0;
|
||||||
|
- if (to >= mtd->size)
|
||||||
|
- return -ENOSPC;
|
||||||
|
+ goto done;
|
||||||
|
+
|
||||||
|
+ if (to >= mtd->size) {
|
||||||
|
+ err = -ENOSPC;
|
||||||
|
+ goto done;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
if (to + len > mtd->size)
|
||||||
|
len = mtd->size - to;
|
||||||
|
|
||||||
|
@@ -202,6 +235,9 @@ static int block2mtd_write(struct mtd_in
|
||||||
|
mutex_unlock(&dev->write_mutex);
|
||||||
|
if (err > 0)
|
||||||
|
err = 0;
|
||||||
|
+
|
||||||
|
+done:
|
||||||
|
+ read_unlock(&dev->bdev_mutex);
|
||||||
|
return err;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -210,33 +246,110 @@ static int block2mtd_write(struct mtd_in
|
||||||
|
static void block2mtd_sync(struct mtd_info *mtd)
|
||||||
|
{
|
||||||
|
struct block2mtd_dev *dev = mtd->priv;
|
||||||
|
+ read_lock(&dev->bdev_mutex);
|
||||||
|
+ if (dev->blkdev)
|
||||||
|
sync_blockdev(dev->blkdev);
|
||||||
|
+ read_unlock(&dev->bdev_mutex);
|
||||||
|
+
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
+static int _open_bdev(struct block2mtd_dev *dev)
|
||||||
|
+{
|
||||||
|
+ const fmode_t mode = FMODE_READ | FMODE_WRITE | FMODE_EXCL;
|
||||||
|
+ struct block_device *bdev;
|
||||||
|
+
|
||||||
|
+ /* Get a handle on the device */
|
||||||
|
+ bdev = blkdev_get_by_path(dev->devname, mode, dev);
|
||||||
|
+#ifndef MODULE
|
||||||
|
+ if (IS_ERR(bdev)) {
|
||||||
|
+ dev_t devt;
|
||||||
|
+
|
||||||
|
+ /* We might not have rootfs mounted at this point. Try
|
||||||
|
+ to resolve the device name by other means. */
|
||||||
|
+
|
||||||
|
+ devt = name_to_dev_t(dev->devname);
|
||||||
|
+ if (devt)
|
||||||
|
+ bdev = blkdev_get_by_dev(devt, mode, dev);
|
||||||
|
+ }
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
+ if (IS_ERR(bdev)) {
|
||||||
|
+ ERROR("error: cannot open device %s", dev->devname);
|
||||||
|
+ return 1;
|
||||||
|
+ }
|
||||||
|
+ dev->blkdev = bdev;
|
||||||
|
+
|
||||||
|
+ if (MAJOR(bdev->bd_dev) == MTD_BLOCK_MAJOR) {
|
||||||
|
+ ERROR("attempting to use an MTD device as a block device");
|
||||||
|
+ return 1;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ return 0;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+static void _close_bdev(struct block2mtd_dev *dev)
|
||||||
|
+{
|
||||||
|
+ struct block_device *bdev;
|
||||||
|
+
|
||||||
|
+ if (!dev->blkdev)
|
||||||
|
+ return;
|
||||||
|
+
|
||||||
|
+ bdev = dev->blkdev;
|
||||||
|
+ invalidate_mapping_pages(dev->blkdev->bd_inode->i_mapping, 0, -1);
|
||||||
|
+ blkdev_put(dev->blkdev, FMODE_READ|FMODE_WRITE|FMODE_EXCL);
|
||||||
|
+ dev->blkdev = NULL;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
static void block2mtd_free_device(struct block2mtd_dev *dev)
|
||||||
|
{
|
||||||
|
if (!dev)
|
||||||
|
return;
|
||||||
|
|
||||||
|
kfree(dev->mtd.name);
|
||||||
|
-
|
||||||
|
- if (dev->blkdev) {
|
||||||
|
- invalidate_mapping_pages(dev->blkdev->bd_inode->i_mapping,
|
||||||
|
- 0, -1);
|
||||||
|
- blkdev_put(dev->blkdev, FMODE_READ|FMODE_WRITE|FMODE_EXCL);
|
||||||
|
- }
|
||||||
|
-
|
||||||
|
+ _close_bdev(dev);
|
||||||
|
kfree(dev);
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
-/* FIXME: ensure that mtd->size % erase_size == 0 */
|
||||||
|
-static struct block2mtd_dev *add_device(char *devname, int erase_size, const char *mtdname)
|
||||||
|
+static int block2mtd_refresh(struct mtd_info *mtd)
|
||||||
|
{
|
||||||
|
- const fmode_t mode = FMODE_READ | FMODE_WRITE | FMODE_EXCL;
|
||||||
|
+ struct block2mtd_dev *dev = mtd->priv;
|
||||||
|
struct block_device *bdev;
|
||||||
|
+ dev_t devt;
|
||||||
|
+ int err = 0;
|
||||||
|
+
|
||||||
|
+ /* no other mtd function can run at this point */
|
||||||
|
+ write_lock(&dev->bdev_mutex);
|
||||||
|
+
|
||||||
|
+ /* get the device number for the whole disk */
|
||||||
|
+ devt = MKDEV(MAJOR(dev->blkdev->bd_dev), 0);
|
||||||
|
+
|
||||||
|
+ /* close the old block device */
|
||||||
|
+ _close_bdev(dev);
|
||||||
|
+
|
||||||
|
+ /* open the whole disk, issue a partition rescan, then */
|
||||||
|
+ bdev = blkdev_get_by_dev(devt, FMODE_WRITE | FMODE_READ, mtd);
|
||||||
|
+ if (!bdev || !bdev->bd_disk)
|
||||||
|
+ err = -EINVAL;
|
||||||
|
+#ifndef CONFIG_MTD_BLOCK2MTD_MODULE
|
||||||
|
+ else
|
||||||
|
+ err = rescan_partitions(bdev->bd_disk, bdev);
|
||||||
|
+#endif
|
||||||
|
+ if (bdev)
|
||||||
|
+ blkdev_put(bdev, FMODE_READ|FMODE_WRITE|FMODE_EXCL);
|
||||||
|
+
|
||||||
|
+ /* try to open the partition block device again */
|
||||||
|
+ _open_bdev(dev);
|
||||||
|
+ write_unlock(&dev->bdev_mutex);
|
||||||
|
+
|
||||||
|
+ return err;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+/* FIXME: ensure that mtd->size % erase_size == 0 */
|
||||||
|
+static struct block2mtd_dev *add_device(char *devname, int erase_size, char *mtdname)
|
||||||
|
+{
|
||||||
|
struct block2mtd_dev *dev;
|
||||||
|
struct mtd_partition *part;
|
||||||
|
char *name;
|
||||||
|
@@ -244,36 +357,17 @@ static struct block2mtd_dev *add_device(
|
||||||
|
if (!devname)
|
||||||
|
return NULL;
|
||||||
|
|
||||||
|
- dev = kzalloc(sizeof(struct block2mtd_dev), GFP_KERNEL);
|
||||||
|
+ dev = kzalloc(sizeof(struct block2mtd_dev) + strlen(devname) + 1, GFP_KERNEL);
|
||||||
|
if (!dev)
|
||||||
|
return NULL;
|
||||||
|
|
||||||
|
- /* Get a handle on the device */
|
||||||
|
- bdev = blkdev_get_by_path(devname, mode, dev);
|
||||||
|
-#ifndef MODULE
|
||||||
|
- if (IS_ERR(bdev)) {
|
||||||
|
-
|
||||||
|
- /* We might not have rootfs mounted at this point. Try
|
||||||
|
- to resolve the device name by other means. */
|
||||||
|
+ strcpy(dev->devname, devname);
|
||||||
|
|
||||||
|
- dev_t devt = name_to_dev_t(devname);
|
||||||
|
- if (devt)
|
||||||
|
- bdev = blkdev_get_by_dev(devt, mode, dev);
|
||||||
|
- }
|
||||||
|
-#endif
|
||||||
|
-
|
||||||
|
- if (IS_ERR(bdev)) {
|
||||||
|
- ERROR("error: cannot open device %s", devname);
|
||||||
|
+ if (_open_bdev(dev))
|
||||||
|
goto devinit_err;
|
||||||
|
- }
|
||||||
|
- dev->blkdev = bdev;
|
||||||
|
-
|
||||||
|
- if (MAJOR(bdev->bd_dev) == MTD_BLOCK_MAJOR) {
|
||||||
|
- ERROR("attempting to use an MTD device as a block device");
|
||||||
|
- goto devinit_err;
|
||||||
|
- }
|
||||||
|
|
||||||
|
mutex_init(&dev->write_mutex);
|
||||||
|
+ rwlock_init(&dev->bdev_mutex);
|
||||||
|
|
||||||
|
/* Setup the MTD structure */
|
||||||
|
/* make the name contain the block device in */
|
||||||
|
@@ -298,6 +392,7 @@ static struct block2mtd_dev *add_device(
|
||||||
|
dev->mtd.read = block2mtd_read;
|
||||||
|
dev->mtd.priv = dev;
|
||||||
|
dev->mtd.owner = THIS_MODULE;
|
||||||
|
+ dev->mtd.refresh_device = block2mtd_refresh;
|
||||||
|
|
||||||
|
part = kzalloc(sizeof(struct mtd_partition), GFP_KERNEL);
|
||||||
|
part->name = name;
|
@ -1,10 +1,10 @@
|
|||||||
--- a/drivers/mtd/devices/block2mtd.c
|
--- a/drivers/mtd/devices/block2mtd.c
|
||||||
+++ b/drivers/mtd/devices/block2mtd.c
|
+++ b/drivers/mtd/devices/block2mtd.c
|
||||||
@@ -268,6 +268,7 @@ static int _open_bdev(struct block2mtd_d
|
@@ -269,6 +269,7 @@ static int _open_bdev(struct block2mtd_d
|
||||||
/* We might not have rootfs mounted at this point. Try
|
/* We might not have rootfs mounted at this point. Try
|
||||||
to resolve the device name by other means. */
|
to resolve the device name by other means. */
|
||||||
|
|
||||||
+ wait_for_device_probe();
|
+ wait_for_device_probe();
|
||||||
dev_t devt = name_to_dev_t(dev->devname);
|
devt = name_to_dev_t(dev->devname);
|
||||||
if (devt)
|
if (devt)
|
||||||
bdev = blkdev_get_by_dev(devt, mode, dev);
|
bdev = blkdev_get_by_dev(devt, mode, dev);
|
@ -1,6 +1,6 @@
|
|||||||
--- a/net/netfilter/Kconfig
|
--- a/net/netfilter/Kconfig
|
||||||
+++ b/net/netfilter/Kconfig
|
+++ b/net/netfilter/Kconfig
|
||||||
@@ -1020,6 +1020,27 @@ config NETFILTER_XT_MATCH_STATE
|
@@ -1018,6 +1018,27 @@ config NETFILTER_XT_MATCH_STATE
|
||||||
|
|
||||||
To compile it as a module, choose M here. If unsure, say N.
|
To compile it as a module, choose M here. If unsure, say N.
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
--- a/net/netfilter/Kconfig
|
--- a/net/netfilter/Kconfig
|
||||||
+++ b/net/netfilter/Kconfig
|
+++ b/net/netfilter/Kconfig
|
||||||
@@ -834,6 +834,27 @@ config NETFILTER_XT_MATCH_IPVS
|
@@ -832,6 +832,27 @@ config NETFILTER_XT_MATCH_IPVS
|
||||||
|
|
||||||
If unsure, say N.
|
If unsure, say N.
|
||||||
|
|
||||||
@ -28,7 +28,7 @@
|
|||||||
config NETFILTER_XT_MATCH_LENGTH
|
config NETFILTER_XT_MATCH_LENGTH
|
||||||
tristate '"length" match support'
|
tristate '"length" match support'
|
||||||
depends on NETFILTER_ADVANCED
|
depends on NETFILTER_ADVANCED
|
||||||
@@ -1020,26 +1041,11 @@ config NETFILTER_XT_MATCH_STATE
|
@@ -1018,26 +1039,11 @@ config NETFILTER_XT_MATCH_STATE
|
||||||
|
|
||||||
To compile it as a module, choose M here. If unsure, say N.
|
To compile it as a module, choose M here. If unsure, say N.
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -91,6 +91,11 @@ config MICREL_PHY
|
@@ -97,6 +97,11 @@ config MICREL_PHY
|
||||||
---help---
|
---help---
|
||||||
Supports the KSZ9021, VSC8201, KS8001 PHYs.
|
Supports the KSZ9021, VSC8201, KS8001 PHYs.
|
||||||
|
|
||||||
@ -14,7 +14,7 @@
|
|||||||
depends on PHYLIB=y
|
depends on PHYLIB=y
|
||||||
--- a/drivers/net/phy/Makefile
|
--- a/drivers/net/phy/Makefile
|
||||||
+++ b/drivers/net/phy/Makefile
|
+++ b/drivers/net/phy/Makefile
|
||||||
@@ -13,6 +13,7 @@ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
|
@@ -14,6 +14,7 @@ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
|
||||||
obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
|
obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
|
||||||
obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
|
obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
|
||||||
obj-$(CONFIG_ICPLUS_PHY) += icplus.o
|
obj-$(CONFIG_ICPLUS_PHY) += icplus.o
|
Some files were not shown because too many files have changed in this diff Show More
Loading…
Reference in New Issue
Block a user