1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 06:26:47 +03:00

[au1000] bump to 2.6.25.4, refresh kernel patches

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11199 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2008-05-19 07:34:56 +00:00
parent f3a87e2bd8
commit b8abb00e2f
8 changed files with 45 additions and 41 deletions

View File

@ -1,4 +1,4 @@
# #
# Copyright (C) 2006 OpenWrt.org # Copyright (C) 2006 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
@ -11,7 +11,7 @@ BOARD:=au1000
BOARDNAME:=RMI/AMD AU1x00 BOARDNAME:=RMI/AMD AU1x00
FEATURES:=jffs2 usb pci FEATURES:=jffs2 usb pci
LINUX_VERSION:=2.6.25 LINUX_VERSION:=2.6.25.4
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += yamonenv DEFAULT_PACKAGES += yamonenv

View File

@ -10,15 +10,12 @@ Signed-off-by: Florian Fainelli <florian.fainelli@telecomint.eu>
arch/mips/au1000/Kconfig | 1 + arch/mips/au1000/Kconfig | 1 +
1 files changed, 1 insertions(+), 0 deletions(-) 1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/arch/mips/au1000/Kconfig b/arch/mips/au1000/Kconfig Index: linux-2.6.25.4/arch/mips/au1000/Kconfig
index 29c95d9..f03b2eb 100644 ===================================================================
--- a/arch/mips/au1000/Kconfig --- linux-2.6.25.4.orig/arch/mips/au1000/Kconfig
+++ b/arch/mips/au1000/Kconfig +++ linux-2.6.25.4/arch/mips/au1000/Kconfig
@@ -141,3 +141,4 @@ config SOC_AU1X00 @@ -135,3 +135,4 @@ config SOC_AU1X00
select SYS_SUPPORTS_32BIT_KERNEL select SYS_SUPPORTS_32BIT_KERNEL
select SYS_SUPPORTS_APM_EMULATION select SYS_SUPPORTS_APM_EMULATION
select SYS_SUPPORTS_KGDB select SYS_SUPPORTS_KGDB
+ select GENERIC_GPIO + select GENERIC_GPIO
--
1.5.2.4

View File

@ -2,11 +2,11 @@ This patch adds support for the GPIO connected system button on the MTX-1 boards
Signed-off-by: Florian Fainelli <florian.fainelli@telecomint.eu> Signed-off-by: Florian Fainelli <florian.fainelli@telecomint.eu>
--- ---
diff --git a/arch/mips/au1000/mtx-1/platform.c b/arch/mips/au1000/mtx-1/platform.c Index: linux-2.6.25.4/arch/mips/au1000/mtx-1/platform.c
index 49c0fb4..ce8637b 100644 ===================================================================
--- a/arch/mips/au1000/mtx-1/platform.c --- linux-2.6.25.4.orig/arch/mips/au1000/mtx-1/platform.c
+++ b/arch/mips/au1000/mtx-1/platform.c +++ linux-2.6.25.4/arch/mips/au1000/mtx-1/platform.c
@@ -22,9 +22,32 @@ @@ -23,9 +23,32 @@
#include <linux/types.h> #include <linux/types.h>
#include <linux/platform_device.h> #include <linux/platform_device.h>
#include <linux/leds.h> #include <linux/leds.h>
@ -38,10 +38,10 @@ index 49c0fb4..ce8637b 100644
+ +
static struct resource mtx1_wdt_res[] = { static struct resource mtx1_wdt_res[] = {
[0] = { [0] = {
.start = 15, .start = 15,
@@ -66,11 +89,13 @@ static struct platform_device mtx1_gpio_leds = { @@ -62,11 +85,13 @@ static struct platform_device mtx1_gpio_
static struct __initdata platform_device * mtx1_devs[] = { static struct platform_device *mtx1_devs[] = {
&mtx1_gpio_leds, &mtx1_gpio_leds,
- &mtx1_wdt - &mtx1_wdt
+ &mtx1_wdt, + &mtx1_wdt,

View File

@ -1,7 +1,8 @@
diff -urN linux-2.6.16.7/drivers/net/au1000_eth.c linux-2.6.16.7.new/drivers/net/au1000_eth.c Index: linux-2.6.25.4/drivers/net/au1000_eth.c
--- linux-2.6.16.7/drivers/net/au1000_eth.c 2006-04-17 23:53:25.000000000 +0200 ===================================================================
+++ linux-2.6.16.7.new/drivers/net/au1000_eth.c 2006-04-23 01:42:48.000000000 +0200 --- linux-2.6.25.4.orig/drivers/net/au1000_eth.c
@@ -12,6 +12,9 @@ +++ linux-2.6.25.4/drivers/net/au1000_eth.c
@@ -15,6 +15,9 @@
* Author: MontaVista Software, Inc. * Author: MontaVista Software, Inc.
* ppopov@mvista.com or source@mvista.com * ppopov@mvista.com or source@mvista.com
* *
@ -11,9 +12,9 @@ diff -urN linux-2.6.16.7/drivers/net/au1000_eth.c linux-2.6.16.7.new/drivers/net
* ######################################################################## * ########################################################################
* *
* This program is free software; you can distribute it and/or modify it * This program is free software; you can distribute it and/or modify it
@@ -1672,6 +1675,10 @@ @@ -835,6 +838,10 @@ static int au1000_init(struct net_device
aup->phy_ops->phy_status(dev, aup->phy_addr, &link, &speed);
control = MAC_DISABLE_RX_OWN | MAC_RX_ENABLE | MAC_TX_ENABLE; control = MAC_RX_ENABLE | MAC_TX_ENABLE;
#ifndef CONFIG_CPU_LITTLE_ENDIAN #ifndef CONFIG_CPU_LITTLE_ENDIAN
+ /*riemer: fix for startup without cable */ + /*riemer: fix for startup without cable */
+ if (!link) + if (!link)
@ -21,4 +22,4 @@ diff -urN linux-2.6.16.7/drivers/net/au1000_eth.c linux-2.6.16.7.new/drivers/net
+ +
control |= MAC_BIG_ENDIAN; control |= MAC_BIG_ENDIAN;
#endif #endif
if (link && (dev->if_port == IF_PORT_100BASEFX)) { if (aup->phy_dev) {

View File

@ -1,8 +1,10 @@
--- linux-2.6.19.2/arch/mips/au1000/mtx-1/init.c.old 2007-04-06 15:01:13.503777992 +0200 Index: linux-2.6.25.4/arch/mips/au1000/mtx-1/init.c
+++ linux-2.6.19.2/arch/mips/au1000/mtx-1/init.c 2007-04-06 15:01:36.296313000 +0200 ===================================================================
@@ -59,7 +58,7 @@ --- linux-2.6.25.4.orig/arch/mips/au1000/mtx-1/init.c
mips_machgroup = MACH_GROUP_ALCHEMY; +++ linux-2.6.25.4/arch/mips/au1000/mtx-1/init.c
mips_machtype = MACH_MTX1; /* set the platform # */ @@ -54,7 +54,7 @@ void __init prom_init(void)
prom_argv = (char **) fw_arg1;
prom_envp = (char **) fw_arg2;
- prom_init_cmdline(); - prom_init_cmdline();
+ strcpy(arcs_cmdline, CONFIG_CMDLINE); + strcpy(arcs_cmdline, CONFIG_CMDLINE);

View File

@ -1,6 +1,8 @@
--- linux-2.6.19.2/drivers/mtd/maps/mtx-1_flash.c 2007-07-10 20:56:30.000000000 +0200 Index: linux-2.6.25.4/drivers/mtd/maps/mtx-1_flash.c
+++ linux-2.6.19.2.new/drivers/mtd/maps/mtx-1_flash.c 2007-07-23 12:21:16.000000000 +0200 ===================================================================
@@ -28,7 +28,7 @@ --- linux-2.6.25.4.orig/drivers/mtd/maps/mtx-1_flash.c
+++ linux-2.6.25.4/drivers/mtd/maps/mtx-1_flash.c
@@ -28,7 +28,7 @@ static struct map_info mtx1_map = {
static struct mtd_partition mtx1_partitions[] = { static struct mtd_partition mtx1_partitions[] = {
{ {

View File

@ -1,6 +1,8 @@
--- linux-2.6.22.1.orig/drivers/net/au1000_eth.c 2007-07-24 18:43:25.527583520 +0200 Index: linux-2.6.25.4/drivers/net/au1000_eth.c
+++ linux-2.6.22.1/drivers/net/au1000_eth.c 2007-07-24 23:07:00.388821102 +0200 ===================================================================
@@ -1320,9 +1320,12 @@ --- linux-2.6.25.4.orig/drivers/net/au1000_eth.c
+++ linux-2.6.25.4/drivers/net/au1000_eth.c
@@ -1306,9 +1306,12 @@ static void set_rx_mode(struct net_devic
} }
} }

View File

@ -1,7 +1,7 @@
diff --git a/arch/mips/au1000/common/pci.c b/arch/mips/au1000/common/pci.c Index: linux-2.6.25.4/arch/mips/au1000/common/pci.c
index c93d7a6..6c25e6c 100644 ===================================================================
--- a/arch/mips/au1000/common/pci.c --- linux-2.6.25.4.orig/arch/mips/au1000/common/pci.c
+++ b/arch/mips/au1000/common/pci.c +++ linux-2.6.25.4/arch/mips/au1000/common/pci.c
@@ -39,15 +39,15 @@ @@ -39,15 +39,15 @@
/* TBD */ /* TBD */