mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-12-26 02:38:59 +02:00
[kernel] update ocf-linux to 20080917
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13282 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9ebd805c01
commit
bb1747ae92
@ -1016,11 +1016,13 @@ CONFIG_NORTEL_HERMES=m
|
|||||||
# CONFIG_NTFS_FS is not set
|
# CONFIG_NTFS_FS is not set
|
||||||
# CONFIG_NTFS_RW is not set
|
# CONFIG_NTFS_RW is not set
|
||||||
# CONFIG_OCF_BENCH is not set
|
# CONFIG_OCF_BENCH is not set
|
||||||
|
# CONFIG_OCF_EP80579 is not set
|
||||||
# CONFIG_OCF_IXP4XX is not set
|
# CONFIG_OCF_IXP4XX is not set
|
||||||
# CONFIG_OCF_HIFN is not set
|
# CONFIG_OCF_HIFN is not set
|
||||||
# CONFIG_OCF_HIFNHIPP is not set
|
# CONFIG_OCF_HIFNHIPP is not set
|
||||||
# CONFIG_OCF_SAFE is not set
|
# CONFIG_OCF_SAFE is not set
|
||||||
# CONFIG_OCF_TALITOS is not set
|
# CONFIG_OCF_TALITOS is not set
|
||||||
|
# CONFIG_OCF_OCF is not set
|
||||||
# CONFIG_OCF_OCFNULL is not set
|
# CONFIG_OCF_OCFNULL is not set
|
||||||
# CONFIG_OCFS2_FS is not set
|
# CONFIG_OCFS2_FS is not set
|
||||||
# CONFIG_OSF_PARTITION is not set
|
# CONFIG_OSF_PARTITION is not set
|
||||||
|
@ -1045,11 +1045,13 @@ CONFIG_NORTEL_HERMES=m
|
|||||||
# CONFIG_NTFS_FS is not set
|
# CONFIG_NTFS_FS is not set
|
||||||
# CONFIG_NTFS_RW is not set
|
# CONFIG_NTFS_RW is not set
|
||||||
# CONFIG_OCF_BENCH is not set
|
# CONFIG_OCF_BENCH is not set
|
||||||
|
# CONFIG_OCF_EP80579 is not set
|
||||||
# CONFIG_OCF_IXP4XX is not set
|
# CONFIG_OCF_IXP4XX is not set
|
||||||
# CONFIG_OCF_HIFN is not set
|
# CONFIG_OCF_HIFN is not set
|
||||||
# CONFIG_OCF_HIFNHIPP is not set
|
# CONFIG_OCF_HIFNHIPP is not set
|
||||||
# CONFIG_OCF_SAFE is not set
|
# CONFIG_OCF_SAFE is not set
|
||||||
# CONFIG_OCF_TALITOS is not set
|
# CONFIG_OCF_TALITOS is not set
|
||||||
|
# CONFIG_OCF_OCF is not set
|
||||||
# CONFIG_OCF_OCFNULL is not set
|
# CONFIG_OCF_OCFNULL is not set
|
||||||
# CONFIG_OCFS2_FS is not set
|
# CONFIG_OCFS2_FS is not set
|
||||||
# CONFIG_OSF_PARTITION is not set
|
# CONFIG_OSF_PARTITION is not set
|
||||||
|
@ -1094,6 +1094,7 @@ CONFIG_NORTEL_HERMES=m
|
|||||||
# CONFIG_NTFS_RW is not set
|
# CONFIG_NTFS_RW is not set
|
||||||
# CONFIG_OCFS2_FS is not set
|
# CONFIG_OCFS2_FS is not set
|
||||||
# CONFIG_OCF_BENCH is not set
|
# CONFIG_OCF_BENCH is not set
|
||||||
|
# CONFIG_OCF_EP80579 is not set
|
||||||
# CONFIG_OCF_HIFN is not set
|
# CONFIG_OCF_HIFN is not set
|
||||||
# CONFIG_OCF_HIFNHIPP is not set
|
# CONFIG_OCF_HIFNHIPP is not set
|
||||||
# CONFIG_OCF_IXP4XX is not set
|
# CONFIG_OCF_IXP4XX is not set
|
||||||
|
@ -0,0 +1,25 @@
|
|||||||
|
--- a/crypto/Kconfig
|
||||||
|
+++ b/crypto/Kconfig
|
||||||
|
@@ -590,6 +590,8 @@ config CRYPTO_LZO
|
||||||
|
help
|
||||||
|
This is the LZO algorithm.
|
||||||
|
|
||||||
|
+source "crypto/ocf/Kconfig"
|
||||||
|
+
|
||||||
|
source "drivers/crypto/Kconfig"
|
||||||
|
|
||||||
|
endif # if CRYPTO
|
||||||
|
--- a/crypto/Makefile
|
||||||
|
+++ b/crypto/Makefile
|
||||||
|
@@ -66,6 +66,11 @@ obj-$(CONFIG_CRYPTO_LZO) += lzo.o
|
||||||
|
obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
|
||||||
|
|
||||||
|
#
|
||||||
|
+# OCF
|
||||||
|
+#
|
||||||
|
+obj-$(CONFIG_OCF_OCF) += ocf/
|
||||||
|
+
|
||||||
|
+#
|
||||||
|
# generic algorithms and the async_tx api
|
||||||
|
#
|
||||||
|
obj-$(CONFIG_XOR_BLOCKS) += xor.o
|
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,25 @@
|
|||||||
|
--- a/crypto/Kconfig
|
||||||
|
+++ b/crypto/Kconfig
|
||||||
|
@@ -675,6 +675,8 @@ config CRYPTO_PRNG
|
||||||
|
for cryptographic modules. Uses the Algorithm specified in
|
||||||
|
ANSI X9.31 A.2.4
|
||||||
|
|
||||||
|
+source "crypto/ocf/Kconfig"
|
||||||
|
+
|
||||||
|
source "drivers/crypto/Kconfig"
|
||||||
|
|
||||||
|
endif # if CRYPTO
|
||||||
|
--- a/crypto/Makefile
|
||||||
|
+++ b/crypto/Makefile
|
||||||
|
@@ -73,6 +73,11 @@ obj-$(CONFIG_CRYPTO_PRNG) += prng.o
|
||||||
|
obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
|
||||||
|
|
||||||
|
#
|
||||||
|
+# OCF
|
||||||
|
+#
|
||||||
|
+obj-$(CONFIG_OCF_OCF) += ocf/
|
||||||
|
+
|
||||||
|
+#
|
||||||
|
# generic algorithms and the async_tx api
|
||||||
|
#
|
||||||
|
obj-$(CONFIG_XOR_BLOCKS) += xor.o
|
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,25 @@
|
|||||||
|
--- a/crypto/Kconfig
|
||||||
|
+++ b/crypto/Kconfig
|
||||||
|
@@ -666,6 +666,8 @@ config CRYPTO_LZO
|
||||||
|
help
|
||||||
|
This is the LZO algorithm.
|
||||||
|
|
||||||
|
+source "crypto/ocf/Kconfig"
|
||||||
|
+
|
||||||
|
source "drivers/crypto/Kconfig"
|
||||||
|
|
||||||
|
endif # if CRYPTO
|
||||||
|
--- a/crypto/Makefile
|
||||||
|
+++ b/crypto/Makefile
|
||||||
|
@@ -73,6 +73,11 @@ obj-$(CONFIG_CRYPTO_LZO) += lzo.o
|
||||||
|
obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
|
||||||
|
|
||||||
|
#
|
||||||
|
+# OCF
|
||||||
|
+#
|
||||||
|
+obj-$(CONFIG_OCF_OCF) += ocf/
|
||||||
|
+
|
||||||
|
+#
|
||||||
|
# generic algorithms and the async_tx api
|
||||||
|
#
|
||||||
|
obj-$(CONFIG_XOR_BLOCKS) += xor.o
|
File diff suppressed because it is too large
Load Diff
@ -1,9 +1,10 @@
|
|||||||
--- a/crypto/ocf/cryptosoft.c
|
--- a/crypto/ocf/cryptosoft.c
|
||||||
+++ b/crypto/ocf/cryptosoft.c
|
+++ b/crypto/ocf/cryptosoft.c
|
||||||
@@ -48,6 +48,7 @@
|
@@ -47,7 +47,7 @@
|
||||||
|
#include <linux/mm.h>
|
||||||
#include <linux/skbuff.h>
|
#include <linux/skbuff.h>
|
||||||
#include <linux/random.h>
|
#include <linux/random.h>
|
||||||
#include <asm/scatterlist.h>
|
-#include <asm/scatterlist.h>
|
||||||
+#include <linux/scatterlist.h>
|
+#include <linux/scatterlist.h>
|
||||||
|
|
||||||
#include <cryptodev.h>
|
#include <cryptodev.h>
|
Loading…
Reference in New Issue
Block a user