1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-10-01 19:32:00 +03:00

[kernel] update to 2.6.27.8 and refresh patches

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13528 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2008-12-06 09:59:55 +00:00
parent 8896ddb199
commit bd2e5d7b03
13 changed files with 40 additions and 62 deletions

View File

@ -28,8 +28,8 @@ endif
ifeq ($(LINUX_VERSION),2.6.26.8) ifeq ($(LINUX_VERSION),2.6.26.8)
LINUX_KERNEL_MD5SUM:=05dd0d4f8f110b4219ae6ec7a36c046d LINUX_KERNEL_MD5SUM:=05dd0d4f8f110b4219ae6ec7a36c046d
endif endif
ifeq ($(LINUX_VERSION),2.6.27.7) ifeq ($(LINUX_VERSION),2.6.27.8)
LINUX_KERNEL_MD5SUM:=db323884c7dc46e4cd33d0d944fa59a9 LINUX_KERNEL_MD5SUM:=cbdc1b350ef79dd323b9aeda5cf7f1b6
endif endif
# disable the md5sum check for unknown kernel versions # disable the md5sum check for unknown kernel versions

View File

@ -11,7 +11,7 @@ BOARD:=au1000
BOARDNAME:=RMI/AMD AU1x00 BOARDNAME:=RMI/AMD AU1x00
FEATURES:=jffs2 usb pci FEATURES:=jffs2 usb pci
LINUX_VERSION:=2.6.27.7 LINUX_VERSION:=2.6.27.8
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += yamonenv DEFAULT_PACKAGES += yamonenv

View File

@ -10,7 +10,7 @@ ARCH:=avr32
BOARD:=avr32 BOARD:=avr32
BOARDNAME:=Atmel AVR32 BOARDNAME:=Atmel AVR32
FEATURES:=squashfs FEATURES:=squashfs
LINUX_VERSION:=2.6.27.7 LINUX_VERSION:=2.6.27.8
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View File

@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=brcm63xx BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx BOARDNAME:=Broadcom BCM63xx
FEATURES:=squashfs jffs2 usb atm FEATURES:=squashfs jffs2 usb atm
LINUX_VERSION:=2.6.27.7 LINUX_VERSION:=2.6.27.8
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View File

@ -19,7 +19,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
--- a/drivers/usb/host/ehci-hcd.c --- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c +++ b/drivers/usb/host/ehci-hcd.c
@@ -1040,6 +1040,11 @@ MODULE_LICENSE ("GPL"); @@ -1039,6 +1039,11 @@ MODULE_LICENSE ("GPL");
#define PLATFORM_DRIVER ixp4xx_ehci_driver #define PLATFORM_DRIVER ixp4xx_ehci_driver
#endif #endif

View File

@ -11,7 +11,7 @@ BOARD:=olpc
BOARDNAME:=OLPC XO-1 BOARDNAME:=OLPC XO-1
FEATURES:=squashfs ext2 FEATURES:=squashfs ext2
LINUX_VERSION:=2.6.27.7 LINUX_VERSION:=2.6.27.8
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci

View File

@ -11,7 +11,7 @@ BOARD:=ppc40x
BOARDNAME:=AMCC/IBM PPC40x BOARDNAME:=AMCC/IBM PPC40x
FEATURES:=squashfs FEATURES:=squashfs
LINUX_VERSION:=2.6.27.7 LINUX_VERSION:=2.6.27.8
LINUX_KARCH:=powerpc LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View File

@ -1,5 +1,3 @@
diff --git a/arch/powerpc/platforms/40x/Kconfig b/arch/powerpc/platforms/40x/Kconfig
index a9260e2..72ba3a7 100644
--- a/arch/powerpc/platforms/40x/Kconfig --- a/arch/powerpc/platforms/40x/Kconfig
+++ b/arch/powerpc/platforms/40x/Kconfig +++ b/arch/powerpc/platforms/40x/Kconfig
@@ -14,6 +14,15 @@ @@ -14,6 +14,15 @@
@ -45,8 +43,6 @@ index a9260e2..72ba3a7 100644
config 405GPR config 405GPR
bool bool
diff --git a/arch/powerpc/platforms/40x/Makefile b/arch/powerpc/platforms/40x/Makefile
index 5533a5c..1d93273 100644
--- a/arch/powerpc/platforms/40x/Makefile --- a/arch/powerpc/platforms/40x/Makefile
+++ b/arch/powerpc/platforms/40x/Makefile +++ b/arch/powerpc/platforms/40x/Makefile
@@ -3,3 +3,4 @@ obj-$(CONFIG_MAKALU) += makalu.o @@ -3,3 +3,4 @@ obj-$(CONFIG_MAKALU) += makalu.o
@ -54,9 +50,6 @@ index 5533a5c..1d93273 100644
obj-$(CONFIG_XILINX_VIRTEX_GENERIC_BOARD) += virtex.o obj-$(CONFIG_XILINX_VIRTEX_GENERIC_BOARD) += virtex.o
obj-$(CONFIG_EP405) += ep405.o obj-$(CONFIG_EP405) += ep405.o
+obj-$(CONFIG_PPC40x_SIMPLE) += ppc40x_simple.o +obj-$(CONFIG_PPC40x_SIMPLE) += ppc40x_simple.o
diff --git a/arch/powerpc/platforms/40x/ppc40x_simple.c b/arch/powerpc/platforms/40x/ppc40x_simple.c
new file mode 100644
index 0000000..4498a86
--- /dev/null --- /dev/null
+++ b/arch/powerpc/platforms/40x/ppc40x_simple.c +++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
@@ -0,0 +1,80 @@ @@ -0,0 +1,80 @@

View File

@ -1,8 +1,6 @@
diff --git a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
index 6403275..5f4a59c 100644
--- a/arch/powerpc/boot/Makefile --- a/arch/powerpc/boot/Makefile
+++ b/arch/powerpc/boot/Makefile +++ b/arch/powerpc/boot/Makefile
@@ -68,7 +68,8 @@ src-plat := of.c cuboot-52xx.c cuboot-824x.c cuboot-83xx.c cuboot-85xx.c holly.c @@ -68,7 +68,8 @@ src-plat := of.c cuboot-52xx.c cuboot-82
fixed-head.S ep88xc.c ep405.c cuboot-c2k.c \ fixed-head.S ep88xc.c ep405.c cuboot-c2k.c \
cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \ cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \
cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \ cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \
@ -12,7 +10,7 @@ index 6403275..5f4a59c 100644
src-boot := $(src-wlib) $(src-plat) empty.c src-boot := $(src-wlib) $(src-plat) empty.c
src-boot := $(addprefix $(obj)/, $(src-boot)) src-boot := $(addprefix $(obj)/, $(src-boot))
@@ -211,6 +212,7 @@ image-$(CONFIG_DEFAULT_UIMAGE) += uImage @@ -211,6 +212,7 @@ image-$(CONFIG_DEFAULT_UIMAGE) += uImag
# Board ports in arch/powerpc/platform/40x/Kconfig # Board ports in arch/powerpc/platform/40x/Kconfig
image-$(CONFIG_EP405) += dtbImage.ep405 image-$(CONFIG_EP405) += dtbImage.ep405
image-$(CONFIG_WALNUT) += treeImage.walnut image-$(CONFIG_WALNUT) += treeImage.walnut
@ -20,9 +18,6 @@ index 6403275..5f4a59c 100644
# Board ports in arch/powerpc/platform/44x/Kconfig # Board ports in arch/powerpc/platform/44x/Kconfig
image-$(CONFIG_EBONY) += treeImage.ebony cuImage.ebony image-$(CONFIG_EBONY) += treeImage.ebony cuImage.ebony
diff --git a/arch/powerpc/boot/cuboot-acadia.c b/arch/powerpc/boot/cuboot-acadia.c
new file mode 100644
index 0000000..0634aba
--- /dev/null --- /dev/null
+++ b/arch/powerpc/boot/cuboot-acadia.c +++ b/arch/powerpc/boot/cuboot-acadia.c
@@ -0,0 +1,174 @@ @@ -0,0 +1,174 @@

View File

@ -1,6 +1,5 @@
diff -Nur a/arch/powerpc/boot/cuboot-magicboxv1.c b/arch/powerpc/boot/cuboot-magicboxv1.c --- /dev/null
--- a/arch/powerpc/boot/cuboot-magicboxv1.c 1970-01-01 01:00:00.000000000 +0100 +++ b/arch/powerpc/boot/cuboot-magicboxv1.c
+++ b/arch/powerpc/boot/cuboot-magicboxv1.c 2008-11-23 20:13:57.000000000 +0100
@@ -0,0 +1,40 @@ @@ -0,0 +1,40 @@
+/* +/*
+ * Old U-boot compatibility for Magicbox v1 + * Old U-boot compatibility for Magicbox v1
@ -42,9 +41,8 @@ diff -Nur a/arch/powerpc/boot/cuboot-magicboxv1.c b/arch/powerpc/boot/cuboot-mag
+ fdt_init(_dtb_start); + fdt_init(_dtb_start);
+ serial_console_init(); + serial_console_init();
+} +}
diff -Nur a/arch/powerpc/boot/dts/magicboxv1.dts b/arch/powerpc/boot/dts/magicboxv1.dts --- /dev/null
--- a/arch/powerpc/boot/dts/magicboxv1.dts 1970-01-01 01:00:00.000000000 +0100 +++ b/arch/powerpc/boot/dts/magicboxv1.dts
+++ b/arch/powerpc/boot/dts/magicboxv1.dts 2008-11-26 09:14:46.000000000 +0100
@@ -0,0 +1,217 @@ @@ -0,0 +1,217 @@
+/* +/*
+ * Device Tree Source for Magicbox v1 + * Device Tree Source for Magicbox v1
@ -263,10 +261,9 @@ diff -Nur a/arch/powerpc/boot/dts/magicboxv1.dts b/arch/powerpc/boot/dts/magicbo
+ linux,stdout-path = "/plb/opb/serial@ef600300"; + linux,stdout-path = "/plb/opb/serial@ef600300";
+ }; + };
+}; +};
diff -Nur a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile --- a/arch/powerpc/boot/Makefile
--- a/arch/powerpc/boot/Makefile 2008-11-26 09:14:31.000000000 +0100 +++ b/arch/powerpc/boot/Makefile
+++ b/arch/powerpc/boot/Makefile 2008-11-22 21:21:01.000000000 +0100 @@ -69,7 +69,7 @@ src-plat := of.c cuboot-52xx.c cuboot-82
@@ -69,7 +69,7 @@
cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \ cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \
cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \ cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \
virtex405-head.S virtex.c redboot-83xx.c cuboot-sam440ep.c \ virtex405-head.S virtex.c redboot-83xx.c cuboot-sam440ep.c \
@ -275,7 +272,7 @@ diff -Nur a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
src-boot := $(src-wlib) $(src-plat) empty.c src-boot := $(src-wlib) $(src-plat) empty.c
src-boot := $(addprefix $(obj)/, $(src-boot)) src-boot := $(addprefix $(obj)/, $(src-boot))
@@ -213,6 +213,7 @@ @@ -213,6 +213,7 @@ image-$(CONFIG_DEFAULT_UIMAGE) += uImag
image-$(CONFIG_EP405) += dtbImage.ep405 image-$(CONFIG_EP405) += dtbImage.ep405
image-$(CONFIG_WALNUT) += treeImage.walnut image-$(CONFIG_WALNUT) += treeImage.walnut
image-$(CONFIG_ACADIA) += cuImage.acadia image-$(CONFIG_ACADIA) += cuImage.acadia
@ -283,10 +280,9 @@ diff -Nur a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
# Board ports in arch/powerpc/platform/44x/Kconfig # Board ports in arch/powerpc/platform/44x/Kconfig
image-$(CONFIG_EBONY) += treeImage.ebony cuImage.ebony image-$(CONFIG_EBONY) += treeImage.ebony cuImage.ebony
diff -Nur a/arch/powerpc/platforms/40x/Kconfig b/arch/powerpc/platforms/40x/Kconfig --- a/arch/powerpc/platforms/40x/Kconfig
--- a/arch/powerpc/platforms/40x/Kconfig 2008-11-26 09:14:31.000000000 +0100 +++ b/arch/powerpc/platforms/40x/Kconfig
+++ b/arch/powerpc/platforms/40x/Kconfig 2008-11-18 14:28:06.000000000 +0100 @@ -41,6 +41,16 @@ config KILAUEA
@@ -41,6 +41,16 @@
help help
This option enables support for the AMCC PPC405EX evaluation board. This option enables support for the AMCC PPC405EX evaluation board.
@ -303,10 +299,9 @@ diff -Nur a/arch/powerpc/platforms/40x/Kconfig b/arch/powerpc/platforms/40x/Kcon
config MAKALU config MAKALU
bool "Makalu" bool "Makalu"
depends on 40x depends on 40x
diff -Nur a/arch/powerpc/platforms/40x/ppc40x_simple.c b/arch/powerpc/platforms/40x/ppc40x_simple.c --- a/arch/powerpc/platforms/40x/ppc40x_simple.c
--- a/arch/powerpc/platforms/40x/ppc40x_simple.c 2008-11-26 09:14:31.000000000 +0100 +++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
+++ b/arch/powerpc/platforms/40x/ppc40x_simple.c 2008-11-18 14:29:59.000000000 +0100 @@ -51,7 +51,8 @@ machine_device_initcall(ppc40x_simple, p
@@ -51,7 +51,8 @@
* board.c file for it rather than adding it to this list. * board.c file for it rather than adding it to this list.
*/ */
static char *board[] __initdata = { static char *board[] __initdata = {

View File

@ -1,6 +1,5 @@
diff -Nur a/arch/powerpc/boot/cuboot-magicboxv2.c b/arch/powerpc/boot/cuboot-magicboxv2.c --- /dev/null
--- a/arch/powerpc/boot/cuboot-magicboxv2.c 1970-01-01 01:00:00.000000000 +0100 +++ b/arch/powerpc/boot/cuboot-magicboxv2.c
+++ b/arch/powerpc/boot/cuboot-magicboxv2.c 2008-11-26 09:29:02.000000000 +0100
@@ -0,0 +1,40 @@ @@ -0,0 +1,40 @@
+/* +/*
+ * Old U-boot compatibility for Magicbox v2 + * Old U-boot compatibility for Magicbox v2
@ -42,9 +41,8 @@ diff -Nur a/arch/powerpc/boot/cuboot-magicboxv2.c b/arch/powerpc/boot/cuboot-mag
+ fdt_init(_dtb_start); + fdt_init(_dtb_start);
+ serial_console_init(); + serial_console_init();
+} +}
diff -Nur a/arch/powerpc/boot/dts/magicboxv2.dts b/arch/powerpc/boot/dts/magicboxv2.dts --- /dev/null
--- a/arch/powerpc/boot/dts/magicboxv2.dts 1970-01-01 01:00:00.000000000 +0100 +++ b/arch/powerpc/boot/dts/magicboxv2.dts
+++ b/arch/powerpc/boot/dts/magicboxv2.dts 2008-11-26 09:28:10.000000000 +0100
@@ -0,0 +1,250 @@ @@ -0,0 +1,250 @@
+/* +/*
+ * Device Tree Source for Magicbox v2 + * Device Tree Source for Magicbox v2
@ -296,10 +294,9 @@ diff -Nur a/arch/powerpc/boot/dts/magicboxv2.dts b/arch/powerpc/boot/dts/magicbo
+ linux,stdout-path = "/plb/opb/serial@ef600300"; + linux,stdout-path = "/plb/opb/serial@ef600300";
+ }; + };
+}; +};
diff -Nur a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile --- a/arch/powerpc/boot/Makefile
--- a/arch/powerpc/boot/Makefile 2008-11-26 09:15:15.000000000 +0100 +++ b/arch/powerpc/boot/Makefile
+++ b/arch/powerpc/boot/Makefile 2008-11-26 09:17:01.000000000 +0100 @@ -69,7 +69,7 @@ src-plat := of.c cuboot-52xx.c cuboot-82
@@ -69,7 +69,7 @@
cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \ cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \
cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \ cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \
virtex405-head.S virtex.c redboot-83xx.c cuboot-sam440ep.c \ virtex405-head.S virtex.c redboot-83xx.c cuboot-sam440ep.c \
@ -308,7 +305,7 @@ diff -Nur a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
src-boot := $(src-wlib) $(src-plat) empty.c src-boot := $(src-wlib) $(src-plat) empty.c
src-boot := $(addprefix $(obj)/, $(src-boot)) src-boot := $(addprefix $(obj)/, $(src-boot))
@@ -214,6 +214,7 @@ @@ -214,6 +214,7 @@ image-$(CONFIG_EP405) += dtbImage.ep40
image-$(CONFIG_WALNUT) += treeImage.walnut image-$(CONFIG_WALNUT) += treeImage.walnut
image-$(CONFIG_ACADIA) += cuImage.acadia image-$(CONFIG_ACADIA) += cuImage.acadia
image-$(CONFIG_MAGICBOXV1) += cuImage.magicboxv1 image-$(CONFIG_MAGICBOXV1) += cuImage.magicboxv1
@ -316,10 +313,9 @@ diff -Nur a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
# Board ports in arch/powerpc/platform/44x/Kconfig # Board ports in arch/powerpc/platform/44x/Kconfig
image-$(CONFIG_EBONY) += treeImage.ebony cuImage.ebony image-$(CONFIG_EBONY) += treeImage.ebony cuImage.ebony
diff -Nur a/arch/powerpc/platforms/40x/Kconfig b/arch/powerpc/platforms/40x/Kconfig --- a/arch/powerpc/platforms/40x/Kconfig
--- a/arch/powerpc/platforms/40x/Kconfig 2008-11-26 09:15:15.000000000 +0100 +++ b/arch/powerpc/platforms/40x/Kconfig
+++ b/arch/powerpc/platforms/40x/Kconfig 2008-11-26 09:16:08.000000000 +0100 @@ -51,6 +51,16 @@ config MAGICBOXV1
@@ -51,6 +51,16 @@
help help
This option enables support for the Magicbox v1 board. This option enables support for the Magicbox v1 board.
@ -336,10 +332,9 @@ diff -Nur a/arch/powerpc/platforms/40x/Kconfig b/arch/powerpc/platforms/40x/Kcon
config MAKALU config MAKALU
bool "Makalu" bool "Makalu"
depends on 40x depends on 40x
diff -Nur a/arch/powerpc/platforms/40x/ppc40x_simple.c b/arch/powerpc/platforms/40x/ppc40x_simple.c --- a/arch/powerpc/platforms/40x/ppc40x_simple.c
--- a/arch/powerpc/platforms/40x/ppc40x_simple.c 2008-11-26 09:15:15.000000000 +0100 +++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
+++ b/arch/powerpc/platforms/40x/ppc40x_simple.c 2008-11-26 09:15:46.000000000 +0100 @@ -52,7 +52,8 @@ machine_device_initcall(ppc40x_simple, p
@@ -52,7 +52,8 @@
*/ */
static char *board[] __initdata = { static char *board[] __initdata = {
"amcc,acadia", "amcc,acadia",

View File

@ -11,7 +11,7 @@ BOARD:=ppc44x
BOARDNAME:=AMCC/IBM PPC44x BOARDNAME:=AMCC/IBM PPC44x
FEATURES:=squashfs FEATURES:=squashfs
LINUX_VERSION:=2.6.27.7 LINUX_VERSION:=2.6.27.8
LINUX_KARCH:=powerpc LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=x86
FEATURES:=squashfs jffs2 ext2 vdi vmdk FEATURES:=squashfs jffs2 ext2 vdi vmdk
SUBTARGETS=generic SUBTARGETS=generic
LINUX_VERSION:=2.6.27.7 LINUX_VERSION:=2.6.27.8
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci