1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-11-30 17:40:16 +02:00

kernel: update to 2.6.31.9 and 2.6.32.2, and refresh patches

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18982 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2010-01-01 11:11:17 +00:00
parent d7d997edfc
commit c48f4513dc
8 changed files with 22 additions and 22 deletions

View File

@ -19,11 +19,11 @@ endif
ifeq ($(LINUX_VERSION),2.6.30.10) ifeq ($(LINUX_VERSION),2.6.30.10)
LINUX_KERNEL_MD5SUM:=eb6be465f914275967a5602cb33662f5 LINUX_KERNEL_MD5SUM:=eb6be465f914275967a5602cb33662f5
endif endif
ifeq ($(LINUX_VERSION),2.6.31.7) ifeq ($(LINUX_VERSION),2.6.31.9)
LINUX_KERNEL_MD5SUM:=ae93db04f169f35c98e786f25e84c237 LINUX_KERNEL_MD5SUM:=e531261b99e34208eb823be63fb0ce91
endif endif
ifeq ($(LINUX_VERSION),2.6.32) ifeq ($(LINUX_VERSION),2.6.32.2)
LINUX_KERNEL_MD5SUM:=260551284ac224c3a43c4adac7df4879 LINUX_KERNEL_MD5SUM:=9809778a867dfd3d6811a2f929256334
endif endif
# disable the md5sum check for unknown kernel versions # disable the md5sum check for unknown kernel versions

View File

@ -127,7 +127,7 @@
+} +}
--- a/arch/mips/kernel/Makefile --- a/arch/mips/kernel/Makefile
+++ b/arch/mips/kernel/Makefile +++ b/arch/mips/kernel/Makefile
@@ -85,6 +85,7 @@ @@ -85,6 +85,7 @@ obj-$(CONFIG_GPIO_TXX9) += gpio_txx9.o
obj-$(CONFIG_KEXEC) += machine_kexec.o relocate_kernel.o obj-$(CONFIG_KEXEC) += machine_kexec.o relocate_kernel.o
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
@ -137,7 +137,7 @@
--- a/arch/mips/Kconfig --- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig +++ b/arch/mips/Kconfig
@@ -803,6 +803,9 @@ @@ -803,6 +803,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
config SYNC_R4K config SYNC_R4K
bool bool
@ -157,7 +157,7 @@
unsigned int vced_count, vcei_count; unsigned int vced_count, vcei_count;
@@ -33,8 +34,12 @@ @@ -33,8 +34,12 @@ static int show_cpuinfo(struct seq_file
/* /*
* For the first processor also print the system type * For the first processor also print the system type
*/ */

View File

@ -127,7 +127,7 @@
+} +}
--- a/arch/mips/kernel/Makefile --- a/arch/mips/kernel/Makefile
+++ b/arch/mips/kernel/Makefile +++ b/arch/mips/kernel/Makefile
@@ -87,6 +87,7 @@ @@ -87,6 +87,7 @@ obj-$(CONFIG_GPIO_TXX9) += gpio_txx9.o
obj-$(CONFIG_KEXEC) += machine_kexec.o relocate_kernel.o obj-$(CONFIG_KEXEC) += machine_kexec.o relocate_kernel.o
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
@ -137,7 +137,7 @@
--- a/arch/mips/Kconfig --- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig +++ b/arch/mips/Kconfig
@@ -837,6 +837,9 @@ @@ -837,6 +837,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
config SYNC_R4K config SYNC_R4K
bool bool
@ -157,7 +157,7 @@
unsigned int vced_count, vcei_count; unsigned int vced_count, vcei_count;
@@ -31,8 +32,12 @@ @@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file
/* /*
* For the first processor also print the system type * For the first processor also print the system type
*/ */

View File

@ -834,7 +834,7 @@
#include <linux/proc_fs.h> #include <linux/proc_fs.h>
#include <linux/seq_file.h> #include <linux/seq_file.h>
#include <linux/stat.h> #include <linux/stat.h>
@@ -1686,7 +1689,11 @@ int dev_hard_start_xmit(struct sk_buff * @@ -1687,7 +1690,11 @@ int dev_hard_start_xmit(struct sk_buff *
int rc; int rc;
if (likely(!skb->next)) { if (likely(!skb->next)) {
@ -847,7 +847,7 @@
dev_queue_xmit_nit(skb, dev); dev_queue_xmit_nit(skb, dev);
if (netif_needs_gso(dev, skb)) { if (netif_needs_gso(dev, skb)) {
@@ -1771,8 +1778,7 @@ u16 skb_tx_hash(const struct net_device @@ -1772,8 +1779,7 @@ u16 skb_tx_hash(const struct net_device
} }
EXPORT_SYMBOL(skb_tx_hash); EXPORT_SYMBOL(skb_tx_hash);
@ -857,7 +857,7 @@
{ {
const struct net_device_ops *ops = dev->netdev_ops; const struct net_device_ops *ops = dev->netdev_ops;
u16 queue_index = 0; u16 queue_index = 0;
@@ -1785,6 +1791,7 @@ static struct netdev_queue *dev_pick_tx( @@ -1786,6 +1792,7 @@ static struct netdev_queue *dev_pick_tx(
skb_set_queue_mapping(skb, queue_index); skb_set_queue_mapping(skb, queue_index);
return netdev_get_tx_queue(dev, queue_index); return netdev_get_tx_queue(dev, queue_index);
} }
@ -1033,7 +1033,7 @@
new->csum = old->csum; new->csum = old->csum;
new->local_df = old->local_df; new->local_df = old->local_df;
new->pkt_type = old->pkt_type; new->pkt_type = old->pkt_type;
@@ -2778,6 +2867,13 @@ void __init skb_init(void) @@ -2779,6 +2868,13 @@ void __init skb_init(void)
0, 0,
SLAB_HWCACHE_ALIGN|SLAB_PANIC, SLAB_HWCACHE_ALIGN|SLAB_PANIC,
NULL); NULL);

View File

@ -127,7 +127,7 @@
+} +}
--- a/arch/mips/kernel/Makefile --- a/arch/mips/kernel/Makefile
+++ b/arch/mips/kernel/Makefile +++ b/arch/mips/kernel/Makefile
@@ -87,6 +87,7 @@ @@ -87,6 +87,7 @@ obj-$(CONFIG_GPIO_TXX9) += gpio_txx9.o
obj-$(CONFIG_KEXEC) += machine_kexec.o relocate_kernel.o obj-$(CONFIG_KEXEC) += machine_kexec.o relocate_kernel.o
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
@ -137,7 +137,7 @@
--- a/arch/mips/Kconfig --- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig +++ b/arch/mips/Kconfig
@@ -854,6 +854,9 @@ @@ -854,6 +854,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
config SYNC_R4K config SYNC_R4K
bool bool
@ -157,7 +157,7 @@
unsigned int vced_count, vcei_count; unsigned int vced_count, vcei_count;
@@ -31,8 +32,12 @@ @@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file
/* /*
* For the first processor also print the system type * For the first processor also print the system type
*/ */

View File

@ -10,7 +10,7 @@
--- a/fs/Makefile --- a/fs/Makefile
+++ b/fs/Makefile +++ b/fs/Makefile
@@ -126,3 +126,4 @@ obj-$(CONFIG_OCFS2_FS) += ocfs2/ @@ -125,3 +125,4 @@ obj-$(CONFIG_OCFS2_FS) += ocfs2/
obj-$(CONFIG_BTRFS_FS) += btrfs/ obj-$(CONFIG_BTRFS_FS) += btrfs/
obj-$(CONFIG_GFS2_FS) += gfs2/ obj-$(CONFIG_GFS2_FS) += gfs2/
obj-$(CONFIG_EXOFS_FS) += exofs/ obj-$(CONFIG_EXOFS_FS) += exofs/

View File

@ -1,6 +1,6 @@
--- a/mm/shmem.c --- a/mm/shmem.c
+++ b/mm/shmem.c +++ b/mm/shmem.c
@@ -2775,6 +2775,16 @@ int shmem_lock(struct file *file, int lo @@ -2608,6 +2608,16 @@ int shmem_lock(struct file *file, int lo
/* common code */ /* common code */
@ -17,7 +17,7 @@
/** /**
* shmem_file_setup - get an unlinked file living in tmpfs * shmem_file_setup - get an unlinked file living in tmpfs
* @name: name for dentry (to be seen in /proc/<pid>/maps * @name: name for dentry (to be seen in /proc/<pid>/maps
@@ -2854,9 +2864,6 @@ int shmem_zero_setup(struct vm_area_stru @@ -2687,9 +2697,6 @@ int shmem_zero_setup(struct vm_area_stru
if (IS_ERR(file)) if (IS_ERR(file))
return PTR_ERR(file); return PTR_ERR(file);
@ -68,7 +68,7 @@
* macro override instead of weak attribute alias, to workaround * macro override instead of weak attribute alias, to workaround
--- a/kernel/sched.c --- a/kernel/sched.c
+++ b/kernel/sched.c +++ b/kernel/sched.c
@@ -6075,6 +6075,7 @@ int can_nice(const struct task_struct *p @@ -6095,6 +6095,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur || return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
capable(CAP_SYS_NICE)); capable(CAP_SYS_NICE));
} }

View File

@ -12,7 +12,7 @@ BOARDNAME:=x86
FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
SUBTARGETS=generic olpc SUBTARGETS=generic olpc
LINUX_VERSION:=2.6.31.7 LINUX_VERSION:=2.6.31.9
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk