mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2025-04-04 06:07:30 +03:00
[ar71xx] refresh 3.2 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29934 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b5c844a59d
commit
ccc47d58db
@ -20,7 +20,7 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
|
|||||||
|
|
||||||
--- a/arch/mips/ath79/Makefile
|
--- a/arch/mips/ath79/Makefile
|
||||||
+++ b/arch/mips/ath79/Makefile
|
+++ b/arch/mips/ath79/Makefile
|
||||||
@@ -20,7 +20,7 @@ obj-$(CONFIG_ATH79_DEV_GPIO_BUTTONS) +=
|
@@ -20,7 +20,7 @@ obj-$(CONFIG_ATH79_DEV_GPIO_BUTTONS) +=
|
||||||
obj-$(CONFIG_ATH79_DEV_LEDS_GPIO) += dev-leds-gpio.o
|
obj-$(CONFIG_ATH79_DEV_LEDS_GPIO) += dev-leds-gpio.o
|
||||||
obj-$(CONFIG_ATH79_DEV_SPI) += dev-spi.o
|
obj-$(CONFIG_ATH79_DEV_SPI) += dev-spi.o
|
||||||
obj-$(CONFIG_ATH79_DEV_USB) += dev-usb.o
|
obj-$(CONFIG_ATH79_DEV_USB) += dev-usb.o
|
||||||
|
@ -99,7 +99,7 @@ dereference, that will be fixed in a subsequent patch.
|
|||||||
static struct ar724x_pci_data *pci_data;
|
static struct ar724x_pci_data *pci_data;
|
||||||
static int pci_data_size;
|
static int pci_data_size;
|
||||||
|
|
||||||
@@ -38,14 +39,15 @@ int __init pcibios_map_irq(const struct
|
@@ -38,14 +39,15 @@ int __init pcibios_map_irq(const struct
|
||||||
|
|
||||||
int pcibios_plat_dev_init(struct pci_dev *dev)
|
int pcibios_plat_dev_init(struct pci_dev *dev)
|
||||||
{
|
{
|
||||||
|
@ -51,7 +51,7 @@ Acked-by: Luis R. Rodriguez <mcgrof@qca.qualcomm.com>
|
|||||||
static inline int ar724x_pcibios_init(int irq) { return 0 };
|
static inline int ar724x_pcibios_init(int irq) { return 0 };
|
||||||
--- a/arch/mips/pci/Makefile
|
--- a/arch/mips/pci/Makefile
|
||||||
+++ b/arch/mips/pci/Makefile
|
+++ b/arch/mips/pci/Makefile
|
||||||
@@ -20,7 +20,7 @@ obj-$(CONFIG_BCM63XX) += pci-bcm63xx.o
|
@@ -20,7 +20,7 @@ obj-$(CONFIG_BCM63XX) += pci-bcm63xx.o
|
||||||
ops-bcm63xx.o
|
ops-bcm63xx.o
|
||||||
obj-$(CONFIG_MIPS_ALCHEMY) += pci-alchemy.o
|
obj-$(CONFIG_MIPS_ALCHEMY) += pci-alchemy.o
|
||||||
obj-$(CONFIG_SOC_AR71XX) += pci-ar71xx.o
|
obj-$(CONFIG_SOC_AR71XX) += pci-ar71xx.o
|
||||||
|
@ -31,7 +31,7 @@ Acked-by: Luis R. Rodriguez <mcgrof@qca.qualcomm.com>
|
|||||||
#include <asm/mach-ath79/ath79.h>
|
#include <asm/mach-ath79/ath79.h>
|
||||||
#include <asm/mach-ath79/irq.h>
|
#include <asm/mach-ath79/irq.h>
|
||||||
#include <asm/mach-ath79/pci.h>
|
#include <asm/mach-ath79/pci.h>
|
||||||
@@ -57,7 +58,9 @@ int __init pcibios_map_irq(const struct
|
@@ -57,7 +58,9 @@ int __init pcibios_map_irq(const struct
|
||||||
if (soc_is_ar71xx()) {
|
if (soc_is_ar71xx()) {
|
||||||
ath79_pci_irq_map = ar71xx_pci_irq_map;
|
ath79_pci_irq_map = ar71xx_pci_irq_map;
|
||||||
ath79_pci_nr_irqs = ARRAY_SIZE(ar71xx_pci_irq_map);
|
ath79_pci_nr_irqs = ARRAY_SIZE(ar71xx_pci_irq_map);
|
||||||
|
@ -32,18 +32,19 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||||||
- status = gpio_request(cdata->gpio, dev_name(&spi->dev));
|
- status = gpio_request(cdata->gpio, dev_name(&spi->dev));
|
||||||
- if (status)
|
- if (status)
|
||||||
- return status;
|
- return status;
|
||||||
+ flags = GPIOF_DIR_OUT;
|
-
|
||||||
+ if (spi->mode & SPI_CS_HIGH)
|
|
||||||
+ flags |= GPIOF_INIT_HIGH;
|
|
||||||
+ else
|
|
||||||
+ flags |= GPIOF_INIT_LOW;
|
|
||||||
|
|
||||||
- status = gpio_direction_output(cdata->gpio,
|
- status = gpio_direction_output(cdata->gpio,
|
||||||
- spi->mode & SPI_CS_HIGH);
|
- spi->mode & SPI_CS_HIGH);
|
||||||
- if (status) {
|
- if (status) {
|
||||||
- gpio_free(cdata->gpio);
|
- gpio_free(cdata->gpio);
|
||||||
- return status;
|
- return status;
|
||||||
- }
|
- }
|
||||||
|
+ flags = GPIOF_DIR_OUT;
|
||||||
|
+ if (spi->mode & SPI_CS_HIGH)
|
||||||
|
+ flags |= GPIOF_INIT_HIGH;
|
||||||
|
+ else
|
||||||
|
+ flags |= GPIOF_INIT_LOW;
|
||||||
|
+
|
||||||
+ status = gpio_request_one(cdata->gpio, flags,
|
+ status = gpio_request_one(cdata->gpio, flags,
|
||||||
+ dev_name(&spi->dev));
|
+ dev_name(&spi->dev));
|
||||||
}
|
}
|
||||||
|
@ -9,7 +9,7 @@ Subject: [PATCH 5/7] spi/ath79: introduce ath79_spi_{en,dis}able helpers
|
|||||||
|
|
||||||
--- a/drivers/spi/spi-ath79.c
|
--- a/drivers/spi/spi-ath79.c
|
||||||
+++ b/drivers/spi/spi-ath79.c
|
+++ b/drivers/spi/spi-ath79.c
|
||||||
@@ -89,16 +89,8 @@ static void ath79_spi_chipselect(struct
|
@@ -89,16 +89,8 @@ static void ath79_spi_chipselect(struct
|
||||||
|
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -53,7 +53,7 @@ Subject: [PATCH 5/7] spi/ath79: introduce ath79_spi_{en,dis}able helpers
|
|||||||
|
|
||||||
status = 0;
|
status = 0;
|
||||||
if (spi->chip_select) {
|
if (spi->chip_select) {
|
||||||
@@ -134,11 +145,6 @@ static void ath79_spi_cleanup_cs(struct
|
@@ -134,11 +145,6 @@ static void ath79_spi_cleanup_cs(struct
|
||||||
struct ath79_spi_controller_data *cdata = spi->controller_data;
|
struct ath79_spi_controller_data *cdata = spi->controller_data;
|
||||||
gpio_free(cdata->gpio);
|
gpio_free(cdata->gpio);
|
||||||
}
|
}
|
||||||
|
@ -38,7 +38,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||||||
struct ath79_spi {
|
struct ath79_spi {
|
||||||
struct spi_bitbang bitbang;
|
struct spi_bitbang bitbang;
|
||||||
u32 ioc_base;
|
u32 ioc_base;
|
||||||
@@ -62,6 +64,7 @@ static void ath79_spi_chipselect(struct
|
@@ -62,6 +64,7 @@ static void ath79_spi_chipselect(struct
|
||||||
{
|
{
|
||||||
struct ath79_spi *sp = ath79_spidev_to_sp(spi);
|
struct ath79_spi *sp = ath79_spidev_to_sp(spi);
|
||||||
int cs_high = (spi->mode & SPI_CS_HIGH) ? is_active : !is_active;
|
int cs_high = (spi->mode & SPI_CS_HIGH) ? is_active : !is_active;
|
||||||
@ -46,7 +46,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||||||
|
|
||||||
if (is_active) {
|
if (is_active) {
|
||||||
/* set initial clock polarity */
|
/* set initial clock polarity */
|
||||||
@@ -73,20 +76,21 @@ static void ath79_spi_chipselect(struct
|
@@ -73,20 +76,21 @@ static void ath79_spi_chipselect(struct
|
||||||
ath79_spi_wr(sp, AR71XX_SPI_REG_IOC, sp->ioc_base);
|
ath79_spi_wr(sp, AR71XX_SPI_REG_IOC, sp->ioc_base);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -10,7 +10,7 @@
|
|||||||
|
|
||||||
#define DRIVER_NAME "wndr3700-led-usb"
|
#define DRIVER_NAME "wndr3700-led-usb"
|
||||||
|
|
||||||
@@ -20,14 +21,14 @@ static void wndr3700_usb_led_set(struct
|
@@ -20,14 +21,14 @@ static void wndr3700_usb_led_set(struct
|
||||||
enum led_brightness brightness)
|
enum led_brightness brightness)
|
||||||
{
|
{
|
||||||
if (brightness)
|
if (brightness)
|
||||||
|
@ -97,7 +97,7 @@
|
|||||||
u32 t;
|
u32 t;
|
||||||
|
|
||||||
t = __raw_readl(base + AR71XX_GPIO_REG_OUT);
|
t = __raw_readl(base + AR71XX_GPIO_REG_OUT);
|
||||||
@@ -236,7 +234,7 @@ static int rb750_nand_verify_buf(struct
|
@@ -236,7 +234,7 @@ static int rb750_nand_verify_buf(struct
|
||||||
|
|
||||||
static void __init rb750_nand_gpio_init(void)
|
static void __init rb750_nand_gpio_init(void)
|
||||||
{
|
{
|
||||||
|
@ -39,7 +39,7 @@
|
|||||||
|
|
||||||
#ifdef RB4XX_SPI_DEBUG
|
#ifdef RB4XX_SPI_DEBUG
|
||||||
static inline void do_spi_delay(void)
|
static inline void do_spi_delay(void)
|
||||||
@@ -60,10 +67,11 @@ static inline void do_spi_delay(void) {
|
@@ -60,10 +67,11 @@ static inline void do_spi_delay(void) {
|
||||||
|
|
||||||
static inline void do_spi_init(struct spi_device *spi)
|
static inline void do_spi_init(struct spi_device *spi)
|
||||||
{
|
{
|
||||||
|
@ -10,7 +10,7 @@
|
|||||||
#endif /* __ATH79_COMMON_H */
|
#endif /* __ATH79_COMMON_H */
|
||||||
--- a/arch/mips/ath79/gpio.c
|
--- a/arch/mips/ath79/gpio.c
|
||||||
+++ b/arch/mips/ath79/gpio.c
|
+++ b/arch/mips/ath79/gpio.c
|
||||||
@@ -184,6 +184,34 @@ void ath79_gpio_function_setup(u32 set,
|
@@ -184,6 +184,34 @@ void ath79_gpio_function_setup(u32 set,
|
||||||
spin_unlock_irqrestore(&ath79_gpio_lock, flags);
|
spin_unlock_irqrestore(&ath79_gpio_lock, flags);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -50,7 +50,7 @@
|
|||||||
#define PB44_GPIO_SW_RESET (PB44_GPIO_EXP_BASE + 6)
|
#define PB44_GPIO_SW_RESET (PB44_GPIO_EXP_BASE + 6)
|
||||||
#define PB44_GPIO_SW_JUMP (PB44_GPIO_EXP_BASE + 8)
|
#define PB44_GPIO_SW_JUMP (PB44_GPIO_EXP_BASE + 8)
|
||||||
#define PB44_GPIO_LED_JUMP1 (PB44_GPIO_EXP_BASE + 9)
|
#define PB44_GPIO_LED_JUMP1 (PB44_GPIO_EXP_BASE + 9)
|
||||||
@@ -92,21 +117,66 @@ static struct ath79_spi_controller_data
|
@@ -92,21 +117,66 @@ static struct ath79_spi_controller_data
|
||||||
.cs_line = 0,
|
.cs_line = 0,
|
||||||
};
|
};
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user