mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 04:26:16 +02:00
hostapd: update to latest git, remove openssl dependency for hostapd-full, it works with internal crypto now
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18360 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
be57a0a21b
commit
cd60446ca1
@ -8,14 +8,15 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=hostapd
|
PKG_NAME:=hostapd
|
||||||
PKG_VERSION:=0.6.9
|
PKG_VERSION:=20091111
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
PKG_REV:=dc6d9ac250f793a62b21ca828445967fb484305f
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
|
PKG_SOURCE_URL:=git://w1.fi/srv/git/hostap.git
|
||||||
PKG_SOURCE_SUBDIR:=hostapd-$(PKG_VERSION)
|
PKG_SOURCE_SUBDIR:=hostapd-$(PKG_VERSION)
|
||||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||||
PKG_MD5SUM:=83630d11fa66ade9091f1b304fccd74c
|
PKG_SOURCE_PROTO:=git
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:= \
|
PKG_BUILD_DEPENDS:= \
|
||||||
PACKAGE_kmod-madwifi:madwifi \
|
PACKAGE_kmod-madwifi:madwifi \
|
||||||
@ -50,7 +51,6 @@ endef
|
|||||||
define Package/hostapd
|
define Package/hostapd
|
||||||
$(call Package/hostapd/Default)
|
$(call Package/hostapd/Default)
|
||||||
TITLE+= (full)
|
TITLE+= (full)
|
||||||
DEPENDS+= +PACKAGE_hostapd:libopenssl
|
|
||||||
VARIANT:=full
|
VARIANT:=full
|
||||||
endef
|
endef
|
||||||
|
|
||||||
@ -81,6 +81,8 @@ define Package/hostapd-utils/description
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
|
rm -f $(PKG_BUILD_DIR)/hostapd/hostapd
|
||||||
|
rm -f $(PKG_BUILD_DIR)/src/drivers/drivers.o
|
||||||
$(CP) ./files/$(BUILD_VARIANT).config $(PKG_BUILD_DIR)/hostapd/.config
|
$(CP) ./files/$(BUILD_VARIANT).config $(PKG_BUILD_DIR)/hostapd/.config
|
||||||
endef
|
endef
|
||||||
|
|
||||||
@ -96,9 +98,6 @@ TARGET_CPPFLAGS := \
|
|||||||
ifdef CONFIG_PACKAGE_kmod-mac80211
|
ifdef CONFIG_PACKAGE_kmod-mac80211
|
||||||
TARGET_LDFLAGS += -lm -lnl-tiny
|
TARGET_LDFLAGS += -lm -lnl-tiny
|
||||||
endif
|
endif
|
||||||
ifeq ($(BUILD_VARIANT),full)
|
|
||||||
TARGET_LDFLAGS += -lssl -lcrypto
|
|
||||||
endif
|
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
|
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
|
||||||
|
@ -142,3 +142,17 @@ CONFIG_IEEE80211N=y
|
|||||||
# This can be used to reduce the size of the hostapd considerably if debugging
|
# This can be used to reduce the size of the hostapd considerably if debugging
|
||||||
# code is not needed.
|
# code is not needed.
|
||||||
#CONFIG_NO_STDOUT_DEBUG=y
|
#CONFIG_NO_STDOUT_DEBUG=y
|
||||||
|
|
||||||
|
# Remove support for RADIUS accounting
|
||||||
|
#CONFIG_NO_ACCOUNTING=y
|
||||||
|
|
||||||
|
# Remove support for RADIUS
|
||||||
|
#CONFIG_NO_RADIUS=y
|
||||||
|
|
||||||
|
# Remove support for VLANs
|
||||||
|
#CONFIG_NO_VLAN=y
|
||||||
|
|
||||||
|
CONFIG_TLS=internal
|
||||||
|
CONFIG_INTERNAL_LIBTOMMATH=y
|
||||||
|
CONFIG_INTERNAL_AES=y
|
||||||
|
NEED_AES_DEC=y
|
||||||
|
@ -40,7 +40,7 @@ CONFIG_DRIVER_NL80211=y
|
|||||||
#CONFIG_DRIVER_NONE=y
|
#CONFIG_DRIVER_NONE=y
|
||||||
|
|
||||||
# IEEE 802.11F/IAPP
|
# IEEE 802.11F/IAPP
|
||||||
CONFIG_IAPP=y
|
# CONFIG_IAPP=y
|
||||||
|
|
||||||
# WPA2/IEEE 802.11i RSN pre-authentication
|
# WPA2/IEEE 802.11i RSN pre-authentication
|
||||||
CONFIG_RSN_PREAUTH=y
|
CONFIG_RSN_PREAUTH=y
|
||||||
@ -142,3 +142,14 @@ CONFIG_IEEE80211N=y
|
|||||||
# This can be used to reduce the size of the hostapd considerably if debugging
|
# This can be used to reduce the size of the hostapd considerably if debugging
|
||||||
# code is not needed.
|
# code is not needed.
|
||||||
#CONFIG_NO_STDOUT_DEBUG=y
|
#CONFIG_NO_STDOUT_DEBUG=y
|
||||||
|
|
||||||
|
# Remove support for RADIUS accounting
|
||||||
|
CONFIG_NO_ACCOUNTING=y
|
||||||
|
|
||||||
|
# Remove support for RADIUS
|
||||||
|
CONFIG_NO_RADIUS=y
|
||||||
|
|
||||||
|
# Remove support for VLANs
|
||||||
|
#CONFIG_NO_VLAN=y
|
||||||
|
|
||||||
|
CONFIG_TLS=internal
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/hostapd/driver_madwifi.c
|
--- a/src/drivers/driver_madwifi.c
|
||||||
+++ b/hostapd/driver_madwifi.c
|
+++ b/src/drivers/driver_madwifi.c
|
||||||
@@ -312,6 +312,7 @@ madwifi_set_iface_flags(void *priv, int
|
@@ -318,6 +318,7 @@ madwifi_set_iface_flags(void *priv, int
|
||||||
{
|
{
|
||||||
struct madwifi_driver_data *drv = priv;
|
struct madwifi_driver_data *drv = priv;
|
||||||
struct ifreq ifr;
|
struct ifreq ifr;
|
||||||
@ -8,7 +8,7 @@
|
|||||||
|
|
||||||
wpa_printf(MSG_DEBUG, "%s: dev_up=%d", __func__, dev_up);
|
wpa_printf(MSG_DEBUG, "%s: dev_up=%d", __func__, dev_up);
|
||||||
|
|
||||||
@@ -326,10 +327,14 @@ madwifi_set_iface_flags(void *priv, int
|
@@ -332,10 +333,14 @@ madwifi_set_iface_flags(void *priv, int
|
||||||
return -1;
|
return -1;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/hostapd/hostapd.c
|
--- a/hostapd/hostapd.c
|
||||||
+++ b/hostapd/hostapd.c
|
+++ b/hostapd/hostapd.c
|
||||||
@@ -1546,10 +1546,8 @@ static int setup_interface(struct hostap
|
@@ -1344,10 +1344,8 @@ static int setup_interface(struct hostap
|
||||||
if (hapd->iconf->country[0] && hapd->iconf->country[1]) {
|
if (hapd->iconf->country[0] && hapd->iconf->country[1]) {
|
||||||
os_memcpy(country, hapd->iconf->country, 3);
|
os_memcpy(country, hapd->iconf->country, 3);
|
||||||
country[3] = '\0';
|
country[3] = '\0';
|
||||||
@ -11,4 +11,4 @@
|
|||||||
- }
|
- }
|
||||||
}
|
}
|
||||||
|
|
||||||
if (hapd->iconf->ieee80211d &&
|
if (hapd->iconf->bridge_packets != INTERNAL_BRIDGE_DO_NOT_CONTROL &&
|
16
package/hostapd/patches/120-nl80211_ap_fix.patch
Normal file
16
package/hostapd/patches/120-nl80211_ap_fix.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
--- a/src/drivers/driver_nl80211.c
|
||||||
|
+++ b/src/drivers/driver_nl80211.c
|
||||||
|
@@ -4418,10 +4418,10 @@ static void *i802_init(struct hostapd_da
|
||||||
|
/* start listening for EAPOL on the default AP interface */
|
||||||
|
add_ifidx(drv, drv->ifindex);
|
||||||
|
|
||||||
|
- if (params->bssid) {
|
||||||
|
- if (hostapd_set_iface_flags(drv, drv->ifname, 0))
|
||||||
|
- goto failed;
|
||||||
|
+ if (hostapd_set_iface_flags(drv, drv->ifname, 0))
|
||||||
|
+ goto failed;
|
||||||
|
|
||||||
|
+ if (params->bssid) {
|
||||||
|
if (set_ifhwaddr(drv, drv->ifname, params->bssid))
|
||||||
|
goto failed;
|
||||||
|
}
|
@ -1,18 +0,0 @@
|
|||||||
--- a/hostapd/driver_nl80211.c
|
|
||||||
+++ b/hostapd/driver_nl80211.c
|
|
||||||
@@ -29,6 +29,7 @@
|
|
||||||
#include "wireless_copy.h"
|
|
||||||
#include <linux/filter.h>
|
|
||||||
#include <net/if_arp.h>
|
|
||||||
+#include <linux/rtnetlink.h>
|
|
||||||
|
|
||||||
#include "hostapd.h"
|
|
||||||
#include "driver.h"
|
|
||||||
@@ -45,6 +46,7 @@
|
|
||||||
/* libnl 2.0 compatibility code */
|
|
||||||
#define nl_handle_alloc_cb nl_socket_alloc_cb
|
|
||||||
#define nl_handle_destroy nl_socket_free
|
|
||||||
+#define nl_handle nl_sock
|
|
||||||
#endif /* CONFIG_LIBNL20 */
|
|
||||||
|
|
||||||
enum ieee80211_msg_type {
|
|
Loading…
Reference in New Issue
Block a user