mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-05 04:02:27 +02:00
[lantiq] move ltq-ifxos
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34692 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6732edcca7
commit
cec4e04bcc
@ -1,12 +0,0 @@
|
|||||||
--- a/src/linux/ifxos_linux_thread_drv.c
|
|
||||||
+++ b/src/linux/ifxos_linux_thread_drv.c
|
|
||||||
@@ -34,7 +34,9 @@
|
|
||||||
#include <linux/sched.h>
|
|
||||||
#include <linux/version.h>
|
|
||||||
#include <linux/completion.h>
|
|
||||||
+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33))
|
|
||||||
#include <linux/smp_lock.h>
|
|
||||||
+#endif
|
|
||||||
#include <linux/signal.h>
|
|
||||||
|
|
||||||
|
|
@ -1,9 +1,7 @@
|
|||||||
#
|
# Copyright (C) 2009-2012 OpenWrt.org
|
||||||
# Copyright (C) 2009-2010 OpenWrt.org
|
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
@ -19,7 +17,9 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
|
|||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define KernelPackage/ltq-ifxos
|
define KernelPackage/ltq-ifxos
|
||||||
SUBMENU:=Voice over IP
|
SECTION:=sys
|
||||||
|
CATEGORY:=Kernel modules
|
||||||
|
SUBMENU:=Libraries
|
||||||
TITLE:=Lantiq OS abstraction library
|
TITLE:=Lantiq OS abstraction library
|
||||||
URL:=http://www.lantiq.com/
|
URL:=http://www.lantiq.com/
|
||||||
DEPENDS:=@TARGET_lantiq
|
DEPENDS:=@TARGET_lantiq
|
@ -9,3 +9,13 @@
|
|||||||
AC_SUBST([KERNEL_BUILD_PATH],[$enableval])
|
AC_SUBST([KERNEL_BUILD_PATH],[$enableval])
|
||||||
else
|
else
|
||||||
AC_MSG_ERROR([The kernel build directory is not valid or not configured!])
|
AC_MSG_ERROR([The kernel build directory is not valid or not configured!])
|
||||||
|
--- a/src/linux/ifxos_linux_thread_drv.c
|
||||||
|
+++ b/src/linux/ifxos_linux_thread_drv.c
|
||||||
|
@@ -34,7 +34,6 @@
|
||||||
|
#include <linux/sched.h>
|
||||||
|
#include <linux/version.h>
|
||||||
|
#include <linux/completion.h>
|
||||||
|
-#include <linux/smp_lock.h>
|
||||||
|
#include <linux/signal.h>
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user