mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 00:30:16 +02:00
adjust package/{openssl,mac80211} to openwrt-backfire
This commit is contained in:
parent
62adc73a59
commit
cf4c25dcd8
File diff suppressed because it is too large
Load Diff
@ -1,114 +0,0 @@
|
||||
--- a/drivers/net/wireless/ath/ath9k/xmit.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/xmit.c
|
||||
@@ -260,19 +260,40 @@ static void ath_tx_set_retry(struct ath_
|
||||
hdr->frame_control |= cpu_to_le16(IEEE80211_FCTL_RETRY);
|
||||
}
|
||||
|
||||
-static struct ath_buf* ath_clone_txbuf(struct ath_softc *sc, struct ath_buf *bf)
|
||||
+static struct ath_buf *ath_tx_get_buffer(struct ath_softc *sc)
|
||||
{
|
||||
- struct ath_buf *tbf;
|
||||
+ struct ath_buf *bf = NULL;
|
||||
|
||||
spin_lock_bh(&sc->tx.txbuflock);
|
||||
- if (WARN_ON(list_empty(&sc->tx.txbuf))) {
|
||||
+
|
||||
+ if (unlikely(list_empty(&sc->tx.txbuf))) {
|
||||
spin_unlock_bh(&sc->tx.txbuflock);
|
||||
return NULL;
|
||||
}
|
||||
- tbf = list_first_entry(&sc->tx.txbuf, struct ath_buf, list);
|
||||
- list_del(&tbf->list);
|
||||
+
|
||||
+ bf = list_first_entry(&sc->tx.txbuf, struct ath_buf, list);
|
||||
+ list_del(&bf->list);
|
||||
+
|
||||
spin_unlock_bh(&sc->tx.txbuflock);
|
||||
|
||||
+ return bf;
|
||||
+}
|
||||
+
|
||||
+static void ath_tx_return_buffer(struct ath_softc *sc, struct ath_buf *bf)
|
||||
+{
|
||||
+ spin_lock_bh(&sc->tx.txbuflock);
|
||||
+ list_add_tail(&bf->list, &sc->tx.txbuf);
|
||||
+ spin_unlock_bh(&sc->tx.txbuflock);
|
||||
+}
|
||||
+
|
||||
+static struct ath_buf* ath_clone_txbuf(struct ath_softc *sc, struct ath_buf *bf)
|
||||
+{
|
||||
+ struct ath_buf *tbf;
|
||||
+
|
||||
+ tbf = ath_tx_get_buffer(sc);
|
||||
+ if (WARN_ON(!tbf))
|
||||
+ return NULL;
|
||||
+
|
||||
ATH_TXBUF_RESET(tbf);
|
||||
|
||||
tbf->aphy = bf->aphy;
|
||||
@@ -1084,9 +1105,7 @@ void ath_draintxq(struct ath_softc *sc,
|
||||
list_del(&bf->list);
|
||||
spin_unlock_bh(&txq->axq_lock);
|
||||
|
||||
- spin_lock_bh(&sc->tx.txbuflock);
|
||||
- list_add_tail(&bf->list, &sc->tx.txbuf);
|
||||
- spin_unlock_bh(&sc->tx.txbuflock);
|
||||
+ ath_tx_return_buffer(sc, bf);
|
||||
continue;
|
||||
}
|
||||
}
|
||||
@@ -1306,25 +1325,6 @@ static void ath_tx_txqaddbuf(struct ath_
|
||||
txq->axq_depth++;
|
||||
}
|
||||
|
||||
-static struct ath_buf *ath_tx_get_buffer(struct ath_softc *sc)
|
||||
-{
|
||||
- struct ath_buf *bf = NULL;
|
||||
-
|
||||
- spin_lock_bh(&sc->tx.txbuflock);
|
||||
-
|
||||
- if (unlikely(list_empty(&sc->tx.txbuf))) {
|
||||
- spin_unlock_bh(&sc->tx.txbuflock);
|
||||
- return NULL;
|
||||
- }
|
||||
-
|
||||
- bf = list_first_entry(&sc->tx.txbuf, struct ath_buf, list);
|
||||
- list_del(&bf->list);
|
||||
-
|
||||
- spin_unlock_bh(&sc->tx.txbuflock);
|
||||
-
|
||||
- return bf;
|
||||
-}
|
||||
-
|
||||
static void ath_tx_send_ampdu(struct ath_softc *sc, struct ath_atx_tid *tid,
|
||||
struct list_head *bf_head,
|
||||
struct ath_tx_control *txctl)
|
||||
@@ -1806,9 +1806,7 @@ int ath_tx_start(struct ieee80211_hw *hw
|
||||
}
|
||||
spin_unlock_bh(&txq->axq_lock);
|
||||
|
||||
- spin_lock_bh(&sc->tx.txbuflock);
|
||||
- list_add_tail(&bf->list, &sc->tx.txbuf);
|
||||
- spin_unlock_bh(&sc->tx.txbuflock);
|
||||
+ ath_tx_return_buffer(sc, bf);
|
||||
|
||||
return r;
|
||||
}
|
||||
@@ -2122,13 +2120,12 @@ static void ath_tx_processq(struct ath_s
|
||||
txq->axq_depth--;
|
||||
txok = !(ts.ts_status & ATH9K_TXERR_MASK);
|
||||
txq->axq_tx_inprogress = false;
|
||||
+ if (bf_held)
|
||||
+ list_del(&bf_held->list);
|
||||
spin_unlock_bh(&txq->axq_lock);
|
||||
|
||||
- if (bf_held) {
|
||||
- spin_lock_bh(&sc->tx.txbuflock);
|
||||
- list_move_tail(&bf_held->list, &sc->tx.txbuf);
|
||||
- spin_unlock_bh(&sc->tx.txbuflock);
|
||||
- }
|
||||
+ if (bf_held)
|
||||
+ ath_tx_return_buffer(sc, bf_held);
|
||||
|
||||
if (!bf_isampdu(bf)) {
|
||||
/*
|
@ -1,23 +0,0 @@
|
||||
--- a/Makefile.org
|
||||
+++ b/Makefile.org
|
||||
@@ -179,7 +179,7 @@ WTARFILE= $(NAME)-win.tar
|
||||
EXHEADER= e_os2.h
|
||||
HEADER= e_os.h
|
||||
|
||||
-all: Makefile build_all openssl.pc libssl.pc libcrypto.pc
|
||||
+all: build_all openssl.pc libssl.pc libcrypto.pc
|
||||
|
||||
# as we stick to -e, CLEARENV ensures that local variables in lower
|
||||
# Makefiles remain local and variable. $${VAR+VAR} is tribute to Korn
|
||||
@@ -474,11 +474,6 @@ openssl.pc: Makefile
|
||||
echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
|
||||
echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > openssl.pc
|
||||
|
||||
-Makefile: Makefile.org Configure config
|
||||
- @echo "Makefile is older than Makefile.org, Configure or config."
|
||||
- @echo "Reconfigure the source tree (via './config' or 'perl Configure'), please."
|
||||
- @false
|
||||
-
|
||||
libclean:
|
||||
rm -f *.map *.so *.so.* *.dll engines/*.so engines/*.dll *.a engines/*.a */lib */*/lib
|
||||
|
Loading…
Reference in New Issue
Block a user