mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 00:14:05 +02:00
kernel: update to kernel version 2.6.32.32
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26124 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8cde29c6b1
commit
d6c6d9b502
@ -8,8 +8,8 @@ endif
|
||||
ifeq ($(LINUX_VERSION),2.6.31.14)
|
||||
LINUX_KERNEL_MD5SUM:=3e7feb224197d8e174a90dd3759979fd
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.32.29)
|
||||
LINUX_KERNEL_MD5SUM:=0eea644c2cef06b4ec170228866b9685
|
||||
ifeq ($(LINUX_VERSION),2.6.32.32)
|
||||
LINUX_KERNEL_MD5SUM:=25a3ba004aaaa409c24dfb2cc268d03e
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.34.7)
|
||||
LINUX_KERNEL_MD5SUM:=8964e26120e84844998a673464a980ea
|
||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
BOARD:=adm5120
|
||||
BOARDNAME:=Infineon/ADMtek ADM5120
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
LINUX_VERSION:=2.6.32.32
|
||||
SUBTARGETS:=router_le router_be
|
||||
INITRAMFS_EXTRA_FILES:=
|
||||
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Cobalt Microservers
|
||||
FEATURES:=targz pci ext4
|
||||
CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
LINUX_VERSION:=2.6.32.32
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -11,7 +11,7 @@ BOARD:=etrax
|
||||
MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
|
||||
BOARDNAME:=Axis ETRAX 100LX
|
||||
FEATURES:=squashfs jffs2 usb
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
LINUX_VERSION:=2.6.32.32
|
||||
DEVICE_TYPE=
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
@ -127,10 +127,11 @@
|
||||
|
||||
e = (struct ipt_entry *)(loc_cpu_entry + off);
|
||||
if (copy_to_user(userptr + off
|
||||
@@ -1002,6 +1042,14 @@ copy_entries_to_user(unsigned int total_
|
||||
@@ -1001,6 +1041,14 @@ copy_entries_to_user(unsigned int total_
|
||||
ret = -EFAULT;
|
||||
goto free_counters;
|
||||
}
|
||||
|
||||
+
|
||||
+ flags = e->ip.flags & ~IPT_F_NO_DEF_MATCH;
|
||||
+ if (copy_to_user(userptr + off
|
||||
+ + offsetof(struct ipt_entry, ip.flags),
|
||||
@ -138,7 +139,6 @@
|
||||
+ ret = -EFAULT;
|
||||
+ goto free_counters;
|
||||
+ }
|
||||
+
|
||||
|
||||
for (i = sizeof(struct ipt_entry);
|
||||
i < e->target_offset;
|
||||
i += m->u.match_size) {
|
||||
|
@ -11038,14 +11038,14 @@
|
||||
+ yaffs_UnpackTags2(tags, &pt);
|
||||
+ }
|
||||
+ }
|
||||
|
||||
- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
|
||||
- tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
|
||||
+
|
||||
+ if (localData)
|
||||
+ yaffs_ReleaseTempBuffer(dev, data, __LINE__);
|
||||
|
||||
- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
|
||||
+ if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
|
||||
+ tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
|
||||
tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
|
||||
-
|
||||
if (retval == 0)
|
||||
return YAFFS_OK;
|
||||
else
|
||||
|
@ -343,7 +343,10 @@
|
||||
+static int ssb_pcmcia_get_mac(struct pcmcia_device *p_dev,
|
||||
+ tuple_t *tuple,
|
||||
+ void *priv)
|
||||
+{
|
||||
{
|
||||
- tuple_t tuple;
|
||||
- int res;
|
||||
- unsigned char buf[32];
|
||||
+ struct ssb_sprom *sprom = priv;
|
||||
+
|
||||
+ if (tuple->TupleData[0] != CISTPL_FUNCE_LAN_NODE_ID)
|
||||
@ -359,10 +362,7 @@
|
||||
+static int ssb_pcmcia_do_get_invariants(struct pcmcia_device *p_dev,
|
||||
+ tuple_t *tuple,
|
||||
+ void *priv)
|
||||
{
|
||||
- tuple_t tuple;
|
||||
- int res;
|
||||
- unsigned char buf[32];
|
||||
+{
|
||||
+ struct ssb_init_invariants *iv = priv;
|
||||
struct ssb_sprom *sprom = &iv->sprom;
|
||||
struct ssb_boardinfo *bi = &iv->boardinfo;
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Intel IOP32x
|
||||
FEATURES:=squashfs
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
LINUX_VERSION:=2.6.32.32
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP35xx
|
||||
FEATURES:=broken
|
||||
SUBTARGETS=beagleboard gumstix
|
||||
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
LINUX_VERSION:=2.6.32.32
|
||||
KERNELNAME:="uImage"
|
||||
|
||||
DEVICE_TYPE=developerboard
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
||||
CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
LINUX_VERSION:=2.6.32.32
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
||||
CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
LINUX_VERSION:=2.6.32.32
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Marvell/Intel PXA2xx
|
||||
FEATURES:=squashfs
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
LINUX_VERSION:=2.6.32.32
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -11,7 +11,7 @@ BOARD:=rb532
|
||||
BOARDNAME:=Mikrotik RouterBoard 532
|
||||
FEATURES:=jffs2 pci targz
|
||||
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
LINUX_VERSION:=2.6.32.32
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=RDC 321x
|
||||
FEATURES:=squashfs jffs2 pci usb pcmcia
|
||||
CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
LINUX_VERSION:=2.6.32.32
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=fpu
|
||||
CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
LINUX_VERSION:=2.6.32.32
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=x86
|
||||
FEATURES:=squashfs jffs2 ext4 vdi vmdk pcmcia targz
|
||||
SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos
|
||||
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
LINUX_VERSION:=2.6.32.32
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user