mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 06:38:27 +02:00
[uml] replace unfortify patch with a better one
Thanks to Richard Weinberger for providing this patch git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27168 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
02388a2e16
commit
d7f70f01a8
@ -0,0 +1,14 @@
|
|||||||
|
diff --git a/arch/um/os-Linux/user_syms.c b/arch/um/os-Linux/user_syms.c
|
||||||
|
index 05f5ea8..9e71e7e 100644
|
||||||
|
--- a/arch/um/os-Linux/user_syms.c
|
||||||
|
+++ b/arch/um/os-Linux/user_syms.c
|
||||||
|
@@ -18,6 +18,9 @@ extern void *memmove(void *, const void *, size_t);
|
||||||
|
extern void *memset(void *, int, size_t);
|
||||||
|
extern int printf(const char *, ...);
|
||||||
|
|
||||||
|
+extern int __sprintf_chk(char *str, int flag, size_t strlen, const char *format);
|
||||||
|
+EXPORT_SYMBOL(__sprintf_chk);
|
||||||
|
+
|
||||||
|
/* If it's not defined, the export is included in lib/string.c.*/
|
||||||
|
#ifdef __HAVE_ARCH_STRSTR
|
||||||
|
EXPORT_SYMBOL(strstr);
|
@ -1,21 +0,0 @@
|
|||||||
--- a/arch/um/Makefile-i386
|
|
||||||
+++ b/arch/um/Makefile-i386
|
|
||||||
@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
|
|
||||||
echo $(call cc-option,-fno-unit-at-a-time); \
|
|
||||||
else echo $(call cc-option,-funit-at-a-time); fi ;)
|
|
||||||
|
|
||||||
+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
|
|
||||||
+# and later
|
|
||||||
+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
|
|
||||||
+
|
|
||||||
KBUILD_CFLAGS += $(cflags-y)
|
|
||||||
--- a/arch/um/Makefile-x86_64
|
|
||||||
+++ b/arch/um/Makefile-x86_64
|
|
||||||
@@ -24,3 +24,7 @@ LINK-y += -m64
|
|
||||||
|
|
||||||
# Do unit-at-a-time unconditionally on x86_64, following the host
|
|
||||||
KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
|
|
||||||
+
|
|
||||||
+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
|
|
||||||
+# and later
|
|
||||||
+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
|
|
Loading…
Reference in New Issue
Block a user