mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 10:11:33 +02:00
[brcm63xx] refresh 2.6.32 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21086 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
636b91e85b
commit
dc11a30bbd
@ -11,11 +11,9 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
|
|||||||
drivers/mtd/redboot.c | 13 ++++++++++---
|
drivers/mtd/redboot.c | 13 ++++++++++---
|
||||||
3 files changed, 18 insertions(+), 3 deletions(-)
|
3 files changed, 18 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
Index: linux-2.6.32.10/drivers/mtd/maps/Kconfig
|
--- a/drivers/mtd/maps/Kconfig
|
||||||
===================================================================
|
+++ b/drivers/mtd/maps/Kconfig
|
||||||
--- linux-2.6.32.10.orig/drivers/mtd/maps/Kconfig 2010-03-29 06:35:59.987293878 -0400
|
@@ -259,6 +259,13 @@ config MTD_ALCHEMY
|
||||||
+++ linux-2.6.32.10/drivers/mtd/maps/Kconfig 2010-03-29 06:37:14.968545954 -0400
|
|
||||||
@@ -259,6 +259,13 @@
|
|
||||||
help
|
help
|
||||||
Flash memory access on AMD Alchemy Pb/Db/RDK Reference Boards
|
Flash memory access on AMD Alchemy Pb/Db/RDK Reference Boards
|
||||||
|
|
||||||
@ -29,11 +27,9 @@ Index: linux-2.6.32.10/drivers/mtd/maps/Kconfig
|
|||||||
config MTD_DILNETPC
|
config MTD_DILNETPC
|
||||||
tristate "CFI Flash device mapped on DIL/Net PC"
|
tristate "CFI Flash device mapped on DIL/Net PC"
|
||||||
depends on X86 && MTD_CONCAT && MTD_PARTITIONS && MTD_CFI_INTELEXT && BROKEN
|
depends on X86 && MTD_CONCAT && MTD_PARTITIONS && MTD_CFI_INTELEXT && BROKEN
|
||||||
Index: linux-2.6.32.10/drivers/mtd/redboot.c
|
--- a/drivers/mtd/redboot.c
|
||||||
===================================================================
|
+++ b/drivers/mtd/redboot.c
|
||||||
--- linux-2.6.32.10.orig/drivers/mtd/redboot.c 2010-03-29 06:36:00.017292877 -0400
|
@@ -39,7 +39,7 @@ static inline int redboot_checksum(struc
|
||||||
+++ linux-2.6.32.10/drivers/mtd/redboot.c 2010-03-29 06:37:14.968545954 -0400
|
|
||||||
@@ -39,7 +39,7 @@
|
|
||||||
return 1;
|
return 1;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -42,7 +38,7 @@ Index: linux-2.6.32.10/drivers/mtd/redboot.c
|
|||||||
struct mtd_partition **pparts,
|
struct mtd_partition **pparts,
|
||||||
unsigned long fis_origin)
|
unsigned long fis_origin)
|
||||||
{
|
{
|
||||||
@@ -162,6 +162,14 @@
|
@@ -162,6 +162,14 @@ static int parse_redboot_partitions(stru
|
||||||
goto out;
|
goto out;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -57,7 +53,7 @@ Index: linux-2.6.32.10/drivers/mtd/redboot.c
|
|||||||
for (i = 0; i < numslots; i++) {
|
for (i = 0; i < numslots; i++) {
|
||||||
struct fis_list *new_fl, **prev;
|
struct fis_list *new_fl, **prev;
|
||||||
|
|
||||||
@@ -184,9 +192,8 @@
|
@@ -184,9 +192,8 @@ static int parse_redboot_partitions(stru
|
||||||
new_fl->img = &buf[i];
|
new_fl->img = &buf[i];
|
||||||
if (fis_origin) {
|
if (fis_origin) {
|
||||||
buf[i].flash_base -= fis_origin;
|
buf[i].flash_base -= fis_origin;
|
||||||
@ -68,19 +64,15 @@ Index: linux-2.6.32.10/drivers/mtd/redboot.c
|
|||||||
|
|
||||||
/* I'm sure the JFFS2 code has done me permanent damage.
|
/* I'm sure the JFFS2 code has done me permanent damage.
|
||||||
* I now think the following is _normal_
|
* I now think the following is _normal_
|
||||||
Index: linux-2.6.32.10/drivers/mtd/maps/Makefile
|
--- a/drivers/mtd/maps/Makefile
|
||||||
===================================================================
|
+++ b/drivers/mtd/maps/Makefile
|
||||||
--- linux-2.6.32.10.orig/drivers/mtd/maps/Makefile 2010-03-29 06:35:59.947294290 -0400
|
@@ -61,3 +61,4 @@ obj-$(CONFIG_MTD_BFIN_ASYNC) += bfin-asy
|
||||||
+++ linux-2.6.32.10/drivers/mtd/maps/Makefile 2010-03-29 06:37:14.968545954 -0400
|
|
||||||
@@ -61,3 +61,4 @@
|
|
||||||
obj-$(CONFIG_MTD_RBTX4939) += rbtx4939-flash.o
|
obj-$(CONFIG_MTD_RBTX4939) += rbtx4939-flash.o
|
||||||
obj-$(CONFIG_MTD_VMU) += vmu-flash.o
|
obj-$(CONFIG_MTD_VMU) += vmu-flash.o
|
||||||
obj-$(CONFIG_MTD_GPIO_ADDR) += gpio-addr-flash.o
|
obj-$(CONFIG_MTD_GPIO_ADDR) += gpio-addr-flash.o
|
||||||
+obj-$(CONFIG_MTD_BCM963XX) += bcm963xx-flash.o
|
+obj-$(CONFIG_MTD_BCM963XX) += bcm963xx-flash.o
|
||||||
Index: linux-2.6.32.10/drivers/mtd/maps/bcm963xx-flash.c
|
--- /dev/null
|
||||||
===================================================================
|
+++ b/drivers/mtd/maps/bcm963xx-flash.c
|
||||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
|
||||||
+++ linux-2.6.32.10/drivers/mtd/maps/bcm963xx-flash.c 2010-03-29 13:33:58.797288897 -0400
|
|
||||||
@@ -0,0 +1,266 @@
|
@@ -0,0 +1,266 @@
|
||||||
+/*
|
+/*
|
||||||
+ * Copyright (C) 2006-2008 Florian Fainelli <florian@openwrt.org>
|
+ * Copyright (C) 2006-2008 Florian Fainelli <florian@openwrt.org>
|
||||||
@ -148,7 +140,7 @@ Index: linux-2.6.32.10/drivers/mtd/maps/bcm963xx-flash.c
|
|||||||
+ return -ENOMEM;
|
+ return -ENOMEM;
|
||||||
+
|
+
|
||||||
+ /* Get the tag */
|
+ /* Get the tag */
|
||||||
+ ret = master->read(master,0x10000,sizeof(struct bcm_tag), &retlen, (void *)buf);
|
+ ret = master->read(master,master->erasesize,sizeof(struct bcm_tag), &retlen, (void *)buf);
|
||||||
+ if (retlen != sizeof(struct bcm_tag)){
|
+ if (retlen != sizeof(struct bcm_tag)){
|
||||||
+ vfree(buf);
|
+ vfree(buf);
|
||||||
+ return -EIO;
|
+ return -EIO;
|
||||||
@ -348,11 +340,9 @@ Index: linux-2.6.32.10/drivers/mtd/maps/bcm963xx-flash.c
|
|||||||
+MODULE_DESCRIPTION("Broadcom BCM63xx MTD partition parser/mapping for CFE and RedBoot");
|
+MODULE_DESCRIPTION("Broadcom BCM63xx MTD partition parser/mapping for CFE and RedBoot");
|
||||||
+MODULE_AUTHOR("Florian Fainelli <florian@openwrt.org>");
|
+MODULE_AUTHOR("Florian Fainelli <florian@openwrt.org>");
|
||||||
+MODULE_AUTHOR("Mike Albon <malbon@openwrt.org>");
|
+MODULE_AUTHOR("Mike Albon <malbon@openwrt.org>");
|
||||||
Index: linux-2.6.32.10/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
===================================================================
|
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
--- linux-2.6.32.10.orig/arch/mips/bcm63xx/boards/board_bcm963xx.c 2010-03-29 06:35:59.927292275 -0400
|
@@ -722,20 +722,6 @@ static int board_get_mac_address(u8 *mac
|
||||||
+++ linux-2.6.32.10/arch/mips/bcm63xx/boards/board_bcm963xx.c 2010-03-29 06:37:35.178541753 -0400
|
|
||||||
@@ -722,20 +722,6 @@
|
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -373,7 +363,7 @@ Index: linux-2.6.32.10/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
|||||||
static struct resource mtd_resources[] = {
|
static struct resource mtd_resources[] = {
|
||||||
{
|
{
|
||||||
.start = 0, /* filled at runtime */
|
.start = 0, /* filled at runtime */
|
||||||
@@ -745,12 +731,9 @@
|
@@ -745,12 +731,9 @@ static struct resource mtd_resources[] =
|
||||||
};
|
};
|
||||||
|
|
||||||
static struct platform_device mtd_dev = {
|
static struct platform_device mtd_dev = {
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- linux-2.6.32.10.orig/drivers/net/bcm63xx_enet.c 2010-04-06 19:25:52.612158288 +0100
|
--- a/drivers/net/bcm63xx_enet.c
|
||||||
+++ linux-2.6.32.10/drivers/net/bcm63xx_enet.c 2010-04-07 21:40:26.991801424 +0100
|
+++ b/drivers/net/bcm63xx_enet.c
|
||||||
@@ -965,7 +965,9 @@
|
@@ -965,7 +965,9 @@ static int bcm_enet_open(struct net_devi
|
||||||
/* all set, enable mac and interrupts, start dma engine and
|
/* all set, enable mac and interrupts, start dma engine and
|
||||||
* kick rx dma channel */
|
* kick rx dma channel */
|
||||||
wmb();
|
wmb();
|
||||||
|
Loading…
Reference in New Issue
Block a user