1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 16:45:05 +03:00

update kismet to 2006-04-R1 (from #485)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3664 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
mbm 2006-04-17 17:15:43 +00:00
parent 97ab85558c
commit dc6cdad9ce
3 changed files with 494 additions and 338 deletions

View File

@ -3,9 +3,9 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=kismet PKG_NAME:=kismet
PKG_VERSION:=2005-08-R1 PKG_VERSION:=2006-04-R1
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_MD5SUM:=17edb7688e04dd28028d5268a77d0ce7 PKG_MD5SUM:=8ec2de513f2911df1b7edfcba5ad1c26
PKG_SOURCE_URL:=http://www.kismetwireless.net/code PKG_SOURCE_URL:=http://www.kismetwireless.net/code
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz

View File

@ -9,21 +9,3 @@ diff -urN kismet-2005-04-R1.old/configfile.cc kismet-2005-04-R1.dev/configfile.c
#include "configfile.h" #include "configfile.h"
#include "util.h" #include "util.h"
diff -urN kismet-2005-04-R1.old/macaddr.h kismet-2005-04-R1.dev/macaddr.h
--- kismet-2005-04-R1.old/macaddr.h 2005-04-03 07:33:42.000000000 +0200
+++ kismet-2005-04-R1.dev/macaddr.h 2005-04-26 01:42:38.000000000 +0200
@@ -321,12 +321,12 @@
}
// equal
- inline bool operator==(const iterator& op) const {
+ inline bool operator==(const iterator& op) {
return (singleton_itr == op.singleton_itr) && (vector_itr == op.vector_itr);
}
// not
- inline bool operator!=(const iterator& op) const {
+ inline bool operator!=(const iterator& op) {
return (singleton_itr != op.singleton_itr) || (vector_itr != op.vector_itr);
}

File diff suppressed because it is too large Load Diff